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Notice/Disclaimer Statement 

This document has been reviewed by the U.S. Environmental Protection Agency, 
Office of Research and Development, and approved for publication.  

Any mention of trade names, products, or services does not imply an 
endorsement by the U.S. Government or the U.S. Environmental Protection Agency. 
EPA does not endorse any commercial products, services, or enterprises.  

Disclaimer of Liability 

With respect to this multimedia system of HTML pages and the EPA H2O software 
products and their documentation, neither the U.S. Government nor any of their 
employees, makes any warranty, express or implied, including the warranties of 
merchantability and fitness for a particular purpose, or assumes any legal liability or 
responsibility for the accuracy, completeness, or usefulness of any information, 
apparatus, product, or process disclosed, or represents that its use would not infringe 
privately owned rights.  

Disclaimer of Software Installation/Application 

Execution of any EPA H2O installation program and modification to system 
configuration files must be made at the user’s own risk. Neither the U.S. EPA nor the 
program author(s) can assume responsibility for program modification, content, output, 
interpretation, or usage.  

EPA H2O installation programs have been extensively tested and verified. 
However, as for all complex software, these programs may not be completely free of 
errors and may not be applicable for all cases. In no event will the U.S. EPA be liable 
for direct, indirect, special, incidental, or consequential damages arising out of the 
use of the programs. 
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Introduction

About EPA H2O 

EPA H2O is a Geographic Information System (GIS) based demonstration tool for assessing Ecosystem 
Services (ES). ES can be defined as the use of ecological structures and functions that humans can 
directly relate to their state of well-being (Russell et al., 2013). ES may also be referred to as ecosystem 
goods and services (EGS). EPA H2O was developed as a preliminary assessment tool in support of 
research being conducted in the Tampa Bay watershed. EPA H2O provides information, data, 
approaches and guidance that communities can use to examine alternative land use scenarios in the 
context of nature’s benefits to the human community. Knowledge gained from using this tool may help 
community representatives make strategic decisions for moving towards a more environmentally 
sustainable future.  

As packaged, EPA H2O allows users to: 
o Gain a greater understanding of the significance of ES
o Explore the spatial distribution of ES and other ecosystem features
o Obtain map and summary statistics of ES production's potential value
o Analyze and compare potential impacts from predicted development scenarios or user

specified changes in land use patterns on ES production's potential value
o Get started with a prepackaged database specifically designed for the Tampa Bay, FL estuary

and its watershed

EPA H2O is designed to be used at a range of skill levels for use and analysis of GIS data. Database 
creation does require a basic understanding of GIS tools for creating data layers, but analysis of existing 
databases (e.g., Tampa) using the tool can be performed at a Basic or Advanced level as appropriate. 
EPA H2O is designed for analyzing data at neighborhood to regional scales. While this software tool is 
packaged with data from the Tampa Bay region, advanced users can edit existing Tampa Bay data, 
substitute different datasets for the Tampa Bay region, and/or build completely new databases for new 
assessment areas. The tool is transferable to other locations if the required data are available, and if the 
data are processed into an EPA H2O compatible format. See the Database Creation section for guidance 
on how to create EPA H2O compatible datasets.  

For general information regarding the tool please contact: 

Marc J. Russell, Ph.D.  
Research Ecologist  
US EPA Gulf Ecology Division 
One Sabine Island Drive  
Gulf Breeze, FL 32561  
Email: russell.marc@epa.gov 

EPA H2O tool was developed by: 

Global Solutions Group Inc. 
24453 Grand River Avenue, Detroit, MI 48219 
Phone: 313.397.8311 
Email: info@globalsolgroup.com 

In association with: 

FutureNet Group Inc. 

mailto:russell.marc@epa.gov
mailto:info@globalsolgroup.com
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12801 Auburn St, Detroit, MI 48223 
Phone: 313.544.7117 
Email: info@futurenetgroup.com 

About GIS 
EPA H2O is a Geographic Information System (GIS) based hydro-ecology tool. A GIS is typically used to 
describe and characterize the earth and other geographies to visualize and analyze spatially referenced 
information. The purpose of a GIS is to create, share, and apply useful map-based information products 
that strengthen the work of organizations, as well as to create and manage the supporting geographic 
information. 

Maps portray logical collections of geographic information as map layers. They provide an effective 
metaphor for modeling and organizing geographic information as a series of thematic layers. In 
addition, interactive GIS maps provide the user an interface for interacting with geographic 
information.  

Examples of widely used GIS systems are: 
o Esri ArcGIS Suite (Commercial) - https://www.esri.com
o QGIS (Open Source) - https://www.qgis.org
o MapInfo (Commercial) - https://www.mapinfo.com
o PostGIS (Open Source) - https://postgis.net/

About QGIS 
EPA H2O is based on the open source GIS software QGIS. QGIS provides sophisticated tools to 
perform advanced geographic analysis. The following links are helpful resources about QGIS 
software: 

o QGIS Official Website - https://www.qgis.org/
o QGIS Help - https://download.osgeo.org/qgis/doc/manual/qgis-1.8.0_user_guide_en.pdf
o QGIS Documentation - https://www.qgis.org/en/docs/index.html

Definitions of GIS Terms 
Definitions for additional terms can be found using the Esri GIS Dictionary: 
https://support.esri.com/en/other-resources/gis-dictionary 

User Interface – The part of the software that allows users to interact with a GIS system through 
graphical icons and visual indicators; sometimes referred to as a Graphical User Interface (GUI). 

Map Projection – Describes how the curved surface of the earth is manipulated to display 
properly on a plane. Map projections distort either distance, area, shape, direction, or some 
combination thereof. There are a number of common map projections, and the one that is most 
suitable depends on the specific area/region being mapped, the type of analysis being 
performed and the end use of map product (Esri Support, 2018). 

Coordinate System – A reference framework consisting of a set of points, lines, and/or surfaces, and 
a set of rules, used to define the positions of points in space in either two or three dimensions (Esri 
Support, 2018). 

Extent – The minimum bounding rectangle (xmin, ymin and xmax, ymax) defined by coordinate 
pairs of a data source. All coordinates for the data source fall within this boundary (Esri Support, 
2018).  

mailto:info@futurenetgroup.com
http://www.esri.com/
https://www.qgis.org/
https://www.mapinfo.com/
https://postgis.net/
https://www.qgis.org/
https://download.osgeo.org/qgis/doc/manual/qgis-1.8.0_user_guide_en.pdf
https://www.qgis.org/en/docs/index.html
http://www.qgis.org/en/docs/index.html
https://support.esri.com/en/other-resources/gis-dictionary
https://support.esri.com/en/other-resources/gis-dictionary/term/projection
https://support.esri.com/en/other-resources/gis-dictionary/term/coordinate%20system
https://support.esri.com/en/other-resources/gis-dictionary/term/coordinate%20system
http://support.esri.com/en/knowledgebase/GISDictionary/term/coordinate%20system
https://support.esri.com/en/other-resources/gis-dictionary/search/extent
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Data Layer – The visual representation of a geographic dataset in a digital map environment (Esri 
Support, 2018). Each environmental variable is represented as a distinct data layer – for example 
Eagle Nests or Wetland Areas. Each data layer can be stored as either feature vector data or raster 
image data. 

Raster Data – In raster data, each cell, or pixel, of a given color marks a value such as elevation 
or priority level. Figure 1 and Figure 2 illustrate raster data on two different scales.  

 Feature Data – A representation of a real-world object on a map (e.g. a specific eagle's nest or 
wetland area). Feature types in a GIS are Point, Line, and Polygon (Esri Support, 2018). In 
addition to geographic information that allows each feature to be visualized on a map, features 
may also be associated with non-spatial attribute data (Figure 3).  

Attribute Data – Non-spatial information associated with a geographic feature in a GIS. 
Attributes are usually stored in a table and linked to the feature by a unique identifier. For 
example, attributes of a river might include its name, length, and flow rate. 

Symbology – The set of conventions, rules, or encoding systems that define how geographic 
features are represented with symbols on a map. A characteristic of a map feature may 
influence the size, color, and shape of the symbol used (Esri Support, 2018). 

Figure 1 Fine scale view of raster data Figure 2 Sample raster data for the Tampa Bay region

Figure 3 Sample map showing example features with points, lines and polygons 

https://support.esri.com/en/other-resources/gis-dictionary/term/layer
https://support.esri.com/en/other-resources/gis-dictionary/term/layer
http://support.esri.com/en/knowledgebase/GISDictionary/term/layer
https://support.esri.com/en/other-resources/gis-dictionary/term/feature
http://support.esri.com/en/knowledgebase/GISDictionary/term/feature
https://support.esri.com/en/knowledgebase/GISDictionary/term/symbology
http://support.esri.com/en/knowledgebase/GISDictionary/term/symbology
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EPA H2O Download and Installation

System Requirements 

The EPA H2O application was developed around the open source GIS software QGIS, version 1.8. 
The special EPA H2O tools and capabilities are not all forward compatible with newer versions of 
QGIS. System requirements for EPA H2O are the same as for QGIS 1.8 for Windows systems. It is 
recommended that EPA H2O be installed on a system with: 

o Windows XP or newer
o 1GB of available RAM
o 1.6GHz processor
o 5GB Hard Disk Space

Installing EPA H2O 
This section illustrates the step-by-step procedure for installing EPA H2O. 

1. Download the latest version of EPA H2O from:
https://www.epa.gov/water-research/ecosystem-services-scenario-assessment-using-epa-h2o

2. Save the H2O_Set_Up.exe installation file to your computer.
3. Ensure you have administrative rights to install the program on your computer or contact your

network/systems administrator.
4. Double-click on the H2O_Set_Up.exe installation file. If you receive a security warning (Figure 4),

ignore it by clicking Run.

Figure 4 Security Warning window that may be received when running the H2O_Set_Up.exe installation

https://www.epa.gov/water-research/ecosystem-services-scenario-assessment-using-epa-h2o
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5. Setup may take a few moments to load, during which time a window may appear with progress
(Figure 5).

6. Once the EPA H2O Setup Wizard appears (Figure 6),
click the Next button to proceed.

Figure 5 Window displaying Setup Wizard 
loading progress 
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Figure 6 EPA H2O Setup Wizard welcome window 

7. Next the EPA H2O license agreement window will appear (Figure 7). Click the I Agree button, to agree
with the EPA H2O license agreement.

Figure 7 EPA H2O Setup license agreement window 
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8. In the EPA H2O Setup Install Location window (Figure 8), choose the Destination Folder where EPA
H2O program files will be stored. The recommended destination folder is the Program Files directory,
as shown in Figure 8.

Figure 8 EPA H2O Setup Install Location window 

9. EPA H2O will be selected for installation by default on the Components window (Figure 9). Click the
Install button to install the program.
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Figure 9 EPA H2O Setup Components window 

10. An installation progress window will appear (Figure 10). Please wait while EPA H2O is being installed.
This may take a few moments.

Figure 10 EPA H2O Setup Progress window 
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11. For EPA H2O installation to take effect, the computer will have to be rebooted/restarted. On the
Setup Reboot window (Figure 11), choose to Reboot now or manually reboot later and click on the
Finish button.

Figure 11 EPA H2O Setup Reboot window 

After installation, EPA H2O and EPA H2O Browser shortcuts will 
automatically be created on the desktop (Figure 12). Both the EPA H2O 
program and EPA H2O Browser can also be accessed from the Windows All 
Programs menu.  

Uninstalling EPA H2O 
EPA H2O does not have a separate uninstallation utility that can be accessed from the Windows All 
Programs feature, this section describes how to uninstall EPA H2O. 

1. Access the Control Panel through the Windows start menu (Figure 13).

Figure 12 EPA H2O and EPA 
H2O Browser shortcuts 
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Figure 13 Location of Control Panel in Windows 7 start menu 

2. Click on the Uninstall a program under Programs (Figure 14). Depending on the version of Windows,
the Uninstall a Program option may have to be accessed through the Programs and Features menu.

Figure 14 Windows 7 Control Panel with Programs option 

3. The Uninstall/Change window listing installed programs will appear. Right-click on the EPA H2O
1.0.0 Beta program and select the Uninstall/Change option (Figure 15).
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Figure 15 Uninstall/Change the EPA H2O 1.0.0 Beta program 

4. Click Next in the EPA H2O Uninstall Wizard (Figure 16).

Figure 16 EPA H2O Uninstall Wizard Startup 

5. Click Uninstall (Figure 17). It may take a few moments for uninstallation to complete.
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Figure 17 Uninstall window, with file location of EPA H2O 

6. Click Finish (Figure 18).

Figure 18 Finish in the EPA H2O Uninstall Wizard 
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7. The EPA H2O Setup window may appear (Figure 19). Do not continue with EPA H2O installation.
Instead click Cancel to close the EPA H2O Setup Wizard.

Figure 19 Beginning of EPA H2O Setup Wizard 

8. The EPA H2O program has successfully been uninstalled.
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Navigating EPA H2O

GIS Tools 
QGIS software includes various GIS tools to assist users navigating, analyzing and visualizing data within 
the EPA H2O program. These tools are accessed by selecting icons from dropdown menus or by clicking 
individual icons on toolbars.  

View Menu 
Many tools can be accessed using the View dropdown menu (Figure 
20). Common tools are available on toolbars for quicker access. 
Toolbars are activated/deactivated using the View menu > Toolbars 
and can be moved around to different locations on the screen. 
Panels show the user specific information about their current map. 
Panels are activated/deactivated using the View menu > Panels. 

Map Navigation Toolbar 
These navigation tools are in the Map Navigation Toolbar (Figure 
21) and can also be accessed using the View menu.

Tools in dropdown menus and in toolbars are greyed out if 
prerequisite requirements for using that tool are not met. For 
example, Zoom Next appears greyed out until the user moves back 
to a previous zoom or pan (Figure 20 and Figure 21). 

Depending on the tool, clicking a tool icon may perform a function 
once or enable functionality until turned off or a different tool 
functionality is enabled. Enabled functions are shown in a grey, 
highlighted box; the Pan icon, for example, is highlighted when 
enabled (Figure 20 and Figure 21). There may be alternative ways to 
perform functions without enabling these tools. 

Figure 20 View dropdown menu in 
EPA H2O 
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Pan icon – When enabled, panning allows the user to click or click-and-drag to move the map 
across the screen. Alternatively, holding down the mouse scroll wheel while dragging the map 
will also pan. 

Pan to selection icon – Pan to selected feature/features. 

Zoom In/Out icons – When enabled, click or draw a rectangle to zoom in or out. Alternatively, 
the mouse up-scroll will zoom in and down-scroll will zoom out.  

Zoom Actual Size icon – Zoom to native pixel resolution. For example, if the selected 
raster is a 30m raster, the map will zoom to a 30m by 30m area.  

Zoom Full icon – Zoom to the full extent of all layers visible in the Layers panel. 

Zoom to Selection icon - Zoom to selected feature/features.  

Zoom to Layer icon – Zoom to a selected layer’s full extent.  

Zoom Last/Next icons – Use this tool to return to the previous or next viewing frame (i.e. undo 
and redo for zoom or pan). 

Refresh icon – Update the map canvas. 

EPA H2O Toolbar 
The default location for the EPA H2O Toolbar is above the Layers panel. There are slight differences in 
the toolbar between the Basic (Figure 22) and Advanced (Figure 23) Modules. In the Basic Module the EPA 
H2O Toolbar has an added Generate Report icon that allows the user to generate a statistical report (see 
Basic Module Report Section); whereas in the Advanced Module, the user instead manages and 
compares different scenarios in reports (see the Create Scenario section). The main function of the EPA 
H2O Toolbar is that it allows the user to move between module types, and between projects. The EPA 
H2O Toolbar also allows easier access to the Identify Feature tool; alternatively found in the View menu 
(Figure 20). 

Select EPA H2O Module icon – Click to open the EPA H2O Project Manager window (Figure 
22) and switch between Basic and Advanced Modules (see Getting Started section).

Select EPA H2O Project icon – Click to open a new or existing EPA H2O project (see Create 
New Project section). 

Generate Report icon – Click to run an analysis report in the Basic Module. The 
Basic report is detailed further in the Basic Module Report Analysis 
section.  

Identify Feature icon – Click on a feature in a layer selected in the Layers panel, and 
an Identify Results window will display attribute table information for the 
clicked feature in the selected layer. This tool is also accessed using 
the View menu. 

Figure 21 Map Navigation Toolbar 

Figure 22 Basic EPA 
H2O Toolbar 

Figure 23 Advanced 
EPA H2O Toolbar 
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Layers/ Table of Contents Panel 
The Layers panel, or Table of Contents, lists each data layer on the map (Figure 24). Data layers are listed 
in the order they appear on the map (e.g. if the Roads_2013 layer is listed above NHD_flowlines, they will 
appear in front or on top of those flowline features). The Layers panel indicates the symbology of each 
layer, and whether each layer is currently visible in the map. QGIS software incorporates other tools in 
the Layers panel, which may help the user manipulate EPA H2O.  

Layer icons – Each data layer added to the map appears in the 
Layers panel, in the order it appears on the map. 

Change layer order – Rearrange the data in the Layers panel by 
clicking, dragging, and dropping the name of the data layer into its 
new, desired position. 

Show Layer in Overview – The checkbox next to each data layer 
heading demonstrates whether the layer is currently turned on in the 
map. The Layers panel in Figure 24 indicates that the NHD_flowlines, 
Land_Use_2006 and Google Streets layers are displayed in the map. 

Collapse Symbology – Clicking the (+)/(-) sign to the left of the 
checkbox expands or collapses a list of possible values for the data 
layer to the right. 

A list of functions can also be accessed through the Layers panel, with a right-click on each data layer 
(Figure 25). This list provides shortcuts to certain QGIS operations and assists in EPA H2O navigation.  

Remove – Click to remove the selected data layer from the Layers 
panel. The removed layer will no longer appear in the Layers panel, or 
in the map canvas.  

Set Layer CRS – The shapefile Coordinate Reference System (CRS) 
must match all spatial layers. Click to edit or add a CRS or to confirm a 
match for new data layers. Details on setting CRS are given in the 
database creation section.    

Open Attribute Table – Click to open the attribute table of the selected 
data layer. The attribute table contains characteristics for the spatial 
data. In QGIS, attribute tables can only be opened for vector data. 

Toggle Editing – Click to start or stop editing the selected layer. Editing 

can also be turned on and off by clicking the pencil icon  in the 
attribute table or in Layer Properties.  

Properties – Click to open the Layer Properties window for the selected 
data layer. This window provides information regarding metadata, 
coordinate reference system, fields in the attribute table, as well as 
tools for data processing and display.  

Figure 24 Layers/ Table of Contents 
Panel in EPA H2O 

Figure 25 Right-click functions 
in EPA H2O Layers panel 
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Selection Tools 
EPA H2O utilizes six different Select Tools to select and highlight specific features in a layer. The 
tools are located under View menu > Select (Figure 26). In the Layers panel, click on the layer the user 
wants to select the features from. Once selected, a feature will be highlighted in yellow. Line and 
polygon layers, such as trails or conservation areas, respectively, are grouped together to enable 
faster processing time. Therefore, large areas may be highlighted outside the selection shape drawn.  

Figure 26 The six Selection Tools located in the EPA H2O View menu > Select 

Select Single Feature icon – When enabled, clicking a feature will select it. Holding down 
the Control Key while Select Single Feature is enabled allows one to add features to the 
current selection.  

Select Features by Rectangle icon – When enabled, click and drag to draw a rectangle 
around features to select. 

Select Features by Polygon icon – When enabled, left click to draw vertices for the polygon, 
right-click to finish the polygon and select features within it. 

Select Features by Freehand icon – When enabled, click and drag to draw an abstract 
shape around the area to select. The selection will follow the cursor; no vertices are drawn. 

Select Features by Radius icon – When enabled, click and drag to draw a circle around the 
area to select. 

Deselect Features from All Layers icon – Clears the current selection; features will no 
longer be highlighted.  
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Getting Started 

EPA H2O is opened from the program list or by double clicking the EPA H2O shortcut on the desktop. 
Once opened, the first window that appears is the EPA H2O Project Manager window (Figure 27). The 
user must choose which module to operate in, but the module can be changed later using the EPA H2O 
Select Module icon (Figure 22). This section describes the major differences between the two modules. 

Figure 27 EPA H2O Project Manager window 

Basic Module 
The Basic Module is designed for a user with limited GIS software experience. Basic users can explore 
the various ES and other environmentally relevant features in their area of interest and generate maps 
and reports to summarize what those features are and their ES values.  

An example of a basic user would be a neighborhood association member who wants to explore the 
value of surrounding “greenspace” in their neighborhood. The user can quickly get simple summaries for 
a suite of ecosystem services the area produces and the resulting cumulative value of benefits using the 
Basic Module. The user is then able to share this info with neighbors interested in preserving that 
“greenspace,” and/or finding hotspot areas for producing or delivering ES value.  

Advanced Module 
The Advanced Module is designed for a user with more GIS expertise who wishes to expand from 
exploring ecosystem services to scenario creation and comparison. Users can compare preexisting 
scenarios for the Tampa Bay region or create custom land use scenarios. Scenarios are then able to be 
analyzed and compared, with a map and report summarizing the ES values generated for each. 

An example of an advanced user would be a regional planner interested in the cumulative effects of 
increased impervious surfaces on the provision and value of water retention ecosystem services. The 
user can select a multi-county area and appropriate drainage areas as their area of interest. New land 
use scenarios can then be generated by modifying a copy of the initial land use map. The user is then 
able to compare the changes in ES value that result from their modifications to land uses. 
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Create New Project 

This section illustrates how to start a new EPA H2O project. 

1. Select either the Basic or Advanced Module from the EPA H2O Project Manager window (Figure 27),
click OK. The user can click Cancel to exit EPA H2O.

2. The Select Project window will appear (Figure 28). Select Create new project and click OK.

Figure 28 EPA H2O Select Project window 

3. The Select Database Location window will appear (Figure 29). Click on the Select button if you want to
change the Data Folder Path from the default “C:\Users\USERNAME\.qgis\0.0.3”. If using a different
Data Folder Path, start by navigating to the root EPA H2O data folder.

Figure 29 EPA H2O Select Database Location window 

4. Enter a name for the new database in the Name Your Project Database field (e.g. “Basic” in Figure 29)
and click OK to proceed.

The Select Area of Interest (AOI) window will appear (Figure 30 & Figure 31). Selecting an area of interest 
is illustrated under the Select AOI section.  
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Select AOI 

This section illustrates how to select an area of interest for a new EPA H2O project starting from the 
Select Area of Interest window (Figure 30 & Figure 31). The options available in this window depend on the 
current project user module, where the Advanced Module has the additional option to Select by River 
Basin. Each option in the EPA H2O Select Area of Interest window is detailed in its own section. 

By County 
1. In the EPA H2O Select Area of Interest window (Figure 30 & Figure 31), choose the Select from list of

counties option. Click OK.
2. The Select counties to create project window will appear in front of the EPA H2O map screen (Figure

32).
3. The window in the foreground will list counties in Florida to choose a county from. Click to select or

unselect counties from the list.
4. Note that the default data are only available for areas in Pinellas, Hillsborough, Polk, Manatee,

Hardee, and Pasco counties, which drain to Tampa Bay. Selecting other counties may yield no data.
5. In the background map the program will load base layers - Counties, River basins and Google

Streets. As counties are selected from the list they will be highlighted in yellow on the map (e.g.
Alachua County in Figure 32).

Figure 30 EPA H2O Select Area of Interest window in 
Basic Module Figure 31 EPA H2O Select Area of Interest window in 

Advanced Module 
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Figure 32 Select Florida county from list in EPA H2O map 

6. Hillsborough County, FL will be used as the AOI for illustration purpose. Select Hillsborough county
from the list and click RUN (Figure 33).

Figure 33 Select Hillsborough county for illustrative purposes; county is highlighted in yellow 

7. All EPA H2O data will be clipped to the selected AOI and its upstream area. Depending on the AOI it
may take a few moments, during which time the user will see the progress bar (Figure 34).
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Figure 34 Select AOI progress bar window 

8. Please note: EPA H2O may display the phrase “Not responding” while processing data. This error
may be shown in the progress bar (Figure 35), or at the top of the project window. Despite the
message, the program is still actively processing. Please do not close the window, or the EPA H2O
program.

Figure 35 Select AOI progress bar window, with (Not Responding) error shown 

9. When clipping is complete the Save Project window will appear (Figure 36). To save the project,
choose the desired File name and location, and click Save. The project should be saved as a QGIS
file with the extension “.qgs” (e.g. Basic.qgs in Figure 36).

Figure 36 Window to save the EPA H2O project 

10. By default, all data layers except Google Streets and River basins will be turned off. Other layers
must be turned on to make them visible on the map (see Layers/ Table of Contents Panel). Once
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made visible, land use layer results using Hillsborough County, FL as the AOI can be examined in the 
EPA H2O map (Figure 37). 

Figure 37 EPA H2O map for Hillsborough County, with River basins, Counties, and Google Streets visible, and Land 
Use layer turned on 

By Shapefile 
1. In the EPA H2O Select Area of Interest window (Figure 30 & Figure 31), choose the Select a polygon

shapefile option. Click OK.
2. The Select Shapefile window will appear (Figure 38), click the Select button to choose the shapefile to

use as the AOI.

Figure 38 EPA H2O Select Shapefile window 

3. A window will appear to select a shapefile (Figure 39). Navigate to and select a shapefile with the .shp
file extension (e.g. the EMA.shp file is used in Figure 39).
Please Note:
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a. Only one shapefile can be selected as an AOI at a given time.
b. No shapefile is included in the H2O download package.
c. The XML metadata file type with extension .shp.xml cannot be opened using EPA H2O.
d. The shapefile Coordinate Reference System (CRS) must match the data CRS in EPA H2O.

The Tampa data CRS is "EPSG:3857", and the Geographic Coordinate System is
"GCS_WGS_1984".

i. In Esri software (ArcGIS), this coordinate system is called
WGS_1984_Web_Mercator_Auxiliary_Sphere.

ii. In QGIS, this coordinate system is named WGS 84 / Pseudo Mercator.
iii. The naming schemes are different between the two programs, but they represent the

same coordinate system.
4. Click Open to select the shapefile and return to the Select Shapefile window.

Figure 39 Window to select a shapefile as the AOI 

5. Once selected, the shapefile will be displayed on the map in the background (Figure 40). Click
Intersect in the Select Shapefile window to clip the AOI to the shapefile area.
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Figure 40 Shapefile selected in Select Shapefile window is displayed on the map in background 

6. All the EPA H2O data will be clipped to the selected AOI and its upstream areas. Depending on the
AOI this may take several moments, during which time a progress bar will appear (Figure 41).

Figure 41 Select AOI by Shapefile progress bar window 

7. When clipping is complete the Save Project window will appear (Figure 42). To save the project,
choose the desired File name and location, and click Save. The project should be saved as a QGIS
file with the extension “.qgs” (e.g. Basic.qgs in Figure 42).



34 

Figure 42 Window to save the EPA H2O project 

8. By default, all data layers except Google Streets and River basins will be turned off. Other layers
must be turned on to make them visible on the map (see Layers/ Table of Contents Panel). Land use
layer results using a shapefile as the AOI can be examined in the EPA H2O map once made visible
(Figure 43).

Figure 43 EPA H2O map drawn by shapefile; River basins and Google Streets are visible, and the Land Use layer is 
turned on 
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By Drawing on Map 
1. In the EPA H2O Select Area of Interest window (Figure 30 & Figure 31), choose the Select by drawing

on map option. Click OK.
2. The Draw the AOI window will appear with Navigation tools, and the Select Features by Rectangle

tool to draw the AOI onto the map (Figure 44). The map will load in the background with pre-loaded
base layers - River basins and Google Streets (Figure 45).

a. Use the Zoom In , Zoom Out , and Pan  icons to focus the map on the Area 
of Interest (Figure 44).

Figure 44 Draw the AOI Shape window with navigation icons 

b. Click the Select Features by Rectangle icon  to click and draw a rectangle around the 
desired AOI on the map.

c. Click RUN to confirm the selected AOI.

Figure 45 AOI drawn by shape on the EPA H2O map 

3. All the EPA H2O data will be clipped to the selected AOI and its upstream areas. Depending on the
AOI this may take several moments, during which time the user will see the progress bar (Figure 46).
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Figure 46 Select AOI progress bar 

4. When clipping is complete the Save Project window will appear (Figure 47). To save the project,
choose the desired File name and location and click Save. The project should be saved as a QGIS
file with the extension “.qgs” (e.g. Basic.qgs in Figure 47).

Figure 47 Window to save the EPA H2O project 

5. By default, all data layers except Google Streets and River basins will be turned off. Other layers
must be turned on to make them visible on the map (see Layers/ Table of Contents Panel). Land use
layer results using the drawn AOI can be examined in the EPA H2O map once made visible (Figure
48).
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Figure 48 AOI drawn on map, with Google Streets and River basins layers visible, and Land Use turned on 

By River Basin (Advanced Module Only) 
1. In the EPA H2O Select Area of Interest window (Advanced Module, Figure 31), choose the Select by

River Basin option. Click OK.
2. The Watershed Selection window will appear (Figure 49). The map will load in the background with

pre-loaded base layers - River basins and Google Streets (Figure 50).

Figure 49 Watershed Selection window with navigation and selection icons 

a. The Watershed Selection window is the same as the Draw the AOI window, except that
instead of Select Features by Rectangle, it has the Select Features tool to choose single or
multiple watershed(s) as the AOI. As watersheds are selected on the map they will appear in
yellow (Figure 50).
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Figure 50 Watersheds selected using the Select by River Basin tool, highlighted in yellow 

b. Once the desired watersheds have been selected, click RUN in the Watershed Selection
window.

3. All the EPA H2O data will be clipped to the selected AOI and its upstream areas. Depending on the
AOI this may take several moments, during which time the user will see the progress bar (Figure 51).

Figure 51 Select by River Basin progress bar 

4. When clipping is complete the Save Project window will appear (Figure 52). To save the project,
choose the desired File name and location and click Save. The project should be saved as a QGIS
file with the extension “.qgs” (e.g. Advanced.qgs in Figure 52).
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Figure 52 Save project with .qgs extension in Save Project window 

5. By default, all data layers will be turned off except Google Streets and River basins. Other layers
must be turned on to make them visible on the map (see Layers/ Table of Contents Panel). Land use
layer results using the selected watersheds as the AOI can be examined in the EPA H2O map once
made visible (Figure 53).

Figure 53 Advanced Module map drawn by River Basin; Land Use, River basins, and Google Streets are visible 
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Saving and Moving the Project 

Saving the Project  
EPA H2O will allow the user to save work in the QGIS file format (.qgs) using Save or Save As 
functions in the File menu of EPA H2O. Saved projects preserve all loaded data layers, drawing 
order, symbology, and view extents. 

It is recommended that all EPA H2O data and files be saved in the same folder directory to 
facilitate moving of projects. EPA H2O does not support relative pathing; if a user moves the EPA 
H2O project file (.qgis file) or relevant data, the EPA H2O program will no longer be able to find the 
source data to map the layers. Transferring data and project files is not supported within EPA H2O 
default functionality, however, advanced QGIS users will be able to perform this task. 

The Tampa Bay data provided with the EPA H2O software follows the recommended folder structure 
with specific types of content in each folder (Table 1). Keeping this folder structure will help the 
advanced QGIS user more easily navigate and move projects. 

Table 1 folder structure of EPA H2O software with content descriptions 

Folder/Filename Content Description 
Root Folder 0.0.3 
Data 
Rasters Contains raster files for ES layers. 
Databases 

Legends Contains the legend file (.qml) for each standard data layer used by 
EPA H2O. 

TampaBay.sqlite Contains the original data provided with EPA H2O for the Tampa 
Bay region. These are standard data layers used by EPA H2O. 

Projects Contains a sqlite database for each project, clipped to the user 
specified Area of Interest. Database names are also user specified. 

Reports Contains reports saved by the user. Note: the user specifies the 
location to save reports, it is not required to be saved to this folder. 

Moving a Project
When a user moves the EPA H2O project file (.qgis file) or relevant data, the EPA H2O program is 
not able to find the source data for layers in the expected location, resulting in a broken data 
connection. The step-by-step procedure to fix broken data connections is as follows: 

1. If there is a broken data connection(s), the Handle bad layers window will appear when opening
the project file (Figure 54). Each line represents a data layer that cannot be found in the expected
location, with the expected location shown in red under the New file column.
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Figure 54 Handle bad layers window in EPA H2O 

2. In the Handle Bad Layers window, double click on a file in the New File column. A File Selection
window will open (Figure 55). Navigate to and select the appropriate file that represents the data
layer, then click Open.

Figure 55 File Selection window in EPA H2O to reconnect a broken data connection 
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3. The broken data connection will now appear in green and be fixed (Figure 56).

Figure 56 Data connection fixed for Subwatershed layer in Handle bad layers window 

Once all the broken data layers are fixed in this fashion, the EPA H2O project can be successfully 
opened again. 
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Tampa Bay Data Layers 

Basic Module Tampa Data 

The EPA H2O download packages a variety of different Tampa Bay datasets into the Basic Module: 
Note: Depending on the selected AOI not al of the datasets may be visible.  

NHD Flowlines - This dataset consists of line features that make up a linear surface water 
drainage network. The National Hydrography Dataset (NHD) contains Reach Codes for 
networked features, flow direction, names, and centerline representations for areal water bodies 
allowing upstream and downstream flow to be traced (Horizon Systems Corporation, 2016). 

Eagle Nests – Point features representing eagle nests from 2008 to 2009. The Bald Eagle is the 
national bird of the United States of America and was once severely endangered in the United 
States. Populations have recovered, and although the Bald Eagle is no longer protected under 
the Endangered Species Act, it is still protected under the Bald and Golden Eagle Protection Act 
and the Migratory Bird Treaty Act (FWC, 2018).  

Wood Stork Nests – Point features representing Wood Stork nests. The US Breeding 
Population of Wood Storks is protected under the Endangered Species Act (Federal Register, 
Feb. 1984; proposed status upgrade to Threatened, Dec. 2013). Nesting sites specifically are 
protected. Wood Storks are birds of freshwater and estuarine wetlands, primarily nesting in 
cypress or mangrove swamps. Primary reasons for the decline of Wood Stork populations are a 
decrease in food availability (mainly small fish) and loss of wetland habitat (USFWS, 2018).  

Parks and Recreational Facilities – This dataset consists of point features, indicating parks 
and recreational locations. Parks provide opportunities for residents to enjoy outdoors, and 
recreational activities including hiking, biking, fishing, boating, swimming, camping, wildlife 
viewing and more. Parks benefit businesses such as tourism and recreational supply industries 
(camping equipment etc.) and are a source of employment. They can also provide added 
benefits, such as improvement in air or water quality, reduction of noise pollution, reduction of 
heat island effects in urban areas, and increased habitat for wildlife.  

Birding and Wildlife Viewpoints – Point features representing sites along Florida trails, which 
provide opportunities for Birding and Wildlife viewing. The total spent annually in Florida for 
wildlife viewing is two and a half times greater than the value of the state’s annual orange crop 
harvest ($3.08 billion and $1.23 billion, respectively, in 2006; Southwick Associates Inc., 2013). 

Existing Trails – This dataset consists of line features that indicate existing trails. These are 
publicly accessible paved or unpaved trails for motorized use (e.g. ATV, OHM, ROV), as well as 
hiking, biking, equestrian, multiple-use, or paddling. In-road bike lanes and sidewalks are not 
included (Florida Department of Environmental Protection, 2012).  

Sensitive Shoreline - These line features exhibit shorelines that are environmentally and 
economically sensitive to oil and hazardous material spills from 1993 to 2003 (FWC, 2017). The 
Clean Water Act with amendments by the Oil Pollution Act of 1990 requires response plans for 
immediate and effective protection of sensitive areas. These areas may contain sensitive 
shoreline habitats, sensitive biological resources, and human-use resources. 

Ecological Greenways and Critical Linkages – This dataset consists of polygon features that 
represent ecological greenways and critical linkages. The Florida Ecological Greenways 
Network outlines the largest and most intact landscapes that aid in the conservation of 
biodiversity and ecosystem services in Florida (University of Florida GeoPlan Center, 2005). The 
Florida Greenways project is an analysis of potential ecological connectivity, using land use data 
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to identify landscape-scale areas with conservation significance (e.g. ecological hubs) and 
potential landscape linkages (e.g. ecological greenways and wildlife corridors).  

Forever Acquired Lands – Polygon features indicating Forever Acquired lands (Florida Natural 
Areas Inventory, 2012). Florida Forever is the nation's largest conservation land buying program. 
As of December 2017, collectively, the State of Florida has protected over 770,279 acres of land 
with $3 billion in Florida Forever funds (Florida DEP, 2017). Florida Forever lands are proposed 
for acquisition because of outstanding natural resources, opportunity for natural resource-based 
recreation, or historical and archaeological resources. However, these areas may not currently 
be managed for their resource value. 

Strategic Habitat Conservation Areas – This dataset consists of polygon features that 
represent strategic habitat conservation areas (SHCAs). SHCAs are utilized to determine the 
minimum amount of land in Florida required to maintain long-term biological diversity for 33 
terrestrial vertebrates (Florida Natural Areas Inventory, 2017). Over 8 million acres of privately-
owned areas have been identified as SHCAs, to conserve habitat for these 33 species. SHCAs 
also include potential habitat within conservation lands for 29 other vertebrate species.  

Coastal Barrier Resources System - These polygons indicate areas which were designated 
under the Coastal Barrier Resources Act (CRBA). This Act limits federal expenditures that 
support development, such as federal flood insurance. This, in return, promotes the 
conservation of biologically diverse coastal barriers often impacted by hurricanes. Areas within 
the Coastal Barrier Resources System (CBRS) can only be developed if the private developers 
(or other non-federal parties) cover all costs (USFWS, 2018). The CBRA is intended to save 
federal dollars, protect human lives, and conserve natural resources. 

Fragile Coastal Resources – This dataset consists of polygon features that exhibit fragile 
coastal resources. These areas include natural communities most susceptible to disturbance or 
development, such as beach dune, coastal grassland, coastal strand, coastal scrub, maritime 
hammock, salt marsh, and mangrove communities (Florida Natural Areas Inventory, 2017). 
These coastal communities face a variety of threats, especially invasion by non-native species, 
encroaching development and other human activities. 

Coastal Critical Erosion Areas – Line dataset representing eroded coastal areas, which have 
been negatively impacted by natural processes or human activity. The erosion and recession of 
the beach or dune system in these areas jeopardize upland development, recreational interests, 
wildlife habitat, or important cultural resources (Florida DEP, 2017). These coastlines are 
necessary to protect these important resources and ecosystem services.  

Functional Wetlands – This dataset consists of polygon features that indicate functional 
wetland locations. In addition to being unique ecosystems, wetlands act as a filter for pollution 
and sediment. When rainwater runoff laden with pesticides, excess nutrients, and other 
pollutants flows through a wetland prior to reaching open water, the pollutants are naturally 
filtered out. Excess sediment builds up in the wetland instead of in rivers or other water bodies. 
Wetlands also offer flood protection by storing runoff and releasing it slowly. The prioritization 
method was based on a Land Use Intensity index and Florida Natural Areas Inventory (FNAI) 
Potential Natural Areas ranking (Florida Natural Areas Inventory, 2017). Wetlands in the most 
natural state are given the highest priority. 

Prioritized Recharge - These polygon features represent recharge locations, which provide 
ground water recharge important to natural and human use. This recharge is critical to springs, 
sinks, aquifers, natural habitats, and human water supply. The data are prioritized by aquifer 
vulnerability factors; these include thickness of the intermediate aquifer confining unit and closed 
topographical depressions, as well as prioritizing those that are within springshed protection 
zones and in proximity to public water supply wells (Florida Natural Areas Inventory, 2017). 
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Wetland Habitat – Polygon dataset indicating the distribution of 35 wetland-dependent species, 
which were used to determine priority wetlands for listed species. Documented and potential 
wetland habitats were identified using known occurrence records and vegetative cover derived 
from 1985-1989 Landsat Thematic Mapper Imagery (FGDL, 2006). The "hot spot" dataset was 
created by aggregating predictive habitat maps for each of the 35 listed species. 

Wildlife Refuge – This dataset consists of polygon features that represent the location of wildlife 
refuges (USFWS, 2017). The National Wildlife Refuge system is a system of public lands and 
waters protected by the US Fish and Wildlife Service. These lands help to conserve America’s 
wildlife for future generations. The National Wildlife Refuges in the Tampa Bay area are 
Passage Key and Pinellas, which are closed to the public because of their small size and 
importance to wildlife, and Edgemont Key, which is open to the public for recreational activities. 
These include hiking, swimming, boating, fishing, and wildlife viewing (USFWS, 2018).  

Sustainable Forestry - This polygon data layer identifies existing pinelands (natural and 
planted) and former pinelands that are potentially available for forest management. Prioritization 
is based on four criteria set by the Florida Forest Service: whether trees are natural or planted, 
size of tract, distance to market, and hydrology (Florida Natural Areas Inventory, 2017). Large 
tracts of natural pine on mesic soils (compared to very dry or wet soils) that are within 50 miles 
of a mill receive the highest priority. Former pinelands that currently do not have trees receive 
the lowest priority.  

Mitigation Banks – Polygon dataset representing the location of mitigation banks (Florida DEP, 
2004). Mitigation banking is the restoration, creation, enhancement, or preservation of a 
wetland, stream, or habitat conservation area, which offsets expected adverse impacts to similar 
nearby ecosystems (Florida DEP, 2018). The goal is to replace the exact function and value of 
the specific wetland habitats that would be adversely affected by a proposed development 
project.  

Usable Water Value – This polygon dataset indicates the categorized value of usable water. 
Human activities produce water pollutants (University of Florida GeoPlan Center, 2006). As 
water moves through a watershed, it is filtered by wetlands, forests, and aquatic areas. 
Replacement costs for removing a pound of nitrogen from various sources range from less than 
$10 to as high as $855 (U.S. EPA, 2016). Cost increases as the nitrogen becomes harder to 
route towards treatment areas and as simpler, more cost-efficient mechanisms for removing 
nitrogen need to be replaced by more centralized advanced wastewater treatment facilities. 
Click to see how usable water value is determined.  

Flood Protection Value* - Polygon dataset representing the categorized value of flood 
protection (University of Florida GeoPlan Center, 2006). Human activities alter the way water 
moves through the landscape. Natural landscapes retain and slow the movement of water, 
offering protection from flooding (U.S. EPA, 2016). The loss of these natural landscapes would 
result in an increased need for manmade flood protection at much higher cost. Click to see how 
flood protection value is determined.  

Stable Climate Value - This dataset consists of polygon features that exhibit the categorized 
value of a stable climate (University of Florida GeoPlan Center, 2006). Stored carbon provides a 
more stable climate by reducing greenhouse gases. In 2010, CO2 accounted for about 84% of all 
U.S. greenhouse gas emissions from human activities (U.S. EPA, 2016). Click to see how stable 
climate value is determined .  

Usable Air Value – Polygon feature dataset that represents the categorized value of usable air 
(University of Florida GeoPlan Center, 2006). Human activities produce air pollutants. Trees and 
other plants remove these harmful pollutants. Pollution removal results in healthier people with 
reduced health care costs (U.S. EPA, 2016). The relative air pollutant cost to human health was 

https://archive.epa.gov/ged/tbes/web/html/UsableWater.html
https://archive.epa.gov/ged/tbes/web/html/FloodProtection.html
https://archive.epa.gov/ged/tbes/web/html/FloodProtection.html
https://archive.epa.gov/ged/tbes/web/html/AStableClimate.html
https://archive.epa.gov/ged/tbes/web/html/AStableClimate.html
http://www.epa.gov/ged/tbes/AStableClimate.html
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used to translate the various pollutant removal rates to decreases in human health impact costs. 
Click to see how usable air value is determined.  

Land Use 2006 – Polygon feature dataset that indicates land use type. Land use maps based 
on Florida Land Use and Cover Classification System (FLUCCS) data derived from aerial 
imagery (Southwest Florida WMD, 2007). 

NHD Waterbodies – Polygon features in the National Hydrography Dataset (NHD) represent 
areas that contain water such as lake/pond, swamp/marsh, stream/river, canal/ditch, area of 
complex channels, estuary, ice mass, playa, reservoir, sea/ocean, and wash (Horizon Systems 
Corporation, 2016).  

Subwatershed – Polygon areas that define drainage basins; used to identify a hydrological 
feature such as a river, river reach, lake, or area like a drainage basin. Subwatershed data are 
obtained from the National Hydrography Dataset (Horizon Systems Corporation, 2016). 

Counties – This dataset consists of polygon features that represent Florida counties. Population 
data from 2004 and 2009 Florida Statistical Abstract was sampled for each county to create the 
shapefile layer (University of Florida GeoPlan Center, 2010).  

River Basins – Polygon feature dataset that represents river basins. River basins are areas of 
land where rivers and tributaries drain to the same point or body of water. In this scenario tool, 
that body of water is Tampa Bay. Eight-digit hydrologic unit codes (HUC) are used to identify 
these hydrological features (USGS, 2018). 

Google Streets - OpenLayers map of Google Street map data (Google, 2018). 

*The reported values for Flood Protection will be slightly smaller in the Basic Module report
versus the Advanced Module report. This difference is less than 5% between the two modules
and is further detailed in the ES Calculations Theory section.

Advanced Module Tampa Data 
The EPA H2O download packages a variety of different Tampa Bay datasets into the Advanced 
Module: 

Roads 2013 – Line features that define the name and speed limit of roads and highways in the 
Tampa Bay area (U.S. Census Bureau, 2018).  

Land Use 2006 – Polygon feature dataset that indicates land use type. Land use maps based 
on Florida Land Use and Cover Classification System (FLUCCS) data derived from aerial 
imagery (Southwest Florida WMD, 2007). 

Land Use 2020 – Polygon feature dataset representing possible land use in 2020. Future 
scenarios resulting from models or subjective tabletop exercises (U.S. EPA, 2016).  

Land Use 2040 - Polygon feature dataset representing possible land use in 2040. Future 
scenarios resulting from models or subjective tabletop exercises (U.S. EPA, 2016).   

Land Use 2060 - Polygon feature dataset representing possible land use in 2060. Future 
scenarios resulting from models or subjective tabletop exercises (U.S. EPA, 2016). 

To learn more about the land use scenarios: 
https://archive.epa.gov/ged/tbes/web/html/landuse.html 

https://archive.epa.gov/ged/tbes/web/html/UsableAir.html
https://archive.epa.gov/ged/tbes/web/html/landuse.html
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Counties – This dataset consists of polygon features that represent Florida counties. Population 
data from 2004 and 2009 Florida Statistical Abstract was sampled for each county to create the 
shapefile layer (University of Florida GeoPlan Center, 2010).  

NHD Flowlines - This dataset consists of line features that make up a linear surface water 
drainage network. The National Hydrography Dataset (NHD) contains Reach Codes for 
networked features, flow direction, names, and centerline representations for areal water bodies 
allowing upstream and downstream flow to be traced (Horizon Systems Corporation, 2016). 

Subwatershed - Polygon areas that define drainage basins. Subwatershed data are obtained 
from the National Hydrography Dataset (Horizon Systems Corporation, 2016). 

Google Streets - OpenLayers map of Google Street map data (Google, 2018). 

River Basins – Polygon feature dataset that represents river basins. River basins are areas of 
land where rivers and tributaries drain to the same point or body of water. In this scenario tool, 
that body of water is Tampa Bay. Eight-digit hydrologic unit codes (HUC) are used to identify 
these hydrological features (USGS, 2018). 
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Creating Reports 

Basic Module Report 

Create Report Tool 
This section illustrates the Create Report tool functionality in the Basic Module. 

1. Click on the Create Report icon  located in the EPA H2O Toolbar. The Create Report window 
will appear (Figure 57). 

a. In the Report Name box, enter the preferred report name. WARNING: re-running Create
Report with same Report Name will overwrite the previously saved report.

b. If necessary, click the Change button to designate a different Report Folder location.

Figure 57 Create Report window 

c. Use either the Select by Irregular Polygon icon or the Select by Rectangle icon to select
the area to run the report on. These selection tools work much like the Select Features by
Polygon or Select Features by Rectangle tools (see GIS Tools section), except that the
report area appears as a semi-transparent blue polygon while drawing (Figure 58) and the
polygon area is closed by double clicking the final vertex instead of right-clicking, as is
done when making a selection.

d. Once the desired report area is drawn, click Run Stats to generate the report using that
area.
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Figure 58 Report area (indicated by the blue polygon) selected with the irregular polygon tool 

2. Depending on the size of the report area, it may take a few moments to generate the report in
PDF format. A progress bar displaying the percentage of the process completed for each layer will
be displayed during this time (Figure 59).

Figure 59 Report progress bar window 

3. The report area will automatically be added to the Layers panel as Area of Interest (Figure 60).
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Figure 60 EPA H2O map with report area displayed and added to the Layers panel 

4. The report will be saved as a PDF in the user specified location.

Basic Module Report Analysis 
This section overviews the contents of the Basic Module report (Figure 61). 

Figure 61 Basic Module Report, map with legend 
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The cover page of the Basic Module report contains four main map elements (Figure 61): 
Title – Generic description of the Basic report, “EPA H2O Green Value Analysis Report.” 
Legend - List of layers that are turned on/visible in the Layers panel, in the order they appear 
on the map. Each layer has its name and symbology, the symbols used to represent layer 
data and values. 
Map – Data layers from the legend shown using their respective symbologies on a map. 
Scale - Displayed as a ratio of map units to the actual measurement. 

 The Map and Legend both include layers defining the areas compared in the report: 
Upstream Area of Interest – A red dashed line that is comprised of subwatersheds that 
overlap with or drain into the chosen AOI. 
Area of Interest – A black dashed line that shows the user defined AOI for the report. 

The second page of the Basic report summarizes statistics for all non-water flow related features in 
the user-selected AOI (Figure 62). The statistics for water flow related features, Functional Wetlands, 
Prioritized Recharge, Flood Protection Value, and Usable Water, are summarized for the user-
selected AOI and its upstream area.  

The report summarizes each feature data type differently: 
Point Features - Displays the total number of features in the summarized area. 
Polyline Features - Displays the lengths and units for each feature and the total length for all 
features in the summarized area. 
Polygon Features- Displays areas and units for each feature and the total area of all features 
in the summarized area. 
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Figure 62 Statistics for example features in the user’s AOI report 

Advanced Module Report 

Create Scenario  
This section illustrates the workflow to create a user-defined land use scenario in the EPA H2O Advanced 
Module.  

Figure 63 EPA H2O Toolbar 4: Scenarios Toolbar 

1. Click on the Scenario Manager button found on the EPA H2O Scenarios Toolbar (Figure 63).
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2. In the Scenario Manager window that appears (Figure 64), type the desired scenario name
(e.g. Demo) and click Run Scenario.

Figure 64 Scenario manager window, where user may name and run the scenario 

3. Depending on the size of the area of interest, it may take a few moments for the scenario to
be created. A progress bar will be displayed while creation is in progress (Figure 65).

Figure 65 Scenario Manager progress bar 

4. After all new scenarios of interest have been created, click Done to close the Scenario
Manager window.

5. Note that the new scenario(s) with the user-specified name(s) will be created in the Layers
panel (Figure 66). Each newly created scenario is an exact copy of the default land use data
loaded in the Advanced Module. New scenarios can later be modified/edited as shown in the
Edit Scenarios section.
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Figure 66 New scenario located in the Layers panel 

Edit Scenarios 
This section illustrates the workflow to edit a user-defined scenario in the Advanced Module of EPA 
H2O. For illustration purposes, land use types in the example scenario created in the Create 
Scenario section will be edited for selected features for hypothetical scenarios. 

Edit Scenario Land Use 

1. Click the Edit Scenario button on the EPA H2O toolbar to open the Edit Scenario window
(Figure 67).

Figure 67 Edit Scenario window 



55 

2. Make sure Scenario-Demo is selected and click on the Start Editing button (Figure 67). This
will cause several things to occur in the EPA H2O interface (labeled A-D in Figure 68):
a. The name of the scenario being edited (e.g. Scenario-Demo) will display in red on the

EPA H2O toolbar.

b. The edit icon will appear next to the layer being edited (e.g. Scenario-Demo) in the
Layers panel.

c. The Selection tools will appear in the upper left corner of the user interface.

d. The Stop Editing  button will replace the Start Editing button in the Edit Scenario 
window. 

Figure 68 Edit the scenario in the Edit Scenario window; changes to the program are indicated with letters A-D 

3. The user can navigate and zoom to the to-be-edited area (Figure 69) using normal map
navigation controls (the GIS Tools section describes these). Zooming in on an area within the
AOI makes it easier to observe and update the land use of individual features. For example, in
Figure 69 it is easier to see that land use types for most of the area are Urban and Built-Up or
Agriculture.

A B C 

D 
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Figure 69 Zoomed in area within the AOI, demonstrating symbology of polygons 

4. While EPA H2O is in edit mode (see step 2 a-d) use the Feature Selection tools (see GIS
Tools section) to select the polygon(s) the user wants to change in the scenario. Selected
polygons will appear bright yellow in color, with the vertices outlined by red crosshairs (Figure
70 shows an Agriculture polygon (TREE CROPS) from Figure 69 after being selected).

Figure 70 Tree Crops polygon is selected during scenario editing, indicated by the blue arrow 

5. In the Edit scenario window, use the dropdown list under the Update Selected Polygons Land
Use to: label to choose the land use type the selected polygons will become (e.g.
COMMERCIAL AND SERVICES in Figure 71).
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6. Click the Update button to update the selected polygon land use to the type in the dropdown
list (Figure 71).

Figure 71 Edit Scenario window, allows the user to change the land use type of selected polygons 

7. Updating the land use type may take a few moments depending on the area of interest and
the features selected. Do not close the program while the update process is in progress.

8. Once complete a pop-up window will appear, click OK to continue (Figure 72).
9. Click on the Stop Editing button in the Edit Scenario window to commit changes made to the

land use polygon.
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Figure 72 Scenario Land Use Updated message window 

10. The user can continue editing the land use scenario in this fashion to create alternative land
use scenarios for comparison and analysis.

In the example here, TREE CROPS type land use features were converted into COMMERCIAL AND 
SERVICES. Figure 73 displays the newly converted land use polygon in a light red color for Urban and 
Built up land use. Multiple land uses are combined into single symbology categories for better 
representation on the map. In this case, the COMMERCIAL AND SERVICES land use type falls under 
the Urban and Built up land use category. This hypothetical scenario could represent an urban 
development project being evaluated using EPA H2O. The next step of the scenario comparison is 
assessment of the impact of this land use change on ES values.  
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Figure 73 Edit Scenario window; the TREE CROPS polygon was converted to COMMERCIAL AND SERVICES 

Technical users may also input their own land use comparison data into EPA H2O. This land use data 
may be edited in the same fashion, and can be used to Compare Scenarios. The Create Land Use 
Comparison Data section explains how the technical user may insert their own data.  

Changes in land use are summarized in the Compare Scenarios section. 

Edit ES Unit Values 

The ES value estimation algorithm used for each ES is explained below and detailed further in the ES 
Calculations Theory section.  

Stable Climate - https://archive.epa.gov/ged/tbes/web/html/AStableClimate.html 

The social cost of carbon was used to value carbon sequestration. The dollar value of carbon 
reductions in the form of the greenhouse gas carbon dioxide has been estimated as $20 per ton ($0.01 
per lb) of Carbon Dioxide in 2010 (US Government 2010). We applied this 2010 estimate across years 
without year specific corrections for inflation. This social cost of carbon is an estimate of the monetized 
damages associated with an incremental increase in carbon emissions for a given year.  It is intended 
to include, but is not limited to, changes in net agricultural productivity, human health, property 
damages from increased flood risk, and the value of ecosystem services.  Even without year specific 
cost adjustments the $20 per ton of CO represents a conservative estimate that has been recalculated 
as 12 times larger using a discount rate more appropriate for intergenerational cost-benefit analysis 
(Johnson and Hope, 2012). Carbon sequestration rates were multiplied by the conservative cost 
estimate to arrive at the total value of this ecosystem good that benefits humans by moderating climate 
change and then summarized by National Hydrography Dataset Plus catchments (http://www.horizon-
systems.com/nhdplus/). 

Flood Protection - https://archive.epa.gov/ged/tbes/web/html/FloodProtection.html 

The replacement cost for installing drainage infrastructure to compensate for lost water retention was 
used as an estimated value of reduced flooding. Retained volume of water was multiplied by $2 per 
cubic foot, a default cost of built drainage infrastructure. For our 30x30m cells:  

https://archive.epa.gov/ged/tbes/web/html/AStableClimate.html
http://www.horizon-systems.com/nhdplus/
http://www.horizon-systems.com/nhdplus/
https://archive.epa.gov/ged/tbes/web/html/FloodProtection.html
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$Value = mm* 304.8 mm per ft * 9687.5 ft2 per cell * $2 per ft3 = $63.57 per mm water retained. 

These values were then summarized by National Hydrography Dataset Plus catchments. 
(http://www.horizon-systems.com/nhdplus/). 

Usable Air - https://archive.epa.gov/ged/tbes/web/html/UsableAir.html 

The relative air pollutant cost to human health was used to translate the various pollutant removal 
rates to decreases in human health impact costs.  The estimated value for removal of the selected 
pollutants was $959/ton Carbon Monoxide, $6752/ton Ozone, $1653/ton Sulfur Dioxide, $4508/ton 
PM10, and $6752 ton NO2 (Murray et al., 1994).   

The total value of air pollutant removal was calculated as  

Air Pollution Removed= ∑ Value * FluxRate * %Can * Cell Size 

where i represents the individual pollutants 

Value is the decrease in costs associated with a decrease in pollutant species, and FluxRate is the 
removal rate of the specific pollutant species. Canopy coverage estimates were used to calculate the 
total air pollution removed in U.S. dollars ($) per year summarized by National Hydrography Dataset 
Plus catchments (http://www.horizon-systems.com/nhdplus/). 

Usable Water - https://archive.epa.gov/ged/tbes/web/html/UsableWater.html 

Replacement costs for removing a pound of nitrogen from various sources range from less than $10 to 
as high as $855.  Costs increase as the nitrogen becomes harder to route towards treatment areas 
and as simpler, more cost-efficient mechanisms for removing nitrogen need to be replaced by more 
centralized advanced wastewater treatment facilities.  Compton et al. (2011) reviewed the cost of 
removing nitrogen from a wide range of sources and concluded that costs ranged from $1.22 - $43.54 
per pound of nitrogen ($2.71 - $96 kg N).  Abatement costs of reducing nitrogen from point sources 
are estimated as $8.16 per pound ($18 kg) of nitrogen (Birch et al. 2011).  We use this cost as our 
conservative ecosystem replacement value estimate based on using traditional wastewater treatment 
to remove nitrogen from upstream point sources.  The values are summarized by National 
Hydrography Dataset Plus catchments (http://www.horizon-systems.com/nhdplus/). 

Several lifecycle estimates, however, including upgrading and maintaining existing or building 
additional advanced wastewater treatment facilities and drainage structures to remove nitrogen, put 
the cost as high as $855 per pound ($388 kg) of nitrogen removed (Roeder 2007).  This higher 
ecosystem replacement value may be more appropriate than our more conservative number for 
illustrating the potential future value for bay habitats in a scenario of increasing nitrogen removal 
needs. 

Users can use the Edit Scenario tool to modify ES dollar values. Default dollar values for flood 
protection ($2), stable climate ($37) and usable water ($3) can all be updated in the Edit Scenario 
window (Figure 74, for example these were changed to $4, $47 and $6, respectively).  

http://www.horizon-systems.com/nhdplus/
https://archive.epa.gov/ged/tbes/web/html/UsableAir.html
http://www.horizon-systems.com/nhdplus/
https://archive.epa.gov/ged/tbes/web/html/UsableWater.html
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Figure 74 Edit Scenario window allows the user to change the ES Algorithm Values 

1. Click the Edit Scenario tool to open the Edit Scenario window (Figure 74).
a. In the Modify EGS Algorithm Values section, enter the preferred ES monetary value.
b. Click the Update Attributes button.

2. The progress bar will appear while attributes are being updated (Figure 75). This may take few
moments, depending on the number of the features within the area.

Figure 75 Modify ES Algorithm Values progress bar 

3. Once the ES attributes are updated, a message will be displayed, stating the attributes have
been successfully updated, and to commit changes using the Stop Editing button (Figure 76).
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4. Please make sure to click Stop Editing to save the changes.

Figure 76 ES Algorithm Values Update Finished window 

Changes to ES dollar values are summarized in the Compare Scenarios section. Please note, 
updating the ES values may result in a slight change in Flood Protection; this is due to rounding 
during the repopulation of the scenario’s attribute table.  

Compare Scenarios 
This section illustrates the workflow for comparing scenarios in the Advanced Module of EPA H2O. 
Note that only two scenarios can be compared at a given time.  

1. Click on the Compare Scenario button.
2. The Compare Scenario window will open (Figure 77):

a. In the Scenario A and Scenario B dropdown lists, select the scenarios to be compared
(e.g. Land_Use_2006 and Scenario-Demo).

b. In the Report Name box, type the preferred report name. If an existing report name is
chosen, it will overwrite the existing report.

c. The default report folder will be displayed in Compare Scenario window
(C:/Users/Username/.qgis/reports/); click on the Change button to modify the report
location.

d. Use the Zoom In , Zoom Out , and Pan  icons to focus on the desired area. 

Figure 77 Compare Scenario window 
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e. Click on the Area Selection  icon and draw an area on the map for which the user
wants to create the report (AOI). Please note that EPA H2O will automatically compute
the upstream area and the statistics for it.

f. The user-selected area will be highlighted in a blue color (Figure 78). Click on the
Compare button to generate the PDF report.

Figure 78 User-selected area is shown inside the blue box, to be used in the Compare Scenario tool 

3. A progress bar will be displayed while the report is generated (Figure 79). It may take a few
moments, depending on the size of AOI and its upstream area.

Figure 79 Compare Scenario progress bar 

4. New data layers, Area of Interest and Upstream Area of Interest, will be generated in the
Layers panel (Figure 80). The Upstream Area of Interest includes subwatersheds that overlap
with or drain into the chosen AOI.
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Figure 80 EPA H2O map after the Compare Scenario tool is run 

Advanced Module Report Analysis 
This section overviews the contents of the Advanced Module report (Figure 81). 

Figure 81 Sample Advanced Module report, map with legend 
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The cover page of the Advanced Module report contains four main map elements (Figure 81): 
Title – Generic description of the Advanced report, “Ecosystem Valuation Report.” 
Legend - List of layers that are turned on/visible in the Layers panel, in the order they appear 
on the map. Each layer has its name and symbology, the symbols used to represent layer 
data and values. 
Map – Data layers from the legend shown using their respective symbologies on a map. 
Scale - Displayed as a ratio of map units to the actual measurement. 

The Map and Legend both include layers defining the areas compared in the report: 
Upstream Area of Interest – A red dashed line that is comprised of subwatersheds that 
overlap with or drain into the chosen AOI. 
Area of Interest – A black dashed line that shows the user defined AOI for the report. 

The second page of the sample report summarizes the total value of each ES in the AOI or areas 
upstream for each scenario (Figure 82). The report also provides a short description of each ES, visit 
US EPA’s Archived Tampa Bay Ecosystem Services Project website to learn more about ES and their 
estimations. 

In this example, the user made significant changes to the land use and attribute values in the Edit 
Scenarios section. Below is the interpretation of the report in relation to those changes: 
o The usable water value has been increased from 2,028,898 $/yr to 4,068,561 $/yr. This is the

result of increasing the value of nitrogen removed ($/lb) from 3 to 6 in the Edit ES Unit Values
section, as well as the change in land use type from TREE CROPS to COMMERCIAL AND
SERVICES.

o The usable air value has decreased from 486,382 $/yr to 472,583 $/yr. This is a result of
converting an area of TREE CROPS to the COMMERCIAL AND SERVICES land use type (Edit
Scenario Land Use section).

o The stable climate value has increased from 2,482,571 $/yr to 2,997,867 $/yr. This is a result of
increasing the value of carbon removed ($/Ton) from 37 to 47 in the Edit ES Unit Values section,
as well as the change in land use type from TREE CROPS to COMMERCIAL AND SERVICES.

o The flood protection value significantly increased, from 27,214,370 $/yr to 50,768,155 $/yr. This
is a result of increasing the water retention value ($/ft3) from 2 to 4 in the Edit ES Unit Values
section, as well as the change in land use type from TREE CROPS to COMMERCIAL AND
SERVICES.

o The TREE CROPS area has been changed from 2,578,233 sq. meters to 893,548 sq. meters.
The reduction of the area is due to converting TREE CROPS to COMMERCIAL AND
SERVICES in the Edit Scenario Land Use section.

o The COMMERCIAL AND SERVICES area has increased from 6,903 sq. meters to 1,691,588
sq. meters. This is also a result of converting TREE CROPS to COMMERCIAL AND SERVICES
in the Edit Scenario Land Use section.

https://archive.epa.gov/ged/tbes/web/html/index.html
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Figure 82 Sample Advanced Module report; summary of ES in each scenario 
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Delete Scenario 
This section illustrates the workflow for deleting a user-defined scenario in EPA H2O’s Advanced Module. 

1. Click on Scenario Manager to open the Scenario Manager window (Figure 83).
a. Under Delete Scenario dropdown list, select the desired scenario to-be-removed.
b. Click on the Delete button to delete the scenario. All the land use features and ES value

data for that scenario will be deleted. Deletion of a scenario is irreversible.

Figure 83 Scenario Manager window, used to irreversibly delete a scenario 
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Transportation Tool (Advanced Module Only) 
The transportation tool allows for an assessment of connectivity between potential users and 
ecosystem services by measuring the proximity in both distance and time between population 
centers and ES points of interest defined by the user (e.g., parks, greenways, forests). 

The Transportation tool in the Advanced Module of EPA H2O allows users to: 
o Add Points of Interest (POI) to the existing transportation network.
o Edit the existing transportation network.
o Compare changes in driving and walking time to POIs for the existing and modified

transportation network.

This section illustrates use of Transportation Module features. 

1. Create or choose an existing project with a defined AOI (see Select AOI section) and open in
the Advanced Module (see Advanced Module section).

2. Click Transportation menu > Transportation scenario manager (Figure 84).

Figure 84 Location of the Transportation scenario manager in EPA H2O 

3. The Transportation scenario manager window will appear (Figure 85):
a. In the Name Scenario box, enter the desired scenario name.
b. Click the Run Scenario button to create a new, editable Transportation layer.
c. Click Done to close the window.
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Figure 85 Transportation Scenario Manager window 

4. Under the Transportation menu, choose Edit transportation scenario (Figure 86).

Figure 86 Location of the Edit transportation scenario tool in the Transportation menu 

5. The Edit Transportation Scenario window will open.
a. In the Scenario to Edit dropdown list, select a scenario to edit (e.g. Scenario- Demo,

Figure 87).
b. Click the Start Editing button.

Figure 87 Edit Transportation Scenario window 

6. Click the Connector  icon to add a new road to the map. 
a. Single click on the map to start drawing the road
b. Single click again to add a bend or joint in the road
c. Double click to finish drawing the road

Note: Although new road lines may appear to start at an existing road, the Transportation Module will 
only route to the existing road if the new road intersects it. To ensure the roads intersect, users should 
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place the start point for new roads before the desired intersection so that the new road crosses over 
the existing road. The end point for new roads will automatically snap to the nearest vertex of an 
existing road, ensuring an intersection but potentially altering the end point location of the new road. 

7. In the New Road Feature window (Figure 88):
a. In the Road Name text box, type the preferred road name.
b. In the Speed (mph) text box, designate a speed limit in miles per hour.
c. Click OK

Figure 88 New Road Feature window 

8. The user can add multiple roads in a similar fashion (repeating steps 6 & 7).
9. The New Road Feature window can also be used to create recreational trails. Roads not

intended for driving should receive a speed limit of 1 mph.
a. The Transportation Module looks for the fastest route of travel during the Transportation

Scenario Comparison Report. A speed limit of 1 mph will decrease the likelihood that the
new trail is used for driving.

b. However, when a Point of Interest (POI) is located off the Road network, the point is
associated with the nearest road available. If a POI is closest to a user-created trail (with
1 mph speed), the Transportation Module will drive on this slow road.

10. In the Edit Transportation Scenario window click Stop Editing to save edits and click Done to
close the window.

Multiple transportation scenarios can be generated each with multiple roads added or altered. These 
scenarios can then be compared using the Create Comparison Report tool. 

Transportation Scenario Comparison Report 
Comparison reports are tables of travel times between a starting location and all the Points of 
Interest (POIs) within a given radius. Any two transportation scenarios can be compared by creating 
comparison reports: 

1. Under the Transportation menu, choose Create comparison report (Figure 89).

Figure 89 EPA H2O transportation map and location of the Create comparison report tool 

2. The transportation report window will appear (Figure 90).
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Figure 90 Two input methods for the starting point in the Transportation tool 

3. The starting point can be chosen using two input methods (Figure 90):
a. Coordinate capture:

i. In the Starting location box, enter the latitude and longitude coordinates, or click the

Coordinate capture  icon and use the crosshair cursor to select a point on the
map (Figure 91).

Figure 91 Coordinate capture option chosen to indicate a starting point in the Transportation tool 

b. Geocoding address:
i. In the Geocoding address box, enter the full address (Figure 92). All address fields

must be filled out to geocode an address (Address, City, State, Zip code).
ii. Click Submit.
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Figure 92 Geocoding address option chosen to indicate a starting point in the Transportation tool 

4. Once the starting point is chosen, slide the Maximum Distance buffer bar to constrain the
analysis to a set Euclidean distance (miles) to POI’s. POI’s outside this distance will not be
considered.

5. In the Transportation Scenario A and Transportation Scenario B dropdown lists (Figure 93),
choose two different transportation scenarios to compare.

6. Choose the Transportation method, either Walking or Driving:
a. Walking – analyzes routes using a constant walking speed of 8 miles per hour in the

scenario comparisons. It also limits analysis to roads that are safe for pedestrians. The
phrase “No Path” will appear in the comparison report if a point of interest is only
accessible using a highway.

b. Driving – analyzes routes using the speed limit designated in the scenario
comparisons.

Figure 93 Transportation tool with two different scenarios and the Driving method selected 

7. Click Submit to run the comparison and generate a report (Figure 93).
8. A Warning! window may appear (Figure 94). If satisfied with the road changes made, click

Yes. If not, click No and adjust the scenario accordingly.
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Figure 94 Warning! message to confirm changes to Road network 

9. Once generated, a report will open in the system's default PDF reader.
10. The Transportation report contains five main components (Figure 95):

Title – General description of the report, “Transportation network report” 
Starting point – When using the Geocoding address option, this is the address entered. 
If using the Coordinate capture option, this is the latitude and longitude selected. 
User interest point column – Lists the names of the points in the User_POIs layer. 
Scenario A – Column that contains the name of the first network chosen, and the time in 
hh:mm:ss it would take to drive or walk from the starting point to each POI.  
Scenario B – Column that contains the name of the second network chosen, and the time 
in hh:mm:ss it would take to drive or walk from the starting point to each POI. 

Figure 95 Example of the Transportation Network report in EPA H2O 

11. Please note: starting points and ending points that are located off the Roads network are
calculated differently.
a. Starting points will snap to the nearest vertex in a road and calculate travel time from that

point.
b. Ending points will snap to the nearest line in the Road network and calculate travel time

from that spot in the road.
c. Therefore, the Transportation network report is an estimate; point locations and travel

times may vary slightly.

Select POI 
The Parks_and_Recreation layer is used for User_POIs by default. However, the user may add 
points of interest (POIs) to the User_POIs using the Destination Locations dropdown list in the 
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destination locations section (Figure 96) of the transportation tool (Figure 90). There are three options in 
this dropdown list for adding points of interest:  

o Coordinate Capture – by POI coordinate longitude and latitude, or clicking on the map.
o Geocoding Address – by POI address.
o Load Point of Interest file – by .csv file of POI addresses.

Figure 96 Methods of determining Destination Location in EPA H2O Transportation tool 

Coordinate Capture 
1. In the Destination locations dropdown list, choose Coordinate capture (Figure 96).
2. In the Position name text box, enter the desired POI name.

3. In the following text box, enter the longitude and latitude, or click the Coordinate capture
icon and select coordinates on the map for the POI. A blue cross marker will indicate the user-
selected POI on the map (illustrated by arrow in Figure 97).

4. Click on the Add positions(s) button.

Figure 97 Destination location (blue X, indicated by blue arrow) chosen by Coordinate capture 
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 Geocoding Address 
1. In the Destination locations dropdown list, choose Geocoding address (Figure 96).
2. Type in the POI Street Address, City, State, and Zip Code (Figure 98).
3. Click the Submit button. A blue cross marker will indicate the user selected POI on the map.
4. Click on the Add positions(s) button.

Figure 98 Destination location chosen by Geocoding address in Transportation tool 

Load Point of Interest file 
1. In the Destination locations dropdown list, choose Load Point of interest file (Figure 99).

Figure 99 Destination location chosen by Load Point of Interest file in Transportation tool 

2. Click on the Browse button   (under the Destination locations dropdown list) to select the 
user’s POI file on the computer (Figure 99). 

Note: only comma delimited CSV files are acceptable. The CSV file should have the headers 
Name, Address as shown in Figure 100.  
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Figure 100 Sample comma delimited CSV file as Point of Interest in Transportation tool 

Please note: new POIs are not visible until the user refreshes the map (see refresh in Map Navigation 
Toolbar).  

To run a report with the added POIs, click the Submit button under the Transportation method section 
(see Transportation Scenario Comparison Report). New POIs will be located at the bottom of the list.  
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Power Mode

This section illustrates the step-by-step procedure to set EPA H2O to Power Mode by changing the 
registry settings. Power mode allows the user to enable all the default QGIS functionality in EPA 
H2O. A few key features available by enabling the Power Mode include:  

o Use of all the QGIS tools for navigation, analysis, printing etc.
o Installation of QGIS plug-ins and updates to existing plug-ins.
o Customization of EPA H2O user interface layout.
o Ability to develop a new EPA H2O database, as explained in the Database Creation section.

To set EPA H2O to Power Mode: 

1. Ensure EPA H2O is started at least once in the default mode before switching it to the
Power mode.

2. Open Command Prompt from Windows menu on the computer (Figure 101).

Figure 101 Command Prompt located in Windows menu 

3. In a command prompt window, type REGEDIT without spaces before or after the command
and press enter (Figure 102).
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Figure 102 Command Prompt window with REGEDIT command entered 

4. Within the Windows registry window that opens, navigate to file path:
"HKEY_CURRENT_USER(S)\Software\EPAH2O\QGIS\PythonPlugins" 

5. Right-click on the userMode option and select Modify… as shown in Figure 103.

Figure 103 Modify the userMode option 

6. The Edit String window will open (Figure 104). In the userMode key's Value data box, change
from Basic to Power and click OK.
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Figure 104 Change the userMode Value data to Power 

7. Restart the EPA H2O program. The Project Manager window will appear as the EPA H2O
program starts up (Figure 105).

Figure 105 EPA H2O program with access to QGIS menu functionality 

Menus now include File, Edit, View, Layer, Raster, etc., and the user now has access to complete 
QGIS functionality.  

To change EPA H2O back to Basic/default mode, repeat steps in this section but changing the 
userMode key's Value data from Power to Basic.  
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ES Calculations Theory

This section describes the assumptions and theory underlying calculations of ES values assigned in 
reports. This section is for technical users who want to better understand calculations the tool makes so 
that they may adjust inputs to those calculations to make results better reflect their use case. This section 
starts with the Tampa dataset and FLUCCS lookup table included with EPA H2O. All descriptions, 
references and values used in this section are from the Tampa database and FLUCCS lookup table. The 
Database Creation section provides guidance on how to generate new databases and specifics on how to 
update lookup tables to reflect new user inputs. The Edit ES Unit Values section describes how to change 
the specific dollar value per unit of ES used in the calculations. 

Flood Water Retention Value 
The value of flood water retention ($/ft3) is calculated for each land use feature based on its infiltration 
rate, or ability to hold water, measured as the runoff Curve Number (CN) (Figure 106). The lower a CN is, 
the lower its runoff potential. For example, a land use type with a CN of 30 has a very high-water 
retention rate and a low runoff potential, whereas a land use type with a CN of 100 has a very low water 
retention rate and a high runoff potential.  

Figure 106 Flood Water Retention calculation model in EPA H2O 

An area’s Curve Number (CN) is determined based on the area’s main SSURGO hydrologic group 
(“A”, “B”, “C” or “D”) and the area’s land use type. Both these feature characteristics are stored in the 
land use layer and can be updated as described in the Create Soil Data Layer section of database 
creation. 
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The following equations show how the flood water retention volume (“FloodProt” field) and value ($/ft3) 
are calculated from a feature’s CN and area: 

Water retention depth is calculated using the feature’s CN: 
Depth (mm) of water retained = 0.05 * ((25,400mm / CN) – 254mm) 
Depth (m) of water retained = (0.05 * ((25,400mm / CN) – 254mm))) / 1000 

Total volume (m3) of water retained is calculated using this water retention depth (m) and the feature Area 
(m2):   

Volume (m3) of water retained = (0.05 * ((25,400mm / CN) – 254mm))) / 1000 * Area m2 

The Volume (m3) of water retained can be converted from m3 to ft3: 
Volume (ft3) of water retained = Volume retained (m3) * 35.3147 m3/ft3  

To estimate the value of this retention, the Volume (ft3) of water retained is multiplied by the replacement 
cost, the cost to retain the same volume using stormwater infrastructure (“waterRet” field, where the 
default is $2/ft3): 

Total Value ($/ft3) = Volume retained (m3) * 35.3147 m3/ft3 * $2/ft3 

This can be simplified to: 
Total Value ($/ft3) = Volume retained (m3) * $70.629265 

To calculate the value of an area using a different per unit Cost (e.g. $3/ft3) a percent-change multiplier is 
added: 

Total Value ($/ft3) = Volume retained (m3) * $70.629265 * ($3/ft3/$2/ft3) 

The full equation would be: 
Total Value ($/ft3) = (0.05 * ((25,400mm / CN) – 254mm))) / 1000 * Area m2 * 70.629265 * 

(Cost/2) 

Usable Air Value 
The usable air value ($/yr) is calculated for each land use feature based on the pollutants trees on 
that feature will remove, estimated using a local removal rate and the average canopy cover for that 
feature’s land use type (Figure 107). The method used to determine the % Canopy Cover for each 
feature is described in the Tree Canopy section of database creation. Although the “Canopy” field in 
the lookup table is an integer value it represents the % Canopy Cover for each land use type. 
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Figure 107 Air Pollution Removal calculation model in EPA H2O 

The removal rate of carbon monoxide (CO), ozone (O3), particulate matter (PM10), sulfur dioxide, and 
nitrogen dioxide (NO2) were previously estimated for 55 metropolitan areas in the continental United 
States by Nowak et al. (2006), as the dry deposition to tree canopies. Removal rates vary depending on 
location; different estimated rates should be used when creating a database in a different location, 
following the Air Quality section. The following equations use values for Tampa, FL. The following 
equations are tedious, but only need to be solved once and then the lookup table can be used to directly 
relate land use classes to their value ($/m2/yr) for removal of pollutants. 

The estimated values for removal of the selected pollutants in Tampa FL, (Murray et al., 1994), were: 
$ 959/ton Carbon Monoxide 
$6752/ton Ozone 
$1653/ton Sulfur Dioxide 
$4508/ton Particulate Matter (PM10), 
$6752/ton Nitrogen Dioxide 

To get the value of Carbon Monoxide removal by a feature: 
Value ($/yr) = 0.5 g/m2/yr * %Canopy * (1 ton/1000000 g) * Area m2 * 959 $/ton/yr 

To get the value of Ozone removal by a feature: 
Value ($/yr) = 5.8 g/m2/yr * %Canopy * (1 ton/1000000 g) * Area m2 * 6752 $/ton/yr 

To get the value of Sulfur Dioxide removal by a feature: 
Value ($/yr) = 2.4 g/m2/yr * %Canopy * (1 ton/1000000 g) * Area m2 * 1653 $/ton/yr 

To get the value of Particulate Matter (PM10) removal by a feature: 
Value ($/yr) = 4.5 g/m2/yr * %Canopy * (1 ton/1000000 g) * Area m2 * 4508 $/ton/yr 

To get the value of Nitrogen Dioxide removal by a feature: 
Value ($/yr) = 1.1 g/m2/yr * %Canopy * (1 ton/1000000 g) * Area m2 * 6752 $/ton/yr 
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Values from the removal of each pollutant are combined to get the total value of pollutant removal by 
a feature. The values for %Canopy and Area m2 are consistent for a feature across all the pollutants, 
allowing the following simplification of the equation: 

Total Value ($/yr) = 713121.5 * 1-6 (ton/g) * %Canopy * Area m2

The Total Value can also be calculated in ($/m2/yr): 

Total Value ($/m2/yr) = 0.07131215 * %Canopy 

The total removal rate and value for all the pollutants removed (e.g. 0.07131215) will change when 
creating a database for a new location other than Tampa, FL. In the original land use layer, the Total 
Value equation was solved for each feature and stored in the “US_Air_Dol” Field. The lookup table 
now includes a “canopyVal” field with the air pollutant removal rate and value as $/m2/yr. This makes 
calculation of “US_Air_Dol” more transparent and allows the user to update it more easily. See the 
Air Quality section for more directions on updating field values. 

Usable Water Value 
The usable water value ($/yr) is calculated for each land use feature based on the nitrogen that feature 
will removal, estimated using a denitrification coefficient (g N/m2/yr) for that feature’s land use type (Figure 
108).  

Figure 108 Usable Water Value calculation model in EPA H2O 

Denitrification coefficients (g N/m2/yr) are determined from literature values. The literature values used in 
Tampa, FL are shown in Table 2. The characteristics that influence denitrification rates for the same land 
use class may vary from one location to another. For example, in Tampa FL, the rate from Morris 1991 for 
freshwater marshes is reflective of intertidal fresh and salt water marshes, a marsh type not present in 
many other regions. 
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For more developed land use classes, buildings and impervious surfaces will prevent denitrification. 
However, developed land use classes commonly include lawns which have high denitrification rates, 
particularly where lawns are well irrigated and fertilized (Raciti et al. 2011). One denitrification coefficient 
rate was determined for the portion of developed land classes characterized as lawn, 1.4 N/m2/yr (Raciti 
et al. 2011). For each of the developed land use classes this coefficient is reduced proportionately to the 
area of that land use class that is impervious. Methods to calculate and update the coefficients are 
described in in the Denitrification section.    

The costs for reducing nitrogen from point sources are estimated at $8.16 per pound ($18 / kg) of 
nitrogen (Birch et al. 2011). The following equation shows how the usable water value ($/yr) is 
estimated for a land use feature using the feature’s denitrification rate (g N/m2/yr): 

Usable Water Value ($/yr) = Denitrification (g N/m2/yr) * Area (m2) * 1kg/1000g * $18/kg 

Table 2 Denitrification rates assigned to land use classifications 

FLUCCS Land Use Description 

Denitrification 
(g N/m2/yr) 
Average 

Standard 
Deviation 
(g N/m2/yr) References 

Cropland and Pastureland 0.72 0.62 
(Espinoza 1997; Robertson et al. 1987; 
Tsai 1989; Barton et al. 1999) 

Row Crops 3.15 4.75 
(Espinoza 1997; Piña-Ochoa and 
Álvarez-Cobelas 2006; Tsai 1989) 

Tree Crops 0.45 — (Robertson et al. 1987) 

Feeding Operations 0.06 — (E. Cooter, personal communication) 

Nurseries and Vineyards 0.45 — (Robertson et al. 1987) 

Other Open Lands (Rural) 0.82 0.69 (Tsai 1989; Barton et al. 1999) 

Herbaceous 0.06 — (Tsai 1989) 

Shrub and Brushland 0.06 — (Tsai 1989) 

Mixed Rangeland 0.82 0.69 (Tsai 1989; Barton et al. 1999) 

Upland Coniferous Forests 0.12 0.10 (Robertson et al. 1987; Barton et al. 1999) 

Pine Flatwoods 0.12 0.10 (Robertson et al. 1987; Barton et al. 1999) 

Longleaf Pine – Xeric Oak 0.12 0.10 (Robertson et al. 1987; Barton et al. 1999) 

Upland Hardwood Forests 0.19 — (Barton et al. 1999) 

Hardwood Conifer Mixed 0.19 — (Barton et al. 1999) 

Tree Plantations 0.45 — (Robertson et al. 1987) 

Streams and Waterways 20.73 12.52 
(Piña-Ochoa and Álvarez-Cobelas 2006; 
Seitzinger et al. 2006)  
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Lakes 12.16 11.47 

(James et al. 2011; Piña-Ochoa and 
Álvarez-Cobelas 2006; Seitzinger 1988; 
Seitzinger et al. 2006)  

Reservoirs 6.73 5.34 
(James et al. 2011; Brenner et al. 2001; 
Seitzinger 1988; Seitzinger et al. 2006) 

Bays and Estuaries 5.66 3.64 
(Gardner et al. 2006; Seitzinger 1988; 
Yoon and Benner 1992)  

Gulf of Mexico 6.89 6.16 (Fennel et al. 2009; Gihring et al. 2010) 

Wetland Hardwood Forests 25.50 7.21 

(Martin and Reddy 1997; Pinay et al. 
2007; Seitzinger 1994; Walbridge and 
Lockaby 1994)  

Bay Swamps 25.50 — (Seitzinger 1994) 

Mangrove Swamps 0.69 0.65 

(Corredor et al.1999; Kristensen et al.  
1998; Nedwell et al. 1994; Rivera-Monroy 
and Twilley 1996; Sutula et al. 2001)  

Stream and Lake Swamps 25.50 — (Seitzinger 1994) 

Wetland Coniferous Forests 25.50 — (Seitzinger 1994) 

Cypress 24.66 7.39 

(Martin and Reddy 1997; Pinay et al. 
2007; Lindau et al. 2007; Walbridge and 
Lockaby 1994) 

Wetland Forested Mixed 25.50 8.12 
(Seitzinger 1994; Walbridge and Lockaby 
1994; Dodla et al. 2008) 

Vegetated Non-Forested 
Wetlands 28.26 8.09 

(Ensign et al. 2008; Seitzinger 1994; 
Reddy et al. 1989; Martin and Reddy 
1997, Pinay et al. 2007) 

Freshwater Marshes 28.26 8.09 

(Ensign et al. 2008; Martin and Reddy 
1997; Pinay et al. 2007; Reddy et al. 1989; 
Seitzinger 1994) 

Saltwater Marshes 4.52 2.83 
(Craft et al. 2009; Morris 1991; Seitzinger 
et al. 2006)  

Wet Prairies 25.48 8.87 
(Ensign et al. 2008; Martin and Reddy 
1997, Pinay et al. 2007) 

Emergent Aquatic Vegetation 26.22 12.42 
(Ensign et al. 2008; Martin and Reddy 
1997) 

Tidal Flats 10.00 5.67 

(Cabrita and Brotas 2000; Ensign et al.  
2008; Trimmer et al. 2000; Trimmer et al. 
2006)  

Intermittent Ponds 17.44 — (Ensign et al. 2008) 

Seagrass and Algae Beds  5.00  — (Eyre and Ferguson 2002) 
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Carbon Sequestration Value 
The carbon sequestration value ($/yr) is calculated for each land use feature based on the carbon 
that feature will sequester, estimated using a carbon fixation coefficient (g C/m2/yr) for that features 
land use type (Figure 109). Carbon sequestration coefficients (g C/m2/yr) will differ significantly 
depending on if the carbon is being fixed into biomass or buried. 

Figure 109 Stable Climate Value calculation model in EPA H2O 

Carbon sequestration coefficients (g C/m2/yr) are determined from literature values. The literature values 
used in Tampa, FL are shown in Table 3. Carbon fixed into biomass may later be removed and re-
released (e.g. crops fix carbon but are harvested for consumption) whereas carbon that is buried is more 
likely to remain in the soil even if the vegetation is removed. The characteristics that influence carbon 
sequestration rates for the same land use class may vary from one location to another. For example, in 
Tampa FL, the rate from Chmura et al. 2003 for saltwater marshes is reflective of mangroves, a marsh 
type not present in many other regions. 

For more developed land use classes buildings and impervious surfaces will not contribute to carbon 
sequestration. However, developed land use classes commonly include trees and lawns which have high 
carbon sequestration rates, particularly where lawns are cut and mulched in place (Pouyat et al., 2009). 
One carbon sequestration rate was determined for the portion of developed land classes characterized as 
having trees, 28 g C/m2/yr (average carbon sequestration rate for all tree land use types), and for lawns, 
100 g C/m2/yr (Table 4 summarizes the references used to calculate the Lawn Rate coefficient for 
“Recreational”, “Open Land”, “Residential Low Density” and “Golf Courses” land use types). For each of 
the developed land use classes these per unit area coefficients are reduced proportionately to the percent 
of that area that is impervious. The tree rate is reduced proportional to the canopy cover for that land use 
class, and the lawn rate is reduced proportional to the percent impervious for that land use class. The 
carbon sequestration by trees or lawns are then combined to get the coefficient for that developed land 
use class. Methods to calculate and update the coefficients are described in the Carbon Sequestration 
section.    
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The social costs for emitting carbon to, and inversely the value of sequestering the same amount from, 
the atmosphere are estimated at $37 per ton of Carbon Dioxide (US Government, 2010). To convert this 
to $ per ton of Carbon removed, the molecular mass of carbon dioxide (44.0095 g/mol) is compared to 
that of carbon (12.0107 g/mol), for a factor of 3.66 times, or a cost of $135.42 per ton of Carbon. The 
following equation shows how the stable climate value ($/yr) is estimated for a land use feature using the 
feature’s carbon fixation rate (g C/m2/yr): 

Stable Climate Value ($/yr) = Carbon Fixation (g/m2/yr) * Area (m2) * 1-6 (ton/g) * $37/ton * 3.66 
Stable Climate Value ($/yr) = Carbon Fixation (g/m2/yr) * Area (m2) * 1-6 (ton/g) * $135.42/ton 

Table 3 Carbon sequestration rates assigned to non-Developed land use classifications 

FLUCCS Land Use Description 

Carbon 
Sequestration 
(g C/m2/yr) 
Average 

Standard 
Deviation 
(g C/m2/yr) References 

Open Land 611 229 (Ajtay et al. 1979; Milesi et al. 2005) 

Cropland and Pastureland 423 — (Ajtay et al. 1979) 

Row Crops 959 758 (Ajtay et al. 1979; Schlesinger 1999) 

Tree Crops 571 283 
(Ajtay et al. 1979; Clark et al. 1999; 
Montagnini and Nair 2004)  

Feeding Operations 
423 — (Ajtay et al. 1979) 

Nurseries and Vineyards 571 283 
(Ajtay et al. 1979; Clark et al. 1999; 
Montagnini and Nair 2004)  

Other Open Lands 
(Rural) 673 235 (Ajtay et al. 1979; Milesi et al. 2005) 

Herbaceous 743 286 
(Ajtay et al. 1979) 

Shrub and Brushland 945 — (Ajtay et al. 1979) 

Mixed Rangeland 540 — (Ajtay et al. 1979) 

Upland Coniferous 
Forest  698 32 (Ajtay et al. 1979; Kroeger 2008) 

Pine Flatwoods 698 32 (Ajtay et al. 1979; Clark et al. 1999) 
Longleaf Pine – Xeric 
Oak  313 359 

(Ajtay et al. 1979; Clark et al. 1999; 
Kroeger 2008)  

Upland Hardwood 
Forests  590 113 

(Ajtay et al. 1979; Clark et al. 1999; 
Kroeger 2008)  

Hardwood Conifer Mixed 660 85 
(Ajtay et al. 1979; Kroeger 
2008)  

Tree Plantations 731 79 (Ajtay et al. 1979; Clark et al. 1999) 

Streams 180 — (Ajtay et al. 1979) 

Lakes 397 141 
(Carpenter et al. 1998; Carrick et al. 
1993)  



88 

Reservoirs 368 112 
(Carpenter et al. 1998; Carrick et al. 
1993; Knoll et al. 2003) 

Bays and Estuaries 195 205 (Zieman et al.1999) 

Ocean and Gulf of Mexico 115 — (De Vooys 1979) 
Gulf of Mexico 115 — (De Vooys 1979) 
Wetland Hardwood 
Forests  808 299 (Lugo et al. 1988) 

Bay Swamps 808 299 (Lugo et al. 1988) 

Mangrove Swamp 778 672 

(Chmura et al. 2003; Duarte et al. 2005; 
Eong 1993; Estevez and Mosura 1985; 
Kroeger 2008)  

Stream and Lake 
Swamps 
(Bottomland) 808 299 (Lugo et al. 1988) 
Wetland Coniferous 
Forests  298 181 (Kroeger 2008) 

Cypress 241 256 (Clark et al. 1999; Kroeger 2008) 

Wetland Forested 
Mix  552 — (Kroeger 2008) 
Vegetated Non-Forested 
Wetlands 142 — (Kroeger 2008) 

Freshwater Marshes 618 — (Smith et al. 1983) 

Saltwater Marshes 492 628 

(Chmura et al. 2003; Choi and Wang 
2004; Duarte et al. 2005; Lewis III and 
Estevez 1988; Smith et al. 1983)  

Wet Prairies 142 — (Kroeger 2008) 

Emergent Aquatic Vegetation 142 — (Kroeger 2008) 

Tidal Flats 195 205 
(Zieman et al.1999) 

Intermittent Ponds 142 — (Kroeger 2008) 

Seagrass 814 363 
(Duarte et al. 2005; Lewis III and Estevez 
1988)  

Table 4 Carbon sequestration rates used to calculate the lawn rate coefficient 

FLUCCS Land Use Description 

Carbon 
Sequestration 
(g C/pixel) 
Average 

Standard 
Deviation 
(g C/m2/yr) References 

Recreational 18 — (Pouyat et al. 2009) 

Open Land 3 — (Pouyat et al. 2010) 
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Residential Low Density 382 — (Pouyat et al. 2009, Raciti et al. 2011) 

Golf Courses 95 — (Qian and Follett 2002) 
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Database Creation

The default database provided with EPA H2O (TampaBay.sqlite) only includes data for the Tampa Bay 
estuary and watershed. However, .sqlite databases compatible with the EPA H2O tool can be created for 
other areas of interest. This section illustrates the step-by-step procedure for creating .sqlite databases 
for use in EPA H2O’s Advanced Module.  

Please note: 
1. Database creation requires EPA H2O to be in Power Mode.
2. EPA H2O Basic Module can only be used for the Tampa Bay region unless data layers are
updated for other areas; scenario comparisons in other regions must be done using the EPA H2O
Advanced Module.

New .sqlite databases can be created for any area in the contiguous United States using default data 
sources (Table 5). Depending on the area of the new database, an alternative data source may be 
available. In the Tampa Bay area, most of the default data sources were used for the database (Table 
6). One exception was the land use dataset used, the Florida Land Use Cover Classification System 
(FLUCCS), a higher resolution dataset only available within the State of Florida. The lookup table 
used to assign Ecosystem Service coefficients is based on the land use layer classification, meaning 
the lookup table included in the Tampa Bay database will not work for other land use classifications 
such as the default NLCD. A new national lookup table for NLCD is included in Appendix A: 
Supplemental NLCD Lookup Table. The database creation section uses this lookup table and the 
default NLCD dataset. Appendix D: Extracting and Updating the Original FLUCCS Lookup Table 
describes how the Tampa Bay database lookup table can be updated to create databases using 
FLUCCS. Both lookup tables may be updated with more regionally specific values. The NLCD 
Percent Tree Canopy data do not need to be downloaded if the lookup table Canopy Cover values are 
not being updating. 

Table 5 Default Data Sources with national scope for new user databases 

Dataset Download Instructions Download Link 
USGS Watershed 
Boundaries: HUC_8 .shp 

Download HUC Boundaries https://viewer.nationalmap.gov/basic/?b
asemap=b1&category=nhd&title=NHD
%20Vie 

National Land Cover 
Database (NLCD) 2011 

Download Land Use Data https://www.mrlc.gov/data/nlcd-2011-
land-cover-conus-0 

SSURGO: Soil Classification Download Soil Data https://websoilsurvey.sc.egov.usda.gov/
App/WebSoilSurvey.aspx 

NLCD 2011 Percent Tree 
Canopy 

Download Tree Canopy 
Data 

https://www.mrlc.gov/data/nlcd-2011-
usfs-tree-canopy-cover-conus 

TIGER/Line Roads Download TIGER/Line data https://www.census.gov/cgi-
bin/geo/shapefiles/index.php 

Maximum Speed Download Max Speed data Must be obtained by user on a state or local 
scale, or be created by user.  

NHD+_V2 Hydrography 
(Catchments, Basins and 
Flow directions) 

Download NHDPlus Data https://nhdplus.com/NHDPlus/NHDPlus
V2_data.php 

https://viewer.nationalmap.gov/basic/?basemap=b1&category=nhd&title=NHD%20Vie%20
https://viewer.nationalmap.gov/basic/?basemap=b1&category=nhd&title=NHD%20Vie%20
https://viewer.nationalmap.gov/basic/?basemap=b1&category=nhd&title=NHD%20Vie%20
https://www.mrlc.gov/data/nlcd-2011-land-cover-conus-0
https://www.mrlc.gov/data/nlcd-2011-land-cover-conus-0
https://websoilsurvey.sc.egov.usda.gov/App/WebSoilSurvey.aspx
https://websoilsurvey.sc.egov.usda.gov/App/WebSoilSurvey.aspx
https://www.mrlc.gov/data/nlcd-2011-usfs-tree-canopy-cover-conus
https://www.mrlc.gov/data/nlcd-2011-usfs-tree-canopy-cover-conus
https://www.census.gov/cgi-bin/geo/shapefiles/index.php
https://www.census.gov/cgi-bin/geo/shapefiles/index.php
https://nhdplus.com/NHDPlus/NHDPlusV2_data.php
https://nhdplus.com/NHDPlus/NHDPlusV2_data.php
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Original EPA H2O database Included in Installing EPA 
H2O 

User copy of TampaBay.sqlite 
saved in any directory EXCEPT 
‘C:/Users/<USER_NAME>/.qgis/
0.0.3/data/database/’  

Setting Up a Project 
Directory 

Table 6 Data Sources used to create original TampaBay.sqlite database 

Dataset Download Link File Names 
USGS Watershed 
Boundaries: HUC_8 
.shp 

https://nhd.usgs.gov/data.html hucs00m020_nt00013.tar.gz to obtain 
WBDHU8.shp 

State of Florida 
FLUCCS Land Use 

https://www.swfwmd.state.fl.us/re
sources/data-maps 

2006_Land_Use_Land_Cover.zip 

SSURGO: Soil 
Classification 

https://websoilsurvey.sc.egov.usd
a.gov/App/WebSoilSurvey.aspx

wss_SSA_FL049_soildb_FL_2003_[201
7-10-05].zip (Hardee county)
wss_SSA_FL057_soildb_FL_2003_[201
7-10-04].zip (Hillsborough county)
wss_SSA_FL081_soildb_FL_2003_[201
7-10-02].zip (Manatee county)
wss_SSA_FL101_soildb_FL_2003_[201
7-10-02].zip (Pasco county)
wss_SSA_FL103_soildb_FL_2003_[201
7-10-02].zip (Pinellas county)
wss_SSA_FL105_soildb_FL_2003_[201
7-10-06].zip (Polk county)

TIGER/Line Roads https://www.census.gov/cgi-
bin/geo/shapefiles2013/main 

tl_2013_12049_roads.zip (Hardee) 
tl_2013_12057_roads.zip (Hillsborough) 
tl_2013_12081_roads.zip (Manatee) 
tl_2013_12101_roads.zip (Pasco) 
tl_2013_12103_roads.zip (Pinellas) 
tl_2013_12105_roads.zip (Polk) 

Maximum Speed https://www.arcgis.com/home/ite
m.html?id=4a61f17ab4784202ae
10d7d5fb3bf9de#overview 

maxspeed.zip 

NHD+_V2 
Hydrography 
(Catchments, Basins 
and Flow directions) 

https://nhdplus.com/NHDPlus/NH
DPlusV2_data.php 

NHDPlusV21_SA_03S_NHDPlusAttribute
s_02.7z  
NHDPlusV21_SA_03S_NHDPlusCatchm
ent_01.7z  
NHDPlusV21_SA_03S_NHDPlusBurnCo
mponents_02.7z 
NHDPlusV21_SA_03S_NHDSnapshot_03
.7z  

https://nhd.usgs.gov/data.html
https://www.arcgis.com/home/item.html?id=4a61f17ab4784202ae10d7d5fb3bf9de%23overview
https://www.arcgis.com/home/item.html?id=4a61f17ab4784202ae10d7d5fb3bf9de%23overview
https://www.arcgis.com/home/item.html?id=4a61f17ab4784202ae10d7d5fb3bf9de%23overview
https://nhdplus.com/NHDPlus/NHDPlusV2_data.php
https://nhdplus.com/NHDPlus/NHDPlusV2_data.php
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Setting Up a Project Directory 
During installation EPA H2O creates a default database for the Tampa Bay area (TampaBay.sqlite). 
A new database must be created to use EPA H2O for a different area. The following steps show the 
procedure to set up a directory for the new database; hereafter referred to as the User Folder.  

On a Windows machine, by default QGIS data are stored in a ".qgis" folder found in the current user’s 
home directory .  

1. Using File Explorer , COPY the directory ‘C:\Users\<USERNAME>\.qgis\0.0.3\’ to another
location in the user directory, e.g.('C:\Users\<USERNAME>\My Documents\0.0.3\') (Figure 110).

Figure 110 Create a copy of the 0.0.3 folder in File Explorer 

2. Make sure the folder contents were copied properly, including the “data” folder, “projects” folder,
and the TampaBay.sqlite database.

3. Right-click on the new copy of the EPA H2O database (TampaBay.sqlite), choose Rename,
and rename the new database (for example, UserDatabase.sqlite in Figure 110). The
database MUST BE RENAMED; the Qspatialite plug-in cannot connect to two different
databases with the same file name regardless of their file paths.

Set Up ArcGIS Map Document 

1. Open ArcMap from the Start menu > All Programs > ArcGIS > ArcMap.
2. Right-click on the Layers icon in the Table of Contents. From the dropdown list, choose the

Properties option (Figure 112).

file://AA/ORD/GBR/Data/lab/TampaPilot/Decision%20Support%20Tool/Help%20Manual/explorer.exe
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Figure 112 Layer Properties location in ArcMap          

3. The Data Frame Properties window will open (Figure 111). Under the Coordinate System tab,
choose Web Mercator Auxiliary Sphere. It is located under Projected Coordinate System > World,
or can be located by typing 3857 in the search field and hitting enter, as shown in Figure 111.

4. Once the coordinate system is selected, it will appear in blue. Click OK.
5. It is suggested that the user save their created map document, in .mxd format (File > Save As…).

Set Up QGIS Map Document 

1. Open EPA H2O in Power Mode.
2. In the Choose a Module window, click OK (Figure 113).

Figure 111 Set Coordinate System for Data Frame 
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Figure 113 EPA H2O Choose a Module window 

3. In the Select Project window, select Open existing project or Create new project. For first time
Power Mode users, choose Create new project (Figure 114).

Figure 114 EPA H2O Select Project window 

4. In the Project Configuration window (Figure 115), confirm that the Source Database Name is
referencing the original TampaBay.sqlite.
a. If the source database is not the original TampaBay.sqlite, click the Select button, and

navigate to the original “0.0.3” folder.
5. In the Name Your Project Database box, enter the preferred project name (e.g. Demo), and

click OK.
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Figure 115 Project Configuration window 

6. In the Select Area of Interest window, click Cancel.
7. From the Settings dropdown (Figure 116) open the Project Properties window (Main Menu >

Settings > Project Properties).

Figure 116 Location of Project Properties in EPA H2O 

8. In the Project Properties window (Figure 117):
a. Click the Coordinate Reference System (CRS) tab and check the box labeled Enable 'on

the fly' CRS transformation.
b. In the Filter text box, type 3857. Under the Coordinate reference systems of the world

section, select WGS 84 / Pseudo Mercator.
c. Click OK to apply these changes and close the Project Properties window.
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Figure 117 Set the Coordinate Reference System in EPA H2O 

9. It is suggested that the user save their created map document, in .qgs format (File > Save
Project As).
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Create HUC Watershed Boundaries 

A Watershed defines the area upstream of a point (e.g. an outflow point) where flows of water will be 
directed to that point. Hydrologic Unit Codes (HUC) are unique codes assigned watershed boundaries 
that vary in length (2-14 digits) depending of the scale of the watershed. At the broad scale, each 
region of the United States has a unique 2-digit Hydrologic Unit (Figure 118). For example, Tampa Bay 
is within the HUC 03 South-Atlantic Gulf region. At broader scales (2-digit), HUC watersheds match 
the NHDPlus catchments, but at finer scale (14-digit) there may be differences. HUC boundaries are 
often used to define the Area of Interest (AOI) for a new EPA H2O database because these 
boundaries are similar to the NHDPlus catchments used to define upstream areas. 

Figure 118 HUC Region Number for the entire United States and U.S Caribbean territories 

Download HUC Boundaries 

This section illustrates the step-by-step procedure to download the HUC watershed boundary 
dataset from the USGS Website by HU-2 region.  

1. Navigate to the following link, to open the USGS National Map website (Figure 119):
https://viewer.nationalmap.gov/basic/?basemap=b1&category=nhd&title=NHD%20Vie

https://viewer.nationalmap.gov/basic/?basemap=b1&category=nhd&title=NHD%20Vie%20
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Figure 119 USGS National Map download website 

2. Click-and-drag on the National Map to pan and use the Zoom in  icon to zoom in to the user’s 
AOI (e.g. Tampa Bay).

3. In the Product Search Filter section, check the Watershed Boundary Dataset (WBD) option
(Figure 120).

Figure 120 Search for all Watershed Boundary Datasets available for the Tampa Bay area 

4. Click the Find Products icon, located above the Product Search Filter box.
5. The available USGS Watershed Boundary Datasets for the user’s AOI will replace the search

filters (Figure 121). The product name will include the 2-digit Hydrologic Unit (03 for Tampa).
6. Locate the USGS Watershed Boundary Dataset (WBD) file in the Product list with Format:

Shapefile. It is strongly suggested that the user download the shapefile, and not the file
geodatabase. In the Actions column, click the corresponding Download link.



99 

Figure 121 Download the USGS Watershed Boundary Shapefile for Hydrologic Unit 03 

7. Save the zip file to the computer and unzip the contents to a known location.

The next section illustrates the creation of EPA H2O compatible watershed boundary data from the 
unzipped download file, either using Esri ArcGIS software (Using ArcGIS) or QGIS (Using QGIS). 

Using ArcGIS 

This section illustrates the creation of EPA H2O compatible HUC watershed boundary data using 
Esri ArcGIS software (About GIS).  

1. Download and unzip the HUC Watershed Boundary data, as shown in the Download HUC
Boundaries section.

2. Open your existing ArcGIS map document file (.mxd), or create one following the steps
outlined in Set Up ArcGIS Map Document.

3. Use the Add Data  icon to navigate to the unzipped HUC watershed boundary dataset.
Select the WBDHU8.shp file and add the layer to the Table of Contents of the map document.

4. Use the Select Features icon to select watersheds that overlap the area of interest: 
a. Watersheds are selected either by clicking and dragging a rectangle around them, or by

clicking on each while holding the Shift key.
b. If an incorrect watershed is selected, clear the current selection by clicking the Clear

Selection  icon. 

Selected features are indicated by a cyan blue border. For example, watersheds surrounding Tampa Bay 
are shown selected in Figure 122.  
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Figure 122 Watersheds selected for the Tampa Bay area in ArcMap 

5. Once the watersheds of interest are selected, right-click on the WBDHU8 layer in the Table of
Contents, and choose Data > Export Data, as shown in Figure 123.

Figure 123 Export the selected watershed data using the Export Data button 

6. In the Export Data window (Figure 124):
a. In the Export dropdown list, select Selected features.
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b. Under Use the same coordinate system as, toggle the data frame option.
c. In the Output feature class text box, type the desired shapefile name (e.g. HUC_Tampa).
d. Click OK.

Figure 124 Export Data window 

7. A window may appear that asks: “Do you want to add the export data to the map as a layer?”
(Figure 125). If so, click Yes.

Figure 125 ArcMap window, which will add the newly exported data to the Table of Contents 

The Importing Layers into QGIS section details how to upload the HUC watershed boundary into the 
user database in QGIS. Database creation is continued in the Create Land Use Data Layer section. 

Using QGIS 

This section illustrates the creation of EPA H2O compatible HUC watershed boundary data using 
QGIS software (About QGIS).  

1. Download and unzip the HUC Watershed Boundary data, as shown in the Download HUC
Boundaries section.

2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined
in Set Up QGIS Map Document.

3. From the Layer menu (Figure 126) open the Add Vector Layer window (Main Menu > Layer >
Add Vector Layer).
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Figure 126 Location of the Add Vector Layer tool in EPA H2O 

4. In the Add vector layer window (Figure 127), click Browse to locate and select the unzipped
HUC watershed boundaries file (e.g. WBDHU8.shp), then click Open.

Figure 127 Add vector layer window in EPA H2O 

5. Use the Zoom In  icon to zoom to the area of interest. 
6. From the View menu, activate the Select Single Feature tool (Main Menu > View > Select

Single Feature, Figure 128).
7. While holding the Ctrl key, select the specific watersheds in the area of interest. Alternatively,

other selection tools may be used to make the selection, such as selecting watersheds by
drawing a rectangle around them using the Select Features by Rectangle tool.

Figure 128 Select Single Feature in EPA H2O 
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Selected watersheds will be highlighted in yellow; Figure 129 shows watersheds selected in 
the Tampa Bay area. 

Figure 129 Selected watersheds in the Tampa Bay area 

8. With the area-specific watersheds selected, use the Layer menu (Figure 130) to open the
Save Selection as Vector File window (Main Menu > Layer > Save Selection as Vector
File…).

Figure 130 Save the selected watersheds as a vector file in EPA H2O 

9. In the Save vector layer as… window (Figure 131):
a. In the Format dropdown list, select ESRI Shapefile.
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b. In the Save as box, browse to or type the desired output shapefile name and file path
(e.g. HUC_Tampa_QGIS.shp).

c. In the CRS dropdown list, choose Layer CRS; NAD83 should show as the CRS
automatically.

d. Check Add saved file to map.
e. Do not check Skip attribute creation.
f. Click OK.

Figure 131 Save vector layer as… window in EPA H2O 

This user-specific watershed shapefile (with NAD83 projection) will be used to clip the land use data in 
the Create Land Use Data Layer section. The user must create a second copy of the watershed 
shapefile to upload into the user database, with WGS84/ Pseudo Mercator projection. 

10. Right-click on the HUC watershed boundary layer (e.g. HUC_Tampa_QGIS) in the Layers panel
and choose Save As... (Figure 132).

Figure 132 Location of the Save As… tool in EPA H2O 
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11. In the Save vector layer as… window (Figure 133):
a. From the Format dropdown list, select ESRI Shapefile.
b. In the Save as box, browse to or type the preferred file path and shapefile name (e.g.

HUC_Tampa_reproj.shp).
c. In the CRS dropdown list, choose Selected CRS, and click Browse.
d. In the Coordinate Reference System Selector window that opens (Figure 134), type 3857

in the Filter box, choose WGS 84/ Pseudo Mercator and click OK.
e. Be sure to check Add saved file to map. Do not check Skip attribute creation.
f. Click OK.

Figure 133 Save vector layer as… window in EPA H2O 
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Figure 134 Select WGS 84/ Pseudo Mercator as the Coordinate Reference System 

The Importing Layers into QGIS section details how to upload this re-projected HUC watershed 
boundary into the Qspatialite user database in QGIS. Database creation is continued in the Create 
Land Use Data Layer section, where the other HUC watershed boundary (with NAD83 projection) will 
be used to clip the land use data.  
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Create Land Use Data Layer 
The land use data layer is essential to several H2O functions. Several attributes in the land use layer 
are characterized using other datasets in addition to the initial land cover classification. For example, 
the EPA H2O tool computes the dollar value of flood protection based on Curve Number (CN). The 
land use layer is where Curve Number (CN) values, characterized using land cover and soil type, are 
attributed. 

Land cover data can be obtained from a variety of sources, at a variety of resolutions or times, and 
may be based on a variety of classification systems. More detailed land cover datasets are often 
available at more limited scales and offer more value when differentiating between areas in EPA 
H2O, but more detailed land cover data is rarely available across all areas.  

The Tampa database that comes with the EPA H2O tool uses the Florida Land Use Cover 
Classification System (FLUCCS) as the land cover layer. Although this land cover dataset uses a 
very detailed land use classification system, covering more classes than the National Land Cover 
Dataset (NLCD), it is only available for Florida. Since the National Land Cover Dataset (NLCD) 
covers the entire United States, and is updated at a regular interval, it is recommended for areas of 
interest where other, more detailed land use data is not available. For this reason, this section will 
describe how to download the National Land Cover Dataset (NLCD) and process it to prepare the 
land use data layer. 

Either Esri ArcMap software or QGIS can be used to prepare the land cover data. The procedure for 
both software applications is explained in this section.  

Download Land Use Data 

This section illustrates the step-by-step procedure for downloading NLCD 2011 Land Cover datasets 
from the MRLC database.  

1. Navigate to https://www.mrlc.gov/viewer/ as shown in Figure 135.

Figure 135 MRLC website, download NLCD Land Cover by AOI

https://www.mrlc.gov/viewer/
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2. Click-and-drag on the National Map to pan and use the Zoom in  icon to zoom in to the user’s AOI 
(e.g. Tampa Bay).

3. In the Contents section, under the NLCD Land Cover dropdown list, check the 2011 CONUS Land
Cover option (or the preferred display year).

4. From the map viewer toolbar, click the Open Data Download Tool  icon and click to draw a 
bounding box around the user’s AOI (Figure 136).

5. Under the Data Download dropdown list, check the Land Cover option and toggle All Land Cover
Years (Figure 137).

Figure 136 MRLC viewer with bounding box drawn around Tampa Bay AOI

Figure 137 Data Download dropdown list
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6. In the Email text box, enter the user’s email address (e.g. user@epa.gov), then click Download.
7. A notification will appear indicating the download request has been sent. Click OK (Figure 138).

8. The download link will be emailed to the user by the USGS server. Click the first link in the email
to download the NLCD zip file.

9. Save the zip file to the computer and unzip the contents to a known location.

The next section illustrates the creation of EPA H2O compatible land use data from the unzipped 
download file, using either Esri ArcGIS software (Using ArcGIS) or QGIS (Using QGIS). 

Using ArcGIS 

This section illustrates the creation of EPA H2O compatible land use data using Esri ArcGIS 
software.  

1. Download and unzip the NLCD datasets, as shown in the Download Land Use Data section,
and locate the appropriate HUC boundaries for the study area, as shown in the Create HUC
Watershed Boundaries section.

2. Open your existing ArcGIS map document file (.mxd), or create one following the steps
outlined in Set Up ArcGIS Map Document.

3. Use the Add Data  icon to navigate to the NLCD 2011 .tif dataset (or most recent year) and 
add the layer to the Table of Contents of the map document. 

4. If using a new map document, the shapefile created in the Create HUC Watershed Boundaries
section must be added in the same way.

The watershed layer should represent a smaller, more focused area, whereas the new land use layer will 
be a larger bounding box around the AOI (Figure 139). 

Figure 138 MRLC request notification
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5. Click on the Toolbox  icon to open ArcToolbox.
6. From the ArcToolbox window, navigate to and open the Clip tool (ArcToolbox > Data

Management Tools > Raster > Raster Processing > Clip, Figure 140).

7. In the Clip tool window (Figure 141):
a. In the Input Raster text box, select the user-specific NLCD dataset (e.g.

NLCD_2011_Land_Cover_L48_20190424_umtxeyAuXzMnsc7vNE8j.tiff).

Figure 139 NLCD 2011 dataset, displayed with Tampa Bay watershed shapefile

Figure 140 Location of the Clip tool in ArcToolbox
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b. In the Output Extent text box, select the HUC watershed boundary shapefile (e.g.
HUC_Tampa).

c. Check the Use Input Features for Clipping Geometry option.
d. In the Output Raster Dataset text box, browse to or type the desired file name (e.g.

NLCD_Tampa) and file path.
e. Click OK.

Figure 141 Clip tool window in ArcMap 

8. The output is a raster dataset, which needs to be converted to a polygon layer for future
processing.

9. From the ArcToolbox window, navigate to and open the Raster to Polygon tool (ArcToolbox >
Conversion Tools > From Raster > Raster to Polygon).

10. In the Raster to Polygon window (Figure 142):
a. In the Input Raster text box, select the clipped NLCD raster dataset (e.g. NLCD_Tampa).
b. In the Field text box, choose VALUE.
c. In the Output polygon features text box, name the output (e.g. NLCD_Tampa_poly.shp) and

file path.
d. Check the Simplify polygons option if not already checked.
e. Click OK.
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Note: The Simplify polygons option removes vertices along sides of polygons to smooth and simplify the 
polygon edges, but this option is not available if using QGIS. To create a more comparable land use layer 
using ArcGIS, the user must uncheck the Simplify polygons option in the Raster to Polygon tool.  

11. From the ArcToolbox window, navigate to and open the Project tool (ArcToolbox > Data
Management Tools > Projections and Transformations > Project, Figure 143).

12. In the Project tool window (Figure 144):
a. In the Input Dataset or Feature Class box, select the clipped NLCD polygon (e.g.

NLCD_Tampa_poly).

Figure 142 Raster to Polygon tool

Figure 143 Location of the Project tool in ArcToolbox
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b. The Input Coordinate System automatically lists the input dataset coordinate system (e.g.
NAD_1983_Albers).

c. In the Output Dataset or Feature Class text box, browse to or type the desired file name (e.g.
NLCD_Tampa_poly_reproj.shp) and file path.

d. Click the Spatial Reference  icon to set the Output Coordinate System to
WGS_1984_Web_Mercator_Auxiliary_Sphere, located under the World folder in Projected
Coordinate Systems. Alternatively, search for it by typing 3857 into the search box.

e. A Geographic Transformation is required to reproject the land use dataset. In the dropdown
list, choose WGS_1984_(ITRF00)_To_NAD_1983, if not already listed in the box.

f. If the wrong Geographic Transformation is listed, click on the name, and click the X button to
remove it.

g. Click OK.

This re-projected output is used to complete a spatial join with the soil dataset in the section. 
Database creation is continued in the Create Land Use Comparison Data section.  

Using QGIS 
This section illustrates the creation of EPA H2O compatible land use data using QGIS software. 

1. Download and unzip the NLCD land use data, as shown in the Download Land Use Data
section.

Figure 144 Project tool window in ArcMap
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2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined
in Set Up QGIS Map Document.

3. In the Add vector layer window (example shown in Figure 127), click Browse to locate and
select the previously created HUC watershed boundary shapefile, then click Open.
a. Ensure this HUC watershed boundary shapefile has the correct projection of NAD83 and is

not the shapefile that was re-projected to input into the Qspatialite user database.
4. From the Layer menu, open the Add Raster Layer window (Main Menu > Layer > Add Raster

Layer…, Figure 145).

a. Navigate to the NLCD 2011 land use layer (or most recent year) previously downloaded in
Download Land Use Data section (e.g.
NLCD_2011_Land_Cover_L48_20190424_umtxeyAuXzMnsc7vNE8j.tiff).

b. Choose the file with the “.tif” extension.
c. Click Open.

5. The NLCD 2011 layer needs to be re-projected from the “Custom” projection to WGS 84/ Pseudo
Mercator. From the Raster menu, open the Reproject tool (Main Menu > Raster > Projections >
Warp (Reproject), Figure 146).

6. In the Warp (Reproject) window (Figure 148):
a. In the Input file dropdown list, select the user-specific NLCD layer (e.g.

NLCD_2011_Land_Cover_L48_20190424_umtxeyAuXzMnsc7vNE8j.tiff).
b. Click Select next to the Output file text box to select a file path and name for the output (e.g.

NLCD_FL_reproj.tif). Be sure to name the output with a .tif extension.
c. Check the Source SRS box, and click Select to open the Select the source SRS window.
d. In the Select the source SRS window (Figure 147):

i. Under the Recently used coordinate reference systems section, choose the *
Generated CRS (+proj = aea…) SRS.

ii. Click OK.
e. Check the Target SRS box and click Select to open the Select the target SRS window.

Figure 145 Location of the Add Raster Layer… tool in EPA H2O

Figure 146 Location of the Warp (Reproject) tool in EPA H2O
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f. In the Filter box, type 3857, and under Coordinate reference systems of the world, choose
WGS 84/ Pseudo Mercator. Click OK.

g. Check Load into canvas when finished.
h. Click OK.

7. This reprojection may take a few minutes to process. When a Finished window appears, click OK
to continue.

8. Once the reprojection is complete, click Close to close the Warp tool.
9. The re-projected NLCD layer will appear added to the Layers panel. The original NLCD layer will

also be listed and can be removed to avoid confusion by right-clicking on the layer and choosing
Remove.

10. The re-projected NLCD layer will be “clipped” down to the area of interest. From the Raster menu,
open the Clipper tool (Main Menu > Raster > Extraction > Clipper, Figure 149).

Figure 148 Warp (Reproject) tool window in EPA H2O Figure 147 Select source SRS window, with * 
Generated CRS highlighted 
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11. In the Clipper window (Figure 150):
a. In the Input file dropdown list, select the re-projected NLCD layer (e.g. NLCD_FL_reproj), if

not selected by default.
b. Click Select next to the Output file text box to select a file path and name for the output (e.g.

NLCD_HUC_clip.tif). Be sure to name the output with a .tif extension.
c. Check the box next to No Data Value and choose the default value of 0.
d. In the Clipping mode section, choose Mask layer and select the user-specific HUC watershed

boundary shapefile as the Mask layer, if not selected by default (e.g. HUC_Tampa_QGIS).
e. Check Load into canvas when finished.
f. Click OK.

12. When a Finished window appears, click OK to continue.
13. Click Close to close the Clipper tool after processing is complete.

Figure 149 Location of the Clipper tool in EPA H2O

Figure 150 Clipper tool window in EPA H2O
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Troubleshooting Common Errors: 
Problem: 

A common error with the Clipper tool results in the clipped 
land use layer being shifted from the original shapefile 
location, as shown in Figure 151. This shift occurs if the 
wrong HUC watershed boundaries shapefile was used as 
the Mask layer in the clipper tool. 

Solution: 
Clip the raster using the clipper tool again, repeating steps 
10-13, using the re-projected NLCD layer and the HUC
watershed boundary shapefile first created in the Using
QGIS section. The HUC watershed boundary shapefile
projection should be NAD83. The outline of the resulting
raster from the clipper tool should align with the outline of
the watershed boundary.

After the NLCD raster is clipped to the area of interest it must be converted to a polygon (vector) 
dataset. First a grid of polygons aligned with the raster cells is generated, then points within each 
raster cell are generated to sample the raster and copy the values over to the new grid of polygons. 

14. From the Vector menu, open the Vector grid tool (Main Menu > Vector > Research Tools > Vector
grid, Figure 152).

15. In the Vector grid window (Figure 153):
a. For Grid extent, select the clipped NLCD layer (e.g. NLCD_HUC_clip).
b. Check the box next to Align extents and resolution to selected raster layer and click the

Update extents from layer button.
c. Toggle the button next to Output grid as polygons.
d. In the Output shapefile text box, specify the file path and name for the output shapefile (e.g.

NLCD_HUC_poly.shp).
e. Click OK.

Figure 151 Clipped raster shifted 
from the original shapefile 
location used in the tool 

Figure 152 Location of the Vector grid tool in EPA H2O
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Note: if processing the NLCD raster in sections the difference in X Min and Y Min parameters between 
sections must be divisible by a raster cell (e.g. 30m for NLCD) for polygons to align. For example, if 
section one X Min1= -9229391.18469, and section two X Min2 = -9226500, the distance between X Min is 
2891.18469m. Decreasing this distance to 2880m, X Min2 = -9226511.18469, makes it divisible by 30m 
and moves the sections closer. 

Troubleshooting Common Errors: 
Problem: 

While running the Vector grid tool, an 
error may appear that states the program 
has stopped working (Figure 154). Raster 
processing has size limitations, which 
may cause the program to crash. 

Solution: 
Try repeating the process on a raster 
clipped to a smaller area. If multiple 
watersheds were selected in creating the 
HUC watershed boundary shapefile, try 
clipping the raster to each watershed 
boundary individually. Follow the steps 
outlined in the Create HUC Watershed Boundaries section to create shapefiles for individual 
watersheds. Use the buffer tool (Main Menu > Vector > Geoprocessing Tools > Buffer) to add 
a 30m buffer to each watershed to help eliminate data gaps between watershed edges. 
Repeat the steps in this section (Using QGIS) to clip and prepare the NLCD raster for each 
individual watershed shapefile. The land cover shapefiles created must be recombined (steps 
49-52) before importing them into the .sqlite database.

Figure 154 QGIS error message, which appears when 
the program has stopped working 

Figure 153 Vector Grid tool window in EPA H2O
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16. A Generate Vector Grid message will appear when processing is almost complete. Click Yes.
17. After the output shapefile appears in the Layers panel, and the Vector grid tool progress bar

returns to 0%, click Close to close the Vector grid window.
18. From the Vector menu, open the Regular Points tool (Main Menu > Vector > Research Tools >

Regular Points).
19. In the Regular points window (Figure 155):

a. From the Input Boundary Layer dropdown list, select the clipped NLCD raster (e.g.
NLCD_HUC_clip.tif).

b. Toggle the Use this point spacing option, and in the text box, enter the resolution of the
raster. The 2011 NLCD resolution is 30 m; units in the tool will match the units of the
coordinate system.

c. In the Initial inset from corner (LH side) text box, divide the resolution value by 2, and enter
the result (e.g. 15 m, half of 30 m).

d. In the Output Shapefile text box, specify a file path and name for the output shapefile (e.g.
NLCD_HUC_points.shp).

e. Click OK.

20. A Generate Regular Points message will appear during processing. Click Yes.
21. After the output shapefile appears in the Layers panel, and the Regular Points tool progress bar

returns to 0%, click Close to close the Regular points window.
22. Sampling the raster at the generated points is done using the Point sampling tool plugin. Use the

QGIS Plugin Manager (Main Menu > Plugins > Manage Plugins) to make sure the Point sampling
tool plugin is enabled, as shown in Figure 156. If not already enabled, check the box next to Point
sampling tool (Version 0.3.3) to activate the plugin, and click OK.

Figure 155 Regular points window in EPA H2O
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23. From the Plugins menu, open the Point sampling tool (Main Menu > Plugins > Analyses > Point
Sampling Tool).

24. In the Point Sampling Tool window (Figure 157):
a. In the Layer containing sampling points dropdown list, select the regular points layer

generated in the previous step (e.g. NLCD_HUC_points).
b. In the Layers with fields/bands to get values from list box, click to highlight the clipped NLCD

raster (e.g. NLCD_HUC_clip.tif). Only layers that are currently turned on in the Layers panel
will be available in the Layers with fields/bands to get values from list box.

c. In the Output point vector layer text box, specify a file path and name for the output point
vector layer (e.g. NLCD_HUC_samplepoints.shp).

d. Check Add created layer to the TOC.
e. Click OK.

Figure 156 QGIS Plugin Manager, with the Point sampling tool selected and enabled
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Depending on the size of the AOI this tool may take a few hours to process. The window may say Not 
Responding while the tool is still actively processing.  

25. After the output shapefile appears in the Layers panel, click Close to close the Point Sampling
Tool window.

26. From the Vector menu, open the Join attributes by location tool (Main Menu > Vector > Data
Management Tools > Join attributes by location, Figure 158).

27. In the Join attributes by location window (Figure 159):
a. From the Target vector layer dropdown list, select the polygon vector grid (the output from the

Vector grid tool in step 15, e.g. NLCD_HUC_poly).
b. From the Join vector layer dropdown list, select the sampled points layer (the output from the

Point sampling tool in step 24, e.g. NLCD_HUC_samplepoints).
c. In the Attribute Summary section, toggle Take attributes of first located feature.
d. In the Output Shapefile text box, specify the file path and name for the output polygon layer

(e.g. NLCD_HUC_poly_spoints_join.shp).
e. In the Output table section, toggle Only keep matching records.
f. Click OK.

Figure 157 Point Sampling Tool window, with NLCD_HUC_clip selected in blue

Figure 158 Location of the Join attributes by location tool in EPA H2O
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28. A Join attributes message may appear when processing is almost complete. Click Yes.
29. After the output shapefile appears in the Layers panel, and the Join attributes by location tool

progress bar returns to 0%, click Close to close the Join attributes by location window.
30. Double click on the NLCD polygon layer (e.g. NLCD_HUC_poly_spoints_join) to open Layer

Properties.

31. Under the Fields tab, click the pencil  icon to 
toggle editing mode.

32. Click the New Column  icon to add a new 
gridcode field to the attribute table. 

33. In the Add Column window (Figure 160):
a. In the Name text box, type gridcode.
b. In the Type dropdown list, select Text (string).
c. In the Width text box, enter 2.
d. Click OK.

34. Click the Field Calculator  icon in Layer
Properties to open the Field Calculator window.

35. In the Field Calculator window (Figure 161):
Figure 160 Add column window, to add a new 
field in the land use polygon layer 

Figure 159 Join attributes by location window
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a. Toggle the Update existing field option, and from the dropdown list, select the “gridcode” field.
b. In the Function List, find and expand Fields and Values. Double click the joined field from this

list (e.g. “NLCD_HUC_c”).
c. The name of the joined field should appear in the Expression box.
d. Click OK.

Figure 161 Field Calculator, with NLCD_HUC_c entered as the expression 

36. Click the pencil  icon in the Fields tab of Layer Properties to toggle editing off. In the Stop 
editing window that appears, click Save to save the Field Calculator edits. 

Troubleshooting Common Errors: 
      Problem: 

While processing the field calculation an 
error may appear that states the program 
has stopped working (Figure 162). 
Depending on the size of the user’s AOI, 
EPA H2O may not be able to process the 
full field calculation.  

Figure 162 QGIS error message, which appears when the 
program has stopped working 
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      Solution: 
If this occurs, reopen the EPA H2O program, and load the NLCD polygon layer (e.g. 
NLCD_HUC_poly_spoints_join). Open the attribute table to determine if the “gridcode” field and 
the joined field (e.g. “NLCD_HUC_c”) match completely. Double click on the joined field header 
(e.g. “NLCD_HUC_c”) to sort the field in descending order. If the “gridcode” field did not fully 
populate, click the pencil icon in the attribute table to toggle editing on. Select the first row with a 
blank “gridcode” field and drag down the attribute table to highlight the subsequent rows.  If there 
are many rows that did not update it is recommended that the user highlight rows in sections, to 
avoid having the error repeat. For each selection of rows, click the Field Calculator icon and 
populate the “gridcode” field using the Field Calculator window as shown in step 35 (Figure 161). 
Toggle editing off and save (step 36) after all values in the created field match those in the joined 
field.  

37. In the Layers panel, right-click on the NLCD polygon layer (e.g. NLCD_HUC_poly_spoints_join)
and open the attribute table.

38. In the Look for text box at the bottom of the attribute table, type NULL and from the in dropdown
list, select the “gridcode” field. Click Search.

39. At the bottom of the attribute table, click the Invert Selection  icon. This may take significant 
time to process.

40. From the Vector menu, open the Dissolve tool (Main Menu > Vector > Geoprocessing tools >
Dissolve).

41. In the Dissolve window (Figure 163):
a. In the Input vector layer dropdown list, select the NLCD polygon layer (e.g.

NLCD_HUC_poly_spoints_join).
b. Check the Use only selected features option if not automatically checked.
c. In the Dissolve field dropdown list, select “gridcode”.
d. In the Output shapefile text box, specify the file path and name for the output shapefile (e.g.

NLCD_HUC_dissolve.shp).
e. Click OK.

Figure 163 Dissolve window, used to merge common land use polygons together 

Depending on the size of the area being processed, this step may take significant time to process. Do 
not close out of EPA H2O.  

42. Once the tool is finished, click Close to exit the Dissolve window.
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43. From the Vector menu, open the Multipart to singleparts tool (Main Menu > Vector > Geometry
Tools > Multipart to singleparts).

44. In the Multipart to singleparts window (Figure 164):
a. In the Input line or polygon vector layer dropdown list, select the dissolved polygon layer (e.g.

NLCD_HUC_dissolve).
b. In the Output shapefile text box, specify the file path and name for the output shapefile (e.g.

NLCD_HUC_parts.shp)
c. Click OK.

Figure 164 Multipart to singleparts window in EPA H2O 

45. In the Layers panel, double click on the land use layer (e.g. NLCD_HUC_parts) to open Layer
Properties.

46. From the Fields tab of Layer Properties, click the pencil  icon to toggle editing on. 

47. Select all fields except the “gridcode” field and remove them using the Delete column
icon.

48. Click the pencil  icon under the Fields tab to toggle Editing mode off. In the Stop editing 
window that appears, click Save. 

If the user had to clip the NLCD raster into smaller areas, steps 15 through 48 must be repeated for 
each NLCD clip. The following steps explain how to recombine NLCD shapefiles generated for each 
smaller area into one land use layer. If the NLCD raster was not split into smaller areas the NLCD 
shapefile is complete and the following steps can be skipped. 

49. Use File Explorer to move the shapefile output for each NLCD clip to a common folder if not
already. This common folder should only contain the final NLCD shapefile outputs (from step 44).

50. From the Vector menu, open the Merge shapefiles to one tool (Main Menu > Vector > Data
Management Tools > Merge shapefiles to one, Figure 165).
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Figure 165 Location of the Merge shapefiles to one tool in QGIS 

51. In the Merge shapefiles window (Figure 166):
a. In the Shapefile type dropdown list, select Polygon.
b. For the Input directory text box, click Browse and locate the common folder where each

NLCD clip output was saved (e.g. Polygonize).
c. In the Output shapefile text box, specify the file path and name for the output shapefile (e.g.

NLCD_Tampa_poly_reproj.shp).
d. Check Add result to map canvas.
e. Click OK.

Figure 166 Merge shapefiles window in QGIS, with Polygonize folder indicated as the Input directory 

52. Repeat steps 40-44 on the merged land use layer to combine any land use polygons that have
been split when processing the raster by section; however, un-check the Use only selected
features option when running the Dissolve tool (Step 41b).

The output layer is a vector (polygon) representation of the NLCD raster data layer. This layer has not 
been simplified, resulting in land use polygon boundaries with vertices that follow the jagged outlines 
of their former raster cells. In reality these land use areas will rarely follow straight lines like this and 
removing some of the vertices to smooth and simplify the polygons is an option in ArcGIS. 
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The layer created in this section is used in a spatial join with the soil dataset in the Spatially Join Soils 
to Land Use section. Database creation is continued in the Create Land Use Comparison Data 
section 

Create Land Use Comparison Data 

The original Tampa Bay database contains land use prediction datasets for the years 2020, 2040, and 
2060. These datasets can be used to create and compare scenarios with current land use; however, 
the datasets are specific to the Tampa Bay area. The user can manipulate these tables in EPA H2O 
for use in new areas in multiple ways: 

1. The user may remove these datasets from the Qspatialite plugin in EPA H2O, and not include
created land use comparison data in their database.

2. The user may remove these datasets and insert their own future land use prediction data into
the Qspatialite plugin. This data must be created or obtained by the user.

3. The user may create past land use comparison data from previously published NLCD data
years and insert this comparison data into the Qspatialite plugin.

This section outlines how to process past NLCD data for EPA H2O scenario comparisons. Example 
input and output layers are given for processing the NLCD 2001 land use layer.  

1. Past land use data was previously downloaded in the Download Land Use Data section
(Figure 135 -  Figure 138).
a. If the All Land Cover Years option was toggled during data download, NLCD land cover

for years 2001, 2003, 2006, 2008, 2013, and 2016 were unzipped into the same location
as NLCD 2011.

b. Note: only 3 land use comparison datasets can be inserted into a new database at one
time.

2. Process the land use data as shown in Create Land Use Data Layer, Using ArcGIS or Using
QGIS sections.
a. Clip each land use raster to the AOI boundary.

i. In this example, the
NLCD_2001_Land_Cover_L48_20190424_umtxeyAuXzMnsc7vNE8j.tiff raster is
clipped to the HUC_Tampa AOI shapefile, with the output named NLCD2001_clip.tif.

b. Convert clipped land use raster data to polygon data.
i. In this example, the NLCD2001_clip.tif raster is converted to a shapefile, with the

output named NLCD2001_clip_poly.shp.
c. Reproject each land use shapefile into the WGS 1984 Web Mercator Auxiliary Sphere

(ArcGIS) or WGS 84 Pseudo Mercator (QGIS) coordinate system.
i. In this example, the NLCD2001_clip_poly shapefile is re-projected, with the output

named NLCD2001_clip_poly_reproj.shp.

The remaining steps outline the rest of the requirements for creating land use comparison data. 
Similar steps for processing of the land use layer (e.g. NLCD 2011) are in the Create Soil Data Layer, 
Update ES Coefficients, and Joining Lookup Table sections. However, if completing sections of this 
manual in sequential order, these have not been performed for the land use layer. The reader may 
wish to continue processing the land use layer and then come back to the remaining land use 
comparison data steps after. 

3. Spatially join each land use layer (e.g. NLCD2001_clip_poly_reproj.shp) with the soil
shapefile created in Create Soil Data Layer (e.g. Max_Type_N.shp), and continue the
processing shown in Spatially Join Soils to Land Use (ArcGIS) or Spatially Join Soils to Land
Use (QGIS).
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a. After each join, create a new “Max_Type_N” field in the new land use attribute table (e.g.
NLCD2001_MaxTypeN_join.shp). Populate “Max_Type_N” with integer values based on
the averaged values in the “Avg_Max_Ty” field.

b. Calculate the most common soil type in the land use layer (e.g.
NLCD2001_MaxTypeN_join.shp) and populate the “Max_Type_N” value for the NULL soil
polygons (i.e. “Avg_Max_Ty” = 0).

4. Join each land use layer with the lookup table, as shown in either the Using ArcGIS or Using
QGIS sections. Then update the ES coefficients and continue with field calculations.
a. Join the land use layer (e.g. NLCD2001_MaxTypeN_join.shp) with the lookup table (e.g.

lookUPvars) and export the updated land use layer (e.g. LandUse_2001.shp).
b. Update the “Canopy” field in the final land use layer (e.g. LandUse_2001.shp), as shown

in the Tree Canopy section (Using ArcGIS or Using QGIS). However, the final land use
layer (e.g. LandUse_2001.shp) will be used as the input, rather than the soil/land use
layer.

i. In ArcGIS, continue following the steps outlined in the Tree Canopy Using ArcGIS
section; however, right-click on each land use layer (e.g. LandUse_2001.shp), rather
than the lookup table, to join by attributes.

ii. In QGIS, continue following the steps outlined in the Tree Canopy Using QGIS
section. However, the field calculations will occur in each land use attribute table (e.g.
LandUse_2001.shp), rather than the lookup table. The user must also select all rows
for each gridcode value (not just the first row) and complete the appropriate
calculations. This selection can be completed by clicking and dragging to highlight
rows, or by creating a query for each gridcode in the Look for search box.

c. The % canopy cover may differ between years because the land use changes. The
carbon burial rate for “Developed” land use types incorporates the % canopy values. The
user may choose to update the “CarbonFixe” field for the “Developed” land use in each
layer, as explained in the Carbon Sequestration section.

d. After the “Canopy” fields have been updated, the calculations in the Joining Lookup Table
section can be completed as written for each land use layer.

The Importing Layers into QGIS section details how to upload the land use layers into the user 
database in QGIS. Database creation is continued in the Create Soil Data Layer section. 

Create Soil Data Layer 

The soil data layer defines soil types in EPA H2O. Soil types, along with land cover classes, are used 
to characterize Curve Number (CN) values in the land use layer. These CN values are then used to 
compute the dollar value of flood protection, one of the ecosystem services EPA H2O evaluates. This 
section illustrates the step-by-step method used to obtain and prepare the soil data. The Joining 
Lookup Table section describes how to calculate CN values for the land use data layer using the soil 
data layer that results from this section. 

Either Esri ArcMap software or QGIS can be used to prepare the soil data. The procedure for both 
software applications is explained in this section.  

Download Soil Data 
This section illustrates the step-by-step procedure for downloading soil shapefiles by county from the 
USDA Soil Survey Website.  

1. Navigate to https://websoilsurvey.sc.egov.usda.gov/App/WebSoilSurvey.aspx as shown in
Figure 167.

https://websoilsurvey.sc.egov.usda.gov/App/WebSoilSurvey.aspx
http://websoilsurvey.sc.egov.usda.gov/App/WebSoilSurvey.aspx
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Figure 167 USDA Soil Data download website 

2. Click on the Download Soils Data tab (Figure 168).

Figure 168 Download options located under the Download Soils Data tab 

3. Under the Download Soils Data for…. section click Soil Survey Area (SSURGO) to expand 
this section (Figure 169). 

4. In the newly expanded Options section, select the desired State and County from the
appropriate dropdown lists (Figure 169).

5. Check the Include Template Database option and click Update.

http://websoilsurvey.sc.egov.usda.gov/App/WebSoilSurvey.aspx
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Figure 169 Soil datasets are downloaded by the counties the user’s area of interest is in 

6. From the Soil Survey Area Download Links section, find the desired county dataset and
download it by clicking the hyperlink in the Download Link column (e.g.
wss_SSA_FL057_soildb_FL_2003_[2018-09-14].zip, Figure 170). Multiple county datasets
may need to be downloaded to cover all parts of the user’s Area of Interest.

Figure 170 Link to download soil data is provided by county 

7. Save the zip file to the computer and unzip the contents to a known location on the C:\ drive.
It may be helpful to create a special directory for the soil data (an example directory is shown
in Figure 171). By default, unzipped files for each download are saved in a folder named after
their Area Symbol, as listed in the Area Symbol column in Figure 170.

Figure 171 Recommended workspace for Soil data 
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The next section illustrates the pre-processing of spatial soil data using Microsoft Access. 

Pre-processing Soil Data 

This section illustrates pre-processing of the spatial soil data using Microsoft Access. These steps are 
also detailed in the readme.txt file located in each unzipped soil data folder. Users must complete 
these steps before creating the soil data layer using either Esri ArcGIS software (Using ArcGIS) or 
QGIS (Using QGIS). 

1. Download and unzip the SSURGO soil data, as shown in the Download Soil Data section.
2. Each unzipped soil data folder contains a “.mdb” database file. Locate the “.mdb” file in File

Explorer, right-click and choose Open to open the file in MS Access.
3. When MS Access opens the “.mdb” file a Macro Single Step window may appear (Figure 172).

Click the X button to close the window and click Enable Content to fully enable the program.

Figure 172 Macro Single Step pop-up window in Microsoft Access 

4. A SSURGO Import window will appear when MS Access is fully enabled (Figure 173).

Figure 173 Macro requesting the tabular folder path 
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5. In File Explorer, locate the tabular folder within the unzipped soil data folder on the C:\ drive,
and copy the file path (e.g.
C:\Users\USER\.qgis\0.0.3\Tampa_H2O\D2_Tampa\Soils\FL057\tabular).

6. In the SSURGO Import window, paste the file path in the blank text box and click OK.
7. After the tabular data is imported into MS Access, the user will gain access to the Tables

column on the left sidebar (Figure 173). If Tables is not showing at the top of the sidebar, click
on the column dropdown button, and choose Tables (Figure 174).

Figure 174 List of Access Objects in MS Access; Tables has been selected 

8. The Tables column contains a list of tables; locate the component table and right-click on the
table name to choose Export > Text File (Figure 175).

Figure 175 Tables column in Microsoft Access, used to export the component table as a Text File 

9. The Export -Text File window will appear (Figure 176). Click the Browse button to navigate to
the soils folder and export as Component_AreaSymbol (e.g. Component_FL057.csv), with
the extension “.csv”, then click OK.
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Figure 176 Export – Text File window, with Component_FL057.csv and the file path in the File name box 

10. The Export Text Wizard window will appear (Figure 177).  Check Delimited as the format type
if not checked by default and click Next >.

Figure 177 Export Text wizard, with Delimited format type 
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11. In the next Export Text Wizard window, select Comma as the delimiter and mark the box
Include Field Names on First Row (Figure 178).

Figure 178 Export Text wizard, with Comma as the delimiter and field names included on first row 

12. Click Finish to begin exporting the table.
13. Repeat steps 1-12 above to export component tables for all downloaded soil data.
14. Once all component tables are exported the user can exit Access. The tables in the tabular

folder are now ready for use within ArcMap or QGIS.

The next section illustrates the creation of EPA H2O compatible soil data from the unzipped download 
file(s), using either Esri ArcGIS software (Using ArcGIS) or QGIS (Using QGIS).  

Using ArcGIS 
This section illustrates the creation of EPA H2O compatible soil data using Esri ArcGIS software. 

1. Download and pre-process the soil data, as shown in the Download Soil Data and Pre-
processing Soil Data sections.

2. Open your existing ArcGIS map document file (.mxd), or create one following the steps
outlined in Set Up ArcGIS Map Document.

3. Each county soil data folder (named by Area Symbol, e.g. FL057) contains a Spatial folder.

Use the Add Data  icon to navigate to one of these Spatial folders. Select the soil
shapefile (i.e. soilmu_a…shp) and add the layer to the Table of Contents of the map
document.

4. Use the Add Data icon to locate and add the corresponding component table(s) (e.g.
Component_FL057.csv), to the map document.

5. In the Table of Contents, right-click on the county soil shapefile (i.e. soilmu_a…) and open the
attribute table.
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6. In the attribute table, click on the Table Options  icon and choose Add Field (Figure 179). 

Figure 179 Location of Add Field icon in attribute table 

7. In the Add Field window (Figure 180):
a. In the Name text box, enter MUKEY2.
b. In the Type dropdown list, select Long Integer.
c. Click OK.

Figure 180 Add Field window in ArcMap 

8. The “MUKEY2” field will appear in the attribute table. Right-click on the field header name and
choose Field Calculator (Figure 181).



136 

Figure 181 Field Calculator tool, accessed with a right-click on the field name 

9. In the Field Calculator window (Figure 182):
a. In the Fields list box, double click on “MUKEY”. The field name will appear in the

Expression box as [MUKEY].
b. Click OK.

Figure 182 Field Calculator window, with [MUKEY] entered as the expression 

10. In the Table of Contents, right-click on the county soil layer (e.g. soilmu_a_fl057) and choose
Joins and Relates > Join… (Figure 183).
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Figure 183 Location of the Join feature in ArcMap 

11. In the Join Data window (Figure 184):
a. In the first dropdown list, select Join attributes from a table.
b. In the Choose the field in this layer that the join will be based on dropdown list, select

“MUKEY2”.
c. In the Choose the table to join to this layer dropdown list, select the corresponding

Component table (e.g. Component_FL057.csv).
d. In the Choose the field in the table to base the join on dropdown list, select “mukey”.
e. Toggle Keep all records
f. Click OK.

Figure 184 Join Data window in ArcMap 
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12. Right-click on the county soil layer (e.g. soilmu_a_fl057) in the Table of Contents and choose
Data > Export Data, as shown in Figure 123.

13. In the Export Data window (as shown in Figure 124):
a. In the Export dropdown list, select All features.
b. Under Use the same coordinate system as, toggle the data frame option.
c. In the Output feature class text box, navigate to the preferred file path and name the

shapefile; ensure the output name will be both recognizable and distinguishable by basing
names on the county or soilmu_a_ file (e.g. soilmu_fl057_join.shp).

14. A window may appear that asks: “Do you want to add the export data to the map as a layer?”
(Figure 125). If so, click Yes.

15. From the ArcToolbox window, navigate to and open the Delete Field tool (ArcToolbox > Data
Management Tools > Fields > Delete Field, Figure 185).

Figure 185 Location of the Delete Field tool in ArcMap 

16. In the Delete Field window (Figure 186):
a. In the Input Table dropdown list, select the exported shapefile (e.g. soilmu_fl057_join).
b. Under the Drop Field section, click the Select All button to check all the boxes. Uncheck

the boxes next to “hydgrp” and "MUKEY2".
c. Click OK to delete all checked fields from the attribute table.
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Figure 186 Delete Field tool window, with MUKEY2 field and hydgrp (not shown) field unselected 

17. Repeat steps 3-16, joining the component table to the shapefile, exporting the shapefile
and deleting extra fields, for each county soil shapefile.

18. All prepared soil shapefiles will be combined into one feature layer. In the ArcToolbox window,
navigate to and open the Append tool (ArcToolbox > Data Management Tools > General >
Append, Figure 187).

Figure 187 Location of the Append tool in ArcMap 

19. In the Append window (Figure 188):
a. In the Target Dataset dropdown list, choose any one soil shapefile to append the others to

(e.g. soilmu_fl057_join).
b. In the Input Datasets dropdown list, select all other soil shapefiles (e.g. soilmu_fl081_join,

soilmu_fl103_join). As shapefiles are added they will appear in the list box.
c. Keep the Schema Type set to TEST and do not select a field map or subtype.
d. Click OK.
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Figure 188 Append tool window in ArcMap 

Note: If the newly appended dataset (e.g. soilmu_fl057_join) doesn’t appear to contain the other input 
datasets (e.g. soilmu_fl081_join and soilmu_fl103_join), right-click and Remove the dataset from the 
Table of Contents and re-add the layer into the map.  

20. In the Table of Contents, right-click on the newly appended dataset (Target Dataset from the
append tool, e.g. soilmu_fl057_join) and open the attribute table.

21. In the attribute table, click on the Table Options  icon, and choose Add Field (Figure 179). 
22. In the Add Field window (example shown in Figure 180):

a. In the Name text box, enter the preferred name for the new field (e.g. "Max_Type_N").
b. In the Type dropdown list, select Short Integer.
c. Click OK.

The new field (e.g. “Max_Type_N”) will appear in the attribute table. This field is populated based on 
the “hydgrp” field, which may contain dual soil codes, such as ‘A/D’, ‘B/D’, or ‘C/D’. These codes 
denote that the water table can be close to the surface, causing the soil to act as ‘D’ type. However, 
when drained, these act as ‘A’, ‘B’, or ‘C’ type soils and therefore should be coded according to the 
first letter of the dual code. 

23. From the main menu, choose Selection > Select By Attributes.
24. In the Select By Attributes window (Figure 189):

a. In the Layer dropdown list, select the soil shapefile (e.g. soilmu_fl057_join).
b. From the fields list box, select the “hydgrp” field and click Get Unique Values. The soil

codes will load in the values list box above.
c. Enter the following selection in the Expression box: "hydgrp" = 'A' OR "hydgrp" = 'A/D'
d. Click Apply.
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Figure 189 Select By Attributes window, used to select hydgrp values A and A/D 

25. In the soil attribute table, rows with “hydgrp” values ‘A’ and ‘A/D’ will be selected. Right-click
on the “Max_Type_N” field and choose Field Calculator (example shown in Figure 181).

26. In the Field Calculator window (example shown in Figure 182):
a. In the Expression box, type 1.
b. Click OK.

27. Repeat step 23-26 to change the new field values to 2, 3, and 4, for the respective “hydgrp”
field values ‘B’ (and ‘B/D’), ‘C’ (and ‘C/D’), and ‘D’.
a. The selection for “hydgrp” value ‘D’ will not contain a dual code. Therefore, the selection

expression will be "hydgrp" = 'D'. Please note that not all AOIs will contain all possible
“hydgrp” values.

28. In the Table of Contents, right-click the updated soil shapefile and choose Data > Export Data
(example shown in Figure 123).

29. In the Export Data window (example shown in Figure 124):
a. In the Export dropdown list, select All features.
b. Under the Use the same coordinate system as section, toggle the data frame option on.
c. In the Output feature class text box, specify the file path and name the output

Max_Type_N.shp.
d. Click OK.

30. In the Table of Contents, right-click on the Max_Type_N layer and open the attribute table
31. Delete all fields from the attribute table except “Max_Type_N”, “Shape” and the ID field

(“FID”):
a. To delete each field, right-click on the field header and select Delete Field (Figure 190).

Note: the “Shape” field cannot be deleted.
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Figure 190 Right-click to access the Delete Field tool in ArcMap 

32. Soil polygons in the Max_Type_N layer that do not have Max_Type_N field values will be deleted
using the Editor tool. If the Editor toolbar is not enabled, right-click anywhere on the main menu
bar at the top of the ArcMap program. From the list of optional toolbars that appear select Editor
(Figure 191).

Figure 191 List of extensions and toolbars in ArcMap, with the Editor toolbar highlighted in blue 

33. In the Editor toolbar, click the Editor dropdown list and choose Start Editing (Figure 192).

Figure 192 Editor toolbar, with the Start Editing option selected 

34. If the Start Editing window appears, select the Max_Type_N layer and click OK.
35. From the main menu, choose Selection > Select By Attributes.
36. In the Select By Attributes window (example shown in Figure 189):

a. In the Layer dropdown list, select Max_Type_N.
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b. In the Expression box, type the following expression: "Max_Type_N" = 0
c. Click OK.

37. In the Table of Contents, right-click and open the Max_Type_N attribute table.
38. Click the Delete icon to delete the selected soil polygons.
39. In the Editor toolbar, click the Editor dropdown and choose Save Edits, and then Stop Editing

(Figure 193).

Figure 193 Editor toolbar, with the Save Edits option selected 

The Max_Type_N layer is now complete; next, the values in this layer will be joined to the land use 
layer. 

Spatially Join Soils to Land Use 

After the soil shapefile (e.g. Max_Type_N.shp) is created it must be spatially joined to the land use 
layer created in the Create Land Use Data Layer section. 

1. If using a new map document, use the Add Data  icon to navigate to the land use shapefile 
created in the Create Land Use Data Layer section and add the layer to the Table of Contents. 

2. In the Table of Contents panel, right-click on the land use layer. Under the Joins and Relates
option, select Join… (Figure 194).

Figure 194 Location of the Join tool in ArcMap 

3. In the Join Data window (Figure 195):
a. In the first dropdown list, select Join data from another layer based on spatial location.
b. In the Choose the layer to join to this layer dropdown list, select the updated soil layer

(e.g. Max_Type_N).
c. Toggle on the Each polygon will be given a summary of the numeric attributes of the

polygons in the layer being joined that intersect it option.
d. In the How do you want the attributes to be summarized section, check Average.
e. In the Specify output shapefile text box, designate a file path and new name for the output

shapefile (e.g. NLCD_MaxTypeN_join.shp).
f. Click OK.
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Figure 195 Join land use data to soils layer (e.g. Max_Type_N), summarizing by Average 

After the spatial join is complete, the “Max_Type_N” field in the spatially joined layer will be renamed 
to “Avg_Max_Ty” and will contain average attribute values for each land use polygon. Where a land 
use polygon does not overlap any soil polygons, either because they were missing or were deleted, 
the “Avg_Max_Ty” value will be 0. These NULL polygons will be assigned the value for the most 
prominent soil type (largest area) in the AOI. To determine the most prominent soil type in the AOI: 

4. In the Table of Contents, right-click on the spatially joined layer (e.g. NLCD_MaxTypeN_join)
and open the attribute table.

5. In the attribute table, click on the Table Options icon and choose Add Field (as shown in
Figure 179).

6. In the Add Field window (example shown in Figure 180):
a. In the Name text box, type "Max_Type_N".
b. In the Type dropdown list, select “Short Integer”.
c. Click OK.

7. Click on the Table Options icon and choose Add Field again to add a second field in the
attribute table. This time in the Add Field window:
a. In the Name text box, type "Area".
b. In the Type dropdown list, select “Double”.
c. Click OK.

8. In the attribute table, locate the new “Area” field, right-click on the field name and choose
Calculate Geometry (Figure 196).
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Figure 196 Right-click to access the Calculate Geometry option in NLCD_MaxTypeN_join attribute table 

9. The Calculate Geometry window will open. In the window (Figure 197):
a. In the Property dropdown list, choose Area.
b. Under the Coordinate System section, toggle Use coordinate system of the data frame.
c. In the Units dropdown list, choose Acres US [ac].
d. Click OK.

Figure 197 Calculate Geometry window in ArcMap 

The new "Max_Type_N" field is populated based on the averaged values in the “Avg_Max_Ty” field. 
However, values in “Avg_Max_Ty” must be rounded to the nearest integer for the “Max_Type_N” field. 
For example, for 0 < "averaged values" < 1.5, “Max_Type_N” = 1. This is completed by:  

10. From the main menu, choose Selection > Select By Attributes.
11. In the Select By Attributes window (example shown in Figure 189):

a. In the Layer dropdown list, select NLCD_MaxTypeN_join.
b. In the Expression box, type the following expression: "Avg_Max_Ty" > 0 AND

"Avg_Max_Ty" < 1.5
c. Click Apply.

12. In the Table of Contents, right-click on the spatially joined layer (e.g.
NLCD_MaxTypeN_join.shp) and open the attribute table.

13. Locate the “Max_Type_N” field, right-click on the field name and choose Field Calculator.
14. In the Field Calculator window:

a. In the Expression box, type 1.
b. Click OK.
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15. With the selection still highlighted, right-click on the “Area” field and choose Statistics...
16. From the Statistics window, copy/write down the Sum value (Figure 198). This is the total area

(acres) of the first soil type in the soil/land use layer.

Figure 198 Selection Statistics window, with Sum of the Area (acres) highlighted in blue 

17. Close the Statistics window and clear the selection in the attribute table.
18. For each selection in Table 7, repeat steps 10-17, setting the selection using the expression in

Select By Attributes and the “Max_Type_N” field value using Field Calculator. Then find the
total area of each selection using Statistics and write down the sums for comparison.

Table 7 Expressions for selections and corresponding field calculations 

Expression for Selection “Max_Type_N” Value 
"Avg_Max_Ty" > 0 AND "Avg_Max_Ty" < 1.5 1 
"Avg_Max_Ty" >= 1.5 AND "Avg_Max_Ty" < 2.5 2 
"Avg_Max_Ty" >= 2.5 AND "Avg_Max_Ty" < 3.5 3 
"Avg_Max_Ty" >= 3.5 AND "Avg_Max_Ty" <= 4 4 

19. Compare the areas for each soil type, and determine which classification is most prominent.
In this example, the total area for each soil type (“Max_Type_N” value) is as follows:
a. 1 = 1,870,943.6 acres
b. 2 = 102,619.9 acres
c. 3 = 7,033.8 acres
d. 4 = 4,220.2 acres
In this example, the most common soil type is “Max_Type_N” = 1. This soil type will be used
as the “Max_Type_N” values for the NULL land use polygons.

20. From the main menu, choose Selection > Select By Attributes.
21. In the Select By Attributes window (example shown in Figure 189):

a. Under the Layer dropdown list, select NLCD_MaxTypeN_join.
b. Enter the following expression in the Expression box: "Avg_Max_Ty" = 0
c. Click Apply.

22. In the Table of Contents, right-click on the spatially joined layer (e.g. NLCD_MaxTypeN_join)
and open the attribute table.

23. Locate the “Max_Type_N” field, right-click on the field name and choose Field Calculator.
24. In the Field Calculator window:

a. In the Expression box, type the most common soil type found in the user’s AOI from
step19 (in the example this was 1).



147 

b. Click OK.

Database creation is continued in the Update ES Coefficients section. 

Using QGIS 

This section illustrates the creation of EPA H2O compatible soil data using QGIS software. 

1. Download and pre-process the soil data, as shown in the Download Soil Data and Pre-
processing Soil Data sections.

2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined
in Set Up QGIS Map Document.

3. Add each soil shapefile to the Layers panel:
a. From the Layer menu (Figure 126) open the Add Vector Layer window (Main Menu >

Layer > Add Vector Layer).
b. Each county soil data folder (named by Area Symbol, e.g. FL057) contains a Spatial

folder. In the Add Vector layer window (Figure 127), click Browse to locate this folder and
select the soil shapefile (i.e. soilmu_a…shp), then click Open.

4. Open File Explorer and locate each corresponding Component table. Click and drag the
“.csv” files into the QGIS Layers panel.

Imported files will be displayed in the Layers panel, as shown in Figure 199. 

Figure 199 Soil shapefiles and component tables displayed in the Layers panel in EPA H2O 

5. Double click the first soilmu_a... layer to open the Layer Properties window. Within Layer
Properties, click the Joins tab.

6. In the Joins tab, click the Add Join  icon to open the Add vector join window (Figure 
200).
a. In the Join layer dropdown list, select the Component table corresponding to that soil

layer (e.g. Component_FL057).
b. In the Join field dropdown list, select “mukey”.
c. In the Target field dropdown list, choose “MUKEY”.
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d. Check Cache join layer in virtual memory.
e. Click OK.

Figure 200 Add Vector Join window in Joins tab, within soil layer properties 

7. Right-click on the soilmu_a… layer and select the Save as… option (as shown in Figure 130).
8. In the Save as window (example shown in Figure 133):

a. In the Format dropdown list, select ESRI Shapefile.
b. In the Save as text box, browse to or type the desired output shapefile name and file

path.
c. In the CRS dropdown list, choose Selected CRS, and click the Browse button to

locate WGS 84 / Pseudo Mercator.
d. Check the Add saved file to map option.
e. Do not check the Skip attribute creation option.
f. Click OK.

9. Double click on the exported soil layer to open the Properties window, and click the Fields tab.

10. Toggle the editing  button to start an edit session. 
11. Click and drag to select all fields except “hydgrp” and “MUKEY”.

Please note: field names may get lost during the join; if this occurs, “hydgrp” becomes 
“Component_78”. Make a new field named “hydgrp” and use the Field Calculator to populate the new 
field from the original “hydgrp” data.  

12. Click the Delete Column  button to delete all fields except “hydgrp” and “MUKEY” (Figure 
201).

13. Click OK.
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Figure 201 Layer Properties for joined soil layer, with required fields MUKEY and hydgrp 

Repeat steps 3-13, joining the component table to the soil shapefile, exporting the shapefile 
and deleting extra fields, for each county soil shapefiles. All prepared soil shapefiles will be 
combined into a single layer. 

14. Right-click on the first soilmu_a… layer and open the attribute table.

15. Click the Invert Selection  icon, and then click the Copy rows to clipboard  icon at the 
bottom of the attribute table (Figure 202). 

16. Close this attribute table.
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Figure 202 Soil layer attribute table, with all attributes selected and copied to clipboard 

17. Click on a second soilmu_a… layer to highlight it in the Layers panel.
Note: the second layer will become the combined shapefile from all the soils layers. The 
user must remember which soil layer was highlighted.  

18. From the main menu, select Layer > Toggle editing (Figure 203).

Figure 203 Toggle editing for the other soil layer in the Layers panel 

19. With the second soilmu_a… shapefile still highlighted, from the main menu select Edit > Paste
Features (Figure 204).
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Figure 204 Paste Features tool located in the Edit menu 

20. Repeat steps 14-16, copying rows, and step 19, pasting them into the selected layer, for the
remaining soil shapefiles.

21. Click Layer > Toggle editing again to stop editing.
22. Click OK when prompted to save changes.
23. In the Layers panel, double click on the combined soil layer to open Layer Properties.

24. From the Fields tab, click the pencil  icon to enable Editing mode. 

25. Click on the New Column  icon to add a new field. 
26. In the Add column window (Figure 205):

a. In the Name text box, enter a field name that is 6 characters or less (e.g. "MaxTy").
b. In the Type dropdown list, select Whole number (integer).
c. In the Width text box, enter 1.
d. Click OK.

27. Click OK to close Layer Properties.

Figure 205 Create a new field in the updated attribute table with the Add column button 
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The new field (e.g. “MaxTy”) will appear in the combined soil layer attribute table. This field is 
populated based on the “hydgrp” field, which may contain dual soil codes, such as ‘A/D’, ‘B/D’, or 
‘C/D’. These codes denote that the water table can be close to the surface, causing the soil to act as 
‘D’ type. However, when drained, these act as ‘A’, ‘B’, or ‘C’ type soils and therefore should be coded 
according to the first letter of the dual code. To avoid assigning these dual codes a “MaxTy”’ value of 
4, assign the “MaxTy” value for “hydgrp” ‘D’ first, and then go back to do ‘A’, ‘B’, and ‘C’. 

28. Open the combined soil layer attribute table.
29. In the Look for text box, at the bottom of the attribute table, enter the letter ‘D’.
30. From the in dropdown list, choose “hydgrp”, and click the Search button (Figure 206).

Figure 206 Search for letter D in the hydgrp field 

Note: it may take a few moments for QGIS to select the attributes. Do not close the attribute table 
during this time. 

31. Open the Field Calculator by clicking the Field Calculator  icon in the attribute table. 
32. In the Field Calculator window (Figure 207):

a. Check the box next to Only update selected features.
b. Check the box next to Update existing field.
c. Choose the newly created field (e.g. “MaxTy”) from the dropdown list.
d. Under the Expression section, type the value 4.
e. Click OK.

Figure 207 Field Calculator window, updating Max_Type_N field with a value of 4 
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33. Repeat steps 30 through 32 to find records with values ‘A’, ‘B’, and ‘C’ in the “hydgrp” field,
and assign the corresponding values 1, 2, and 3 to the “MaxTy” field.

34. Click the pencil  icon to toggle Editing mode off and save the edits. 
35. Right-click on the soil layer with updated “MaxTy” values and choose Save as.
36. In the Save as window (example shown in Figure 133):

a. In the Format dropdown list, select ESRI Shapefile.
b. In the Save as text box, browse to the desired file path, and name the file

Max_Type_N.shp.
c. In the CRS dropdown list, choose Selected CRS, and click the Browse button to

locate WGS 84 / Pseudo Mercator.
d. Check the Add saved file to map option.
e. Do not check the Skip attribute creation option.
f. Click OK.

37. In the Layers panel, right-click on Max_Type_N and open the attribute table.

38. Click the pencil  icon to enable Editing mode. 
39. In the Look for text box, type NULL, and from the in dropdown list, choose “hydgrp”.
40. Click the Search button (example shown in Figure 206).
41. All the soil polygons without a soil classification are selected. Click the Delete Selected

Features  icon to delete these polygons.
42. Close the attribute table.
43. In the Layers panel, double click on Max_Type_N to open Layer Properties.
44. From the Fields tab, select all fields except “MaxTy” and remove them using the Delete

column  icon.

45. Click the pencil  icon to toggle Editing mode off and save edits. 
46. Click OK to close Layer Properties.

The Max_Type_N layer is now complete; next, the values in this layer will be joined to the land use 
layer. 

Spatially Join Soils to Land Use 

After the soil shapefile (e.g. Max_Type_N.shp) is created it must be spatially joined to the land use layer 
created in the Create Land Use Data Layer section.  

1. If not in the Layers panel, add the land use layer created in the Create Land Use Data Layer
section to the project using the Add vector layer tool (example shown in Figure 126 and Figure
127).

2. Open the Join attributes by location tool (Main Menu > Vector > Data Management Tools >
Join attributes by location, Figure 158).

3. In the Join attributes by location window (Figure 208):
a. In the Target vector layer dropdown list, select the land use layer (e.g.

NLCD_Tampa_poly_reproj).
b. In the Join vector layer dropdown list, select the updated soils layer (Max_Type_N).
c. In the Attribute Summary section, toggle on Take summary of intersecting features, and

check Mean.
d. In the Output Shapefile text box, browse to or type the file path and desired shapefile

name (e.g. NLCD_MaxTypeN_spatial.shp).
e. Toggle on the Keep all records option.
f. Click OK.
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Figure 208 Join attributes by location, and summarize by Mean 

Note: depending on the size of the datasets and the computer processing them this spatial join may take 
a few hours to complete. Do not close the EPA H2O program during this time.  

Troubleshooting Common Errors: 
      Problem: 

A common error in this step results in an 
Incorrect field names error (Figure 209). 
Three pieces of information help to 
understand the cause of this error: (1) Field 
names cannot be longer than 10 characters 
(2) Attribute Summary by Mean renames
fields by adding MEAN in front of the original
field name (3) This results in field names with
more than 10 characters when the original is
more than 6 characters.

      Solution: 
The user must replace each of the fields listed in the error message with a new field. Open the 

Layer Properties window for the layer and click the pencil  icon to start editing. Click on the 

New Column  icon to add a new field to the fields list (example shown in Figure 205). The new 
field name must have 6 or less characters (e.g. “MaxTy”) and have the same Type as the field it 

is replacing. Open Field Calculator and choose Update Existing Field from the dropdown 
list. Select the newly created field (e.g. “MaxTy”, example shown in Figure 207). From the Field 
and Values dropdown list, double click on the field to be replaced (e.g. “Max_Type_N”). After the 
field appears in the Expression box, click OK. Delete the old field from Layer Properties, using the 

Delete Column  icon.  Repeat these steps for each of the fields listed in the error. Save the 
changes made to the Layer Properties and retry the Join attributes by location tool. 

Figure 209 Incorrect field names error message in QGIS 
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4. A message box will appear when Join attributes by location is finished. After this message
appears click Close to close the tool.

After the spatial join, the “MaxTy” field in the spatially joined layer will be renamed to “MEANMaxTy” 
and will contain average attribute values for each land use polygon. Where a land use polygon does 
not overlap any soil polygons, either because they were missing or because they were deleted, the 
“MEANMaxTy” value will be NULL. The soil classification type of these NULL polygons is assigned 
the most prominent soil type (largest area) in the AOI. 

5. From the main menu, select Plugins > Manage Plugins.
6. In the QGIS Plugins Manager window will (Figure 210):

a. In the Filter box, type Statist.
b. The Statist (1.0.0) plugin will appear in the list of plugins. Check the box next to the plugin

name if it is not already checked.
c. Click OK.

Figure 210 QGIS Plugin Manager window, with the Statist plugin enabled 

7. In the layers panel, double click on the spatial join layer (e.g. NLCD_MaxTypeN_spatial) to
open Layer Properties.

8. From the Fields tab, click the pencil  icon to enable Editing mode. 
9. Click the New Column icon. In the Add column window (Figure 205):

a. In the Name text box, enter “Max_Type_N”.
b. In the Type dropdown list, select Whole number (integer).
c. In the Width text box, enter 1.
d. Click OK.

10. Click the New Column icon again to add a second field. In the Add column window (Figure
205):
a. In the Name text box, enter “Area”.
b. In the Type dropdown list, select Decimal number (real).
c. In the Width text box, enter 10, and in the Precision text box, enter 2.
d. Click OK.
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11. Close Layer properties and open the spatial join layer attribute table.

12. Click the Field Calculator  icon. In the Field Calculator window (Figure 211): 
a. Check the Update existing field option.
b. In the existing field dropdown list, select “Area”.
c. In the Function List list box, expand the Geometry option, and double click on $area.
d. The expression $area will appear in the Expression box.
e. Click OK.

Figure 211 Field Calculator window, used to calculate the area of each polygon 

The new "Max_Type_N" field is populated based on the averaged values in the “MEANMaxTy” field. 
However, values in “MEANMaxTy” must be rounded to the nearest integer for the “Max_Type_N” field. 
For example, for 0 < "averaged values" < 1.5, “Max_Type_N” = 1. This is completed by: 

13. In the Layers panel, right-click the spatial join layer and open the attribute table.
14. In the attribute table click on the Advanced Search button (Figure 212).

Figure 212 Advanced search button in attribute table 
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15. The Search Query Builder window will open. In the Search Query Builder window (Figure 213):
a. In the SQL where clause text box, type the expression: MEANMaxTy > 0 AND

MEANMaxTy< 1.5
b. Click OK.

Figure 213 Search query builder in EPA H2O, used to select averaged values between 0 and 1.5 

Please note, this selection may take a long time to process. Do not close the attribute table/program. 

16. From the spatial join layer attribute table, open the Field Calculator window (example shown
in Figure 207):
a. Check the Only update selected features option.
b. Check the Update existing field option and select “Max_Type_N” from the dropdown list.
c. Type 1 in the Expression box.
d. Click OK.

17. With the selection still highlighted, from the main menu select Vector > Statist > Statist.
18. In the Statist: Field statistics window (Figure 214):

a. In the Input vector layer dropdown list, select NLCD_MaxTypeN_spatial.
b. Check the Use only selected features option if not already checked.
c. In the Target field dropdown list, select Area.
d. Click OK. The statistics for the selection will generate within the window.
e. From the Statistics output, copy down the Sum value (e.g. 7.5714e9).
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Figure 214 Statist: Field statistics window displaying the Area statistics for the first selection 

19. Close the Statist window and clear the current attribute table selection.
20. For each selection in Table 8, repeat steps 13-18, setting the selection using the expression in

Search Query Builder and the “Max_Type_N” field value using Field Calculator. Then find the
total area of each selection using Statist and write down the sums for comparison.

Table 8 Expressions for selections and corresponding field calculations 

Expression for Selection “Max_Type_N” Value 
MEANMaxTy > 0 AND MEANMaxTy < 1.5 1 
MEANMaxTy >= 1.5 AND MEANMaxTy " < 2.5 2 
MEANMaxTy >= 2.5 AND MEANMaxTy < 3.5 3 
MEANMaxTy >= 3.5 AND MEANMaxTy <= 4 4 

21. Compare the areas for each soil type, and determine which classification is most prominent.
The sum is expressed in scientific notation, and the units are in meters (i.e. units of the
coordinate system). In this example, the total area for each soil type (“Max_Type_N” value) is
as follows:
a. 1 = 7,571,440,000 m
b. 2 = 415,287,000 m
c. 3 = 28,464,900 m
d. 4 = 17,078,600 m
In this example, the most common soil type is “Max_Type_N” = 1. This soil type will be used
to assign the “Max_Type_N” values where “MEANMaxTy” is NULL.

22. In the Layers panel, right-click the NLCD_MaxTypeN_spatial layer and open the attribute
table.

23. In the attribute table (Figure 215):
a. In the Look for text box, type NULL.
b. In the in field dropdown list, select “MEANMaxTy”.
c. Click Search.
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Figure 215 Look for NULL values in the MEANMaxTy field 

24. Click the Field Calculator  icon (example shown in Figure 207): 
a. Check the Only update selected features option.
b. Check the Update existing field option and select “Max_Type_N” from the dropdown list.
c. In the Expression box, enter the number corresponding to the most prominent soil from

step 21 (in the example this was 1).
d. Click OK.

Database creation is continued in the Update ES Coefficients section. 
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Update ES Coefficients 

EPA H2O incorporates Tree Canopy, Air Quality, Carbon Sequestration, and Denitrification 
coefficients for each land use type. These coefficients are used to calculate ES values for air pollution 
removal, carbon sequestration, and nitrogen removal from water.  

The land use layer attribute table (Figure 216) will include fields for ES coefficients (“Canopy”, 
“CarbonFixe”, and “denitrific”) and ES values (“waterRet”, “stabClim”, and “usWat”). These fields are 
populated by joining the land use layer to a lookup table with the same land use classification (e.g. 
NLCD); as described in the Joining Lookup Table section. The fields for ES monetary values can be 
updated by Modifying ES Algorithm Values; as described in the Edit Scenarios section. National averages 
for each ES coefficient are provided in the supplemental lookup table (Appendix A: Supplemental NLCD 
Lookup Table) and may be imported to create a database from NLCD classified land use. However, user 
database accuracy may be improved if the default national averages are updated on a more local scale. 
To update coefficients, changes are first made to the lookup table, then changes are joined to the land 
use layer. The ES coefficients in the lookup table and land use table must match. Either Esri ArcMap 
software or QGIS can be used to update the ES coefficients. The procedure for both software 
applications is explained in this section.  

Figure 216 Supplemental lookup table, with ES National Average fields; these fields may be updated to represent 
more local values 

Tree Canopy 
Download Tree Canopy Data 

This section illustrates the step-by-step procedure for downloading NLCD 2011 Percent Tree Canopy 
(cartographic) data from the USGS National Map. This data is used to update the “Canopy” field in the 
lookup table, which is needed to calculate the “Us_Air_Dol” field in the Joining Lookup Table section.  

1. Navigate to https://www.mrlc.gov/viewer/ as shown in Figure 217.

https://www.mrlc.gov/viewer/


161 

Figure 217 MRLC website, download NLCD Canopy Cover by AOI 

2. Click-and-drag on the National Map to pan and use the Zoom in  icon to zoom in to the user’s AOI 
(e.g. Tampa Bay). 

3. In the Contents section, under the NLCD Tree Canopy dropdown list, check the 2011 CONUS
Tree Canopy option (or the preferred display year).

4. From the map viewer toolbar, click the Open Data Download Tool  icon and click to draw a 
bounding box around the user’s AOI (Figure 218).

Figure 218 MRLC viewer with bounding box drawn around Tampa Bay AOI 

5. Under the Data Download dropdown list, check the Tree Canopy option and toggle All Tree
Canopy Years (Figure 219).
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Figure 219 Data Download dropdown list 

6. In the Email text box, enter the user’s email address (e.g. user@epa.gov), then click Download.
7. A notification will appear indicating the download request has been sent. Click OK (Figure 220).

Figure 220 MRLC request notification 

8. The download link will be emailed to the user by the USGS server. Click the first link in the email
to download the NLCD Canopy Cover zip file.

9. Save the zip file to the computer and unzip the contents to a known location.

NLCD Canopy cover raster values represent the percent canopy cover for each 30m x 30m raster cell. 
EPA H2O requires average canopy cover for each land use classification. If using a land use 
classification other than NLCD the land use classification may have a different resolution (e.g. the 
FLUCCS 2006 classification used in the Tampa Bay dataset has a 5-meter resolution) resulting in a 
difference in canopy cover sampling. The next section illustrates the averaging of percent canopy 
cover for each land use type, using either Esri ArcGIS (Using ArcGIS) or QGIS (Using QGIS). 
Averaging canopy cover over larger areas better accounts for local variability and helps to limit errors 
due to differences in sampling.  
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Using ArcGIS 

This section illustrates how to update the % Canopy Cover (“Canopy” field) for the user’s area of interest 
using Esri ArcGIS.  

Note: this step requires the Spatial Analyst extension in ArcMap. If the user’s ArcGIS license does not 
include this extension, the user will skip this step and use the default national averages already in the 
“Canopy” field for calculations. These average canopy cover values come from overlaying NLCD land 
use and cartographic canopy cover. It is important to note that the cartographic canopy cover differs 
from the analytical, in that it has already been corrected for impervious surfaces. 

Although the following process is shown using an NLCD land use dataset, the same steps can be 
performed using an alternative land use vector dataset (e.g. FLUCCS). Simply replace the “gridcode” field 
with the appropriate land use code field where required.  

1. Download and unzip the Canopy Cover data to a known location, as shown in the Download Tree
Canopy Data section.

2. Open your existing ArcGIS map document file (.mxd), or create one following the steps outlined in Set
Up ArcGIS Map Document.

3. Use the Add Data  icon to navigate to the Canopy Cover 2011 .tif dataset (or most recent year).
Select it and click Add to add it as a layer in the Table of Contents.

4. If using a new map document, the shapefile created in the Spatially Join Soils to Land Use section
(e.g. NLCD_MaxTypeN_join) must be located and added in the same way.

5. From the ArcToolbox window, navigate to and open the Project Raster tool, (ArcToolbox > Data
Management Tools > Projections and Transformations > Raster > Project Raster, Figure 221).

6. In the Project Raster window (Figure 222):
a. In the Input Raster dropdown list, select the NLCD canopy cover .tif (e.g.

NLCD_2011_Tree_Canopy_L48_20190831_RTDBmKOdx72K3rodhLUd.tiff).
b. In the Output Raster Dataset text box, name the output with a .tif extension (e.g.

Canopy_reproj.tif) and the file path.

c. Click the Spatial Reference  icon to set the Output Coordinate System to
WGS_1984_Web_Mercator_Auxiliary_Sphere, located under the World folder in Projected
Coordinate Systems. Alternatively, search for it by typing 3857 into the search box.

d. A Geographic Transformation is required to reproject the land use dataset. In the dropdown
list, choose WGS_1984_(ITRF00)_To_NAD_1983, if not already listed in the box.

e. If the wrong Geographic Transformation is listed, click on the name, and click the X button to
remove it.

f. Click OK to run Project Raster.
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7. Check that the Spatial Analyst extension is enabled. From the main menu, click Customize >
Extensions…, and confirm that the Spatial Analyst option is checked. Click Close.

8. Use the Tabulate Area tool to create a table summarizing the re-projected canopy cover layer (e.g.
Canopy_reproj) by the classification in the soil/land use layer (e.g. NLCD_MaxTypeN_join). From the
ArcToolbox window, navigate to and open the Tabulate Area tool (ArcToolbox > Spatial Analyst Tools
> Zonal > Tabulate Area, Figure 223).

9. In the Tabulate Area window (Figure 224):
a. In the Input raster or feature zone data dropdown list, select the soil/land use layer (e.g.

NLCD_MaxTypeN_join).
b. In the Zone field dropdown list, select “gridcode”.
c. In the Input raster or feature class data dropdown list, select the re-projected canopy layer

(e.g. Canopy_reproj).
d. In the Class field dropdown list, select “Value”.
e. In the Output table text box, name the output table (e.g. Canopy_TabArea) and file path.
f. Click OK to run Tabulate Area.

Figure 221 Location of the Project Raster 
tool in ArcToolbox 

Figure 222 Project Raster tool window 
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10. In the Table of Contents, right-click to open the output table (e.g. Canopy_TabArea).
11. Add a new field in the table (example shown in Figure 179 and Figure 180):

a. In the Name text box, type the preferred field name (e.g. “AvgCC”).
b. In the Type dropdown list, select Short Integer.
c. Click OK.

12. In the attribute table, right-click on the new field, and choose Field Calculator.
13. In the expression box, copy and paste the following equation, then click OK (Figure 225):

(([VALUE_1] * 1) + ([VALUE_2] * 2) + ([VALUE_3] * 3) + ([VALUE_4] * 4) + ([VALUE_5] * 5) + 
([VALUE_6] * 6) + ([VALUE_7] * 7) + ([VALUE_8] * 8) + ([VALUE_9] * 9) + ([VALUE_10] * 10) + 
([VALUE_11] * 11) + ([VALUE_12] * 12) + ([VALUE_13] * 13) + ([VALUE_14] * 14) + ([VALUE_15] * 15) + 
([VALUE_16] * 16) + ([VALUE_17] * 17) + ([VALUE_18] * 18) + ([VALUE_19] * 19) + ([VALUE_20] * 20) + 
([VALUE_21] * 21) + ([VALUE_22] * 22) + ([VALUE_23] * 23) + ([VALUE_24] * 24) + ([VALUE_25] * 25) + 
([VALUE_26] * 26) + ([VALUE_27] * 27) + ([VALUE_28] * 28) + ([VALUE_29] * 29) + ([VALUE_30] * 30) + 
([VALUE_31] * 31) + ([VALUE_32] * 32) + ([VALUE_33] * 33) + ([VALUE_34] * 34) + ([VALUE_35] * 35) + 
([VALUE_36] * 36) + ([VALUE_37] * 37) + ([VALUE_38] * 38) + ([VALUE_39] * 39) + ([VALUE_40] * 40) + 
([VALUE_41] * 41) + ([VALUE_42] * 42) + ([VALUE_43] * 43) + ([VALUE_44] * 44) + ([VALUE_45] * 45) + 
([VALUE_46] * 46) + ([VALUE_47] * 47) + ([VALUE_48] * 48) + ([VALUE_49] * 49) + ([VALUE_50] * 50) + 
([VALUE_51] * 51) + ([VALUE_52] * 52) + ([VALUE_53] * 53) + ([VALUE_54] * 54) + ([VALUE_55] * 55) + 
([VALUE_56] * 56) + ([VALUE_57] * 57) + ([VALUE_58] * 58) + ([VALUE_59] * 59) + ([VALUE_60] * 60) + 
([VALUE_61] * 61) + ([VALUE_62] * 62) + ([VALUE_63] * 63) + ([VALUE_64] * 64) + ([VALUE_65] * 65) + 
([VALUE_66] * 66) + ([VALUE_67] * 67) + ([VALUE_68] * 68) + ([VALUE_69] * 69) + ([VALUE_70] * 70) + 
([VALUE_71] * 71) + ([VALUE_72] * 72) + ([VALUE_73] * 73) + ([VALUE_74] * 74) + ([VALUE_75] * 75) + 
([VALUE_76] * 76) + ([VALUE_77] * 77) + ([VALUE_78] * 78) + ([VALUE_79] * 79) + ([VALUE_80] * 80) + 
([VALUE_81] * 81) + ([VALUE_82] * 82) + ([VALUE_83] * 83) + ([VALUE_84] * 84) + ([VALUE_85] * 85) + 
([VALUE_86] * 86) + ([VALUE_87] * 87) + ([VALUE_88] * 88) + ([VALUE_89] * 89) + ([VALUE_90] * 90) + 
([VALUE_91] * 91) + ([VALUE_92] * 92) + ([VALUE_93] * 93) + ([VALUE_94] * 94) + ([VALUE_95] * 95) + 
([VALUE_96] * 96) + ([VALUE_97] * 97) + ([VALUE_98] * 98) + ([VALUE_99] * 99) + ([VALUE_100] * 

Figure 223 Location of the Tabulate Area 
tool in ArcToolbox 

Figure 224 Tabulate Area tool window in ArcMap 
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100))/([VALUE_0] + [VALUE_1] + [VALUE_2] + [VALUE_3] + [VALUE_4] + [VALUE_5] + [VALUE_6] + 
[VALUE_7] + [VALUE_8] + [VALUE_9] + [VALUE_10] + [VALUE_11] + [VALUE_12] + [VALUE_13] + 
[VALUE_14] + [VALUE_15] + [VALUE_16] + [VALUE_17] + [VALUE_18] + [VALUE_19] + [VALUE_20] + 
[VALUE_21] + [VALUE_22] + [VALUE_23] + [VALUE_24] + [VALUE_25] + [VALUE_26] + [VALUE_27] + 
[VALUE_28] + [VALUE_29] + [VALUE_30] + [VALUE_31] + [VALUE_32] + [VALUE_33] + [VALUE_34] + 
[VALUE_35] + [VALUE_36] + [VALUE_37] + [VALUE_38] + [VALUE_39] + [VALUE_40] + [VALUE_41] + 
[VALUE_42] + [VALUE_43] + [VALUE_44] + [VALUE_45] + [VALUE_46] + [VALUE_47] + [VALUE_48] + 
[VALUE_49] + [VALUE_50] + [VALUE_51] + [VALUE_52] + [VALUE_53] + [VALUE_54] + [VALUE_55] + 
[VALUE_56] + [VALUE_57] + [VALUE_58] + [VALUE_59] + [VALUE_60] + [VALUE_61] + [VALUE_62] + 
[VALUE_63] + [VALUE_64] + [VALUE_65] + [VALUE_66] + [VALUE_67] + [VALUE_68] + [VALUE_69] + 
[VALUE_70] + [VALUE_71] + [VALUE_72] + [VALUE_73] + [VALUE_74] + [VALUE_75] + [VALUE_76] + 
[VALUE_77] + [VALUE_78] + [VALUE_79] + [VALUE_80] + [VALUE_81] + [VALUE_82] + [VALUE_83] + 
[VALUE_84] + [VALUE_85] + [VALUE_86] + [VALUE_87] + [VALUE_88] + [VALUE_89] + [VALUE_90] + 
[VALUE_91] + [VALUE_92] + [VALUE_93] + [VALUE_94] + [VALUE_95] + [VALUE_96] + [VALUE_97] + 
[VALUE_98] + [VALUE_99] + [VALUE_100]) 

Figure 225 Field Calculator, with % Canopy equation entered 

The new field should contain values between 0 and 100%, indicating the average percent tree canopy 
cover in each land use type. 

Troubleshooting Common Errors: 
      Problem: 

An error may occur during field calculation as shown in Figure 226. The message references the 
Geoprocessing Results window, to open this window from the main menu click Geoprocessing > Results. 
The Results window may list an error message that states A field name was not found or there were 
unbalanced quotation marks (Figure 227). This may occur if the canopy cover for the user’s area of 
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interest does not contain all values from 0 to 100. It may also appear if one “Value” field contains all 
zeros.  

Figure 226 Field Calculator processing error window, referencing the Geoprocessing Results window 

Figure 227 Results window in ArcMap, with the Messages error shown 

      Solution: 
Open the Tabulate Area table and confirm that fields “Value_0” through “Value_100” appear. If a 
field is missing, it must be removed from both parts of the Field Calculator equation. For example, 
the NLCD canopy cover for Tampa Bay does not contain values 1-4. These values must be 
removed from the equation above. The expression for Tampa Bay will start with (([VALUE_5] * 5) 
+ … and will divide by /([VALUE_0] + [VALUE_5] + … in the second half of the equation.

14. Use the Add Data  icon to navigate to the lookup table with .dbf extension (e.g. supplemental
lookup table exported from Appendix A: Supplemental NLCD Lookup Table) and add the table to the
Table of Contents.

15. Right click on the lookup table and open the Join tool (example shown in Figure 183).
16. In the Join Data window (example shown in Figure 184):

a. In the first dropdown list, select Join attributes from a table.
b. In the Choose the field in this layer that the join will be based on dropdown list, select

“GRIDCODE”.
c. In the Choose the table to join to this layer dropdown list, select the Tabulate Area table

(e.g. Canopy_TabArea).
d. In the Choose the field in the table to base the join on dropdown list, select “GRIDCODE”.
e. Under Join Options, toggle the Keep all records option on.
f. Click OK.
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17. Open the lookup table, locate the “Canopy” field, and open the Field Calculator.
18. In the Field Calculator window (Figure 228):

a. In the Fields list box, double click on the new field name (e.g. Canopy_TabArea:AVGCC).
b. The new field should appear in the expression box. Click OK.

Figure 228 Field Calculator window, with the AvgCC field as the expression 

19. Right click on the lookup table and choose Joins and Relates > Remove Join(s) >Tabulate Area table
(e.g. Canopy_TabArea, Figure 229).

Figure 229 Location of the Remove Join tool, in the Table of Contents 

Although averaging canopy cover helps to limit errors, some manual corrections may be necessary. 
One common instance of this is seen with aquatic land use types. Whereas aquatic areas are known 
to be covered in water bordering areas with trees may cause the land use type to be assigned a small 
percent canopy cover, especially when there are differences in resolution. These errors were 
corrected in the lookup table by adjusting the canopy cover value to zero. The following steps 
illustrate how to zero out the “Canopy” value for NLCD Open Water.  
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20. Open the supplemental lookup table, locate the row for Open Water, and click the to the left of that
row to select it (the entire row will be highlighted in blue when selected).

21. With Open Water selected, right-click the “Canopy” field and open the Field Calculator.
22. In the Field Calculator window (example shown in Figure 228):

a. In the expression box, type 0
b. Click OK.

The average percent canopy cover for the user’s AOI has replaced the national averages in the “Canopy” 
field of the lookup table, and the canopy cover for Open Water has been corrected. This updated field will 
be used to calculate the “Us_Air_Dol” field in the Field Calculations section.   

Using QGIS 

This section illustrates how to update the % Canopy Cover (“Canopy” field) for the user’s area of interest 
using QGIS.  

Although the following process is shown using an NLCD land use dataset, the same steps can be 
performed using an alternative land use vector dataset (e.g. FLUCCS) and a lookup table with 
corresponding land use classes (e.g. the original Qspatialite lookup table). Simply replace the “gridcode” 
field with the appropriate land use code field where required.  

1. Download and unzip the Canopy Cover data, as shown in the Download Tree Canopy Data
section.

2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined
in Set Up QGIS Map Document.

3. From the Layer menu open the Add Raster Layer window (Main Menu > Layer > Add Raster
Layer, Figure 145).

4. Navigate to the cartographic canopy cover data and add the 2011 .tif file (or most recent
year) to the Layers panel (e.g.
NLCD_2011_Tree_Canopy_L48_20190831_RTDBmKOdx72K3rodhLUd.tiff).

5. From the Layer menu open the Add Vector Layer window (Main Menu > Layer > Add Vector
Layer, Figure 126).

6. In the Add vector layer window, click Browse to locate and select the soil/land use layer (e.g.
NLCD_MaxTypeN_spatial) previously created in the Spatially Join Soils to Land Use section.
Click Open to add this layer to the map document.

7. From the Raster menu, open the Warp (Reproject) tool (Main Menu > Raster > Projections >
Warp (Reproject), Figure 146).

8. In the Warp (Reproject) window (example shown in Figure 148):
a. In the Input file dropdown list, select the NLCD canopy raster (e.g.

NLCD_2011_Tree_Canopy_L48_20190831_RTDBmKOdx72K3rodhLUd.tiff).
b. Next to the Output file, click Select to select a file path and name for the output (e.g.

Canopy_reproj.tif). Be sure to name the output with a .tif extension.
c. Check the Source SRS box, and click Select to open the Select the source SRS window.

i. Under the Recently used coordinate reference systems section, choose the * Generated
CRS (+proj = aea…) SRS (Figure 147).

ii. Click OK.
d. Check the Target SRS box and click Select to open the Select the target SRS window.
e. In the Filter box, type 3857, and under Coordinate reference systems of the world, choose

WGS 84/ Pseudo Mercator. Click OK.
f. Check Load into canvas when finished.
g. Click OK.
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9. From the Raster menu, open the Zonal Statistics tool (Main Menu > Raster > Zonal Statistics
> Zonal Statistics).

10. In the Dialog window (Figure 230):
a. In the Raster layer dropdown list, select the re-projected canopy raster (e.g. Canopy_reproj).
b. In the Polygon layer containing the zones dropdown list, select the soil/land use layer (e.g.

NLCD_MaxTypeN_spatial).
c. In the Output column prefix text box, enter LU.
d. Click OK.

Figure 230 Zonal Statistics Dialog window, with LU designated as the Output column prefix 

This tool may take some time to process. Do not close the Dialog window until processing is complete. 
Once finished, the soil/land use layer (e.g. NLCD_MaxTypeN_spatial) will contain three new fields: 
“LUcount”, “LUsum”, and “LUmean”.  

11. Open the soil/land use attribute table and click the pencil icon  to start an edit session. 

12. Click the Add column icon  to add a new field in the attribute table. 
13. In the Add column window (example shown in Figure 205):

a. In the Name field, type Area.
b. In the Type dropdown list, select Decimal number (real).
c. In the Width text box enter 20 and in the Precision text box enter 2.
d. Click OK.

14. Click the Field Calculator icon  to open the Field Calculator window. 
15. In the Field Calculator window (example shown in Figure 161):

a. Check Update existing field option.
b. In the Field dropdown list, select the “Area” field.
c. Click the Geometry option to open the dropdown list, and double click on $area.
d. $area will appear in the Expression box. Click OK.

16. Click the Add column icon again to add a second field.
17. In the Add column window:

a. In the Name field, enter the desired field name (e.g. new_field)
b. In the Type dropdown list, select Decimal number (real).
c. In the Width text box enter 20, and in the Precision text box enter 2.
d. Click OK.

18. Click the Field Calculator icon again to open the Field Calculator.
19. In the Field Calculator window:
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a. Select the Update existing field option.
b. In the Field dropdown list, select the new field (e.g. “new_field”).
c. Click the Fields and Values option to open the dropdown list.
d. Double click on the “Area” field from the list; the name should appear in the Expression box.
e. Click on the multiply (*) operator; it should appear in the Expression box.
f. Double click on the “LUmean” field from the list; the name should appear in the Expression

box. The full expression is: "Area" * "LUmean"
g. Click OK.

20. Click the pencil icon to turn off editing and save changes to the attribute table.
21. In the soil/land use attribute table (e.g. NLCD_MaxTypeN_spatial), click on the Advanced search

tool (as shown in Figure 212).
22. In the Search query builder window (example shown in Figure 213):

a. In the Fields list, double click the “gridcode” field; the name should appear in the Expression
box.

b. Click the Equals (=) operator; it should appear in the Expression box.
c. Under the Values option, click the All button; the list of all gridcode values will appear.
d. Double click on the first code (this is gridcode 11 with NCLD data). The full expression is:

gridcode = 11
e. Click OK.

23. In the attribute table, click the Move selection to top icon  to view the selected features. 
24. While leaving the attribute table open, open the Basic Statistics tool (Main Menu >Vector >

Analysis Tools > Basic statistics).
25. In the Basic statistics window (Figure 232):

a. In the Input Vector Layer dropdown list, select the soil/land use layer (e.g.
NLCD_MaxTypeN_spatial).

b. Check the Use only selected features option if not already checked.
c. In the Target field dropdown list, select the field created in step 19 (e.g. “new_field”).
d. Click OK.

The statistics output will be listed in the Basic statistics window after the tool is run (Figure 231). 
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26. Copy down the Sum value (e.g. 1,804,788,202.05) into a spreadsheet. This value will be used in
a later field calculation.

27. In the same Basic statistics window, change the Target field to “Area”.
28. Click OK to run a new statistical output.
29. Copy down the Sum value into the same spreadsheet. This value will be used in a later field

calculation.
30. Repeat steps 21-29 above for each gridcode value:

a. Select each gridcode individually in the Search query builder window.
b. Copy the Sum value for the “new_field” and “Area” fields in the Basic statistics window for

each selection.
c. It is recommended that the user create a table of the gridcodes and sums, to keep the values

organized for later calculations.

Please note: the sum of the “Area” field for each gridcode is also needed to update the Carbon 
Sequestration (Using QGIS section) and Denitrification coefficients. It is strongly recommended to save 
the Sum values for each gridcode in Excel to avoid repeating the steps above.  

31. Add the supplemental lookup table to the QGIS Layers panel following the QGIS directions in
Appendix A: Supplemental NLCD Lookup Table.

32. Right-click and open the lookup table from the Layers panel.

33. Click the pencil icon  to start an edit session. 
34. Click the “GRIDCODE” field name, to sort the field values in Ascending order.
35. Select the first “GRIDCODE” row with a value. For NLCD, the first gridcode value is 11.

36. Click the Field Calculator icon to open the Field Calculator. 
37. In the Field Calculator window (Figure 233):

a. Check the Only update selected features option.
b. Check the Update existing field option.
c. In the dropdown list, select the “Canopy” field.

Figure 232 Basic statistics window before the 
Statistics output is run 

Figure 231 Basic statistics window, with Statistics 
output gridcode 11 in new_field 
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d. In the Expression box, type the “new_field” sum for the first gridcode, divided by the “Area”
sum for that gridcode. The expression should read “new_field” sum / “Area” sum (e.g.
1804788200.58 / 73515068.6)

e. Click OK.

Figure 233 Field Calculator window, with 1804788200.58 / 73515068.6 entered as the expression 

38. Repeat field calculation steps 35-37 for each gridcode row, with the appropriate “new_field” sum
and “Area” sum.

Once the calculations are complete, the “Canopy” field in the lookup table will contain the average % 
Canopy Cover for each land use type in the AOI. This updated field will be used to calculate the 
“Us_Air_Dol” field in the Field Calculations section.   

Air Quality 

This section illustrates how to update the air quality value (“canopyVal”) for an area of interest. The 
“canopyVal” field will be used to calculate the “Us_Air_Dol” field in the Joining Lookup Table section. 

Average removal rates for carbon monoxide (CO), ozone (O3), particulate matter (PM10), sulfur dioxide 
(SO2), and nitrogen dioxide (NO2) have been previously estimated for 55 metropolitan areas in the 
continental United States (Nowak et al., 2006; Figure 234). If the area of interest is within the 
continental United States or Hawaii, the removal rates for each pollutant in the nearest city can either 
be selected from the Air Quality Reference table (Appendix B: Air Quality Reference Table), or by 
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spatially referencing the Air Quality Reference table and determining the nearest city in either ArcGIS 
or QGIS. The total Air Quality value of canopy cover ($/m2/yr) has been calculated in the Air Quality 
Reference table as described in the ES Calculations Theory section.  

Figure 234 Total value ($/m2/yr) of canopy cover for each metropolitan area in Nowak et al., 2006 

Using ArcGIS 

This section outlines the calculation of land use air pollution removal rates based on the nearest city, 
using the Air Quality Reference table as a shapefile in ArcGIS. This process is suggested if the user is 
unsure which city from Appendix B: Air Quality Reference Table is closest to their AOI. However, if the 
user knows which city from the table is closest, the shapefile is not required. The user can skip to step 
9 and enter the appropriate “Value/m2/yr” value into Field Calculator.   

1. Create a shapefile (AirQualityReference.shp) from the Air Quality Reference table as shown in
Appendix B: Air Quality Reference Table.

2. Open your existing ArcGIS map document file (.mxd), or create one following
the steps outlined in Set Up ArcGIS Map Document.

3. Use the Add Data  icon to navigate to and add the AirQualityReference shapefile as a layer 
in the Table of Contents.

4. If using a new map document, the AOI shapefile created in the Using ArcGIS section must be
added in the same way.
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5. Right click on the layer representing the AOI and select Joins and Relates > Join… (Figure 194).
6. In the Join Data window (Figure 235).

a. From the first dropdown list, select Join
data from another layer based on spatial
location.

b. In the Choose the layer to join to this layer
dropdown list, select AirQualityReference.

c. Toggle the second join option, to join only
the attributes of the nearest point.

d. In the Specify output shapefile text box,
enter the desired file path and shapefile
name (e.g. AOI_Join_AQ.shp).

7. In the Table of Contents, right-click on the output
layer (e.g. AOI_Join_AQ) and open the attribute
table.

8. Find the “Value_m2” field in the attribute table and
write down or copy the value in this field. The
value will be used to populate the “canopyVal”
field in the lookup table in step 9.

Note: if the AOI includes multiple features, for
example when multiple HUCs or counties are
analyzed at once, then the values in the
“Value_m2” field may differ across features/rows
in the nearest join table, if those features are
closer to different cities. It is recommended to
choose one value to use throughout. Alternatively,
separate lookup tables and land use layers can be
created for the different AOI features, each using
their own unique “Value_m2” and “canopyVal”
fields.

9. In the Table of Contents, right-click on the
supplemental lookup table (e.g. lookUPvars) and
open the attribute table.

a. Right-click on the “canopyVal” field in the attribute table and open the Field Calculator.
b. In the “canopyVal” Field Calculator window:

i. Enter the value (e.g. 0.0713215) from the “Value_m2” field in the output layer
(e.g. AOI_Join_AQ).

ii. Type / 100 after the coefficient value in the Expression box (e.g. 0.0713215 /
100).

iii. Click OK.

The lookup table “canopyVal” field contains the air pollutant removal value coefficient. This coefficient 
will be multiplied by the land use average canopy cover to get values for air pollution removal for the 
“Us_Air_Dol” field in the Field Calculations section.  

Using QGIS 

This section outlines the calculation of land use air pollution removal rates based on the nearest city, 
using the Air Quality Reference table as a shapefile in QGIS. This process is suggested if the user is 
unsure which city from Appendix B: Air Quality Reference Table is closest to their AOI. However, if the 

Figure 235 Join Data window filled out as described in 
the text, with the result nearest join table saved as 
AOI_Join_AQ.shp 



176 

user knows which city from the table is closest, the shapefile is not required. The user can skip to step 
22 and enter the appropriate “Value/m2/yr” value into Field Calculator. 

1. Create a shapefile (AirQualityReference.shp) from the Air Quality Reference table as shown in
Appendix B: Air Quality Reference Table.

2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined
in Set Up QGIS Map Document.

3. From the Layer menu open the Add Vector Layer window (Main Menu > Layer > Add Vector
Layer, Figure 126).

4. In the Add vector layer window (example shown in Figure 127), click Browse to locate and
select the AirQualityReference shapefile, then click Open.

5. If using a new map document, the AOI shapefile created in the Using QGIS section must be
added in the same way.

6. From the Vector menu open the Polygon centroids tool (Vector > Geometry tools > Polygon
centroids, Figure 236).

Figure 236 Polygon centroids tool in QGIS, located in Vector menu > Geometry tools 

7. In the Polygon centroids window (Figure 238):
a. In the Input polygon vector layer dropdown list, select the AOI shapefile (e.g. HUC_Tampa).
b. In the Output point shapefile text box, indicate the file path and shapefile name (e.g.

HUC_Tampa_points.shp).
c. Click OK.

The output is a point shapefile, with one point for the center of each watershed polygon (Figure 237). 

 
 
Figure 238 Polygon centroids window, with HUC shapefile 
as input 

Figure 237 HUC shapefile with centroid points 
in blue; closest Air Quality Reference City 
represented by purple point 
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8. From the Vector menu open the Distance matrix tool (Vector > Analysis tools > Distance matrix,
Figure 239).

Figure 239 Distance matrix tool in QGIS, located in Vector menu > Analysis tools 

9. In the Distance matrix window (Figure 240):
a. In the Input point layer dropdown list, select the

HUC centroid points shapefile (e.g.
HUC_Tampa_points).

b. In the Input unique ID field dropdown list,
choose “NAME”.

c. In the Target point layer dropdown list, select
the AirQualityReference shapefile.

d. In the Target unique ID field dropdown list,
select “City”.

e. Under Output matrix type, toggle on the Linear
option if not on by default.

f. Check Use only the nearest (k) target points
and enter 1 in the text box.

g. In the Output distance matrix text box, indicate
the file path and output name (e.g.
DistanceMatrix_HUC.csv).

h. Click OK.
10. A popup window may appear, telling the user that

the output matrix was created. Click OK.
11. Click Close to close the Distance matrix window.
12. Locate the output matrix in File Explorer and click

and drag the .csv file into the Layers panel.
13. In the Layers panel, double click on the matrix .csv

layer to open Layer Properties.
14. In the Layers Properties window, click on the Joins

tab and click the Add Join  icon.
15. In the Add vector join window (example shown in

Figure 200):
a. In the Join layer dropdown list, select the AirQualityReference shapefile.
b. In the Join field dropdown list, select “City”.
c. In the Target field dropdown list, select “TargetID”.
d. Check Cache join layer in virtual memory.
e. Click OK.

16. Click OK to close Layer Properties.
17. In the Layers panel, right click on the matrix .csv layer and choose Open Attribute Table.
18. Locate the “Value_m2” field in the attribute table.

Figure 240 Distance matrix window, with output 
as a .csv file 
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a. Take note of the value in this field, as it will need to be typed into the Field Calculator in the
following steps.

Note: if the AOI includes multiple features, for example when multiple HUCs or counties are 
analyzed at once, then the values in the “Value_m2” field may differ across features/rows in the 
nearest join table, if those features are closer to different cities. It is recommended to choose one 
value to use throughout. Alternatively, separate lookup tables and land use layers can be created 
for the different AOI features, each using their own unique “Value_m2” and “canopyVal” fields. 

19. Load the supplemental lookup table from Appendix A: Supplemental NLCD Lookup Table or
the most recently updated lookup table (e.g. if updated in the Tree Canopy section) into the
Layers panel.

20. In the Layers panel, double click on the lookup table to open Layer Properties.

21. Under the Fields tab, click the Pencil  icon to start editing. 

22. Click the Field Calculator  icon, and in the Field Calculator window (Figure 241): 
a. Check the Update existing field.
b. From the dropdown list, select the “canopyVal” field.
c. In the Expression box, type the value from the “Value_m2” field in step 18 (e.g. 0.0713215).
d. Type / 100 after the coefficient value in the Expression box (e.g. 0.0713215 / 100).
e. Click OK.

Figure 241 Field Calculator in QGIS, used to update the canopyVal field 

23. Click the Pencil icon to toggle editing off and save changes made to the attribute table.
24. Click OK to close Layer Properties.
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The lookup table “canopyVal” field now contains the air pollutant removal value coefficient. This 
coefficient will be multiplied by the land use average canopy cover to get values for air pollution 
removal for the “Us_Air_Dol” field in the Field Calculations section.  

Carbon Sequestration 

This section details how the carbon fixation rate was established for each land use type in the 
Supplemental NLCD Lookup Table (Appendix A) and how rates can be further refined for an area of 
interest. These rates, found in the “CarbonFixe” field (g C/m2/yr), will be used to calculate the 
“StableClim” field in the Joining Lookup Table section. Carbon fixation coefficients (g C/m2/yr) will 
differ significantly depending on if the carbon is being fixed into biomass or buried. The literature 
values used to calculate each NLCD carbon burial rate are listed in Appendix A. These rates differ 
from the FLUCCS carbon fixed into biomass listed in Table 3 and described in the ES Calculations 
Theory section. 

When updating carbon fixation rates, it is suggested that the user first calculate the percent of each 
land use type found in the Area of Interest (AOI). This helps identify the land use types where the 
model will be most sensitive to the “CarbonFixe” rates. It is possible that an AOI will not include some 
land use types from the classification. When this occurs, the rate will have no impact on results and 
would not need to be updated. Steps for determining the percent of each land use type in the AOI are 
illustrated in the Carbon Fixation Rates from Literature Review 

The following summarizes the process and criteria used to determine carbon burial rates for all NLCD 
land use classes that were not “Developed” land use types from reviewed literature. 

• An extensive literature review was conducted. The values obtained from these reviews were
ranked based on specificity to land use type, location, and reliability of the source.

• After the values were selected, a land use type average was calculated; this average value is
the final Carbon Burial Rate for each land use type.

• The available literature varies between land use types, location, units, and sampling duration,
as well as the method of carbon storage (sequestered, fixed, or buried). This results in some
values being more reliable than others.

• Where no carbon burial rates are available, they may be inferred from similar land use types.
This approach was used for the “Mixed Forest” land use type, where values were an average
from “Deciduous Forest” and “Evergreen Forest” rates, two land use types with reliable rates
in the literature. Likewise, when rates are available but not reliable, it may be helpful to
compare the rate against rates for other similar land use types.

Once new carbon burial rates are determined for the user’s AOI, these rates must be updated in the 
NLCD lookup table using Field Calculator to replace the national averages in the “CarbonFixe” field. 

Using ArcGIS or Using QGIS sections. 

Carbon fixation rates either come from rates in reviewed literature or are calculated for developed land 
use classes based on the average characteristics (i.e. percent canopy and impervious surfaces). 
Steps for calculating carbon fixation rates for developed land use types are illustrated for ArcGIS in 
the Rates for Developed Classes section or for QGIS in the Rates for Developed Classes section. 
Determining rates for all other land use types from literature values is detailed in the Carbon Fixation 
Rates from Literature Review section. 

Carbon Fixation Rates from Literature Review 
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The following summarizes the process and criteria used to determine carbon burial rates for all NLCD 
land use classes that were not “Developed” land use types from reviewed literature. 

• An extensive literature review was conducted. The values obtained from these reviews were
ranked based on specificity to land use type, location, and reliability of the source.

• After the values were selected, a land use type average was calculated; this average value is the
final Carbon Burial Rate for each land use type.

• The available literature varies between land use types, location, units, and sampling duration, as
well as the method of carbon storage (sequestered, fixed, or buried). This results in some values
being more reliable than others.

• Where no carbon burial rates are available, they may be inferred from similar land use types. This
approach was used for the “Mixed Forest” land use type, where values were an average from
“Deciduous Forest” and “Evergreen Forest” rates, two land use types with reliable rates in the
literature. Likewise, when rates are available but not reliable, it may be helpful to compare the
rate against rates for other similar land use types.

Once new carbon burial rates are determined for the user’s AOI, these rates must be updated in the 
NLCD lookup table using Field Calculator to replace the national averages in the “CarbonFixe” field. 

Using ArcGIS 

The following steps summarize how to calculate the percent of each land use type using Esri ArcGIS. 
If the user does not have a Spatial Analyst license, the user may be able to estimate the most 
prominent land use types from the raster attribute table after clipping the raster to the AOI. 

1. Tabulate the area between the NLCD raster and the AOI shapefile. In the ArcToolbox window,
navigate to the Tabulate Area tool (ArcToolbox > Spatial Analyst Tools > Zonal, Figure 223).

2. In the Tabulate Area window (example shown in Figure 224):
a. In the zone data dropdown list, select the NLCD raster.
b. In the class data dropdown list, select the AOI shapefile (i.e. the HUC boundary shapefile).

3. The output table will list each area in the land use layer units (for NLCD this in meters). Percent of
total area is calculated by:
a. Add the area of each gridcode together to find the total area of the AOI.
b. Divide each gridcode area by the total area and multiply the value by 100. This will provide

the percent land use out of 100%.
4. When listed in descending order, the percent land use table will outline which land use types are

most prominent (highest percentage) in the user’s AOI.

It is strongly recommended that the user evaluate the values selected in the literature review, with a 
focus on the most prominent land use types.  

Carbon Fixation Rates for Developed Classes 

The following steps summarize how the carbon burial rate is calculated for the NLCD “Developed” 
land use types (e.g. “Developed, Open Space” through “Developed, High Intensity”) using Esri 
ArcGIS. 

1. Calculate the % Canopy Cover and populate the “Canopy” field, as shown in the Tree Canopy
section.

2. Calculate the Canopy based Carbon Burial Rate for each “Developed” land use type:
a. Copy the “Canopy” value for each “Developed” land use type into a spreadsheet.
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b. Determine an average Carbon Burial Rate for trees in developed areas. For NLCD
carbon burial rates listed in Appendix A, the average value for “Evergreen Forest” and
“Deciduous Forest” (i.e. “Mixed Forest”) was 28.

c. Canopy Carbon Burial Rate = (% canopy / 100) * 28
3. Calculate % impervious surface for the user’s specific area of interest, following the same

steps outlined in the Tree Canopy section:
a. Navigate to https://www.mrlc.gov/viewer/ as shown in Figure 217, and download the

Impervious data using the All Impervious Years option.
b. Reproject the NLCD 2011 Impervious .tif dataset (or most recent year), as shown in the

Using ArcGIS section.
c. Run the Tabulate Area tool between the soil/land use layer and the re-projected

impervious layer.
i. In the Input raster zone data dropdown list, select the soil/land use layer (e.g.

NLCD_MaxTypeN_join) and in the Zone field dropdown list, select “gridcode”.
ii. In the Input raster class data dropdown list, select the re-projected impervious

layer, and in the Class field dropdown list, select “Value”.
iii. In the Output table text box, name the output table (e.g. Imp_TabArea) and file

path.
iv. Click OK.

d. In the output Tabulate Area table (e.g. Imp_TabArea) add a new field (e.g. “avgImp”) with
type Short Integer.

e. Right-click on the new field (e.g. “avgImp”) and open Field Calculator.
i. In the Expression box, paste the same equation used to calculate the % canopy

in step 13 of the Tree Canopy (Using ArcGIS) section (example shown in Figure
225) to calculate % impervious surface.

4. Calculate the Lawn Carbon Burial Rate for each “Developed” land use type:
a. Copy the “Impervious” (e.g. “Imp” field) value for each “Developed” land use type into a

spreadsheet.
b. Determine an average Carbon Burial Rate for lawns in developed areas. For NLCD

carbon burial rates listed in Appendix A the average lawn rate from the literature review
was 100 (Table 4).

c. Lawn Carbon Burial Rate = 100 * ((100 - % impervious) / 100)
5. The final Carbon Burial Rate for the “Developed” land use types are calculated as:

Final Carbon Burial Rate = Lawn Carbon Burial Rate + Canopy Carbon Burial Rate.
6. In the lookup table use Field Calculator to update the “CarbonFixe” field value for each

“Developed” land use type to equal the new corresponding Final Carbon Burial Rate.

The lookup table “CarbonFixe” field now contains the updated carbon burial rates, which will be used to 
calculate the “StableClim” field in the Field Calculations section. The database creation is continued in the 
Denitrification section.  

Using QGIS 

The following steps summarize how to calculate the percent of each land use type using QGIS. If the 
user saved the Sum of the “Area” field for each gridcode in a separate spreadsheet (Using QGIS 
section), skip to step 5.   

1. From the soil/land use attribute table, open the Advanced search tool (as shown in Figure 212).
2. Select all polygons representing the first land use type. In the Search query builder window:

a. In the Expression box, enter gridcode =

https://www.mrlc.gov/viewer/
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b. Under the Values option, click the All button; the list of all gridcode values will appear.
Double click on the first gridcode value (e.g. 11).

3. With the selection highlighted, open the Basic Statistics tool (Main Menu >Vector > Analysis
Tools > Basic statistics).

a. In the Input Vector Layer dropdown list select the soil/land use layer.
b. Check Use only selected features.
c. In the Target field dropdown list select “Area”.

4. Copy down the Sum value for the first gridcode into a spreadsheet. Repeat the selection and
Basic Statistics analysis to obtain the total area for each gridcode type.

5. Add the area of each gridcode together to find the total area of the AOI.
6. Divide each gridcode area by the total area and multiply the value by 100. This will provide the

percent land use out of 100%.
7. When the percent land use is listed in descending order in the spreadsheet, the land use types at

the top are most prominent (highest percentage) in the user’s AOI.

It is strongly recommended that the user evaluate the values selected in the literature review, with a focus 
on the most prominent land use types. 

Carbon Fixation Rates for Developed Classes 

The following steps summarize how the carbon burial rate was calculated for the NLCD “Developed” 
land use types (e.g. “Developed, Open Space” through “Developed, High Intensity”) using QGIS. 

1. Calculate the % Canopy Cover and populate the “Canopy” field, as shown in the Tree Canopy
section.

2. Calculate the Canopy Carbon Burial Rate for each “Developed” land use type:
a. Copy the “Canopy” value for each “Developed” land use type into a spreadsheet.
b. Determine an average Carbon Burial Rate for trees in developed areas. For NLCD

carbon burial rates listed in Appendix A, the average value for “Evergreen Forest” and
“Deciduous Forest” (i.e. “Mixed Forest”) was 28.

c. Canopy Carbon Burial Rate = (% canopy / 100) * 28
3. Calculate % impervious surface for the user’s specific area of interest, following the same steps

outlined in the Tree Canopy section:
a. Navigate to https://www.mrlc.gov/viewer/ as shown in Figure 217, and download the

Impervious data using the All Impervious Years option.
b. Reproject the NLCD 2011 Impervious .tif dataset (or most recent year), as shown in the

Using QGIS section.
c. Run the Zonal Statistics tool between re-projected impervious layer and the soil/land use

layer with a new output column prefix (e.g. IMP).
i. In the Raster layer dropdown list, select the re-projected impervious layer.
ii. In the Polygon layer containing the zones dropdown list, select the soil/land use

layer.
iii. In the Output column prefix text box, enter IMP, then click OK.

d. In the soil/land use layer, create a new field (e.g. “avgImp”) with Whole number (integer)
type. Then use Field Calculator to populate the new field using the expression “Area” *
“IMPmean”.

e. Follow the steps outlined in the Using QGIS section to select each “Developed” gridcode
value and use the Basic Statistics tool to find the Sum values for the newly created field
and the “Area” field.

i. Open the attribute table and use the Search query builder to select the first
“Developed” gridcode (e.g. gridcode = 21).

ii. Open the Basic Statistics tool and select the following inputs: in the Input Vector
Layer dropdown list, select the soil/land use layer, check Use only selected
features, and in the Target field dropdown list, choose “avgImp”. Click OK.

https://www.mrlc.gov/viewer/
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iii. Copy down the Sum value for the “avgImp” field, then change the Target field to
“Area” and click OK to run another statistical output. Copy down the Sum value
for the “Area” field.

iv. Repeat step e for each “Developed” gridcode”.
f. In the spreadsheet, complete the following calculation to determine the % impervious

surface for each “Developed” gridcode value: “newest_field” sum / “Area” sum
4. Calculate the Lawn Carbon Burial Rate for each “Developed” land use type:

a. Each “Developed” land use type will have a % impervious in the spreadsheet calculated
in the previous step.

b. Determine an average Carbon Burial Rate for lawns in developed areas. For NLCD
carbon burial rates listed in Appendix A the average lawn rate from the literature review
was 100 (Table 4).

c. Total Carbon Burial Rate = 100 * ((100 - % impervious) / 100)
5. The final Carbon Burial Rate for the “Developed” land use types are calculated as:

Final Carbon Burial Rate = Lawn Carbon Burial Rate + Canopy Carbon Burial Rate.
6. In the lookup table use Field Calculator to update the “CarbonFixe” field value for each

“Developed” land use type to equal the new corresponding Final Carbon Burial Rate.

The lookup table “CarbonFixe” field now contains the updated carbon burial rates, which will be used to 
calculate the “StableClim” field in the Field Calculations section. The database creation is continued in the 
Denitrification section.  

Denitrification 
This section details how the Denitrification rate was established for each land use type in the 
Supplemental NLCD Lookup Table (Appendix A) and how rates can be further refined for an area of 
interest. These rates, found in the “denitrific” field (g N/m2/yr), will be used to calculate the 
“usablewat” field in the Joining Lookup Table section. 

Average nitrogen removal values have been provided for each NLCD land use type, based on an 
extensive literature review (Appendix A). These values may differ from the FLUCCS denitrification 
values listed in Table 3 and described in the ES Calculations Theory section. 

When updating denitrification rates, it is suggested that the user first calculate the percent of each 
land use type found in the user’s Area of Interest (AOI). This helps identify the land use types where 
the model will be most sensitive to the “denitrific” rates. It is possible that an AOI will not include some 
land use types from the classification. When this occurs, the rate will have no impact on results and 
would not need to be updated. Steps for determining the percent of each land use type in the AOI are 
illustrated in the Carbon SequestrationCarbon Fixation Rates from Literature Review 

The following summarizes the process and criteria used to determine carbon burial rates for all NLCD 
land use classes that were not “Developed” land use types from reviewed literature. 

An extensive literature review was conducted. The values obtained from these reviews were ranked 
based on specificity to land use type, location, and reliability of the source.  
After the values were selected, a land use type average was calculated; this average value is the final 
Carbon Burial Rate for each land use type.  
The available literature varies between land use types, location, units, and sampling duration, as well 
as the method of carbon storage (sequestered, fixed, or buried). This results in some values being 
more reliable than others. 
Where no carbon burial rates are available, they may be inferred from similar land use types. This 
approach was used for the “Mixed Forest” land use type, where values were an average from 
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“Deciduous Forest” and “Evergreen Forest” rates, two land use types with reliable rates in the 
literature. Likewise, when rates are available but not reliable, it may be helpful to compare the rate 
against rates for other similar land use types.  

Once new carbon burial rates are determined for the user’s AOI, these rates must be updated in the 
NLCD lookup table using Field Calculator to replace the national averages in the “CarbonFixe” field. 

Using ArcGIS or Using QGIS sections. 

Denitrification rates either come from rates in reviewed literature or are calculated for developed land 
use classes based on the average characteristics (i.e. percent canopy and impervious surfaces). The 
Determine Nitrogen Removal Rates section describes how to update rates using both these methods. 
The steps for calculating denitrification rates are very similar to those illustrated for ArcGIS in the 
Carbon Fixation Rates for Developed Classes section or for QGIS in the Carbon Fixation Rates for 
Developed Classes section.  

Nitrogen Removal Rates from Literature Review 

The following summarizes the process and criteria used to determine nitrogen removal rates for all NLCD 
land use classes that were not “Developed” land use types from reviewed literature. 

• An extensive literature review was conducted. The values obtained from these reviews were
ranked based on specificity to land use type, location, and reliability of the source.

• After the values were selected, a land use type average was calculated; this average value is the
final Nitrogen Removal Rate for each land use type.

• The available literature varies between land use types, location, units, and sampling duration.
This results in some values being more reliable than others.

• Where no nitrogen removal rates are available they may be inferred from similar land use types.
This approach was used for the “Mixed Forest” land use type, where values were an average
from “Deciduous Forest” and “Evergreen Forest” rates, two land use types with reliable rates in
the literature. Likewise, when rates are available but not reliable, it may be helpful to compare the
rate against rates for other similar land use types.

Once new denitrification rates are determined for the user’s AOI, these rates must be updated in the 
NLCD lookup table using Field Calculator to replace the national averages in the “denitrific” field. 

Determine Nitrogen Removal Rates 

The following steps summarize how the nitrogen removal rate was calculated for the NLCD 
“Developed” land use types (e.g. “Developed, Open Space” through “Developed, High Intensity”). 

Calculate % impervious surface for the user’s specific area of interest, as illustrated in the Carbon 
Sequestration Carbon Fixation Rates from Literature Review 

The following summarizes the process and criteria used to determine carbon burial rates for all NLCD 
land use classes that were not “Developed” land use types from reviewed literature. 

• An extensive literature review was conducted. The values obtained from these reviews were
ranked based on specificity to land use type, location, and reliability of the source.

• After the values were selected, a land use type average was calculated; this average value is
the final Carbon Burial Rate for each land use type.



185 

• The available literature varies between land use types, location, units, and sampling duration,
as well as the method of carbon storage (sequestered, fixed, or buried). This results in some
values being more reliable than others.

• Where no carbon burial rates are available, they may be inferred from similar land use types.
This approach was used for the “Mixed Forest” land use type, where values were an average
from “Deciduous Forest” and “Evergreen Forest” rates, two land use types with reliable rates
in the literature. Likewise, when rates are available but not reliable, it may be helpful to
compare the rate against rates for other similar land use types.

Once new carbon burial rates are determined for the user’s AOI, these rates must be updated in the 
NLCD lookup table using Field Calculator to replace the national averages in the “CarbonFixe” field. 

Using ArcGIS or Using QGIS sections. 
1. Calculate the final Nitrogen Removal Rate for each “Developed” land use type:

a. Use the “Impervious” (e.g. “avgImp” field) value for each “Developed” land use type.
b. Determine an average Nitrogen Removal Rate for lawns in developed areas. For

NLCD denitrification rates listed in Appendix A: Supplemental NLCD Lookup Table
the average rate from the literature review was 1.4 N/m2/yr (Raciti et al. 2011).

c. Final Nitrogen Removal Rate = ((100 - % impervious) / 100) * 1.4
2. In the lookup table, use Field Calculator (in ArcGIS or QGIS) to update the “denitrific” field value

for each “Developed” land use type to equal the new corresponding Final Nitrogen Removal Rate.
3. In the lookup table, use Field Calculator to also update the “dni” field to match the values in the

“denitrific” field.

The lookup table “denitrific” field now contains the updated nitrogen removal rates, which will be used to 
calculate the “usablewat” field in the Field Calculations section. The “dni” field is not directly used during 
field calculations; however, this field is used to recalculate the “usablewat” field in the H2O tool and must 
match the “denitrific” field values exactly. The database creation is continued in the Joining Lookup Table 
section. 

Joining Lookup Table 

This section illustrates the joining of the Supplemental NLCD lookup table with the land use layer using 
ArcGIS or QGIS. The lookup table contains the parameter values for each land use type that are required 
to compute Ecosystem Service values. After the join, field calculations are required to update these 
parameter values. 

The NLCD lookup table must be joined to the land use layer as part of database creation even if ES 
Coefficients were not updated in the Update ES Coefficients section. If the NLCD lookup table ES 
Coefficients were updated the updated lookup table should be joined, not the original found in 
Appendix A: Supplemental NLCD Lookup Table. If FLUCCS data were used in the Create Land Use 
Data Layer section instead of NLCD the corresponding lookup table from Appendix D: Extracting and 
Updating the Original FLUCCS Lookup Table may be joined by the “FLUCCS” field instead of the 
“GRIDCODE” field.  

Using ArcGIS 
This section illustrates how to join the lookup table and complete field calculations using Esri ArcGIS. 

1. Open your existing ArcGIS map document file (.mxd), or create one following the steps
outlined in Set Up ArcGIS Map Document.
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2. If using a new map document, use the Add Data  icon to navigate to and add both the 
soil/land use layer created in the Spatially Join Soils to Land Use section and the lookup 
table updated in the Update ES Coefficients section or from Appendix A: Supplemental 
NLCD Lookup Table. 

3. Right-click on the soil/land use layer (e.g. NLCD_MaxTypeN_join) and open the Join tool (as
shown in Figure 183).

4. In the Join Data window (example shown in Figure 184):
a. In the first dropdown list, select the Join attributes from a table option.
b. In the field in this layer that the join will be based on dropdown list, select “gridcode”.
c. In the table to join to this layer dropdown list, select the lookup table (i.e. lookUPvars).
d. In the field in the table to base the join on dropdown list, select “GRIDCODE”.
e. Under Join Options, toggle the Keep all records on.
f. Click OK.

5. Right-click on the land use layer and open the Export Data tool (Figure 123).
6. In the Export Data window (example shown in Figure 124):

a. In the Export dropdown list, select All features.
b. Under the Use the same coordinate system as section, toggle the data frame option on.
c. In the Output feature class text box, specify the file path and name the output Land_Use.shp.
d. Click OK.

Field Calculations 

This section illustrates how to update the blank fields joined from the lookup table (Figure 242). In the 
expressions, “denitrific” is the denitrification rate (g N/M2/yr), “CarbonFixe” is the carbon sequestration 
rate (g C/m2/yr), “Canopy” is percent canopy cover (%), and “CN” is Curve Number. 

Figure 242 Land_Use attribute table, with blank fields from lookup table join 

The following steps detail how to update the “usablewat” field. Similar steps need to be followed to 
update the “StableClim”, “Us_Air_Dol”, “CN” and “FloodProt” fields.  

1. Right-click on the Land_Use layer and open the attribute table.
2. Right-click on the “usablewat” field and choose Field Calculator.
3. In the Field Calculator window (Figure 243):

a. In the Fields list box, locate “denitrific” and double click on the field name; [denitrific] will
appear in the Expression box.
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b. In the Expression box, type * .018 after the field name; the full expression is [denitrific] *
.018.

c. Click OK.

Figure 243 Field Calculator window, with [denitrific] * .018 as the expression 

For each field name listed in Table 9, repeat steps 2 and 3 to populate each field based on the 
corresponding Field Calculator expression.  

Table 9 Field Calculator expressions for each blank field in the Land_Use attribute table 

Field Name Field Calculator Expression 
usablewat [denitrific] * .018 
StableClim 1.3542e-4 * [CarbonFixe] 

Us_Air_Dol [canopyVal] * [Canopy] 
CN See Calculation Explanation Below 

FloodProt (0.05 * (25400.00 / [CN] - 254.00)) / 1000.00 * 70.629265 

The following steps detail how to calculate Curve Number (CN). Please note that the “CN” field 
must be calculated prior to calculating “FloodProt” field values.  

4. From the main menu, choose Selection > Select By Attributes (Figure 244).
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Figure 244 Select By Attributes tool, located under the Selection menu in ArcMap 

5. In the Select By Attributes window (Figure 245):
a. In the Layer dropdown list, select Land_Use.
b. In the Expression box, type the following expression: “Max_Type_N” =1
d. Click OK.

Figure 245 Select By Attributes window, with Max_Type_N = 1 entered as the expression 

6. Right-click on the Land_Use layer in the Table of Contents and open the attribute table.
7. Right click on the “CN” field and choose Field Calculator.
8. In the Field Calculator window (example shown in Figure 243):

a. In the Fields list box, double click on the “A” field. The expression [A] should appear in the
box below.

b. Click OK.
9. Repeat steps 4-8 to select records with “Max_Type_N” field values of 2, 3, and 4, and to

assign corresponding “CN” field values of B, C, and D (1=A, 2=B, 3=C, 4=D) using the Field
Calculator.

Regardless of the land use data used, field headers from the original Tampa database must be present in 
the land use layer and lookup table. If using NLCD instead of FLUCCS, it is still necessary to include a 
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field titled "FLUCSDESC” and “FLUCCS” for EPA H2O to function properly. In the supplemental lookup 
table in Appendix A: Supplemental NLCD Lookup Table, “FLUCSDESC” should already be set equal to 
“NLCDDesc”. If other land use data were used, the user must populate the “FLUCSDESC” field with the 
appropriate descriptions. Both the land use layer and the lookup table must be updated.  

The Importing Layers into QGIS section details how to upload the land use layer into the user 
database in QGIS. Although the NLCD data detailed in the Download Land Use Data section is from 
2011, the naming scheme in Qspatialite must match the original Tampa Bay database (i.e. 
Land_Use_2006). Database creation is continued in the Create NHDPlus V2 Data Layers section. 

Using QGIS 
This section illustrates how to join the lookup table and complete field calculations using QGIS. 

1. Locate the soil/land use layer (e.g. NLCD_MaxTypeN_join) created in the Spatially Join
Soils to Land Use section and locate the lookup table updated in the
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2. Update ES Coefficients section or from Appendix A: Supplemental NLCD Lookup Table.
3. Open your existing QGIS map document file (.qgs), or create one following the steps outlined

in Set Up QGIS Map Document.
4. If using a new map document, use the Add Vector Layer window (Main Menu > Layer > Add

Vector Layer) to add the soil/land use layer and lookup table.
5. In the Layers panel, double click on the land use layer to open the Properties menu.

6. In the Properties window, click on the Joins tab, then click the Add join  icon. 
7. In the Add vector join window (example shown in Figure 200):

a. In the Join layer dropdown list select the lookup table.
b. In the Join field dropdown list select “gridcode”.
c. In the Target field dropdown list, select “Gridcode”.
d. Check Cache join layer in virtual memory.
e. Click OK.

8. In the Layers panel, right-click on the land use layer and select the Save as option (Figure
132).

9. In the Save vector layer as... window (example shown in Figure 133):
a. In the Format dropdown list, select ESRI Shapefile.
b. In the Save as text box, indicate the file path, and name the output Land_Use.
c. From the CRS dropdown list, select Selected CRS, and click the Browse button.
d. In the Filter box, type 3857, choose WGS 84/ Pseudo Mercator and click OK.
e. Check Add saved file to map. Do not check Skip attribute creation.
f. Click OK.

Field Calculations 

This section illustrates how to update the NULL fields joined from the supplemental lookup table (Figure 
246). In the expressions, “denitrific” is the denitrification rate (g N/M2/yr), “CarbonFixe” is the carbon 
sequestration into biomass rate (g C/m2/yr), “Canopy” is percent canopy cover (%), and “CN” is Curve 
Number. 

Figure 246 Land_Use attribute table, with NULL fields from lookup table join 

The fields with NULL values (i.e. “usablewat”, “StableClim”, “Us_Air_Dol”, “CN” and “FloodProt”) were 
added by joining to the lookup table. Values for these fields will be calculated using Field Calculator.  
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The following steps show the procedure to calculate the land use layer “usablewat” field. Similar 
steps need to be followed to update the rest of the fields as well.  

1. In the Layers panel, double click on the Land_Use layer to open Layer Properties.

2. From the Fields tab, click the pencil  icon to enable Editing mode.  Click the Field 

Calculator  icon to open the Field Calculator window. 
3. In the Field Calculator window (Figure 247):

a. Check Update existing field
b. From the dropdown list, select “usablewat”.
c. Under the Function List heading, locate the Fields and Values list box, and double click

on the “denitrific” field. “denitrific” will appear in the Expression box.
d. Type * .018 in the Expression box after “denitrific”. The full expression is “denitrific” * .018.
e. Click OK.

Figure 247 Field Calculator window, with “denitrific” * .018 entered as the expression 

4. Use Field Calculator to populate the other NULL fields. The expressions used in step 3.d. will
be different for each field, as shown in Table 10.

Table 10 Expression for the calculation of each field 

Field Name Expression 

usablewat "denitrific" * .018 

StableClim 1.3542e-4 * "CarbonFixe" 

Us_Air_Dol “canopyVal” * "Canopy" 
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CN See Calculation Explanation Below 
FloodProt (0.05 * ( 25400.00 / "CN" - 254.00 )) / 1000.00 * 70.629265 
waterRet 2 

stabClim 37 

usWat 3 

The following steps detail how to calculate Curve Number (CN). Please note that the “CN” field 
must be calculated prior to calculating “FloodProt” field values.  

5. In the Layers panel, right-click the Land_Use layer, open the attribute table, and locate the
Look for search option at the bottom of the table (Figure 248).

6. In the search box, type 1, and from the in dropdown list select the field created in the Spatially
Join Soils to Land Use section (e.g. “Max_Type_N”).

Figure 248 Land_Use attribute table, searching for value 1 in Max_Type_N field 

7. Click Search to select all attributes that have a value of 1 in the “Max_Type_N” field.

8. Click the Field Calculator  icon in the attribute table. 
9. In the Field Calculator window (example shown in Figure 247):

a. Check the Only update selected features option.
b. Check the Update existing field option.
c. In the dropdown list, select “CN”.
d. In the Fields and Values list box, double click on the “A” field. “A” should appear in the

Expression box.
e. Click OK.

10. Repeat steps 5-9 to select records with Max_Type_N field values of 2, 3, and 4 and assign
the corresponding values B, C, and D using the Field Calculator (1=A, 2=B, 3=C, 4=D).

Regardless of the land use data used, field headers from the original Tampa database must be present in 
the land use layer. If using NLCD instead of FLUCCS, it is still necessary to include a field titled 
"FLUCSDESC” and “FLUCCS” for EPA H2O to function properly. In the supplemental lookup table in 
Appendix A: Supplemental NLCD Lookup Table, “FLUCSDESC” should already be set equal to 
“NLCDDesc”.  

The Importing Layers into QGIS section details how to upload the land use layer into the user 
database in QGIS. Although the NLCD data detailed in the Download Land Use Data section is from 
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2011, the naming scheme in Qspatialite must match the original Tampa Bay database (i.e. 
Land_Use_2006). Database creation is continued in the Create NHDPlus V2 Data Layers section. 

Create NHDPlus V2 Data Layers 

The National Hydrography Dataset (NHD) defines the flowlines, catchments and waterbodies 
necessary for EPA H2O functionality. The NHD data is used to determine the upstream areas of 
interest in the EPA H2O report. This section illustrates the step-by-step method used to obtain and 
prepare the NHD data.  

Either Esri ArcMap software or QGIS can be used to prepare the NHD data. The procedure for both 
software applications is explained in this section.  

Download NHDPlus Data 
This section illustrates the step-by-step procedure for downloading NHD data by region from the 
NHDPlus Version 2 website.   

1. Navigate to https://nhdplus.com/NHDPlus/NHDPlusV2_data.php, as shown in Figure 249.

Figure 249 NHDPlus Version 2 website, published by Horizon Systems Corporation 

2. On the interactive map, click on the region where the user’s area of interest is located (e.g.
South Atlantic South (03S)).

Note: NHDPlus hydrological regions are similar to 2-digit HUC regions (Figure 118). 

https://nhdplus.com/NHDPlus/NHDPlusV2_data.php
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3. In the next page, scroll down to locate the File Name download table for the selected region.
4. From the File Name table, find the following files and download each by clicking on the HTTP

button (Figure 250):
a. NHDPlusV21_SA_03S_NHDPlusAttributes_06.7z
b. NHDPlusV21_SA_03S_NHDPlusBurnComponents_02.7z
c. NHDPlusV21_SA_03S_NHDPlusCatchment_01.7z
d. NHDPlusV21_SA_03S_NHDSnapshot_06.7z

Figure 250 South Atlantic South File Names, with HTTP or FTP download available 

Please note: the number at the end of the file name is the version number and changes as it is 
updated. The “SA” and “03S” in the file name are specific to the South Atlantic region and South 
subregion, respectively; these abbreviations will change based on the user’s AOI location.  

5. Save the zip file to the computer and unzip the contents to a known location.

The next section illustrates the creation of EPA H2O compatible NHD data from the unzipped 
download files, using either Esri ArcGIS software (Using ArcGIS) or QGIS (Using QGIS). 

Using ArcGIS 
This section illustrates the creation of EPA H2O compatible NHDPlus V2 data using Esri ArcGIS 
software.  

1. Download and unzip the NHD datasets, as shown in the Download NHDPlus Data section.
2. Open your existing ArcGIS map document file (.mxd), or create one following the steps

outlined in Set Up ArcGIS Map Document.

3. Click the Add Data icon , and navigate to the unzipped NHD folder (i.e. NHDPlusREGION). 
Select the following files and click the Add button to add each layer to the Table of Contents. 
a. NHDPlusSA\NHDPlusCatchment\Catchment.shp
b. NHDPlusSA\NHDPlusSnapshot\Hydrography\NHDFlowline.shp
c. NHDPlusSA\NHDPlusSnapshot\Hydrography\NHDWaterbody.shp
d. NHDPlusSA\NHDPlusAttributes\PlusFlowlineVAA.dbf
e. NHDPlusSA\NHDPlusAttributes\PlusFlow.dbf
f. NHDPlusSA\NHDPlusAttributes\MegaDiv.dbf

4. Reproject the Catchment layer using the Project tool. From the ArcToolbox window, navigate to
and open the Project tool (ArcToolbox > Data Management Tools > Projections and
Transformations > Project Figure 143).

5. In the Project tool window (example shown in Figure 144):
a. In the Input Dataset or Feature Class box, select Catchment.shp.
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b. In the Output Dataset or Feature Class text box, browse to or type the desired file name (e.g.
Catchment_reproj) and file path.

c. Click the Spatial Reference  icon to set the Output Coordinate System to
WGS_1984_Web_Mercator_Auxiliary_Sphere, located under the World folder in Projected
Coordinate Systems. Alternatively, search for it by typing 3857 into the search box.

a. A Geographic Transformation is required to reproject the land use dataset. In the
dropdown list, choose WGS_1984_(ITRF00)_To_NAD_1983 if not already selected.

d. Click OK.
6. Repeat steps 4 and 5 to reproject NHDWaterbody.shp and NHDFlowline.shp.

7. In the Table of Contents, right-click on the re-projected Catchment layer and choose Joins
and Relates > Join…  (Figure 183).

8. In the Join Data window (example shown in Figure 184).
a. In the first dropdown list, select Join attributes from a table.
b. In the Choose the field in this layer that the join will be based on dropdown list, select

“FEATUREID”.
c. In the Choose the table to join to this layer dropdown list, select PlusFlow.
d. In the Choose the field in the table to base the join on dropdown list, select

“FROMCOMID”.
e. Under Join Options, toggle Keep all records.
f. Click OK.

9. Right-click on the re-projected Catchment layer again and choose Joins and Relates > Join…
to add a second join, this time with the MegaDiv table.
a. In the Choose the table to join to this layer dropdown list, select MegaDiv.
b. Repeat all other inputs from step 8.

10. Right-click on the re-projected Catchment layer a third time and choose Joins and Relates >
Join…  to add a third join, this time with the PlusFlowlineVAA table.
a. In the Choose the table to join to this layer dropdown list, select PlusFlowlineVAA.
b. In the Choose the field in the table to base the join on dropdown list select “ComID”.
c. Repeat all other inputs from step 8.

11. Repeat steps 7-10 to join the re-projected NHDFlowline layer with the PlusFlow,
MegaDiv and PlusFlowlineVAA tables.
a. In the Table of Contents, right-click on the NHDFlowline layer and choose Joins and

Relates > Join…  (Figure 183).
b. In the Join Data window, for the Choose the field in this layer that the join will be based on

dropdown list, select “COMID”.
c. Repeat all other inputs from steps 8-10.

12. In the Table of Contents, right-click on the re-projected Catchment layer and open the
attribute table.

13. In the attribute table, click on the Table Options icon and choose Add Field (Figure 179).
14. In Add Field window (example shown in Figure 180):

a. In the Name text box, type HUC_14.
b. In the Type dropdown list, select “Text”.
c. Click OK.

15. In the Catchment attribute table, right-click on the newly created HUC_14 field and choose Field
Calculator.

16. In the Field Calculator window:
a. From the Fields list box, double click the “FEATUREID” field (e.g.

Catchment_reproj.FEATUREID). The name of the field should appear in the Expression box.
b. Click OK.

17. In the Catchment attribute table, add a second new field.
a. In the Name text box, type HU_14_DS.
b. In the Type dropdown list, select “Text”.
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c. Click OK.
18. There are two fields in the Catchment attribute table named "TOCOMID", one from the joined

PlusFlow table and one from the MegaDiv table.
a. Right-click on each “TOCOMID” field and choose properties to see the full field names, until

finding the "TOCOMID" with “MegaDiv.TOCOMID” as it’s full field name.
b. Right-click on the correct "TOCOMID" field again and choose Sort Descending.
c. Click and drag to select the rows that contain the non-NULL “TOCOMID” values (Figure 251).

There should only be a relatively small amount of non-NULL features at the top of this
“TOCOMID” field.

Figure 251 Catchment attribute table, with non-NULL values in TOCOMID field highlighted 

19. Right-click on the new HU_14_DS field and choose Field Calculator.
20. In the Field Calculator window:

a. Clear any previous text from the expression box.
b. From the Fields list box, double click on the “MegaDiv.TOCOMID” field. The name of the field

should appear in the Expression box.
c. Click OK.

21. In the attribute table, invert the current selection with the Switch Selection  icon. 
22. Right click on the new HU_14_DS field again and choose Field Calculator.
23. In the Field Calculator window:

a. Clear any previous text from the expression box.
b. From the Fields list box, double click on the “PlusFlow.TOCOMID” field. The name of the field

should appear in the Expression box.
c. Click OK.

24. Clear the current selection in the attribute table and open the Select by Attributes tool.
25. In the Select by Attributes window:

a. Clear any previous text from the expression box.
b. From the Fields list box, double click on the “PlusFlowlineVAA.TerminalFl ” field. The name of

the field should appear in the Expression box.
c. Type = 1 after the name of the field. The full expression is "PlusFlowlineVAA.TerminalFl" = 1.
d. Click OK.
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26. In the attribute table, right-click on the HU_14_DS field and choose Field Calculator.
27. In the Field Calculator window:

a. Clear any previous text from the expression box.
b. In the Expression box, type “NULL”.
c. Click OK.

28. Repeat steps 12-27 for the re-projected NHDFlowline layer, using the “COMID” field in
place of the “FEATUREID” field when using field calculator on the “HUC_14” field (step
16).

29. After finishing updating the NHDFlowline layer, clear all selected features by clicking the clear

selection  icon on the tools toolbar.
30. From the main menu, choose Selection > Select By Attributes.
31. In the Select by Attributes window:

a. From the Fields list box, double click on the “NHDFlowline_reproj.FTYPE ” field. The name of
the field should appear in the Expression box.

b. Type LIKE ‘Coastline’ after the name of the field. The full expression is
"NHDFlowline_reproj.FTYPE" LIKE 'Coastline'.

c. Click OK.
32. The selected flow lines must be deleted, which requires the user to be in an edit session. If the

Editor toolbar is not enabled, right-click anywhere on the main menu bar at the top of the ArcMap
window. From the list of optional toolbars that appear select Editor (Figure 252).

Figure 252 List of extensions and toolbars in ArcMap, with the Editor toolbar selected 

33. In the Editor toolbar, click the Editor dropdown list and choose Start Editing (Figure 253).

Figure 253 Editor toolbar, with the Start Editing option selected 

34. If the Start Editing window appears, select the NHDFlowline layer and click OK.
35. In the Table of Contents, right-click and open the NHDFlowline attribute table.
36. Click the Delete  icon to delete the selected flow lines (“FTYPE” LIKE Coastline). 
37. In the Editor toolbar, click the Editor dropdown and choose Save Edits, and then Stop Editing

(Figure 254).
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Figure 254 Editor toolbar, with the Save Edits option selected 

38. In the Table of Contents, right-click on the Catchment layer and choose Joins and Relates >
Remove Join(s) > Remove All Joins. Repeat this for the NHDFlowline layer.

A summary of the calculations used to prepare the NHDPlus data using Esri ArcGIS software is listed 
in Table 11. 

Table 11 Fields added and calculations required to prepare the Catchment and NHDFlowline layers in ArcMap 

The Importing Layers into QGIS section details how to upload the NHD Catchment, Waterbodies and 
Flowlines layers into the user database in QGIS. Database creation is continued in the Grid Water 
Bodies section.  

Using QGIS 
This section illustrates the creation of EPA H2O compatible NHDPlus V2 data using QGIS software. 

1. Download and unzip the NHD datasets, as shown in the Download NHDPlus Data section.

Catchment Layer NHDFlowline Layer 

Joined 
Tables PlusFlow.dbf, MegaDiv.dbf, and PlusFlowlineVAA.dbf PlusFlow.dbf, MegaDiv.dbf, and PlusFlowlineVAA.dbf 

HUC_14 Field 
Field Type “Text” “Text” 

Field 
Calculator 

Attribute Selection New Value Attribute Selection New Value 

All “FEATUREID” All “COMID” 

HU_14_DS Field 
Field Type “Text” “Text” 

Field 
Calculator 

Attribute Selection New Value Attribute Selection New Value 

“MegaDiv.TOCOMID” IS NOT 
NULL “MegaDiv.TOCOMID” “MegaDiv.TOCOMID” IS NOT 

NULL “MegaDiv.TOCOMID” 

*Invert Selection or:
“MegaDiv.TOCOMID” IS NULL “PlusFlow.TOCOMID” *Invert Selection or:

“MegaDiv.TOCOMID” IS NULL “PlusFlow.TOCOMID” 

“PlusFlowlineVAA.TerminalFl” = 
1 “NULL” 

“PlusFlowlineVAA.TerminalFl” = 
1 “NULL” 

“NHDFlowline_proj.FTYPE” LIKE 
‘COASTLINE’ 

*Delete selected
fields 
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2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined
in Set Up QGIS Map Document.

3. In File Explorer, locate the unzipped NHD folder (i.e. NHDPlusREGION). Drag and drop each
of the following files into the QGIS Layers panel (Figure 255):
a. NHDPlusSA\NHDPlusCatchment\Catchment.shp
b. NHDPlusSA\NHDPlusSnapshot\Hydrography\NHDFlowline.shp
c. NHDPlusSA\NHDPlusSnapshot\Hydrography\NHDWaterbody.shp
d. NHDPlusSA\NHDPlusAttributes\PlusFlowlineVAA.dbf
e. NHDPlusSA\NHDPlusAttributes\PlusFlow.dbf
f. NHDPlusSA\NHDPlusAttributes\MegaDiv.dbf

Figure 255 Layers panel in EPA H2O, listing the hydrological tables and shapefiles 

4. In the Layers panel, right-click on the Catchment layer and select the Save as option (Figure
132).

5. In the Save vector layer as... window (example shown in Figure 133):
g. In the Format dropdown list, select ESRI Shapefile.
h. In the Save as text box, browse to or type the desired file path and name the output

Catchment_reproj.
i. In the CRS dropdown list, choose Selected CRS, and click the Browse button.
d. In the Filter box, type 3857, choose WGS 84/ Pseudo Mercator and click OK.
e. Check Add saved file to map. Do not check Skip attribute creation.
f. Click OK.

6. Repeat steps 4 and 5 to reproject NHDWaterbody.shp and NHDFlowline.shp.

7. In the Layers panel, double click the re-projected Catchment layer to open Layer Properties.

8. From the Joins tab, click the Add Join  icon to open the Add vector join window. 
(example shown in Figure 200):
a. In the Join layer dropdown list, select PlusFlow.
b. In the Join field dropdown list, select “FROMCOMID”.
c. In the Target field dropdown list, select “FEATUREID”.
d. Check Cache join layer in virtual memory.
e. Click OK.

9. Click the Add Join icon again. In the Add vector join window:
a. In the Join layer dropdown list, choose MegaDiv.
b. In the Join field dropdown list, choose “FROMCOMID”.
c. In the Target field dropdown list, choose “FEATUREID”.
d. Check Cache join layer in virtual memory.
e. Click OK.

10. Click the Add Join icon a third time. In the Add vector join window:
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a. In the Join layer dropdown list, choose PlusFlowlineVAA.
b. In the Join field dropdown list, choose “ComID”.
c. In the Target field dropdown list, choose “FEATUREID”.
d. Check Cache join layer in virtual memory.
e. Click OK.

The completed joins are listed under the Joins tab, as shown in Figure 256. 

Figure 256 Layer Properties > Joins tab, listing tables joined to Catchment layer 

11. Repeat steps 7-10 to join the re-projected NHDFlowline layer with the PlusFlow,
MegaDiv and PlusFlowlineVAA tables.
a. In the Layers panel, double click on the NHDFlowline layer to add the joins.
b. In the Target field dropdown list, choose “COMID”.
c. Repeat all other inputs from steps 7-10.

12. In the Layers panel, right-click the Catchment layer and choose Open Attribute Table.

13. In the attribute table window, toggle editing on by clicking the pencil icon . 

14. Click the Field Calculator icon  to open the Field Calculator window. 
15. In the Field Calculator window (Figure 257):

a. Check Create a new field.
b. In the Output field name text box, type HUC_14.
c. In the Output field type dropdown list, select Text (string).
d. In the Function List, expand the Fields and Values option and double click the

“FEATUREID” field. The name of the field will appear in the Expression box.
e. Click OK.
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Figure 257 Field Calculator window, used to create and populate the HUC_14 field 

16. In the Attribute table window, click the Save Edits icon. 
17. There are two fields in the attribute table named "TOCOMID". Locate the second or rightmost

column.
a. Click the “TOCOMID” column header twice to sort the attribute table in Descending order.

There should only be a relatively small amount of non-NULL features.
b. Click on row number 0 and drag to select the rows that contain the non-NULL

“TOCOMID” values (Figure 258).
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Figure 258 Catchment attribute table, with non-NULL TOCOMID rows highlighted 

18. Click the Field Calculator icon  to open the Field calculator window. 
19. In the Field Calculator window (example shown in Figure 257):

a. Check Only update selected features.
b. Check Create a new field.
c. In the Output field name text box, type HU_14_DS.
d. In the Output field type dropdown list, select Text (string).
e. Under the Function List, expand the Fields and Values option and double click the second

listed “TOCOMID” field name. The field name “TOCOMID” will appear in the Expression
box.

f. Click OK.

20. In the attribute table, click the Invert Selection  icon to select all the NULL values in the 
second “TOCOMID” field.

21. Click the Field Calculator icon  and in the Field Calculator window: 
a. Check Only update selected features.
b. Check Update existing field.
c. In the field dropdown list, select “HU_14_DS”.
d. Under the Function List, expand the Fields and Values option and double click the first

“TOCOMID” field. The first “TOCOMID” field should appear in the Expression box.
e. Click OK.

22. In the attribute table, click the Save Edits icon, then click the Advanced Search 

 button to open a search query window. 
23. In the Search query builder window (Figure 259):

a. In the Fields list box, double click on the “TerminalFl” field. The name of the field will
appear in the SQL where clause box.

b. Type = 1 after the name of the field. the full expression is TerminalFl = 1.
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c. Click OK.

Figure 259 Search query builder window, with TerminalFl = 1 entered in the Search box 

24. Click the Field Calculator icon to open the Field Calculator window.
25. In the Field Calculator window:

a. Check Only update selected features.
b. Check Update existing field.
c. In the fields dropdown list, select “HU_14_DS”.
d. In the Expression box, type NULL.
e. Click OK.

26. Toggle editing off by clicking the pencil icon and save edits when prompted.
27. Repeat steps 12-26 for the re-projected NHDFlowline layer, replacing “FEATUREID” with

“COMID” during “HUC_14” field calculation.

28. After completing updated to the NHDFlowline layer, open the NHDFlowline attribute table and
click the Advanced search button.

29. In the Search query builder window (example shown in Figure 259):
a. In the Fields list box, double click on the “FTYPE” field. The name of the field will appear

in the SQL where clause box.
b. In the Values box, click the All button. All values found in the “FTYPE” field are listed in

the Values box.
c. In the Operators list, click the LIKE button.
d. Back in the Values list box, double click on the ‘Coastline’ attribute. The full expression in

the search box should read FTYPE LIKE ‘Coastline’.
e. Click OK.
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30. In the NHDFlowline attribute table, click the Delete selected features  icon. 

31. Toggle editing off by clicking the pencil icon  and save edits when prompted. 
32. Deleting the joins made in the beginning of this section is not required but will save disk space

and reduce memory usage when using EPA H2O.
a. In the Layers panel, double click on the Catchment and NHDFlowline layers to open the

Properties window.

b. In the Join tab, highlight each join and click the green minus sign  to remove it. 
c. Click OK when all joins have been removed.

A summary of the calculations used to prepare the NHDPlus layers using QGIS is listed in Table 12. 

Table 12 Fields added and the calculations required to prepare the Catchment and NHDFlowline layers in QGIS 

The Importing Layers into QGIS section details how to upload the NHD Catchment, Waterbodies and 
Flowlines layers into the user database in QGIS. If using QGIS, database creation is continued in the 
Create Road Layer section.  

Grid Water Bodies 

The EPA H2O tool uses the NHD_flowlines and Subwatershed layers to trace data from upstream. 
Upstream data are used to calculate the ES values in the Ecosystem Valuation Reports. However, the 
catchments in the Subwatershed layer do not overlap large bodies of water, such as Tampa Bay. If 
the user’s AOI extends into a large body of water, it may be unclear what data are upstream. 

Catchment Layer NHDFlowline Layer 

Joined 
Tables PlusFlow.dbf, MegaDiv.dbf, and PlusFlowlineVAA.dbf PlusFlow.dbf, MegaDiv.dbf, and PlusFlowlineVAA.dbf 

HUC_14 Field 
Field Type Text (string) Text (string) 

Field 
Calculator 

Attribute Selection New Value Attribute Selection New Value 

All “FEATUREID” All “COMID” 

HU_14_DS Field 
Field Type Text (string) Text (string) 

Field 
Calculator 

Attribute Selection New Value Attribute Selection New Value 

“TOCOMID” IS NOT NULL (MegaDiv) 
2nd “TOCOMID” “TOCOMID” IS NOT NULL (MegaDiv) 

2nd “TOCOMID” 

*Invert Selection or:
“TOCOMID” IS NULL

(PlusFlow) 
1st “TOCOMID” 

*Invert Selection or:
“TOCOMID” IS NULL

(PlusFlow) 
1st “TOCOMID” 

(PlusFlowlineVAA) 
“TerminalFl” = 1 “NULL” 

(PlusFlowlineVAA) 
“TerminalFl” = 1 “NULL” 

(NHDFlowline_proj) 
“FTYPE” LIKE ‘COASTLINE’ *Delete selected fields
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The user may create an interior bay hexagon layer to link upstream data to these large bodies for 
Ecosystem Valuation Reports. This grid will “fill in” the water bodies in the Subwatershed layer with 
hexagonal polygons.  

This section illustrates the creation of an interior bay hexagon layer using Esri ArcGIS software. 

1. Open your existing ArcGIS map document file (.mxd), or create one following the steps
outlined in Set Up ArcGIS Map Document.

2. If using a new map document, use the Add Data  icon to navigate to the AOI shapefile 
(e.g. HUC_Tampa.shp), and add the layer to the Table of Contents. 

3. If not already in the Table of Contents, the re-projected NHD catchment layer (e.g.
Catchment_reproj.shp) must be added in the same way.

4. In the Table of Contents, right-click on Catchment_reproj and open the attribute table.

5. Click the Table Options  icon in the attribute table and select Add Field (Figure 179). 
6. In the Add Field window (example shown in Figure 180):

a. In the Name text box, type “AreaKM2”.
b. Under the Type dropdown list, select Float.
c. Click Ok.

7. In the attribute table, right-click on the “AreaKM2” field and select Calculate Geometry.
8. In the Calculate Geometry window (Figure 260):

a. In the Property dropdown list, select Area.
b. Under Coordinate System, confirm Use coordinate system of the data source is toggled

and lists PCS: WGS 1984 Web Mercator Auxiliary Sphere.
c. In the Units dropdown list, select Square Kilometers [sq km].
d. Click OK.

Figure 260 Calculate Geometry window in ArcMap, used to calculate area 

9. From the main menu, click Selection > Select By Location.
10. In the Select By Location window (Figure 261):

a. In the Selection method dropdown list, choose select features from.
b. In the Target layer(s) box, check the NHD catchment layer (e.g. Catchment_reproj).
c. In the Source layer dropdown list, select the AOI shapefile (e.g. HUC_Tampa).
d. In the Spatial selection method for target layer feature dropdown list, select intersect the

source layer feature.
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e. Click OK.

Figure 261 Select By Location window in ArcMap 

11. Do not clear the selection. Right-click on Catchment_reproj and open the attribute table.
12. Right-click on the “AreaKM2” field and choose Statistics.
13. In the Selection Statistics window (Figure 262):

a. In the Field dropdown list, confirm “AreaKM2” is displayed.
b. From the Statistics box, write down the Mean value (e.g. 6.215708 km2). This value is

used in later calculations.

Figure 262 Selection Statistics for the Catchment_reproj AreaKM2 field 
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14. Various calculations are required to create the area-specific hexagonal grid. It is suggested
that the user copy values and calculations into a spreadsheet or record them on paper to
organize and track work.

15. Hexagon area will be set equal to the average catchment area. However, hexagons will be
created based on their width and height. Width is determined using the equation:

Hex width = 2.0*sqrt(Mean value/6*sqrt(3)) 
Where the example Mean value = 6.215708, 
Hex width = 2.0 * sqrt(6.215708 / 6 * sqrt(3)) 
Hex width = 2.0 * sqrt(6.215708 / 6 * 1.73205080757) 
Hex width = 2.67904485964 

Please note: all decimals listed are required throughout each calculation for accurate 
hexagons.  

16. The height of each hexagon is calculated using the hexagon width. Height is determined
using the equation:

Hex height = Hex width * sqrt(3) 
Where the example hex width = 2.67904485964, 
Hex height = 2.67904485964 * 1.73205080757 
Hex height = 4.64024181265 

17. To determine vertices for hexagon sides the orientation of the height and width values are
swapped. In this example, height is now 2.67904485964 km, and width is now
4.64024181265 km.

18. The new height and width values must be converted from kilometers into meters. In this
example, height is 2679.04485964 meters, and width is 4640.24181265 m.

19. In the Table of Contents, right-click on the AOI shapefile (e.g. HUC_Tampa) and select
Properties.

20. Under the Source tab, the Extent is listed for the Left, Bottom, Right, and Top coordinates
(Figure 263). Copy down each of these extents, indicating the specific location of each.

Figure 263 Layer Properties window, under the Source tab, which displays the extents of the AOI 
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21. New extents must be calculated for the hexagon layer by adding the width and height of the
hexagons to the original extents. Table 13 shows formulas and example calculations for the
new Left, Bottom, Right, and Top extent, where XMin is the original Left extent, YMin is the
original Bottom extent, XMax is the original Right extent, and YMax is the original Top extent.

Table 13 Formulas used to calculate the new area extents, using the original area extents, hex width, and hex 
height 

Extent Location Base Formula Example Formula Example New Extent 
LEFT XMin + width * -2 -9229391.184685 +

4640.24181265* -2
-9238671.66831

BOTTOM YMin + height * -2 3182908.198367 + 
2679.04485964 * -2 

3177550.10865 

RIGHT XMax + width * 2 -9092391.693799 +
4640.24181265* 2

-9083111.21017

TOP YMax + height * 2 3403559.687543 + 
2679.04485964 * 2 

3408917.77726 

22. In ArcMap, click the ArcToolbox  icon to open ArcToolbox. 
23. In the ArcToolbox window, navigate to the Create Fishnet tool (Data Management Tools >

Sampling > Create Fishnet)
24. In the Create Fishnet window (Figure 264):

a. In the Output Feature Class, name the output (e.g. Tampa_Fishnet1) and indicate the file
path.

b. Below the Template Extent option are blank fields for the Left, Bottom, Right, and Top
extents. In each text box, enter the corresponding newly calculated extent (e.g. Example
New Extent values in Table 13). Please note, the Bottom value may need to be entered
last.

c. In the Cell Size Width text box, enter the calculated hex width (e.g. 4640.24181265).
d. In the Cell Size Height text box, enter the calculated hex height (e.g. 2679.04485964).
e. In the Number of Rows text box, enter 0.
f. In the Number of Columns text box, enter 0.
g. The Opposite corner of Fishnet coordinates will populate automatically.
h. Confirm the Create Label Points option is checked.
i. In the Geometry Type dropdown list, confirm POLYLINE is selected.
j. Click OK.
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Figure 264 Create Fishnet window in ArcMap, using the newly calculated extents 

25. A second Fishnet layer must be created using offset extents. This will create an alternating
pattern of points, allowing the hexagons to fit together exactly. Formulas are similar to those
used to calculate the offset extents shown in Table 14. However, the newly created Fishnet1
extents are used as the initial extent in the calculations, instead of the original AOI extents.

Table 14 Formulas used to calculate the offset area extents, using the Fishnet1 extents, hex width, and hex 
height 

Extent Location Base Formula Example Formula New Offset Extent 
LEFT newXMin + width * 0.5 -9238671.66831 +

4640.24181265 * 0.5
-9236351.5474

BOTTOM newYMin + height * 0.5 3177550.10865 + 
2679.04485964 * 0.5 

3178889.63108 

RIGHT newXMax + width * 0.5 -9083111.21017 +
4640.24181265 * 0.5

-9080791.08926

TOP newYMax + height * 0.5 3408917.77726 + 
2679.04485964 * 0.5 

3410257.29969 

26. Open the Create Fishnet tool (ArcToolbox >Data Management Tools > Sampling > Create
Fishnet).

27. In the Create Fishnet window (example shown in Figure 264):
a. In the Output Feature Class, name the output (e.g. Tampa_Fishnet2) and indicate the file

path.
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b. Below the Template Extent option are blank fields for the Left, Bottom, Right, and Top
extents. In each text box, enter the corresponding newly calculated offset extent (e.g.
New Offset Extent values in Table 14). Please note, the Bottom value may need to be
entered last.

c. In the Cell Size Width text box, enter the calculated hex width (e.g. 4640.24181265).
d. In the Cell Size Height text box, enter the calculated hex height (e.g. 2679.04485964).
e. In the Number of Rows text box, enter 0.
f. In the Number of Columns text box, enter 0.
g. The Opposite corner of Fishnet coordinates will populate automatically.
h. Confirm the Create Label Points option is checked.
i. In the Geometry Type dropdown list, confirm POLYLINE is selected.
j. Click OK.

28. Toggle both _label point layers (e.g. Tampa_Fishnet1_label and Tampa_Fishnet2_label) on in
the Table of Contents. The _label point layers should create a rectangle of points around the
user’s AOI in a zig-zag pattern, as shown in Figure 265. The user may right-click and remove
the Fishnet line layers (e.g. Tampa_Fishnet1 and Tampa_Fishnet2).

Figure 265 ArcMap project displaying Fishnet label layers over Tampa AOI and NHD catchments 

29. Open ArcToolbox and navigate to the Define Projection tool (Data Management Tools >
Projections and Transformations > Define Projection).

30. In the Define Projection window (Figure 266):
a. In the Input Dataset or Feature Class dropdown list, select the first Fishnet label layer

(e.g. Tampa_Fishnet1_label).
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b. Click the Coordinate System  icon and enter 3857 into the search box. Select WGS 
1894 Web Mercator (auxiliary sphere) and click OK. 

c. In the Coordinate System text box, WGS_1984_Web_Mercator_Auxiliary_Sphere will
appear. Click OK.

31. Repeat steps 29-30 to define the projection for the second Fishnet label layer (e.g.
Tampa_Fishnet2_label).

Figure 266 Define Projection window, setting the coordinate system for the Fishnet layer 

32. Use the Append tool to combine both Fishnet label layers into one layer (ArcToolbox > Data
Management Tools > General > Append, Figure 187).

33. In the Append window (example shown in Figure 188):
a. In the Input Datasets dropdown list, select Tampa_Fishnet2_label.
b. In the Target Dataset dropdown list, select Tampa_Fishnet1_label.
c. Click OK.

34. Open the ArcToolbox window and locate the Create Thiessen Polygons tool (ArcToolbox >
Analysis Tools > Proximity > Create Thiessen Polygons, Figure 267).

Figure 267 ArcToolbox window, showing the location of the Create Thiessen Polygons tool 

35. In the Create Thiessen Polygons window (Figure 268):
a. In the Input Features dropdown list, select the appended Fishnet layer (e.g.

Tampa_Fishnet1_label).
b. In the Output Feature Class text box, name the file path and shapefile (e.g.

Tampa_Thiessen.shp).
c. In the Output Fields dropdown list, select ONLY_FID.
d. Click OK.
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Figure 268 Create Thiessen Polygons window, used to create Thiessen polygons for the Fishnet points 

36. Open ArcToolbox and navigate to the Minimum Bounding Geometry tool (Data Management
Tools > Features > Minimum Bounding Geometry).

37. In the Minimum Bounding Geometry window (Figure 269):
a. In the Input Features dropdown list, select the AOI shapefile (e.g. HUC_Tampa).
b. In the Output Feature Class text box, name the file path and layer name (e.g.

Tampa_Envelope.shp).
c. In the Geometry Type dropdown list, select ENVELOPE.
d. Click OK.

Figure 269 Minimum Bounding Geometry window, used to create an envelope around the AOI extent 

38. From the main menu, choose Selection > Select By Location.
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39. In the Select By Location window (example shown in Figure 261):
a. In the Selection method dropdown list, choose select features from.
b. In the Target layer(s) section, check Tampa_Thiessen.
c. In the Source layer dropdown list, select Tampa_Envelope.
d. In the Spatial selection method for target layer feature(s) dropdown list, select intersect

the source layer feature.
e. Click OK.

40. In the Table of Contents, right-click on Tampa_Thiessen and choose Data > Export Data.
41. In the Export Data window:

a. In the Export dropdown list, choose Selected features.
b. Under the Use the same coordinate system as option, toggle the data frame.
c. In the Output feature class text box, name the file path and shapefile (e.g.

Tampa_ThiessenEnvelope.shp.
d. Click OK.

42. Open ArcToolbox and locate the Erase tool (ArcToolbox > Analysis Tools > Overlay > Erase).
43. In the Erase window (Figure 270):

a. In the Input Features dropdown list, select the Thiessen Envelope (e.g.
Tampa_ThiessenEnvelope).

b. In the Erase Features dropdown list, select the NHD Catchment layer (e.g.
Catchment_reproj).

c. In the Output Feature Class text box, name the file path and output (e.g.
TampaThiessen_Erase.shp)

d. Click OK.

Figure 270 Erase window, used to remove Thiessen polygons that overlap the Catchment layer 

44. Open ArcToolbox and locate the Merge tool (ArcToolbox > Data Management Tools >
General > Merge).

45. In the Merge window (Figure 271):
a. In the Input Datasets dropdown list, select the NHD Catchment layer (Catchment_reproj),

then select the erased Thiessen layer (e.g. TampaThiessen_Erase). Both layers will
appear in the box.

b. In the Output Dataset text box, name the file path and shapefile (e.g.
Catchment_GridBay.shp).

c. In the Field Map section, select the “Id (Long)” field and click the Remove  icon. 
d. Click OK.
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Figure 271 Merge window, used to combine the Catchment layer with the hexagonal grid 

46. From the main menu, select Selection > Select By Attributes.
47. In the Select By Attributes window:

a. In the Layer dropdown list, select the merged layer (e.g. Catchment_GridBay).
b. In the list of fields, double click “FEATUREID”. The field name will appear in the

Expression box below.
c. In the Expression box, type = 0 after the field name. The full expression is "FEATUREID" =

0.
d. Click OK.

48. In the Table of Contents, right-click on the merged layer (e.g. Catchment_GridBay and open
the attribute table.

49. In the attribute table, click the Show Selected Records  icon. The attributes for each 
hexagon polygon will be listed.

50. Locate the “FID” field, right-click on the name, and choose Sort Ascending. Make note of the
first FID value (e.g. 55586); this value is used in the next Field Calculator calculation.

51. Right-click on the “FEATUREID” field and open the Field Calculator.
52. In the Field Calculator window (Figure 272):

a. In the Expression box, type the following equation: (([FID] - first “FID” value) * -1) -
1000000

b. In this example, the entered expression is: (([FID] - 55586) * -1) - 1000000
c. Click OK.
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Figure 272 Field Calculator window with Catchment_GridBay attribute table 

53. In the merged shapefile attribute table, right-click on “HUC_14” and open the Field Calculator.
54. In the Field Calculator window:

a. Clear the previous expression if it appears in the Expression box.
b. In the Fields list, double click on the “FEATUREID” field. The field name will appear in the

Expression box.
c. Click OK.

55. In the attribute table, locate the “SOURCEFC” field, and right-click to open the Field
Calculator.

56. In the Field Calculator window:
a. In the Expression box, type "Hex" (Please note, the quotation marks are required).
b. Click OK.

The hexagonal grid has been added to the NHD Catchment layer. The Importing Layers into QGIS 
section details how to upload the updated NHD Catchment layer into the user database in QGIS. 
Database creation is continued in the Create Road Layer section.  

Create Road Layer 

Download TIGER/Line data 
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This section shows the step-by-step procedure for downloading the roads data for the Transportation Tool 
(Advanced Module Only) in EPA H2O. The Road layer is only used for the Transportation Tool and the 
rest of EPA H2O functionality is available without this layer. 

1. Navigate to https://www.census.gov/cgi-bin/geo/shapefiles/index.php to open the US Census
Bureau website (Figure 273).

2. In the Select year dropdown list, choose the most recently published year. In this example,
2018 has been selected.

3. In the Select a layer type dropdown list, select Roads.
4. Click the Submit button.

Figure 273 US Census Bureau TIGER/Line Shapefiles download website 

5. The website will navigate to the next page, as shown in Figure 274.
6. Under the All Roads option, select the state containing the user’s AOI (e.g. Florida).
7. Once a state is selected, a Select a County dropdown list will appear. Select the desired

county from the dropdown list (e.g. Hillsborough County).
8. Under the Select a County dropdown list, click the Download button.

https://www.census.gov/cgi-bin/geo/shapefiles/index.php
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Figure 274 TIGER/Line All Roads menu, with Florida selected from the dropdown box 

9. Save the zip file and unzip the contents to a known location.
10. If the user’s AOI is located across multiple counties or multiple states, the user must repeat

these steps to download all necessary data.

Download Max Speed data 
The Transportation Tool (Advanced Module Only) in EPA H2O requires TIGER/Line road data include 
maximum speeds. TIGER does not supply this information, but there are several ways users can 
generate it. Appendix C: Roads Speeds Table provides a lookup table of maximum speed national 
averages for the different MTFCC codes in the TIGER/Line road data. The process for adding this 
information to the Roads shapefile(s) is outlined in the ArcGIS Create Max Speed Dataset and QGIS 
Create Max Speed Data sections. Maximum speeds vary from one area to the next, making local 
sources that are more specific to the area of interest preferable to using the national averages. Each 
state’s Department of Transportation (DOT) may be a useful source of more locally specific max 
speeds data. The following section outlines how a Max Speed shapefile was obtained for the state of 
Florida. 

A Max Speed shapefile can be downloaded for the state of Florida at: 

1. Navigate to
https://www.arcgis.com/home/item.html?id=4a61f17ab4784202ae10d7d5fb3bf9de#overview
to open the ArcGIS website (Figure 275).

2. Under Description > Download Data, click the hyperlink to open the login screen.

https://www.arcgis.com/home/item.html?id=4a61f17ab4784202ae10d7d5fb3bf9de#overview
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Figure 275 ArcGIS website, which contains FDOT MAXSPEED data for the state 

3. Under Client Login, in the Username text box, enter Guest. No password is required.
4. Click Sign In.

Figure 276 Client Login, with Guest entered as the username 

5. Save the maxspeed.zip file and unzip the contents to a known location.

Using ArcGIS 
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This section illustrates the creation of EPA H2O compatible road data using Esri ArcGIS software. 

1. Open your existing ArcGIS map document file (.mxd), or create one following the steps
outlined in Set Up ArcGIS Map Document.

2. Use the Add Data  icon to navigate to the TIGER/Line shapefile(s) and add it as a layer in 
the Table of Contents.

3. If using a previously created Max Speed dataset, the layer must be added in the same way.
4. In the ArcToolbox window, navigate to and open the Project tool (ArcToolbox > Data

Management Tools > Projections and Transformations > Project, Figure 143).
5. In the Project window (example shown in Figure 144):

a. In the Input Dataset or Feature Class dropdown list, select the first TIGER/Line shapefile (e.g.
tl_2013_12057_roads).

b. The Input Coordinate System automatically lists the coordinate system of the selected
dataset (e.g. GCS North American 1983).

c. In the Output Dataset or Feature Class text box, browse to or type the desired file path
and name (e.g. Roads057.shp).

d. Click the Spatial Reference  icon to set the Output Coordinate System to
WGS_1984_Web_Mercator_Auxiliary_Sphere, located under the World folder in
Projected Coordinate Systems. Alternatively, the user may type 3857 into the search box.

e. A Geographic Transformation is required to reproject the land use dataset. In the
dropdown list, choose WGS_1984_(ITRF00)_To_NAD_1983 if not already selected.

f. Click OK.
6. Repeat steps 4-5 to reproject any other TIGER/Line roads or max speed datasets.

If multiple Roads shapefiles were required for the AOI, the user must combine the TIGER/Line layers. 

7. Open the Append tool in ArcToolbox (location shown in Figure 187).
8. In the Append window (example shown in Figure 188):

a. In the Target Dataset dropdown list, choose any one road shapefile to append the others
to (e.g. Roads057).

b. In the Input Datasets dropdown list, select all other road shapefiles.
c. Keep the Schema Type set to TEST and do not select a field map or subtype.
d. Click OK.

Create Max Speed Dataset 

This section illustrates the creation of Maximum Speed data using the supplemental lookup table 
(Appendix C: Roads Speeds Table). If the user obtained a Max Speed shapefile dataset, skip to the 
User-Obtained Max Speed Data section.  

1. Load the MaxSpeed_lookup.csv table into ArcMap, exported from Appendix C: Roads
Speeds Table.

2. Right-click on the appended Roads shapefile in the Table of Contents and choose Joins and
Relates > Join (Figure 183).

3. In the Join Data window (example shown in Figure 184):
a. In the first dropdown list, select Join attributes from a table.
b. In the Choose the field in this layer that the join will be based on dropdown list, choose

“MTFCC”.
c. Under the Choose the table to join to this layer dropdown list, select

MaxSpeed_lookup.csv.
d. In the Choose the field in the table to base the join on dropdown list, select “MTFCC”.
e. Toggle Keep all records
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f. Click OK.
6. Right click on the appended Roads shapefile and select Data > Export Data.
7. In the Export Data window (example shown in Figure 124):

a. In the Export dropdown list, select All features.
b. Under the Use the same coordinate system as option, toggle the data frame.
c. In the Output feature class text box, navigate to the preferred file path and name the

shapefile Roads.shp.
d. Click OK.

The Roads.shp output will contain the maximum speed data in miles per hour and kilometers per 
hour. Database creation is continued in the Importing Layers into QGIS section.   

User-Obtained Max Speed Data 

This section describes steps for using a Max Speed shapefile dataset. 

1. Navigate to the Spatial Join tool in ArcToolbox, located in ArcToolbox > Analysis Tools >
Overlay (Figure 277).

Figure 277 Location of the Spatial Join tool in ArcToolbox 

2. In the Spatial Join window (Figure 278):
a. In the Target Features dropdown list, select the appended Roads shapefile (e.g.

Roads057).
b. In the Join Features dropdown list, select the max speed dataset (e.g. maxspeed_reproj).
c. In the Output Feature Class text box, browse to or type the desired file name (e.g.

Roads_spatialjoin.shp) and file path.
d. From the Join Operation dropdown list, choose JOIN_ONE_TO_MANY.
e. Check Keep All Target Features.
f. In the Match Option dropdown list, select INTERSECT.
g. Click OK.
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Figure 278 Spatial Join window, creating a join between the Roads shapefile and max speed 

Once max speeds have been successfully added to the Roads shapefile these speeds may need to 
be updated to meet the requirements of EPA H2O. The field must be named “SPEED”, cannot contain 
zero values and should be in both miles per hour (MPH) and kilometers per hour (KMH). 

3. To rename the field with the maximum speed data to “SPEED”:
a. Create a new field in the Roads attribute table named “SPEED”, with Short Integer type.
b. Populate this field with the maximum speed data using Field Calculator.

4. To update speeds with zero values to 25:
a. Right click on the spatially joined layer (e.g. Roads_spatialjoin) and open the attribute

table.
b. From the main menu, choose Selection > Select By Attributes (Figure 244).
c. In the Select By Attributes window (example shown in Figure 245):

i. Under the Layer dropdown list, choose the spatial join layer (e.g.
Roads_spatialjoin).

ii. From the list of fields, double click on the “SPEED” field.
iii. In the Expression box, type =0 after the field name, to search for “SPEED” =

0.
iv. Click OK.

d. Right click on the “SPEED” field and choose Field Calculator.
e. In the Field Calculator window:

i. In the Expression box, type 25.
ii. Click OK.

f. Clear the previous selection by clicking the Clear Selection  icon in the attribute table. 
5. If the max speed data are only in miles per hour:
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a. Add a new field in the attribute table (Table Options > Add Field.
b. In the Add Field window:

i. In the Name text box, type SPEED_kmh.
ii. In the Type dropdown list, choose Double.
iii. Click OK.

c. Right click on SPEED_kmh in the attribute table and choose Field Calculator.
d. In the Field Calculator window:

i. From the Fields list, double click on the “SPEED” field.
ii. In the Expression box, type * 1.60934 after the field name.
iii. The full expression is [SPEED] * 1.60934
iv. Click OK.

The spatially joined layer (e.g. Roads_spatialjoin.shp) contains the maximum speed limit for the 
TIGER/Line roads in miles per hour and kilometers per hour. The database creation is continued in 
the Create User Point of Interest (POI) Layer section. 

Using QGIS 
 This section illustrates the creation of EPA H2O compatible road data using QGIS software. 

1. Open your existing QGIS map document file (.qgs), or create one following the steps outlined
in Set Up QGIS Map Document.

2. From the Layer menu (Figure 126) open the Add Vector Layer window (Main Menu > Layer >
Add Vector Layer).

3. In the Add vector layer window (example shown in Figure 127), click Browse to locate each
TIGER/Line roads shapefile, then click Open.

4. If using a previously created Max Speed dataset, the layer must be added in the same way.
5. Right-click on each layer, including the Max Speed layer (if available), and select the Save

as… option.
6. In the Save vector layer as… window (example shown in Figure 131):

a. In the Format dropdown list, select ESRI Shapefile.
b. In the Save as text box, browse to or type the desired output shapefile name (e.g.

Roads057.shp) and file path. The TIGER/Line outputs must be saved together in a new
folder, and the Max Speed dataset must be saved under a different file path.

c. In the CRS dropdown list, choose Selected CRS, and click the Browse button to locate
WGS 84 / Pseudo Mercator.

d. Check Add saved file to map.
e. Do not check Skip attribute creation.
f. Click OK.

7. In the Layers panel, right-click on the original road shapefiles and choose Remove.
8. Open the Merge shapefiles tool to combine all TIGER/Line shapefiles (Vector > Data

Management Tools > Merge shapefiles to one (Figure 279)).

Figure 279 Location of the Merge shapefiles to one tool in EPA H2O 
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9. In the Merge shapefiles window (Figure 280):
a. In the Shapefile type dropdown list, choose Line.
b. Under Input directory, click Browse to navigate to the new TIGER/Line shapefile folder

created to hold the outputs from the step 6.
c. In the Output shapefile text box, name the output shapefile (e.g. TIGER_join.shp) and file

path.
d. Check Add result to map canvas.
e. Click OK.

Figure 280 Merge shapefiles window, with the Roads/Outputs as the Input directory 

Create Max Speed Data 

This section illustrates the creation of Maximum Speed data using the supplemental lookup table 
(Appendix C: Roads Speeds Table). If the user obtained a Max Speed shapefile dataset, skip to the 
User-Obtained Max Speed Data section.  

1. Load the MaxSpeed_lookup.csv table into the Layers panel, exported from Appendix C:
Roads Speeds Table.

2. In the Layers panel, double click on the merged Roads shapefile (e.g. TIGER_join) to open
Layer Properties.

3. Under the Joins tab, click the Add Join  icon. 
4. In the Add vector join window (example shown in Figure 200):

a. In the Join layer dropdown list, select MaxSpeed_lookup.
b. In the Join field dropdown list, choose “MTFCC”.
c. From the Target field dropdown list, select “MTFCC”.
d. Check Cache join layer in virtual memory.
e. Click OK.

5. Right click on the merged Roads shapefile (e.g. TIGER_join) and select Save as (Figure 132).
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6. In the Save vector layer as… window (example shown in Figure 133):
b. In the Format dropdown list, select ESRI Shapefile.
c. In the Save as text box, browse to or type the desired file path and name the output

Roads.shp.
d. In the CRS dropdown list, choose Selected CRS, and click the Browse button to locate

WGS 84 / Pseudo Mercator.
e. Check Add saved file to map.
f. Do not check Skip attribute creation.
g. Click OK.

The Roads.shp output will contain the maximum speed data in miles per hour and kilometers per 
hour. The database creation is continued in the Importing Layers into QGIS section.   

User-Obtained Max Speed Data 

This section describes steps for using a Max Speed shapefile dataset. 

1. Open the Join attributes by location tool, as shown in Figure 158.
2. In the Join attributes by location window (example shown in Figure 159).

a. Under the Target vector layer dropdown list, choose the merged TIGER/Line shapefile
(e.g. TIGER_join.shp).

b. In the Join vector layer dropdown list, select the saved Max Speed layer (e.g.
maxspeed_reproj).

c. Under Attribute Summary, toggle Take summary of intersecting features, and check Mean.
d. In the Output Shapefile text box, browse to or type the file path and name the shapefile

Roads.shp.
e. Under Output table, choose Keep all records (including non-matching target records)
f. Click OK.

Please note that this spatial join may take a few moments to process. 

Troubleshooting Common Errors: 
  Problem: 

A common error in this step results in an Incorrect field names error (Figure 209). Three pieces of 
information help to understand the cause of this error: (1) Field names cannot be longer than 10 
characters (2) Attribute Summary by Mean renames fields by adding MEAN in front of the original 
field name (3) This results in field names with more than 10 characters when the original is more 
than 6 characters. 

Solution: 
The user must create a new field for each of the fields listed in the error message. Open the 

Layer Properties window for the corresponding layer and click the pencil  icon to start editing. 

Click on the New Column  icon to add a new field to the fields list (example shown in Figure 
205). The new field name must have 6 or less characters and have the same Type as the field it is 

replacing. Open Field Calculator and choose Update Existing Field; from the dropdown list, 
select the newly created field. From the Field and Values dropdown list, double click on the field 
to be replaced. After the field appears in the Expression box, click OK. Delete the old field from 

Layer Properties, using the Delete Column  icon.  Repeat these steps for each of the fields 
listed in the error. Save the changes made to the Layer Properties and retry the Join attributes by 
location tool.  
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Once max speeds have been successfully added to the Roads shapefile these speeds may need to 
be updated to meet the requirements of EPA H2O. The field must be named “SPEED”, cannot contain 
zero values and should be in both miles per hour (MPH) and kilometers per hour (KMH). 

3. To rename the field with the maximum speed data to “SPEED”:
a. Create a new field in the attribute table named “SPEED”, with Whole number (integer)

type.
b. Populate this field with the maximum speed data using Field Calculator.

4. To update speeds with zero values to 25:
a. In the Layers panel, locate Roads and toggle the display off, then right-click to open the

attribute table.
b. In the Roads attribute table, locate the Look for option:

i. In the Look for text box, type NULL (as shown in Figure 248).
ii. In the field dropdown list, select “SPEED”.
iii. Click SEARCH.
Please note that the selection may take a few moments. Do not close the attribute table.

c. After the NULL values are selected, click the pencil  icon to start editing. 

d. Click the Field Calculator  icon to open Field Calculator. In the Field Calculator 
window (example shown in Figure 247): 
i. Check the Only update selected features option.
ii. Check the Update existing field option.
iii. In the field dropdown list, select the “SPEED” field.
iv. In the Expression box, type 25.
v. Click OK.

e. Click the Clear Selection  icon to clear the current selection. 

f. Toggle editing off by clicking the pencil  icon and save the edits. 

5. If the max speed data are only in miles per hour:
a. In the Layers panel, right-click on the Roads layer and open the attribute table.

b. Click the pencil  icon to start editing. 

c. Click the Field Calculator  icon to open Field Calculator. In the Field Calculator 
window (example shown in Figure 247): 
i. Check the Create New Field option.
ii. In the Output field name text box, type SPEED_kmh
iii. From the Output field type dropdown list, select Decimal number (real).
iv. Leave the Output field width and precision set to the default.
v. From the Fields and Values dropdown list, double click on the “SPEED” field.
vi. In the Expression box, type * 1.60934 after the field name. The full expression is

"SPEED” * 1.60934
vii. Click OK.

d. Toggle editing off by clicking the pencil  icon and save the edits. 

The Roads.shp output will contain the maximum speed data in miles per hour and kilometers per 
hour. The database creation is continued in the Create User Point of Interest (POI) Layer section.  
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Create User Point of Interest (POI) Layer 
This section illustrates the step- by -step procedure to create a user-defined Point of Interest layer. 
Point features in the Point of Interest layer define the destinations in the Transportation Tool 
(Advanced Module Only). The user can modify the existing transportation network based on these 
points of interest.  

1. Open your existing QGIS map document file (.qgs), or create one following the steps outlined
in Set Up QGIS Map Document.

2. Use the QGIS Plugin Manager (Main Menu > Plugins > Manage Plugins) to make sure the
Qspatialite plugin is enabled, as shown in Figure 290. If not already enabled, check the box next to
QSpatiaLite (Version 6.0.3) to activate the plugin, and click OK.

3. Open the Qspatialite plugin (Main Menu > Database > SpatiaLite > Qspatialite, Figure 291).
4. The Qspatialite window will open (Figure 292). Click the database dropdown list and locate the

user database. If the name of the database is not listed, it must be connected to the Qspatialite
plugin.

5. If the user-created database is not connected:
a. Connect to the UserDatabase.sqlite database by clicking the Open/Create new

Database icon . UserDatabase.sqlite is a renamed copy of TampaBay.sqlite, 
created in the Setting Up a Project Directory section.  

b. A warning message may appear that states “UserDatabase.sqlite already exists. Do
you want to replace it?” If this appears click Yes.

6. The name of the active database appears in the dropdown box. Make sure this is the user-
created database.

7. In the Tables list, right-click on User_POIs, and select Drop Table.
8. From the main menu, select Layer menu > New > New Spatialite Layer…, as shown in Figure 281.

Figure 281 Add a new Spatialite layer in EPA H2O Power Mode 

9. The New Spatialite Layer window will appear as shown in Figure 282. In the New Spatialite Layer
window:

a. Under the Database option, click the Choose a new database  icon, and navigate to the
new database created in Setting Up a Project Directory. This database does not contain POIs
for areas outside of Tampa, but using it as a template ensures the new user-defined POIs are
structured to work with the Transportation Tool (Advanced Module Only).

b. In the Layer name text box, enter User_POIs.
c. In the Type option box, select Point.
d. Click the Specify CRS button and in the Filter box, type 3857. Select WGS 84 / Pseudo

Mercator and click OK.
e. Check the Create an autoincrementing primary key check box.
f. Within the New Attribute section:
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i. In the Name text box enter "NAME".
ii. From the Type dropdown list, select "Text

data".
iii. Click Add to attributes list button. The “NAME”

attribute will appear in the Attributes list
section.

g. Repeat to add the following attributes:
i. In the Name text box enter "TYPE_DESC", and

in the Type dropdown list, select “Text data”.
ii. In the Name text box enter "REC_USE", and in

the Type dropdown list, select “Text data”.
iii. In the Name text box enter "XCOORD", and in

the Type dropdown list, select “Decimal
number”.

iv. In the Name text box enter "YCOORD", and in
the Type dropdown list, select “Decimal
number”.

v. In the Name text box enter "xUTM", and in the
Type dropdown list, select “Decimal number”.

vi. In the Name text box enter "yUTM", and in the
Type dropdown list, select “Decimal number”.

vii. In the Name text box enter "Cost", and in the
Type dropdown list, select “Decimal number”.

h. After the eight new attributes are listed in the
Attributes list section (Figure 282), click OK.

An empty point layer has been added to the new QSpatialite 
database, which will be populated with the points of interest 
when using the Transportation Tool (Advanced Module Only) in 
EPA H2O.  

The database creation steps are complete. The Importing Layers into QGIS section details how to 
import the finals layers into the user database using the QGIS Qspatialite plugin.  

Importing Layers into QGIS 

Each of the final layers created throughout Database Creation must be imported into the QGIS 
Qspatialite plugin. Updating the Qspatialite table removes the Tampa-specific data from the user 
database and replaces it with AOI-specific data. This section details how to upload the AOI shapefile 
(HUC watershed boundary layer) into Qspatialite. The same steps must be followed to import the 
other updated layers; Table 15 outlines the updated layers that need to be uploaded, and the naming 
scheme required for each.  

1. Open EPA H2O in Power Mode.
2. In the Choose a Module window, click OK (Figure 283).

Figure 282 New Spatialite Layer window 
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Figure 283 EPA H2O Choose a Module window 

3. In the Select Project window, select Open existing project or Create new project. For first
time Power Mode users, choose Create new project (Figure 284).

Figure 284 EPA H2O Select Project window 

4. In the Project Configuration window (Figure 285):
a. Confirm that the Source Database Name is referencing the original TampaBay.sqlite.

If the source database is not the original TampaBay.sqlite, click the Select button, and
navigate to the original “0.0.3” folder.

b. In the Name Your Project Database text box, enter the preferred project name (e.g.
Demo), and click OK.
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Figure 285 Project Configuration window 

5. In the Select Area of Interest window, click Cancel.
6. From the Settings menu (Figure 116), open the Project Properties window (Main Menu >

Settings > Project Properties).
7. In the Project Properties window (Figure 286):

a. Click the Coordinate Reference System (CRS) tab and check the box labeled
Enable 'on the fly' CRS transformation.

b. In the Filter text box, type 3857.
c. Under the Coordinate reference systems of the world section, select WGS 84 /

Pseudo Mercator.
d. Click OK to apply these changes and close the Project Properties window.

Figure 286 Project Properties window in EPA H2O 
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8. From the Layer menu (Figure 287) open the Add Vector Layer window (Main Menu > Layer >
Add Vector Layer).

Figure 287 Location of the Add Vector Layer tool in EPA H2O 

9. In the Add vector layer window (Figure 288), click Browse to locate and select the layer being
added (e.g. the HUC watershed boundaries layer,  HUC_Tampa.shp), then click Open.

Figure 288 EPA H2O Add Vector Layer window 

10. In the Layers panel, right-click on the added layer (e.g. HUC_Tampa) and choose Set Layer CRS
(Figure 289).

Figure 289 Set Layer CRS in EPA H2O 
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11. In the Filter box, type 3857 and under the Coordinate reference systems of the world
section, choose WGS 84 / Pseudo Mercator. Click OK.

12. In the Layers panel, right-click on the added layer again, choose Rename, and type
the Required Qspatialite Name from Table 15 that corresponds to the layer. For the HUC
boundaries layer, Watersheds is required as the new layer name, and the layer must be
renamed “Watersheds” to function correctly in the database.

13. Use the QGIS Plugin Manager (Main Menu > Plugins > Manage Plugins) to make sure the
QSpatialite plugin is enabled, as shown in Figure 290. If not already enabled, check the box
next to QSpatiaLite (Version 6.0.3) to activate the plugin, and click OK.

Figure 290 Confirm the box next to Qspatialite plugin in checked 

14. Open the Qspatialite plugin (Main Menu > Database > SpatiaLite > Qspatialite, Figure
291).

Figure 291 Location of the Qspatialite plugin in EPA H2O 

15. When the Qspatialite window opens (Figure 292), the name of the active database appears in the
database box (i.e. TampaBay.sqlite in Figure 292). Click the database dropdown (downward arrow
beside database box) to see the full dropdown list of connected databases. Both the original
TampaBay.sqlite database and the user-created database must be listed in the database
dropdown list.
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Figure 292 Qspatialite plugin window in EPA H2O 

16. If the original TampaBay.sqlite database is not listed:
a. Connect to the TampaBay.sqlite database by clicking the Open/Create new

Database icon  . The database is placed in the following directory during 
installation: (~\.qgis\0.0.3\data\database\TampaBay.sqlite). 

b. A warning message may appear that states “TampaBay.sqlite already exists. Do you
want to replace it?” If this appears click Yes.

17. If the user-created database is not listed:
a. Connect to the UserDatabase.sqlite database by clicking the Open/Create new

Database icon . UserDatabase.sqlite is a renamed copy of TampaBay.sqlite, 
created in the Setting Up a Project Directory section.  

b. A warning message may appear that states “UserDatabase.sqlite already exists.
Do you want to replace it?” If this appears click Yes.

18. Make the user-created database the active database by selecting it from the database
dropdown list (Figure 293).

19. Tables in the active database are listed in the Tables box, below the active database name.
Before a new layer can be added to a database, tables with the same name as the layer (e.g. the
Watersheds table), must be removed by right-clicking the table name and choosing Drop Table
(Figure 293).
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Figure 293 Drop the original Watersheds table in Qspatialite with a right-click 

20. To add the new layer in the database, click on the Import QGIS Layers icon  in the 
Qspatialite window. In the Import QGIS Layers window (Figure 294):

a. Highlight the layer to be added (e.g. Watersheds) from the list of layers in the current
map.

b. Check the box next to Destination SRID and type 3857 into the text box.
c. Click OK

Figure 294 Import Watersheds layer into Qspatialite 
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The final Qspatialite table in QGIS should contain the updated tables for Watersheds, Land Use, 
Roads, and Hydrology, as well as the updated lookup table. Please note, the final lookup table must 
be updated in Qspatialite, even if FLUCCS land use and the original lookup table were used for 
database creation. The name and description of each updated layer is detailed in Table 15, with the 
name required for the user database.  

Table 15 Final Qspatialite table inputs, with the description of each layer, and links to each creation section 

Example File Layer Description Required 
Qspatialite 
Name 

Creation Section(s) 

HUC_Tampa.shp Shapefile of user-specific 
HUC watershed 
boundaries 

Watersheds Create HUC Watershed 
Boundaries 

Land_Use.shp Shapefile with spatially 
joined land use and soil 
data, updated ES 
coefficients, and has been 
joined with the lookup table 
with complete field 
calculations 

Land_Use Create Land Use Data 
Layer 
Create Soil Data Layer 
Update ES Coefficients 
Joining Lookup Table 

Roads.shp Shapefile with spatially 
joined TIGER/Line roads 
(appended) and Max 
Speed data 

Roads 
Create Road Layer 

Catchment_reproj.shp 
OR 
Catchment_GridBay.shp 

NHD Catchment shapefile, 
OR with hexagon layer 
added (Esri ArcGIS only) 

Subwatershed 
Create NHDPlus V2 
Data Layers 

NHDFlowline_reproj.shp NHD Flowline shapefile NHD_flowlines 
NHDWaterbody_reproj.shp NHD Waterbody shapefile NHD_Waterbody 
lookUPvars.dbf supplemental lookup table 

with updated ES 
coefficients 

lookUPvars Updated throughout 
Database Creation 

For full functionality the Qspatialite table must contain the default tables copied from the original 
Tampa Bay database.  

After the tables created throughout Database Creation have been input into the Qspatialite plugin, the 
user’s database is functional in the Advanced Module setting of EPA H2O. The user may select their 
AOI By Shapefile By Drawing on Map, or By River Basin (Advanced Module Only).  

To select an AOI By County in the new database, the Counties layer must be updated in the 
Qspatialite plugin. This requires a Counties shapefile, containing the county boundaries from the area 
of interest. The shapefile must also list the name of each county in a “NAME” field (the field name 
“NAME” is required for functionality).  

Update Land Use Comparison Datasets in Qspatialite 

The user may choose to replace the original FUTUREtwenty, FUTUREforty and/or FUTUREsixty 
tables with their own scenarios, as explained in the Create Land Use Comparison Data section. The 
new land use comparison dataset(s) must be input into the Qspatialite plugin under the names 
created within the Tampa Bay database. The user may add up to three land use comparison datasets, 
and must rename their layer(s) FUTUREtwenty, FUTUREforty, and/or FUTUREsixty. These will 
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appear as Land_Use_2020, Land_Use_2040, and Land_Use_2060 (respectively) in EPA H2O, even 
if data from other years were inserted. The user may change these display names by updating the 
UC2AnalysisLayer table: 

1. Open the Qspatialite plugin and locate UC2AnalysisLayer within the user database.
2. Right-click on the table and choose Load in QGIS.
3. In the Layers panel, right-click on UC2AnalysisLayer and choose Save As.

a. In the Format dropdown list, select Comma Separated Value.
b. Click Browse to save the output in a known location and name the output

UC2AnalysisLayer.
c. Click OK.

4. Locate the UC2AnalysisLayer in File Explorer, right-click, and open the file with Notepad or
the preferred text editor.

a. The user may change Land_Use_2020, Land_Use_2040, and/or Land_Use_2060 to
display a different year. For example, Land_Use_2020 can be changed to
Land_Use_2001. However, the name must start with Land_Use_20; only the last two
digits can be changed.

b. Please note, the Land_Use_2006 name cannot be changed, and therefore other
comparison layers cannot be named Land_Use_2006.

c. Save the updated CSV file.
5. From File Explorer, drag and drop the updated file into the EPA H2O Layers panel.
6. Using the Qspatialite plugin, remove the previous UC2AnalysisLayer table from the user

database and add the new UC2AnalysisLayer (as shown in Importing Layers into QGIS).
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Appendices 

Appendix A: Supplemental NLCD Lookup Table 

This section contains the supplemental NLCD lookup table (Table 16), which is updated throughout database creation. The lookup table contains NLCD land use 
descriptions, as well as the coefficients required for EPA H2O functionality. The table must be exported as a .csv and converted to a .dbf to make changes using Esri 
ArcGIS or QGIS.  Table 17 lists the references used to determine the Denitrification and Carbon Buried coefficients for each NLCD land use class in the lookup table.  

Using ArcGIS 
1. Copy both sections of Table 16 (“PKUID” through “FloodProt” fields) into a new Excel spreadsheet. Save the file to a known location and name the output with a

.csv extension (e.g. lookUPvars_supplemental.csv).
a. Note: if an error occurs while importing the .csv file into ArcMap, resave the Excel spreadsheet with a .txt extension.

2. Open your existing ArcGIS map document file (.mxd), or create one following the steps outlined in Set Up ArcGIS Map Document.

3. Use the Add Data  icon to navigate to and add the lookup .csv file (e.g. lookUPvars_supplemental.csv) as a layer in the Table of Contents. 
4. In the Table of Contents, right-click on the lookup table and choose Data > Export. In the Export Data window:

a. In the Export dropdown list, select All records.
b. Next to the Output table text box, click the Browse button and navigate to the preferred file path. In the Save as type dropdown list, select

dBASE Table, and in the Name text box, enter lookUPvars.dbf. Click Save.
c. Click OK.

The exported lookup table should be edited to update the coefficients for the user’s specific area of interest following the steps outlined in the Update ES Coefficients 
section. The “canopyVal”, “usablewat”, “StableClim”, “Us_Air_Dol”, “CN” and “FloodProt” fields will be populated in the Joining Lookup Table section. Once the table has 
been updated for the specific area of interest, it is imported into the Qspatialite plugin as described in the Importing Layers into QGIS section.   

Using QGIS 
1. Copy both sections of Table 16 (“PKUID” through “FloodProt” fields) into a new Excel spreadsheet. Save the file to a known location and name the output with a

.csv extension (e.g. lookUPvars_supplemental.csv).
2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined in Set Up QGIS Map Document.
3. From the main menu, select Layer > Add Delimited Text Layer.
4. In the Create a Layer from a Delimited Text File window:

a. Click the Browse button to locate the lookup .csv table.
b. Under the Selected Delimiter option, select Comma.
c. In the X field and Y field dropdown list, leave the default fields.
d. Click OK.

5. QGIS may try to map the attributes, this can be disregarded. In the Layers panel, right-click on the lookup table and choose Save as.
6. In the Save vector layer as window:

a. In the Format dropdown list, select ESRI Shapefile.
b. In the Save as text box, browse to the desired location and name the output lookUPvars.shp.
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c. In the CRS dropdown list, choose Selected CRS, and click the Browse button to locate WGS 84 / Pseudo Mercator.
d. Click OK.

7. In File Explorer, locate the .dbf file that coincides with the lookup shapefile (lookUPvars.dbf) and click and drag the file into the Layers panel.

Although the exported lookup table is saved as a “shapefile”, the output is an editable table (lookUPvars.dbf), which is updated throughout database creation to change 
the coefficients for the user’s specific area of interest. The “canopyVal”, “usablewat”, “StableClim”, “Us_Air_Dol”, “CN” and “FloodProt” fields will be populated in the 
Joining Lookup Table section. Once the table has been updated for the specific area of interest, it is imported into the Qspatialite plugin as described in the Importing 
Layers into QGIS section.   

Table 16 Supplemental NLCD lookup table, with land use descriptions and coefficients needed for EPA H2O 

PKUID FLUCCS FLUCSDESC GRIDCODE NLCDDesc denitrific CarbonFixe Canopy canopyVal 
32 5400 Open Water 11 Open Water 8.3 155 0 
11 1900 Developed Open Space 21 Developed Open Space 1.27 105 22 
1 1100 Developed Low Intensity 22 Developed Low Intensity 0.98 78 10 
2 1200 Developed Medium 

Intensity 
23 Developed Medium Intensity 0.6 45 3 

3 1300 Developed High Intensity 24 Developed High Intensity 0.24 17 1 
6 1600 Barren Land 

(Rocks/Sand/Clay) 
31 Barren Land (Rocks/Sand/Clay) 1.1 0 1 

26 4200 Deciduous Forest 41 Deciduous Forest 0.2 8 71 
23 4100 Evergreen Forest 42 Evergreen Forest 0.1 47 57 
27 4340 Mixed Forest 43 Mixed Forest 0.1 28 75 
21 3200 Shrub/Scrub 52 Shrub/Scrub 0.9 20 5 
20 3100 Grassland/ Herbaceous 71 Grassland/Herbaceous 0.1 30 3 
12 2100 Pasture/Hay 81 Pasture/Hay 1.4 49 6 
16 2400 Cultivated Crops 82 Cultivated Crops 0.9 43 1 
41 6300 Woody Wetlands 90 Woody Wetlands 17.2 194 67 
42 6400 Emergent Herbaceous 

Wetlands 
95 Emergent Herbaceous 

Wetlands 
12.9 187 8 
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A B C D LEV1 dni waterRet stabClim usWat usablewat StableClim Us_Air_Dol CN FloodProt 
100 100 100 100 5 8.3 2 37 3 
39 61 74 80 1 1.27 2 37 3 
54 70 80 85 1 0.98 2 37 3 
61 75 83 87 1 0.6 2 37 3 
77 85 90 92 1 0.24 2 37 3 
77 86 91 94 7 1.1 2 37 3 
36 60 73 79 4 0.2 2 37 3 
36 60 73 79 4 0.1 2 37 3 
36 60 73 79 4 0.1 2 37 3 
35 56 70 77 3 0.9 2 37 3 
30 58 71 78 3 0.1 2 37 3 
39 61 74 80 2 1.4 2 37 3 
72 81 88 91 2 0.9 2 37 3 
49 65 72 80 6 17.2 2 37 3 
49 65 72 80 6 12.9 2 37 3 

Table 17 References used to determine Denitrification and Carbon Buried coefficients for each NLCD land use class 

NLCD Land Use Classes Denitrification References Carbon Buried References 
Open Water An et al. 2001; An and Gardner 2002; Bianchi et al. 1999; 

Brenner et al., 2001; DeLaune et al. 2005; Fennel et al. 
2009; Gardner et al. 2006; Gihring et al. 2010; Heffernan 
and Cohen 2010; James et al., 2011; Joye and Anderson 
2008; Messer and Brezonik 1983; Mortazavi et al. 2000; 
Pina-Ochoa and Alvarez-Cobelas 2006; Pina-Ochoa and 
Alvarez-Cobelas 2006; Seitzinger 1988; Seitzinger et al. 
2006; Smith et al. 1985 

Boyd et al. 2010; Brenner et al. 2001; Craft and 
Richardson 1993; Munsiri et al. 1995; Tepe and Boyd 
2002 

Developed Open Space Calculated as explained in the Determine Nitrogen 
Removal Rates section 

Calculated as explained in the Carbon Fixation Rates 
for Developed Classes section Developed Low Intensity 

Developed Medium Intensity 
Developed High Intensity 
Barren Land (Rocks/Sand/Clay) Jackson et al. 1990 N/A 
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Deciduous Forest Barton et al 1999; Chestnut et al. 1999 Downing et al. 2008; Johnston et al. 1996; Laffoley 
and Grimsditch 2009; Mcleod et al. 2011; Vesterdal et 
al. 2002 

Evergreen Forest Barton et al 1999; Henrich and Haselwandter 1997; 
Robertson et al. 1987 

Garten Jr 2002; Hooker and Compton 2003; 
Huntington 1995; Richter et al 1999; Schiffman and 
Johnson 1989 

Mixed Forest Barton et al. 1999; Dutch and Ineson 1990; Goodroad 
and Keeney 1984 

Calculated average based on “Deciduous Forest” and 
“Evergreen Forest” references 

Shrub/Scrub Jackson et al. 1990 Lawrence et al. 2012 
Grassland/Herbaceous Frank and Groffman 1998; Robertson et al. 1987; Tsai 

1989 
Burke et al. 1995; Downing et al. 2008; Gebhart et al 
1994; Knops and Tilman 2000; Laffoley and 
Grimsditch 2009; Post and Kwon 2000 

Pasture/Hay Barton et al. 1999; Espinoza 1997; Seitzinger et al. 
2006 

Downing et al. 2008 

Cultivated Crops Barton et al. 1999, Espinoza 1997, Tsai 1989 Pacala et al. 2001; Houghton 1999 
Woody Wetlands Bowden 1987; DeLaune et al. 1998; Gale et al. 1993; 

Lindau et al. 2008; Seitzinger 1994; Walbridge and 
Lockaby 1994 

Breithaupt et al. 2012; Engle 2011; Hanson and 
Nestlerode 2014 

Emergent Herbaceous Wetlands Craft et al. 2009; DeLaune et al. 1989; Dodla et al. 2008; 
Gale et al. 1993; Morris 1991; Nixon and Lee 1986; 
Reddy et al. 1989; Seitzinger 1988; Wigand et al. 2004 

Brenner et al. 2001; Chmura et al. 2003; Day et al. 
2004; DeLaune et al. 1981; Downing et al. 2008; 
Duarte et al. 2005; Laffoley and Grimsditch 2009 
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Appendix B: Air Quality Reference Table 

This section contains the supplemental Air Quality reference table (Table 18), which details the average pollutant removal rates for 55 metropolitan areas in the 
continental United States (Nowak et al., 2006). The “TOTgm2” field contains the sum of the pollutant rates, and “Value_m2” is the sum of each monetary value 
multiplied by that total. The estimated values ($) for removal of each pollutant were $959/ton Carbon Monoxide, $6752/ton Ozone, $1653/ton Sulfur Dioxide, 
$4508/ton Particulate Matter (PM10), and $6752/ton Nitrogen Dioxide (Murray et al., 1994).  

The user may locate the city nearest their area of interest and use the appropriate “Value_m2” value in the Air Quality section. If the user is unsure which city is 
closest to their area of interest, the user may alternatively copy Table 18 into an Excel spreadsheet, and export the table to create a shapefile using Esri ArcGIS 
or QGIS.  

Using ArcGIS 
1. Copy Table 18 into a new Excel spreadsheet. Save the file to a known location and name the output with a .csv extension (e.g. AQ_AttributeTable.csv).
2. Open your existing ArcGIS map document file (.mxd), or create one following the steps outlined in Set Up ArcGIS Map Document.
3. From the main menu choose File > Add Data > Add XY Data. In the Add XY Data window:

a. In the Choose a table from the map or browse for another table dropdown list, click the Browse button and navigate to the exported .csv file. The
file name will appear in the dropdown list.

b. In the X Field dropdown list select the “X” field, and in the Y Field dropdown list, select the “Y” field (if not already populated).
c. Under the Coordinate System of Input Coordinates box, click the Edit button. In the XY Coordinate System search box, type 4326 and select WGS

1984. Click OK.
d. Click OK.

4. A message will appear that explains “Table Does Not Have Object-ID Field”. Click OK.
5. The table will appear in the Table of Contents. Right-click on the table and choose Data > Export Data (as shown in Figure 123 and Figure 124).
6. In the Export Data window:

a. In the Export dropdown list, select All features.
b. Under the Use the same coordinate system as section, toggle the data frame option.
c. In the Output feature class text box, name the output AirQualityReference.shp.
d. Click OK.

The exported shapefile can be used in the Air Quality section, to calculate the land use air pollution removal rates based on the nearest city. 

Using QGIS 
1. Copy Table 18 into a new Excel spreadsheet. Save the file to a known location and name the output with a .csv extension (e.g. AQ_AttributeTable.csv).
2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined in Set Up QGIS Map Document.
3. From the main menu, select Settings > Project Properties.
4. In the Project Properties window:

a. Toggle on the Enable ‘on the fly’ CRS transformation option if not already on by default.
b. In the Filter box, type 4326, and under Coordinate reference systems of the world, select WGS 84.
c. Click OK.
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5. From the main menu, select the Layer > Add Delimited Text Layer.
6. In the Create a Layer from a Delimited Text File window:

a. Click the Browse button to locate the exported .csv file (e.g. AQ_AttributeTable.csv).
b. Under the Selected Delimiter option, select Comma.
c. In the X field dropdown list select the “X” field, and in the Y field dropdown list, select the “Y” field (if not already populated).
e. Click OK.

7. In the Layers panel, right-click on the Air Quality table and choose Save as.
8. In the Save vector layer as window:

a. In the Format dropdown list, select ESRI Shapefile.
b. In the Save as text box, browse to the desired location and name the output AirQualityReference.shp.
c. In the CRS dropdown list, choose Selected CRS, and click the Browse button to locate WGS 84 / Pseudo Mercator.
d. Check Add saved file to map.
e. Click OK.

9. Repeat steps 3 and 4 to change the project coordinate system back to WGS 84/ Pseudo Mercator.

Note: after the coordinate system is changed back, layers that were previously in the Layers panel may need to be removed and re-added into the map to draw 
correctly.   

The exported shapefile can be used in the Air Quality section, to calculate the land use air pollution removal rates based on the nearest city.  

Table 18 Average removal rates for carbon monoxide (CO), ozone (O3), particulate matter (PM10), sulfur dioxide (SO2), and nitrogen dioxide (NO2) for 55 U.S. cities 

FID X Y City State COgm2 O3gm2 SOgm2 PMgm2 NOgm2 TOTgm2 Value_m2 
0 -73.7562 42.65258 Albany NY 0.1 3.4 0.5 2.4 1 7.4 0.04145 
1 -106.606 35.0853 Albuquerque NM 0.3 2.4 1.1 2.6 1.2 7.6 0.038134 
2 -84.3863 33.75374 Atlanta GA 0.3 4.6 0.8 3.8 1.2 10.7 0.057902 
3 -97.7505 30.26693 Austin TX 0.6 5.2 1.7 3.1 2 12.6 0.065975 
4 -76.6094 39.29923 Baltimore MD 0.3 4 1.3 3.7 2.7 12.1 0.064355 
5 -91.1474 30.47116 Baton Rouge LA 0.5 4.8 0.9 3.5 1.3 11 0.058932 
6 -71.0571 42.36114 Boston MA 0.3 3.8 1.1 2.8 2.1 10.2 0.054565 
7 -73.1952 41.18649 Bridgeport CT 0.3 3.4 0.8 2.8 1.6 9 0.047993 
8 -78.8787 42.88023 Buffalo NY 0.2 3.7 1.5 2.1 1 8.5 0.043873 
9 -81.6326 38.34981 Charleston WV 0.1 2.7 1 1.9 0.9 6.7 0.034621 
10 -84.512 39.10312 Cincinnati OH 0.3 3 1.2 3.3 1.8 9.5 0.049557 
11 -81.6813 41.50549 Cleveland OH 0.3 3.7 1.4 4.7 1.5 11.6 0.0589 
12 -81.0348 34.0007 Columbia SC 0.4 4.1 1.3 3 0.7 9.6 0.048466 
13 -82.9988 39.96119 Columbus OH 0.2 3.7 0.6 3 1.8 9.2 0.051844 
14 -96.797 32.7767 Dallas TX 0.5 4.7 0.4 3.6 1.2 10.5 0.057206 
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15 -104.99 39.73919 Denver CO 0.2 2.1 0.7 3.1 1.8 7.9 0.041656 
16 -83.0458 42.3314 Detroit MI 0.2 3.1 0.9 3.4 1.1 8.7 0.045365 
17 -106.485 31.7619 El Paso TX 0.4 3.1 1.1 4 0.4 9 0.043866 
18 -119.773 36.7468 Fresno CA 0.3 5.1 0.6 6.7 1.6 14.3 0.076721 
19 -157.858 21.3069 Honolulu HI 0.6 6.6 0.5 5 0.5 13.3 0.071881 
20 -95.3698 29.7604 Houston TX 0.4 4.5 1.8 4.7 2 13.4 0.068435 
21 -86.1581 39.7684 Indianapolis IN 0.2 4.5 1.1 3.4 1 10.3 0.054473 
22 -81.6557 30.33219 Jacksonville  FL 0.3 5 0.9 3.4 1.1 10.7 0.05829 
23 -74.0776 40.7282 Jersey City  NJ 0.7 3.6 1.6 4.1 2.7 12.7 0.064337 
24 -94.5786 39.09969 Kansas City  MO 0.3 4 0.8 3.3 0.7 9.2 0.048221 
25 -118.244 34.0522 Los Angeles  CA 1.2 6.9 0.6 8 6.3 23.1 0.127333 
26 -85.7585 38.25269 Louisville  KY 0.3 4.3 1.9 3.5 1.4 11.3 0.057693 
27 -90.049 35.1495 Memphis  TN 0.4 4.8 1 3.6 2.3 12.1 0.066205 
28 -80.1918 25.7617 Miami  FL 0.5 5.5 0.4 4.6 1.7 12.7 0.070492 
29 -87.9065 43.0389 Milwaukee  WI 0.2 3.3 0.5 2.2 1.2 7.4 0.04132 
30 -93.265 44.9778 Minneapolis  MN 0.3 3.1 0.2 1.1 1.5 6.2 0.036636 
31 -86.7816 36.1627 Nashville  TN 0.3 3.4 0.8 3.4 1.2 9.1 0.047996 
32 -90.0715 29.9511 New Orleans  LA 0.6 4.8 1 4.8 1.6 12.8 0.06708 
33 -74.006 40.71279 New York  NY 0.7 3.7 1.7 3.7 3.6 13.5 0.069451 
34 -74.1724 40.7357 Newark  NJ 0.3 3.6 1.1 4.8 2.7 12.5 0.066282 
35 -97.5164 35.4676 Oklahoma City  OK 0.3 5.7 0.8 2.8 0.8 10.4 0.05812 
36 -95.998 41.25239 Omaha  NE 0.2 2.6 0.7 3.4 0.7 7.6 0.038958 
37 -75.1652 39.9526 Philadelphia  PA 0.3 3.8 2 5.5 2 13.7 0.067549 
38 -112.074 33.4484 Phoenix  AZ 0.9 4.3 0.2 7.2 2.3 15 0.078215 
39 -79.9959 40.4406 Pittsburgh  PA 0.2 3.6 2.4 3.8 1.6 11.6 0.0564 
40 -122.677 45.52309 Portland  OR 0.6 3 1 3.1 1.5 9.2 0.046587 
41 -71.4128 41.82399 Providence  RI 0.2 3.7 1 3.7 1.2 9.8 0.051609 
42 -79.9414 37.271 Roanoke  VA 0.2 4.6 1.1 4 1 11 0.057853 
43 -121.494 38.58159 Sacramento  CA 0.4 4.9 0.3 3.8 1.4 10.8 0.060547 
44 -111.891 40.76079 Salt Lake City  UT 0.3 3 0.5 5.2 1.6 10.5 0.055615 
45 -117.161 32.7157 San Diego  CA 0.7 7.6 0.8 5.6 2.8 17.4 0.097459 
46 -122.419 37.77489 San Francisco  CA 0.7 3.5 0.5 4.7 2.7 12.1 0.064548 
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47 -121.886 37.33819 San Jose  CA 0.5 4.6 0.4 3.7 2.8 12 0.067785 
48 -122.332 47.6062 Seattle  WA 0.6 3.3 1.5 3.1 1.5 10 0.049439 
49 -90.1994 38.62699 St. Louis  MO 0.3 3.3 1.8 3.8 1.5 10.7 0.052803 
50 -82.4572 27.95059 Tampa  FL 0.5 5.8 2.4 4.5 1.1 14.2 0.071321 
51 -110.927 32.2217 Tucson  AZ 0.4 4.6 0.3 3.8 1.3 10.3 0.057847 
52 -95.9928 36.154 Tulsa  OK 0.4 5.3 1.2 3.6 0.9 11.4 0.060458 
53 -75.978 36.85289 Virginia Beach-

Norfolk 
 VA 0.2 5.8 1.2 2.8 1.5 11.5 0.064087 

54 -77.0369 38.90719 Washington  DC 0.5 3.9 1.6 3.3 2 11.3 0.057838 



252 

Appendix C: Roads Speeds Table 
This section contains the supplemental Max Speed reference table (Table 19) with the average speed limits for 
the various road types in shapefiles from TIGER roads. Speed data is required to create the road network in 
the Create Road Layer section and is implemented in the Transportation Module of EPA H2O. The table must 
be exported as a .csv to use in Esri ArcGIS or QGIS.   

Using ArcGIS 
1. Copy Table 19 into a new Excel spreadsheet. Save the file to a known location and name the output

with a .csv extension (e.g. MaxSpeed_lookup.csv).
2. Open your existing ArcGIS map document file (.mxd), or create one following the steps outlined in Set

Up ArcGIS Map Document.

3. Use the Add Data  icon to navigate to and add the lookup .csv file (e.g. MaxSpeed_lookup.csv) as a 
layer in the Table of Contents. 

The imported table can be used in the Create Road Layer section, to calculate the speed limits for the road 
network.  

Using QGIS 
1. Copy Table 19 into a new Excel spreadsheet. Save the file to a known location and name the output

with a .csv extension (e.g. MaxSpeed_lookup.csv).
2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined in Set

Up QGIS Map Document.
3. In File Explorer, locate the Max Speed .csv table. Click and drag to load the table into the Layers

panel.

The imported table can now be used to calculate the speed limits for the road network in the Create Road 
Layer section.  

Table 19 Max Speed reference table, with speed limits in mph and kmh 

MTFCC Road_Desc Speed Speed_kmh 
S1100 Primary Road 70 112.6538 
S1200 Secondary Road 65 104.6071 
S1400 Local Neighborhood Road/ Rural Road/ City Street 25 40.2335 
S1500 Vehicular Trail (4WD) 0 0 
S1630 Ramp 25 40.2335 
S1640 Service Drive usually along a limited access highway 25 40.2335 
S1710 Walkway/Pedestrian Trail 0 0 
S1730 Alley 15 24.1401 
S1740 Private Road for service vehicles (logging/ oil fields/ ranches/ etc.) 0 0 
S1750 Drive for census use 0 0 
S1780 Parking Lot Road 15 24.1401 
S1820 Bike Path or Trail 0 0 
S1830 Bridle Path 0 0 
S2000 Road Median 0 0 
S1720 Stairway 0 0 
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Appendix D: Extracting and Updating the Original FLUCCS Lookup Table 

The steps outlined throughout database creation were written using a land use layer based on NLCD and the supplemental lookup table (Appendix A: 
Supplemental NLCD Lookup Table). The supplemental lookup table was intended for users creating a database extending outside of the Tampa Bay 
area, where the FLUCCS land use data and original coefficients may not apply.  

However, if the user is creating a new database completely within the state of Florida, and intends to use FLUCCS land use data, the original lookup table 
may be used with a few modifications. This lookup table contains all available FLUCCS land use types for the Tampa Bay area. If the new FLUCCS data 
include additional land use types it is suggested that the user add each to the lookup table and update the rates accordingly. The FLUCCS classification 
codes are hierological (e.g. code 1110 is a subset of 1100) and joining the land use layer to the lookup table may require codes to be generalized. 
Depending on the software, different steps are required to modify the original lookup table (Using ArcGIS or Using QGIS).  

Using ArcGIS 
This section contains the original lookup table for Tampa, extracted from the TampaBay.sqlite database with some modifications (Table 20). The table 
must be exported as a .csv and converted to a .dbf to make changes using Esri ArcGIS.  

1. Copy both sections of Table 20 (“PKUID” through “FloodProt” fields) into a new Excel spreadsheet. Save the file to a known location and name the
output with a .csv extension (e.g. lookUPvars.csv).

2. Open your existing ArcGIS map document file (.mxd), or create one following the steps outlined in Set Up ArcGIS Map Document.

3. Use the Add Data  icon to navigate to and add the lookup .csv file (e.g. lookUPvars.csv) as a layer in the Table of Contents. 
4. In the Table of Contents, right-click on the lookup table and choose Data > Export.
5. In the Export Data window:

a. In the Export dropdown list, select All records.
b. Next to the Output table text box, click the Browse button and navigate to the preferred file path. In the Save as type dropdown

list, select dBASE Table, and in the Name text box, enter lookUPvars.dbf. Click Save.
c. Click OK.

The exported lookup table should be edited to update the coefficients for the user’s specific area of interest following the steps outlined in the Update ES 
Coefficients section. The “canopyVal”, “usablewat”, “StableClim”, “Us_Air_Dol”, “CN” and “FloodProt” fields will be populated in the Joining Lookup Table 
section. Once the table has been updated for the specific area of interest, it is imported into the Qspatialite plugin as described in the Importing Layers 
into QGIS section.   

Using QGIS 
1. Copy both sections of Table 20 (“PKUID” through “FloodProt” fields) into a new Excel spreadsheet. Save the file to a known location and name the

output with a .csv extension (e.g. lookUPvars_supplemental.csv).



254 

2. Open your existing QGIS map document file (.qgs), or create one following the steps outlined in Set Up QGIS Map Document.
3. From the main menu, select Layer > Add Delimited Text Layer.
4. In the Create a Layer from a Delimited Text File window:

a. Click the Browse button to locate the lookup .csv table.
b. Under the Selected Delimiter option, select Comma.
c. In the X field and Y field dropdown list, leave the default fields.
d. Click OK.

5. QGIS may try to map the attributes, this can be disregarded. In the Layers panel, right-click on the lookup table and choose Save as.
6. In the Save vector layer as window:

a. In the Format dropdown list, select ESRI Shapefile.
b. In the Save as text box, browse to the desired location and name the output lookUPvars.shp.
c. In the CRS dropdown list, choose Selected CRS, and click the Browse button to locate WGS 84 / Pseudo Mercator.
d. Click OK.

7. In File Explorer, locate the .dbf file that coincides with the lookup shapefile (lookUPvars.dbf) and click and drag the file into the Layers panel.

Although the exported lookup table is saved as a “shapefile”, the output is an editable table (lookUPvars.dbf), which is updated throughout database 
creation to change the coefficients for the user’s specific area of interest. The “canopyVal”, “usablewat”, “StableClim”, “Us_Air_Dol”, “CN” and “FloodProt” 
fields will be populated in the Joining Lookup Table section. Once the table has been updated for the specific area of interest, it is imported into the 
Qspatialite plugin as described in the Importing Layers into QGIS section.   

Table 20 Original lookup table for Tampa Bay with FLUCCS land use.  The vital rates for H2O are denitrification rate (denitrific), carbon fixation rate (CarbonFixe), percent 
canopy cover(Canopy), and soil type categories (A, B, C).  

PKUID FLUCCS FLUCSDESC denitrific CarbonFixe Canopy A B C 

1 1100 RESIDENTIAL LOW DENSITY < 2 DWELLING UNITS 1.3 148 22 54 70 80 

2 1200 RESIDENTIAL MED DENSITY 2->5 DWELLING UNIT 1.13 138.5 23 61 75 83 

3 1300 RESIDENTIAL HIGH DENSITY 0.85 91 12 77 85 90 

4 1400 COMMERCIAL AND SERVICES 0.62 56.5 5 89 92 94 

5 1500 INDUSTRIAL 0.6 50.5 3 81 88 91 

6 1600 EXTRACTIVE 1.18 116.5 13 77 86 91 

7 1650 RECLAIMED MINE LAND 1.18 116.5 13 39 61 74 

8 1700 INSTITUTIONAL 0.87 73.11111 4 81 88 91 

9 1800 RECREATIONAL 1.4 127.5 11 49 69 79 

10 1820 GOLF COURSES 1.4 132.5 13 49 69 79 
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11 1900 OPEN LAND 1.4 132.5 13 39 61 74 

12 2100 CROPLAND AND PASTURELAND 0.72 423.1256 7 39 61 74 
13 2140 ROW CROPS 3.15 959.0622 3 67 78 85 

14 2200 TREE CROPS 0.45 570.5556 16 43 65 76 

15 2300 FEEDING OPERATIONS 0.06 423.1256 6 68 79 86 

16 2400 NURSERIES AND VINEYARDS 0.45 570.5556 10 72 81 88 

17 2500 SPECIALTY FARMS 0 0 6 68 79 86 

18 2540 TROPICAL FISH FARM 0 0 19 81 88 91 

19 2600 OTHER OPEN LANDS <RURAL> 0.82 673.3333 18 30 58 71 

20 3100 HERBACEOUS 0.06 742.5 16 30 58 71 

21 3200 SHRUB AND BRUSHLAND 0.06 945 28 35 56 70 

22 3300 MIXED RANGELAND 0.82 540 31 48 67 77 

23 4100 UPLAND CONIFEROUS FOREST 0.12 697.5 56 36 60 73 

24 4110 PINE FLATWOODS 0.12 697.5 49 36 60 73 

25 4120 LONGLEAF PINE - XERIC OAK 0.12 312.9 46 36 60 73 

26 4200 UPLAND HARDWOOD FORESTS - PART 1 0.19 590 55 36 60 73 

27 4340 HARDWOOD CONIFER MIXED 0.19 660 65 36 60 73 

28 4400 TREE PLANTATIONS 0.45 730.8333 56 43 65 76 

29 5100 STREAMS AND WATERWAYS 20.73 180 22 100 100 100 

30 5200 LAKES 12.16 396.5722 0 100 100 100 

31 5300 RESERVOIRS 6.73 367.7989 0 100 100 100 

32 5400 BAYS AND ESTUARIES 5.66 195 0 100 100 100 

33 5700 OCEAN AND GULF OF MEXICO 0 115.3367 0 100 100 100 

34 5720 GULF OF MEXICO 6.89 115.3367 0 100 100 100 

35 6100 WETLAND HARDWOOD FORESTS 25.5 808 76 49 65 72 

36 6110 BAY SWAMPS 25.5 808 79 49 65 72 

37 6120 MANGROVE SWAMPS 0.69 777.9744 76 49 65 72 

38 6150 STREAM AND LAKE SWAMPS (BOTTOMLAND) 25.5 808 81 49 65 72 

39 6200 WETLAND CONIFEROUS FORESTS 25.5 298.2 72 49 65 72 
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40 6210 CYPRESS 24.66 241.25 66 49 65 72 

41 6300 WETLAND FORESTED MIXED 25.5 552.4 73 49 65 72 

42 6400 VEGETATED NON-FORESTED WETLANDS 28.26 141.7 21 49 65 72 

43 6410 FRESHWATER MARSHES 28.26 618 30 49 65 72 

44 6420 SALTWATER MARSHES 4.52 492.2544 30 49 65 72 

45 6430 WET PRAIRIES 25.48 141.7 20 49 65 72 

46 6440 EMERGENT AQUATIC VEGETATION 26.22 141.7 29 49 65 72 

47 6510 TIDAL FLATS 10 195 0 98 98 98 

48 6520 SHORELINES 0 0 0 98 98 98 

49 6530 INTERMITTENT PONDS 17.44 141.7 10 98 98 98 

50 6600 SALT FLATS 0 0 10 98 98 98 

51 7100 BEACHES NO SWIM 0 0 0 98 98 98 

52 7200 SAND OTHER THAN BEACHES 0 0 0 98 98 98 

53 7400 DISTURBED LAND 0 25 10 98 98 98 

54 8100 TRANSPORTATION 1.2 96 4 98 98 98 

55 8200 COMMUNICATIONS 1.16 105.5 9 98 98 98 

56 8300 UTILITIES 1.4 132.5 9 98 98 98 

57 9113 SEAGRASS PATCHY 5 813.6667 0 100 100 100 

58 9116 SEAGRASS CONTINUOUS 5 813.6667 0 100 100 100 

59 9121 ALGAE BEDS 5 0 0 100 100 100 

D LEV1 waterRet stabClim usWat canopyVal usablewat StableClim Us_Air_Dol CN FloodProt 
85 1 2 37 3 

87 1 2 37 3 

92 1 2 37 3 

95 1 2 37 3 

93 1 2 37 3 

94 1 2 37 3 

80 1 2 37 3 
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93 1 2 37 3 

84 1 2 37 3 

84 1 2 37 3 

80 1 2 37 3 

80 2 2 37 3 

89 2 2 37 3 

82 2 2 37 3 

89 2 2 37 3 

91 2 2 37 3 

89 2 2 37 3 

93 2 2 37 3 

78 2 2 37 3 

78 3 2 37 3 

77 3 2 37 3 

83 3 2 37 3 

79 4 2 37 3 

79 4 2 37 3 

79 4 2 37 3 

79 4 2 37 3 

79 4 2 37 3 

82 4 2 37 3 

100 5 2 37 3 

100 5 2 37 3 

100 5 2 37 3 

100 5 2 37 3 

100 5 2 37 3 

100 5 2 37 3 

80 6 2 37 3 

80 6 2 37 3 
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80 6 2 37 3       
80 6 2 37 3       
80 6 2 37 3       
80 6 2 37 3       
80 6 2 37 3       
80 6 2 37 3       
80 6 2 37 3       
80 6 2 37 3       
80 6 2 37 3       
80 6 2 37 3       
98 6 2 37 3       
98 6 2 37 3       
98 6 2 37 3       
98 6 2 37 3       
98 7 2 37 3       
98 7 2 37 3       
98 7 2 37 3       
98 8 2 37 3       
98 8 2 37 3       
98 8 2 37 3       
100 9 2 37 3       
100 9 2 37 3       
100 9 2 37 3       
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Appendix E:  Additional Troubleshooting and Common Errors 

New Project “No Such Table” Error 

When starting a new project, an error window may appear while the selected AOI is processing (Figure 
295). This error states “The SQL query seems to be invalid. No such table:” and lists the table name 
that cannot be found (e.g. FUTUREsixty). The error message may appear behind the progress bar.  

Figure 295 SQL no such table error message 

This message occurs when a table has been deleted or doesn’t have the expected name in the 
Qspatialite plugin. EPA H2O searches for each table name from the original Tampa Bay database; if a 
name does not appear, or it has been renamed incorrectly, the user will receive an error.  

If the named table was deleted intentionally, the user only needs to click the OK button. The rest of 
the data layers will continue to process for the AOI. Please note, this error will appear every time a 
new project is created, and the rest of the data will not load until the OK button is clicked.  

If the named table was deleted unintentionally, or the table was renamed incorretly, the user must 
make changes in the Qspatialite plugin. In a blank map project, the user must rename the table to 
match the Tampa Bay naming scheme or add a new table into Qspatialite with the correct name.  

An exception may occur if the “no such table” name in the error message is Land_Use (Figure 296). 
This may occur if the land use layer was originally named Land_Use_2006.  

Figure 296 EPA H2O Land_Use error window 

The user database requires the name Land_Use_2006 the first time the land use layer is inserted into 
Qspatialite. However, if the user updates the land use layer later, and reuploads it into the Qspatliate 
plugin, the database may require the name Land_Use. Change the name of the land use layer to 
match that in the error message, reupload the table into Qspatialite, and the error should not appear 
again. 
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Cannot Run Advanced Comparison Report 

EPA H2O requires that all layer names in the Qspatialite plugin maintain the naming scheme found in 
the Tampa Bay database. The program also requires that the layer names stay the same in the 
Layers panel. If the user right clicks on a layer in the Layers panel and renames it, two different errors 
may occur when running a comparison report. 

The first error occurs if Land_Use_2006 is renamed. A No Project error message appears that states 
“Please Create a Project, then run Scenario Manager” (Figure 297). The user must right-click on the 
appropriate layer in the Layers panel and rename the layer Land_Use_2006 to run a comparison 
report.  

Figure 297 No Project error message when comparing scenarios 

A second error may appear if the land use scenario layers (e.g. Land_Use_2020, Land_Use_2040, 
and Land_Use_2060) are renamed and the renamed layer is used in a comparison report. A Python 
error window appears that indicates one of the scenario layers (e.g. scenarioLayerB) is out of range 
(Figure 298).  

Figure 298 Python error window while running a comparison report 

The user must rename the layer to match one of the original Future Scenario layer names, even if the 
layers represent NLCD data from a different time. 
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Cannot Update Polygons in Edit Scenario Tool 

After a user database is created, the user can update land use polygons with the Edit Scenarios tool. 
A Python error may occur after the Update button is selected in the tool (Figure 299). The error window 
indicates that the CN Value is out of range.   

Figure 299 Python error window while updating land use polygons 

This error occurs when the “FLUCSDESC” field in the land use layer does not match the attributes in 
the lookup table “FLUCSDESC” field. Both “FLUCSDESC” fields must contain the updated land use 
descriptions (e.g. “NLCDDesc”); this is explained in the Field Calculations sections.  

To fix the error, the user must use Field Calculator to update the “FLUCSDESC” fields with the 
“NLCDDesc” attributes. The updated layer (land use or lookup table) must then be reuploaded into the 
Qspatialite plugin. Create a new project using the user database, and the Edit Scenario tool will be 
fully functional.  

Report Legend Crossed Out in Advanced Report 

When running an Ecosystem Valuation Report (as shown in the Compare Scenarios section), the 
output Legend may appear partially crossed out (Figure 300).  
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Figure 300 Advanced Report legend, with cross hatch error 

This occurs when the layers were not “turned on” in the Layers panel before the comparison was run. 
Both layers must be toggled on prior to running a scenario comparison report; the report does not 
require the layers to stay turned on for the report, they simply must be turned on and off once.  

The user must close the current project and create a new project for the AOI. Turn each land use 
layer on once before the first comparison report is run. 

Flood Protection = 0 in Advanced Report 

When running an Advanced report in a user-created database, the Flood Protection value for 
Land_Use_2006 may equal zero (Figure 301).  

Figure 301 Statistics page of the Advanced Ecosystem Valuation Report 
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This issue may be rooted in an incorrect field calculation in the Joining Lookup Table section. 

1. Open the Land_Use_2006 attribute table and sort the “Max_Type_N” field in ascending order.
2. If the “Max_Type_N” field contains values of 0, this may be the source of the issue above.

a. Recalculate the missing “Max_Type_N” values, as shown in the Spatially Join Soils to
Land Use (ArcGIS) or Spatially Join Soils to Land Use (QGIS) section.

b. Recalulate the “CN” field, then recalculate the “FloodProt” field, as shown in the Joining
Lookup Table section.

3. Drop and re-add the updated Land_Use_2006 table into Qspatialite.
4. When a comparison report is run in the user database, the Flood Protection value should no

longer be zero.

Total Area: 0 sq meters in Advanced Report 

When running an Advanced report, the Total Area may report as 0 sq meters, with no land use types 
listed.  

Figure 302 Statistics page of the Advanced Ecosystem Evaluation Report 

This is simply a processing error. Close the report and remove the Upstream Area of Interest and 
Area of Interest layers from the Layers panel (right-click > Remove). Run another report using the 
Compare Scenarios tool, with a new Report Name; the correct areas will be reported.  

Cannot Open Qspatialite Plugin 

An error may appear when trying to open the Qspatialite plugin in EPA H2O (Database menu > 
SpatiaLite > QspatiaLite). The error message states “The SQL query seems to be invalid. No such 
table: geometry_columns”.  



264 

Figure 303 SQL error window when opening Qspatialite 

This message may appear if a database was renamed or moved within the user’s .qgis folder. All 
databases that were once opened in EPA H2O and/or Qspatialite are linked to the plugin. If a 
database is moved or renamed, the plugin searches for a database that is no longer there.  

The user must delete the connection between Qspatialite and the database. 
1. Close the error messages that appear.
2. Open the Qspatialite plugin and select the old database from the dropdown box.

3. Click the Delete Link to Database  icon.  
The user should now be able to reopen the Qspatialite window with no errors. 

If the user completely deleted a database folder from their C:/ drive, a different error will appear. This 
error message states “Can’t connect to DataBase. Error unable to open database file”. The error 
window also lists the file path of the missing database (Figure 304).  

Figure 304 Missing database error window in EPA H2O 

Qspatialite cannot be opened until a database is returned to the exact file path listed in the error. 
1. Create a copy of the original Tampa Bay database, as shown in the Setting Up a Project

Directory section.
2. The file path for the copied database must exactly match the file path listed in the error

message received.
3. Rename the copied Tampa Bay database to match the deleted database name (e.g.

UserDatabase2.sqlite).
4. The Qspatialite plugin should now open in EPA H2O. Select the database from the dropdown

box.

5. Click the Delete Link to Database  icon. 
6. The user may then delete the copied database folder from their C:/ drive.

Python Error When Opening or Creating Project 

A Python error may appear after selecting an AOI for a new project, or when opening a previously 
saved project (Figure 305). The error window states “UnboundLocalError: local variable ‘olRes’ 
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referenced before assignment”. After clicking the Close button, a second message may appear, 
explaining that the Google Streets layer cannot be drawn (Figure 306).  

Figure 305 Python error while creating a new project, or opening a previous project 

Figure 306 qgis message window, stating Google Streets cannot be drawn 

These error messages appear together when there is an issue with the user’s internet connection. A 
connection to the internet is required to display the Google Streets layer. The user must close the 
program, troubleshoot the internet connection, and reopen EPA H2O to draw Google Streets.  

If the internet is connected and Google Streets continues to fail, right-click on the layer in the Layers 
panel and choose Remove. From the main menu select Plugins > OpenLayers plugin > Add Road 
layer. Google Streets may be experiencing a licensing issue, and the Bing road layer may be used 
instead.   

Please note, the program is completely functional without the streets layer but may be desired when 
exporting reports.  
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FAQ: Frequently Asked Questions 

This section addresses common questions users may have about the program, its use, and its 
development.  

How do I get the EPA H2O?  
EPA H2O is a free software distributed by US EPA’s Gulf Ecology Division, and can be 
downloaded at the following link: https://www.epa.gov/water-research/ecosystem-services-
scenario-assessment-using-epa-h2o 
If you are unable to download EPA H2O, please contact US EPA’s Gulf Ecology Division.  

Do I need to pay for EPA H2O?  
No. It is distributed free of charge by US EPA’s Gulf Ecosystem Measurement and Modeling 
Division. For questions regarding commercial application, the license agreement can be 
found in the Setup Wizard of the EPA H2O Download and Installation section.  

Are there any constraints on use of EPA H2O?  
Yes. EPA H2O relies on the QGIS application, and inherits all QGIS use constraints 
(licensed under the GNU General Public License).  

Where did the EPA H2O data come from? How up to date is the data?  
The Tampa Bay database used in EPA H2O is comprised of data collected by various 
governmental agencies including Florida Natural Areas Inventory (FNAI), Florida Geographic 
Data Library (FGDL), and EPA. Please refer to source agency websites for more information 
on specific datasets (Table 6). Data were further processed for optimum use in EPA H2O. All 
data were downloaded from agency websites in July 2013. However, the last updated date 
of each data are different.  

I am an advanced QGIS user, can I use QGIS functionality in EPA H2O?  
Yes. Users can run EPA H2O with full QGIS functionality in power mode by changing the 
EPA H2O settings in the computer registry as shown under the Power Mode section of the 
help manual.  

Can I use EPA H2O on any operating system?  
No. EPA H2O is currently only compatible with Windows operating systems. Please check 
the System Requirements for further details.  

Can I modify the report style and format in EPA H2O?  
No. The current version of EPA H2O does not allow users to modify the report style and 
format.  

What does the "EPA H2O version 1" popup box mean?  
This box appears when a user action is not supported in the current EPA H2O mode. The 
functionality may be supported when the EPA H2O power mode is enabled, as described in 
the Power Mode section of the help manual.  

Can I simultaneously and seamlessly work on Basic and Advanced Modules of the 
EPA H2O? No. Users can operate EPA H2O only in one mode at a given time. Please save 
your work as an EPA H2O project, and then switch modules using the "EPA H2O Module" 
tool, as shown in the Navigating EPA H2O section.  

Can I save the EPA H2O project and share it with others?  
Yes. Please refer to the Saving and Moving the Project section of the manual. 

https://www.epa.gov/water-research/ecosystem-services-scenario-assessment-using-epa-h2o
https://www.epa.gov/water-research/ecosystem-services-scenario-assessment-using-epa-h2o
https://www.epa.gov/aboutepa/about-gulf-ecosystem-measurement-and-modeling-division
http://www.epa.gov/ged/
https://www.epa.gov/aboutepa/about-gulf-ecosystem-measurement-and-modeling-division
https://www.epa.gov/aboutepa/about-gulf-ecosystem-measurement-and-modeling-division
http://www.epa.gov/ged/
http://www.epa.gov/ged/
https://www.qgis.org/en/site/
http://www.epa.gov/ged/
http://www.epa.gov/ged/
http://www.fnai.org/
http://www.fnai.org/
http://www.fnai.org/
http://www.fgdl.org/metadataexplorer/explorer.jsp
https://www.fgdl.org/metadataexplorer/explorer.jsp
http://www.fgdl.org/metadataexplorer/explorer.jsp
http://www.fgdl.org/metadataexplorer/explorer.jsp
http://www.fgdl.org/metadataexplorer/explorer.jsp
http://www.epa.gov/ged/tbes/
https://www.epa.gov/ged/tbes/
http://www.epa.gov/ged/tbes/
http://www.epa.gov/ged/tbes/
http://www.epa.gov/ged/tbes/
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Appendix F:  Updating QGIS Layer Symbologies 

When starting a new project in the user’s database, the symbology in the Layers panel will match 
that of the original Tampa Bay database. This legend incorporates the user’s land use 
classifications but appears to display FLUCCS categories. Table 21 shows how the Layers panel 
legend categorizes the NLCD descriptions. 

Table 21 NLCD descriptions condensed into EPA H2O legend descriptions 

Legend NLCD Description 
Urban and Built-Up Developed, Open Space 

Developed, Low Intensity 
Developed, Medium Intensity 
Developed, High Intensity 

Agriculture Pasture/Hay 
Cultivated Crops 

Rangeland Shrub/Scrub 
Grassland/Herbaceous 

Woodlands Deciduous Forest 
Evergreen Forest 
Mixed Forest 

Water Open Water 
Wetlands Woody Wetlands 

Emergent Herbaceous Wetlands 
Barren Land Barren Land (Rocks/Sand/Clay) 
Utilities and Transportation N/A 
Seagrass and Algae Beds N/A 
Tidal Flats N/A 

The original Tampa Bay database utilized FLUCCS land use data, which incorporated Utilities and 
Transportation, Tidal Flats, and Seagrass and Algae Beds as land use types. Although these land 
use types are not found in NLCD data, they are still listed in the Layers panel.  

Only data that is present in the selected AOI will appear in the Advanced Module Scenario 
Comparison Report; therefore, Utilities and Transportation, Tidal Flats, and Seagrass and Algae 
Beds, as well as any other land use type not located in the AOI, will not appear in the report 
description.  

Land use types and their symbology are condensed for a cleaner, more simplified map. However, 
the user may update the symbology to display the NLCD descriptions, rather than the condensed 
legend descriptions.  

Note: if the symbology is changed in the land use layer and a comparison report is run, the AOI 
and Upstream AOI boundaries will draw behind the land use layer in the report. The AOI 
boundaries will therefore not display directly on the map in the report output. 

1. In the Layers panel, double click on the Land_Use_2006 layer.
2. From the Layer Properties window, click on the Style tab, and in the first dropdown box,

choose Categorized (Figure 307).
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Figure 307 Land_Use_2006 Layer Properties, with Categorized selected in the Style tab 

3. In the Column dropdown box, choose the “FLUCSDESC” field (Figure 308).
4. Click Classify. The land use descriptions from the user’s land use layer will appear in an

alphabetical list, as shown in Figure 308.

Figure 308 Land_Use_2006 Layer Properties window, with NLCD descriptions listed in the Style tab 

5. Under the Symbol column, right-click on the first square, and choose Change color.
6. Select a new color to appropriately represent the first land use type and click OK.
7. Change the color of the symbol for each land use type, then click OK.
8. Repeat the same changes in symbology for any other land use comparison datasets the

user input into the EPA H2O Qspatialite plugin.
9. The correct land use descriptions will appear in the Layers panel, and in any reports ran

during the current project. These steps must be repeated with every new project created.
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Appendix G: EPA H2O Development From QGIS

This section provides additional information for developers to understand the EPA H2O 
architecture and coding structure.  

Development 

The EPA H2O program is created by customizing the base QGIS program. There are different 
Integrated Development Environments (IDEs) to customize QGIS that are dependent on the 
development operation system platform used. For the EPA H2O tool, the platform used for 
development was a Windows 32bit operating system and the IDE used to customize QGIS was 
Microsoft Visual Studio 2008. The customization consists of creating a Plugin for QGIS 
developed using the Python language. The QGIS plugin is made with Python scripts combined 
into a package. These scripts follow an object-oriented methodology.  

User interface creation: 

The QGIS user interface is based on Qt and PyQt technology. It consists of Qt widgets and 
graphic tools that are generated by “QtDesigner” and compiled using Python code.  

Qt and PyQt libraries are embedded in “OSGEO4W” and accessible by QGIS. 

Spatialite database:  

QGIS accesses the Project database using the “Spatialite” library. This library provides functions 
to access and read the main database, create user scenarios, and edit existing attributes.  

QGIS Python package: 

The QGIS python package has the necessary GIS functionalities required by EPA H2O and the 
ability to programmatically access the existing QGIS features. 

Through the QGIS python package, the QGIS window can be customized by adding menus, 
toolbars, and QDockWidget.  

Cmake and Microsoft Visual C++: 

Customizations made to the QGIS program and plugins need to be compiled in order to create 
the executable file. Running a compilation can be done using Cmake. It will create the Project 
Solution, which can be compiled and released as the package.  

Error catching and debugging QGIS 

QGIS has a Python and PyQt debugger console that facilitates error catching. 

QGIS Source Code Compilation 

The compilation process of QGIS is listed below:  

Set OSGEO4W and MVS environment variables.  

To setup the necessary environment dependencies for the code compilation: 
1. All the software below must be installed first.
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a. Cmake
b. Flex
c. Bison
d. MS Server 2003 R2 SDK

2. Edit OSGeoMSC.bat in the QGIS source folder and set the right paths.
a. Execute OSGeoMSC.bat in a Command console. It is preferable to execute

OSGeoMSC.bat with administrative privileges.

Generate QGIS Microsoft Visual Studio solution 

This step links all required QGIS libraries using Cmake. CMake Files define all the necessary 
rules for solution generation; however, paths linking the source to the libraries may be null or 
wrong. Please correct these paths if required.  

3. Generate a build folder using the command << MKdir build>> the <<Cd build>>.
4. Execute <<Cmake-gui>> and set the source and the build folders path similar to what is

shown in Figure 309.

Figure 309 CMake 2.8.4 window 

5. Set the appropriate value for every unknown path, e.g. library path, App folder, binary file.
6. The paths should resemble:

a. Binary folders: OSGeo4W/bin.
b. Include folder: OSGeo4W/include.
c. App folder: OSGeo4W/apps.
d. Libraries folder: OSGeo4W/lib.

7. Run Configure.
8. Check and fix any errors.
9. When the configuration is complete, run the generate command which will create the

Microsoft Visual C++ solution <<QGIS1.8.0.sln>> and all related Visual C++ projects
(Figure 310).
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Figure 310 Documents library window after the source and build folders path have been set 

Compile the source 

Microsoft Visual Studio Solution Builder is used in this step. 
1. Run the command <<MSbuild QGIS1.8.0.sln /p:Configuration=Release>>
2. Please make sure the build is successfully done. Any kind of error might affect the

compilation later.
3. Run the command <<MSbuild INSTALL.vcproj /p:Configuration=Release>>

Generate the installer package 

Installer package creation requires the installation of Cygwin (https://www.cygwin.com/). 
To run the install: 

1. Run a Cygwin console as an Administrator.
2. Locate to the path Trunk\QGIS-1.8.0\ms-windows\
3. Run the command << ./quickpackage.sh>>
4. The quickpackage.sh script could be edited to set installer name and version.
5. The installer file will be generated in a MS Windows folder.

Project Manager Plugin for EPAH2O 

The Project Manager Plugin is a custom plugin that controls all the functions of the EPA H2O 
program. The sample in Figure 311 shows the directory structure of a typical plugin (Source:  
https://docs.qgis.org/testing/en/docs/pyqgis_developer_cookbook/intro.html#python-plugins). 

PYTHON_PLUGINS_PATH/
 MyPlugin/ 
 __init__.py  --> *required*  mainPlugin.py 
--> *required*  metadata.txt --> *required* 
resources.qrc --> *likely useful* 
 resources.py --> *compiled version, likely useful*  form.ui    
--> *likely useful* 
 form.py    --> *compiled version, likely useful* 

Figure 311 Python plugins path 

https://www.cygwin.com/
https://www.cygwin.com/
https://docs.qgis.org/testing/en/docs/pyqgis_developer_cookbook/intro.html%23python-plugins
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Plugin files include: 
1. __init__.py = The starting point of the plugin. It needs the classFactory() method and may

have any other initialization code.
2. mainPlugin.py = The main working code of the plugin. It contains all the information about

the actions of the plugin and the main code.
3. resources.qrc = The .xml document created by Qt Designer. It contains relative paths to

resources of the forms.
4. resources.py = The translation of the .qrc file described above to Python.
5. form.ui = The GUI created by Qt Designer.
6. form.py = The translation of the form.ui described above to Python.
7. metadata.txt = Required for QGIS >= 1.8.0.

The Project Manager Plugin’s components relate to other familiar components of EPA H2O 
(conceptual diagram shown in Figure 312).  

Figure 312 Conceptual diagram of the Project Manager Plugin’s components 

Project Creation and User Database 

EPA H2O is based on the “Use Case”. Each use case has a different user interface and 
functionality. The project creation has three major components: 

1. Select the Main Database’s and the user database’s names. The main database path will
be saved in the system registry in order to reload it for future use.

2. Select the AOI and clip the main database.
3. Load all layer in the Table of Contents.

Main Database and user database management 

QGIS accesses the project database using the “Spatialite” library. This library provides functions 
to access and read the main database, creates the user database, and edits existing attributes.  

AOI selection and clip using Spatialite 

The function “runListIntersect” in project_manager.py presents the table creation from the 
intersection between AOI and Main Database. The intersection query is in SQL as shown in the 
sample query below.  
Note: countyRect represents the extent of the county selected by the user. This example 
represents the intersection query for a county AOI selection.  

“consSQL = ('create table '+theLayer+' as select * from '+theLayer+' where  
MBRIntersects('+theLayer+'.geometry, GeomFromText(\'POLYGON(('+str(countyRect.xMinimum())+' 
'+str(countyRect.yMinimum())+','+str(countyRect.xMinimum())+'  
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'+str(countyRect.yMaximum())+','+str(countyRect.xMaximum())+'  
'+str(countyRect.yMaximum())+','+str(countyRect.xMaximum())+'  
'+str(countyRect.yMinimum())+','+str(countyRect.xMinimum())+' '+str(countyRect.yMinimum())+'))\'))')” 

Load Layers in the Table of Contents 

The function “runSelectConservationLands” in project_manager.py loads a layer from the user 
spatialite database depending on parameters such as table name, symbology and user database 
path.  

Clip and Summary Operations 

Each use case has the appropriate clip and summarize operations for the calculation needed. 

Use Case I:  

A Vector Clip operation is performed in Use Case I in order to summarize the layer’s statistics. 
The calculation requires going through different attributes in the data. Based on the specific 
operation to execute, the project manager will loop over features and read data attributes. The 
summary of a layer requires running specific operations to a particular attribute for the input AOI. 
Figure 313 displays the conceptual diagram of the sequential steps to clip and summary 
operations.  

Figure 313 Conceptual diagram detailing the steps to clip and summary operations in Use Case I 

A separate table named AnalysisLayer is used to determine the attributes used and the summary 
operation to be executed for the given layer. The list below shows the types of operations 
performed on layers:  

1. Total area calculation
2. Total length calculation
3. Features count within the area
4. Dollar or dollar/area value summation
5. Total area categorized by feature description

The user can choose the AOI three different ways: 
1. By County selection (Counties are listed in “Counties” layer).
2. By a Polygon shapefile (Shapefile should be loaded from the file system).
3. By drawing on the map (Drawing tools will appear in order to select the AOI)

“utils.ClipIt.clip” is the function responsible for the vector clip.  
“runStats” function in Project Manager is responsible to run the summary statistic calculation for 
each layer.  
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Use Case II: 

For Use Case II, a raster clip and summary operation are used. The summary operation 
calculates the mean of pixel values. Figure 314 demonstrates the conceptual diagram of 
sequential steps to the clip and summary operations.  

Figure 314 Conceptual diagram detailing the steps to clip and summary operations in Use Case II 

A separate table named UC2AnalysisLayer is used to determine the attributes used and the 
summary operation to be executed for the given layer. The list below shows the types of 
operations performed on layers.  

AOI selection choices for this use case are the same as Use Case I, with the addition of 
“Selection by river basins.” River basins are listed in “River basins” layer.  

“vectorToRasterGridClip” function lists layers to summarize from the UC2AnalysisLayer table. 
“clipLandUseGrid” function runs the raster clip for a vector layer.  

ES Coefficient Values and Edit User Scenarios 

Editing ES coefficients affects the ES value calculations. A field’s recalculation must be executed 
after every ES coefficient edit is complete. These coefficients are stored in the scenario layer 
table and are considered as default values for future edits. “EGSUpdateAttThread.py” is the 
source of the class responsible for ES coefficient edits and related recalculation executions.  

The user can also edit the land use feature descriptions. EPA H2O will recalculate the ES values 
based on the new descriptions and attribute values found in the “LookUPvars” table. The 
recalculation is executed for all edited features. The “updateSelectedAttributes” function in 
"project_manager.py" performs all the ES values recalculations upon land use feature editing.  

Reporting 

Project Manager generates two different types of reports - one for each Use Case I and Use 
Case II. After calculating the summary statistics based on the use case, EPA H2O Project 
Manager generates the report. It combines the map, the legend, and the summarizing 
description of each ES variable within area of interest and its upstream area.  

Below are the critical functions required for the report generation: 

“writeMap” function in 'project_manager.py' exports the map and legend to a PNG image. 
“writeReport” function in 'project_manager.py' generates the PDF report for Use Case I.  
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“writeReport2” function in 'project_manager.py' generates the PDF report for Use Case II. 

Transportation Tool 

The Transportation Tool is an additional functionality in Use Case II. It provides the user with 
ability to:  

1. Customize the roads network
2. Check the change effects
3. Add new points of interest

Figure 315 shows the conceptual diagram for the Transportation Tool workflow. 

Figure 315 Conceptual diagram of the Transportation network workflow 

Starting point 

The user can choose the starting point two different ways: 
1. By coordinate capture in the map
2. By geocoding an address

The “StPointCapButtonClick” function in 'project_manager.py' serves to capture a map point and set 
it as the starting point.  
The “StPointGeocodeButtonClick” function in 'project_manager.py' serves to geocode an address 
and set it as the starting point.  

Points of interest  

EPA H2O lists standard points of interest and lets the user add extra points using three methods: 
1. By coordinate capture
2. By geocoding an address
3. By loading a .csv file containing a list of addresses

User transportation scenario 

The User transportation scenario is an exact copy of the Roads layer, but with user ability to edit. 

“TrScenarioManager.py” is the UI class for the user transportation scenario’s creation and deletion. 
“TransportationEditScenario.py” is the UI class responsible for editing the scenario.  
“TrNewRoad.py” is the UI class responsible for adding new roads to the edited user scenario.  
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Network Analysis Library 

Network Analysis Library from the QGIS API provides the functionality to build the topology and 
perform network analysis on it.  

“SpeedProperter “class in 'ShortestPathCalculator.py' describes the strategy pattern based on road 
speed used by the network analysis.  

Summary and reporting 

The output of the network analysis updates the cost in time to reach each of the points of interest 
using the starting point as a reference. Upon running the analysis, Project Manager writes the 
cost in the buffered user points of interest layer. The report generated for the transportation 
module compares the main road network to a selected user transportation scenario.  

“TrWriteReport” function in project_manager.py is used for writing the report. 
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