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Summary 
 
 
A Quantitative Microbial Risk Assessment (QMRA) infrastructure that automates the manual process of 
characterizing transport of pathogens and microorganisms, from the source of release to a point of 
exposure, has been developed by loosely configuring a set of modules and process-based models. 
Tutorials describe functionality of a QMRA software infrastructure, guide users through software use 
and assessment options, and provide step-by-step instructions for implementing a mixed-use, 
watershed-based QMRA. The tutorials are applications to portions of watersheds which provide short 
descriptions and discussions that allow users to easily move through the QMRA assessment process 
without having to implement all of the steps. These include:  
 

 Installation of software for watershed modeling in support of QMRA  

 Navigation of software that automates data collection and identifies an 8-digit HUC of interest  

 Importation of local data files to identify and modify contamination sources and input 
parameters 

 Mathematical formulation of the Microbial Source Module (MSM) that determines microbial 
loading rates to a watershed 

 Implementation of land-applied microbial loadings within a 12-Digit HUC  

 Pour-point analysis of land-applied microbial loadings and comparison of simulated and gaging 
station results  

 NLDAS and NCDC meteorological data 

 Point source and land-applied microbial loadings within a 12-digit HUC 

 Publication of a microbial density time series as a TXT File  
 
This tutorial combines several shorter tutorials and applies them to a complete watershed basin, from 
source to receptor. Prior to implementation, it is recommended that users become familiar with earlier 
boutique tutorials since many questions may be answered more concisely by them. This tutorial 
demonstrates how to  
 

 Identify locations of flow gage stations in a watershed of interest. 

 Download flow and microbial observations from a USGS gaging station and text file, respectfully. 

 Export flow and microbial observations. 

 Prepare PEST input files for HSPF flow and microbial parameter calibrations. 

 Calibrate HSPF flow and microbial parameters with PEST. 

 View results of HSPF flow and microbial parameter calibration with PEST. 

 Compare observed, uncalibrated, and calibrated results. 
 
The Manitowoc watershed is a 525 mi2 basin that is used to illustrate a complete source-to-receptor 
assessment on a full-size watershed. The results published here are for illustrative purposes only and do 
NOT represent a final or verified assessment of the Manitowoc watershed.  
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HSPF Setup, Application, and Calibration of Flows and Microbial Fate and 
Transport on an Example Watershed 

 
 
PURPOSE 
 
Automate data acquisition to meet input requirements for the HSPF, MSM, PEST, and BASINS models. 
 
OBJECTIVE 
 
Implement a quantitative microbial assessment at a gaged watershed. 
Pre-populate input data files of the WinHSPF (a.k.a. HSPF), MSM, and PEST models automatically. 
 
 
DEMONSTRATION 
 
This tutorial reviews screens, icons, and basic functions of the SDMProjectBuilder (SDMPB) and how to 
take output from SDMPB; develops microbial spatial and temporal microbial loadings using MSM; 
performs microbial fate and transport on the Manitowoc River Basin using HSPF; and analyzes and 
visualizes the results at multiple locations in the watershed using BASINS. Users will learn how to set up, 
simulate, and calibrate parameters with both hourly and daily flow simulations, although neither 
requires the other since each simulation is independent. It demonstrates how to  
 

 Identify and delineate a watershed of interest. 

 Initiate execution of SDMPB. 

 Navigate the SDMPB. 

 Use basic functions of the SDMPB tool bar. 

 Identify and label a watershed of interest. 

 Choose a pour point of the Manitowoc River Basin, delineate the sub-area that contributes to 
that Pour Point, and collect data for it. 

 Capture contextual data for the Microbial Source Module (MSM) and pre-populate its input data 
files to account for: 

o Land-applied microbial loadings 
o Microbial loadings from septic systems 
o Microbial loadings from direct cattle shedding instream 

 Capture contextual data for the watershed model HSPF and pre-populate its input data files to 
account for: 

o Hydrology and hydrodynamics 
o Snow accumulation/melt 
o Microbial fate and transport 
o Daily and/or Hourly simulations 

 Prepare flow observation time series for HSPF parameter calibration with BASINS 

 Automate PEST input file preparation for HSPF flow parameter calibration 

 Perform HSPF flow parameter calibration with PEST 
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 Compare uncalibrated, calibrated, and observed simulations at the watershed pour point with 
BASINS 

 Visualize and overlay time series of flow and microbial densities at the watershed pour point 
with BASINS 

 
This tutorial implements an assessment on a complete river basin, based on a series of tutorials that had 
previously been developed to aid users in implementing QMRA-related software to assess release, 
migration, and fate of microbes in a mixed-use watershed setting, as described by Whelan et al. (2017a). 
For example, Whelan et al. (2017b) presents a shorter version of the assessment presented here, since it 
demonstrates a pour-point analysis of land-applied microbial loadings and a comparison of simulated 
and gaging station results by simulating microbial fate and transport using HSPF; it then analyzes and 
visualizes results at multiple locations in the watershed using BASINS. 
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SECTION 1: CHOOSING A WATERSHED AND EXECUTING HSPF FOR FLOW AND MICROBIAL 
FATE AND TRANSPORT 

 SOFTWARE ACCESS, RETRIEVAL, AND DOWNLOAD 

 NAVIGATING THE SDMPB AND IDENTIFYING A WATERSHED OF INTEREST 
o Executing the SDMProjectBuilder 
o New SDM Project 
o Navigation Helper 
o Identify, Modify, and Import Local Source-term Data 

 Identify Local Source-term Data 
 Modify Local Source-term Data 

 BoundaryPointsLL.csv 

 FCProdRates.csv 
 Import Local Source-term Data 

o Identify the Pour Point Gaging Station 
o Run Project Builder 

 LABEL SUBWATERSHED WITH AN IDENTIFICATION NUMBER 

 MODIFY MICROBIAL LOADING RATES IN THE HSPF *.UCI FILE 
o Identify Microbial Loading Rates in the HSPF *.uci File which need to be Set Equal to 

Zero 
o Modify Microbial Loading Rates in the HSPF *.uci File by Using a Text Editor 

 Identify Land-use Types by Subwatershed 
 Modify Microbial Loading Rates 

o Modify Microbial Loading Rates in the HSPF *.uci File by Using the HSPF User Interface 

 EXECUTING HSPF 
 

SECTION 2: CALIBRATING FLOW-RELATED PARAMETERS 
 DOWNLOADING AND EXPORTING A TIME SERIES OF FLOW OBSERVATIONS 

o Register Simulation Results for the Manitowoc River Basin 
o Download Discharge Data Associated with Gage Stations in the Manitowoc River Basin 

 Daily Discharge Time Series for USGS Gaging Stations on the Manitowoc River 
Basin 

 Daily Discharge Time Series for USGS Gaging Station 04085427 
o View Observed Data 
o Export Flow Data as a Text File for Parameter Calibration 

 PREPARING PEST INPUT FILES FOR HSPF FLOW PARAMATER CALIBRATION 
o Prepare HSPF for the Flow Calibration Period 
o Execute HSPF for the Flow Calibration Period 

 CALIBRATING HSPF FLOW PARAMETERS WITH PEST 

 VIEWING OUTPUT FILES OF THE FLOW CALIBRATION RESULTS 
o View PEST Output Files of Flow Calibration Results with a Text Editor 
o View Calibrated Flow Parameter Values with WinHSPF 
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SECTION 3: VISUALIZING HSPF FLOW CALIBRATION AND SIMULATION RESULTS 
 REGISTERING CALIBRATION RESULTS WITH BASINS 

 COMPARING HSPF FLOW SIMULATION RESULTS BY PLOTTING MULTIPLE TIME SERIES 
o Identify Data Sources Containing Daily Flow 
o View for a Daily Time Step 

 

SECTION 4: CALIBRATING MICROBIAL-RELATED PARAMETERS
 PREPARING MICROBIAL OBSERVATION DATA 

 PREPARING PEST INPUT FILES FOR HSPF MICROBIAL PARAMETER CALIBRATION 
o Create Microbial Folder and Populate with Necessary Files 
o Execute Microbial Calibration using PEST 

 CALIBRATING HSPF MICROBIAL PARAMETERS WITH PEST 

 
SECTION 5: VISUALIZATING HSPF MICROBIAL CALIBRATION AND SIMULATION RESULTS 

 VIEWING OUTPUT FILES OF THE MICROBIAL CALIBRATION RESULTS 
o View Microbial Results Using a Text Editor 
o View Microbial Results Using WinHSPF 

 REGISTERING CALIBRATED SIMULATION RESULTS AND OBSERVATIONS WITH BASINS 
o Register Calibrated Microbial Simulation Results 
o Register Microbial Observations 

 COMPARING HSPF MICROBIAL SIMULATION RESULTS BY PLOTTING MULTIPLE TIME SERIES 
 

DISCLAIMER 
 
REFERENCES 
 
APPENDIX A: USGS Instantaneous Data Archive for Instantaneous Discharge Data using the 
BASINS Download Data Tools 

 
APPENDIX B: Flow Calibration: Details of “HSPF_PEST_flow.exe” and “Input_flow.in” 
 
APPENDIX C: Flow Calibration: Heuristic Relationships between Land Use Types and Various 
Calibration Parameters 
 
APPENDIX D: Microbial Calibration: Details of “HSPF_PEST_microbe.exe” and 
“Input_microbe.in” 
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SOFTWARE ACCESS, RETRIEVAL, AND DOWNLOAD 
 
Instructions for accessing, retrieving, and downloading the following software, to install on a host 
computer in support of Quantitative Microbial Risk Assessment (QMRA) modeling, are provided by 
Whelan et al. (2017c): 

 SDMProjectBuilder (including the Microbial Source Module as part of the installation) 

 BASINS (including WinHSPF and WinHSPFlt) 

 SARA Timeseries Utility 

 HSPF_PEST_flow and HSPF_PEST_microbe 

 FORTRAN Library 

 PEST 
 
When installed, three shortcut icons appear on the desktop: 
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NAVIGATING THE SDMPB AND IDENTIFYING A WATERSHED OF INTEREST 
 
Executing the SDMProjectBuilder 
 
1. Execute the SDMProjectBuilder (SDMPB) by clicking on the shortcut icon displayed on the 

computer screen: 

 
 
2. If the icon cannot be found on the Desktop, locate the executables on the hard drive (i.e., 

SDMProjectBuilder.exe), which are typically in \SDMPB\bin\, as illustrated below. A detailed, more 
comprehensive tutorial describing how to identify an 8-digit HUC is provided in Whelan et al. 
(2017d); an abbreviated version follows. 
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3. The User Interface (UI) of SDMPB appears. 

 
 
4. Before beginning the application, it is important to understand the meaning of the tool bar icons. 

For additional information, see Whelan et al. (2017d). 

 
 
New SDM Project 
 
5. From the Menu Bar, select “SDMProjectBuilder>New SDM Project” to begin identifying a 

watershed of interest. 
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6. Create a folder where you have administrative rights. Below, a new project file was created as 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\ HSPF-PEST_1.dspx”. Click “Save”. 

 
 
7. A map of the Unites States including Alaska, Hawaii, and Puerto Rico should appear. 

 
 
8. In the “Legend”, layers are sequentially displayed, top to bottom. They can be moved by holding 

the left mouse button down and moving it up or down to the desired position. Layers can be turned 
on or off by checking (“√”) or un-checking the box at the left of the layer’s name. The map layers’ 
definitions are shown below.  
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9. To find a watershed and collect the desired data, identify each 8-digit HUC and its unique ID called 

the Hydrologic Unit Code (HUC) Catalog Unit (CU). Assign CU numbers to the HUC-8s: 
a. Add 8-digit HUC labels by right-clicking on the “HUC-8” Layer. 

 
 

b. Select “Labeling>Label Setup” and double-click left on ”CU”; make sure “[CU]” shows in the 
“SELECT” box at the bottom of the screen. Click “Apply”, then “OK”. 

US States

All 8-digit HUCs
N: not headwater
Y: headwater catchment

US Counties

US States

All 8-digit HUCs
N: not headwater
Y: headwater catchment

US Counties
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c. The following screen should appear. [Note: All HUC-8s should now have associated CU 
numbers.] 
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10. We are interested in the Manitowoc River Basin in the County of Manitowoc, WI (see blue box in 
figure below), but there are many ways to identify it. For example, we can zoom to the general area 

using the “Zoom In” button on the tool bar. Click it, then go to the “Map” screen and identify 
the area to zoom in on, as with the blue box in the figure below. 

 
 
11. The result looks like this. 

 
 

We are interested in the HUC with a CU of 04030101. 
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Navigation Helper 
 
12. Use the “Navigation Helper” to collect the first map layers. On the menu bar, select 

“SDMProjectBuilder>Nav Helper”. 

 
 
13. The following window appears. 
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14. With the “Navigation Helper”, zoom to State, County, or HUC-8. If you do not know the HUC 8 

identification number, but you do know the location, type in the “State” and “County” and choose 
“Zoom”. Our example is for the watershed in Manitowoc County, Wisconsin. 

 
 
15. The following shows 

a. a close-up of HUC 04030101 and 
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b. a regional view, including HUC 04030101 

 
 
16. From the figure, we see that the HUC-8 CU identification number is 04030101, which we will need 

for collecting data. Type or choose “04030101” for the “HUC 8”, check “NHD+” and “HUC-12” 
boxes, then click “Zoom” beside “HUC 8”. 
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17. The following appears, with blue highlighting. 

 
 
18. In the Navigation Helper window, click “Get Data” beside “HUC 8”. 
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19. A screen like the following appears.  

 
 
20. Click “Close”. 
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21. Colors associated with map layers can be modified for clarity:  for example, turn on “nhdflowline 
for 04030101”, “huc 12 for 04030101” and “HUC-8”, with other layers turned off. 

 
 
22. To adjust width and color of flowline associated with “nhdflowline for 04030101”, double-click left 

on the symbol below “nhdflowline for 04030101”. 
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23. The “Line Symbol” window appears. Modify the color by left-clicking on the rounded rectangle to 

open the “Color” window. 

 
 
24. A color palette will appear. Select blue and click “OK”. 
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25. Make sure the color of the rounded rectangle changed to blue, like the screen below. Change 
“Width” to “1” in the “Line Symbol” window. Click “Apply”, then “OK”. 

 
 
26. Now there is a better view of the watershed. 
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27. If you see the Projection Mismatch screen (which may appear more than once), choose ‘Yes’ since 
you want to re-project these map layers to match the coordinate system. 

 
 
Identify, Modify, and Import Local Source-term Data 
 
This section identifies and modifies local data files, and imports local data files to the SDMPB. Local 
source-term data are described in Whelan et al. (2017e) which also describes how to edit the files and 
register them as map layers in the SDMPB. The user can modify certain source-term parameters and 
influence the degree of resolution of the watershed through 12 local-data files that are installed when a 
user begins a new project. They are located in the “…\LocalData” folder within the working folder. 
Whelan et al. (2017d, 2017f, 2017g) provide additional examples identifying and modifying the local 
source-term data example default files. Metadata associated with the parameters contained within each 
file, including definitions and units, are summarized in Whelan et al. (2017e). Five of the 12 files denote 
locations: point sources (PointSourceLL.csv), animal locations (AnimalLL.csv), septic systems 
(SepticsLL.csv), boundary conditions (BoundaryPointsLL.csv), and locations for output results 
(OutputPointsLL.csv). 
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Modifications are made to the following local data files: 

 BoundaryPointsLL.csv – Identifies boundary condition locations. The boundary point location 
(44.027308, -88.164316) was changed to (0.0, 0.0), outside of the watershed and will not 
impact the assessment. Although no boundary condition is consumed for this example and 
this modification is unnecessary, it illustrates how one can modify this CSV file. 

 FCProdRates.csv – Identifies 1) production or shedding rate of microbes from each domestic 
animal, which equals the multiple of the (a) domestic animal shedding rate in mass of waste 
(wet weight) per time and (b) microbial concentration based on mass of waste shed by the 
domestic animal; and 2) identifies typical microbial production or shedding rate per wildlife 
per unit area. The shedding rate of “BeefCow” was changed to the value for “DairyCow” 
because half of dairy cows are grazed. 

 
The following local data files will not be changed for this example: 

 AnimalLL.csv – Identifies domestic animal locations by Latitude and Longitude and domestic 
animals by numbers and by type. 

 GrazingDays.csv – Identifies the 1) number of grazing days per domestic animal per month 
and 2) fraction of the number of grazing days that Beef Cattle spend in a stream per month. 

 ManureApplication.csv – Identifies the 1) fraction of manure applied to soil each month per 
domestic animal and 2) fraction of amount of manure shed by the domestic animal 
incorporated into soil. 

 MonthlyFirstOrderDieOffRateConstants.csv – Defines monthly microbial first-order die-off 
rate constants. 

 OutputPointsLL.csv – Identifies intermediate points, where the user would like the watershed 
model to produce simulation results, and only exist at subwatershed boundaries; therefore, 
these locations impact delineation of the watershed, in particular the number and location of 
subwatersheds.  

 PointSourceLL.csv – Identifies point source locations.  

 PointSourceData.csv – Identifies the annual-average flow, and microbial and/or chemical 
loading rates for each point source. 

 SepticsDataWatershed.csv – Identifies the number of people per septic unit, average fraction 
of septic systems that fail, average septic overcharge rate per person, typical microbial 
density of septic overcharge reaching the stream. 

 SepticsLL.csv – Identifies septic system locations by Latitude and Longitude. 

 WildlifeDensities.csv – Identifies typical number of wildlife per unit area by land use type. 
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Identify Local Source-term Data 
 
28. The 12 default files are located in the “LocalData” directory, as illustrated below 

(“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\LocalData”).  

 
 
Modify Local Source-term Data 
 
Modifications are made to the following local data files: BoundaryPointsLL.csv and FCProdRates.csv. 
 

BoundaryPointsLL.csv 
 
29. Open BoundaryPointsLL.csv using Notepad, Notepad, WordPad, Excel, or other pertinent editor. 

Using Notepad, the Latitude and Longitude of the default boundary point locations are as follows: 
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30. Change the Latitude and Longitude to <0.0, 0.0>. Save the file and exit. 

 
 

FCProdRates.csv 
 
31. Open FCProdRates.csv using TextPad, Notepad, WordPad, Excel, or other pertinent editor. Using 

Notepad, the original file includes the production or shedding rate of microbes from each domestic 
animal, wildlife, or land use. 

 
 
32. Change the shedding rate for “BeefCow” to 2.50E+10. Save the file and exit. 
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Import Local Source-term Data 
 

Ensure that the old files have been replaced with the new files in the “…\LocalData” working folder. 
All files in the “LocalData” folder, which is within the working folder, are used, where appropriate, 
even if the files are not registered as map layers on the SDMPB screen. 

 
33. To register source locations in the folder 

 “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\LocalData” as Map Layers, select 
“SDMProjectBuilder>Import Local Data Files”. 

 
 
34. The “Edit Local Data” window appears. Select “AnimalLL” in “Local Data Files” section, and click 

“Open File”. 
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35. The “Edit Local Data” window will change, as shown below. 

 
 
36. The “AnimalLL” Map Layer will be added to the SDMPB screen as illustrated below. 
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37. When the screen changes, click “Close File.” 

 
 
Identify the Pour Point Gaging Station 
 
There are several methods for identifying USGS gaging stations associated with watersheds. As 
described by Whelan et al. (2017b), one uses BASINS software to download and identify the USGS 
National Water Information System (NWIS) stations. A second approach, described below, goes directly 
to the USGS NWIS web site and identifies the location. 
 
38. The Manitowoc River Basin exists within the HUC-8 “04030101”, as highlighted below. To compare 

monitored and simulated flows and microbial densities, the watershed must be delineated through 
the sampling/monitoring location, where the SDMPB allows the user to delineate watersheds at 
intermediate locations like gaging stations. 
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39. The USGS gaging station near the mouth of the watershed, which will represent the pour point in 
the watershed delineation, is USGS Manitowoc River at Manitowoc, WI gage station (04085427). To 
identify the location, click on 
http://waterdata.usgs.gov/nwis/nwismap/?site_no=04085427&agency_cd=USGS; the following 
USGS webpage appears, with the gaging station highlighted by the red circle. 

 
 
40. By zooming in, an approximate location of the gage within the Manitowoc River Basin can be 

clearly identified (within the red circle), as illustrated below. 

 
 

http://waterdata.usgs.gov/nwis/nwismap/?site_no=04085427&agency_cd=USGS
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41. With this information, the USGS gaging station location can be identified on the SDMPB map layer. 
Turn on Flowline (“nhdlfowline for 04030101”) to see the shape of the river, and zoom to the area 
of interest (see boxed area below). 

 
 

42. An approximate location of the gage station can be estimated on the map layer, as illustrated by 
the red circle below. 
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Run Project Builder 
 
43. From the Menu Bar, choose “SDMProjectBuilder”, then “Run Project Builder”. 

 
 
44. The “Build Frames SDM Project” window appears. Choose “Pour Point” for “Select By”. For 

“Maximum Upstream”, pick a distance that goes at least to the watershed divide – arbitrarily use 
1000 km, as the delineation will automatically stop at the watershed divide. 

 
 
45. Click “Select Pour Point On Map”. 
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46. Go back to the map, and zoom in on the gage station location (representing the pour point of the 

watershed); use the Zoom icon  to clearly see the location highlighted with the red cross. 
Zoom in because identifying the location is crucial to placing the pointer; if this location is 
incorrectly identified, you may include more area than is needed for the assessment by 
inadvertently getting too close to the HUC-12 boundary. On the map, move the cursor to the 
location of the USGS gage station, and click (see red cross below). 

 
 
47. The following window appears to delineate watershed with the selected pour point. 
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48. When the window disappears, the delineated watershed with the selected pour point is indicated 

on the map. 

 
 
49. Click “Next” on the “Build FRAMES SDM Project” interface. 
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50. Complete the “Build FRAMES SDM Project” as shown, using values included in this figure.  

a. To ensure adequate sizes, define the “Minimum Catchment Size” and “Minimum Flowline 
Lengths” as “15” and “15”, respectively. The Minimum Catchment Size and Minimum 
Flowline Length ensure that subwatersheds and stream segment length are not too small.  

b. Land areas that are less than 5% of the total have been factored into other Map Layers, as 
noted by the “Ignore Landuse Areas Below Fraction” of “0.05”.  

c. Check “HSPF.”  
d. The “Degree Day” method is chosen to account for snow accumulation and melt. 
e. Select “Microbes” for the contaminant of concern.  
f. Output is “Hourly”. 
g. Segmentation is “Individual”, which allows model segments to be associated with each 

subwatershed (not each meteorological station, which can have multiple subwatersheds 
assigned to them). 
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51. Click “Next” and the following screen appears. Use the choices illustrated in the screen below. 

 
 
 

Use the choices and values: 

 Choose “STATSGO” which is less detailed than SSURGO for soil options. 

 Choose “NLDAS” under Meteorologic which refers to MET data. NLDAS is the North American 
Land Data Assimilation System and contains automatic quality control (QC), uses hourly gauge 
station data and modeled precipitation, provides estimates at hourly intervals with a 1/8th-
degree resolution, and provides precipitation time series at specified locations (Kim et al., 2014; 
Whelan et al., 2017h). This is used in conjunction with NCDC NOAA meteorological data which 
supplies information for regional data, such as air temperature. BASINS uses cached NCDC data 
up to 2009. For direct access to hourly NCDC data, one would choose “NCDC”, but the user must 
obtain a Token ID. MET stations are assigned to the nearest subwatersheds (based on centroid).  

 Choose the “NHDPlus Elevation” for Elevation and “NHDPlus” for Delineation.  

 The name of the file should already be identified, but a different name or location can be selected 
by choosing the name of the file (e.g., *.mwprj) and where it is saved. The .mwprj file is a 
MapWindow (mw) Project (prj) file directly consumed by BASINS. The program will automatically 
identify the working folder structure the user originally created. If a special location and name is 
chosen, the user may identify a special folder using “Save Project As”. 

 To allow data retrieval, check “Add Layers To Map During Project Creation”. 

 Coordinated Universal Time (UTC) is the world standard for civil time, irrespective of the local 
standard time [i.e., Greenwich Mean Time (GTM)]. Update the “Project Time Zone – UTC minus” 
to the civil time zone of the study area (i.e., Manitowoc, WI). This can be obtained from Figure 1 
as “-6”. 
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Figure 1. Coordinated Universal Time (UTC) for North America (For Daylight Savings time, increase one 
hour in those areas that adhere.) 
[https://en.wikipedia.org/wiki/Eastern_Time_Zone#/media/File:Timezoneswest.PNG] 
 
 
52. Click the “Build” button; progress windows like the one below will appear and disappear several 

times. 
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53. The message in the window below will appear several times during the process. Click “Yes” each 
time. 

 
 
54. When the process is complete, the following screen appears. Click “Open in BASINS”. 

 
 
55. The following map layer appears. 
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LABEL SUBWATERSHED WITH AN IDENTIFICATION NUMBER 
 
56. Unclick the Septic and “Animals” map layers on the left side of the screen, which simplifies the 

screen. 
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57. To label subwatersheds with an identification number, so they match the numbering scheme in the 
HSPF workflow, double-click on the map layer “Simplified Catchment” (the red arrow in the screen 
capture below): 

 
 
58. Choose the “Labels” tab, then “Setup”: 
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59. Under “Expression”, 

 choose “SUBBASIN” under “Fields” 

 change the Font size to 20. 

 click “Ok” 

 
 
60. Choose “middle segment” for the location of the label and click “Ok”. 
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61. Click “Ok” again, and the subwatershds (i.e., subbasins) are labeled. 

 
 
62. Click “File>Save”, then “File>Exit”. 

 
63. We still need to exit the SDMPB, so exit the SDMPB by selecting “File>Exit”. 
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In this example, HSPF input files can be found in “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-
PEST_1\HSPF”. Three input files are required for HSPF modeling: 
1. 04030101.uci: The User Control Input File, a flat file that contains all non-time series data, 

including model parameters. 
2. 04030101.wdm: The binary Watershed Data Management file that captures modeling flow 

results such as time series of flow calculation 
3. met.wdm: The binary Watershed Data Management file that contains meteorological data 

(precipitation, temperature, potential evapotranspiration, etc.) for HSPF modeling. 

 
 
The microbial loading rates published in the HSPF *.uci file will need to be updated; these vary by 
land-use type and subwatershed. 
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MODIFY MICROBIAL LOADING RATES IN THE HSPF *.UCI FILE 
 
HSPF considers up to nine land-use types. For this application only four land-use types will be populated 
with microbial loading rates in the example. This section describes how the user can modify the 
microbial loading rates to land-use types. 
 
Identify Microbial Loading Rates in the HSPF *.uci File which need to be Set Equal to Zero 
 
The Microbial Source Module (MSM) estimates microbial loading rates to four land-use types: 
Urbanized/Built, Forest, Cropland, and Pasture. The SDMPB retrieves these estimates and automatically 
pre-populates the HSPF input *.uci file with microbial loading rates in Cells/ac/d. [Note: The UCI file 
writes the units as “Lbs/ac.d”.] These rates are published for nine HSPF-designated land-use types: 
 

 Water/Wetlands 

 Urban 

 Barren or Mining 

 Forest 

 Upland Shrub Land 

 Agriculture – Cropla 

 Grass Land 

 Agriculture – Pastur 

 Traditional 
 
where Urban, Forest, Agriculture – Cropla, and Agriculture – Pastur correspond to Urbanized/Built, 
Forest, Cropland, and Pasture, respectively, in the MSM documentation (Whelan et al., 2017i). The 
remaining land-use types are pre-populated with loading rates that represent holding places and at 
levels significantly smaller than those associated with Urban, Forest, Cropland, and Pasture. 
 
This section describes the process for modifying microbial loading rates in the HSPF *.uci file by using a 
text editor or the HSPF user interface. In this example, microbial loading rates will be zeroed-out for the 
following five land-use types while leaving the others (Urban, Forest, Cropland, and Pasture) unchanged: 
 

 Water/Wetlands 

 Barren or Mining 

 Upland Shrub Land 

 Grass Land 

 Traditional 
 
Two different procedures for zeroing out microbial loading rates are discussed, of which only one should 
be implemented: 

 Modify Microbial Loading Rates in the HSPF *.uci File by Using a Text Editor 

 Modify Microbial Loading Rates in the HSPF *.uci File by Using the HSPF User Interface 
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Modify Microbial Loading Rates in the HSPF *.uci File by Using a Text Editor 
 
64. Using a text editor (e.g., WordPad), open the *.uci file, in this case “04030101.uci”, located in the 

working folder:  <…\HSPF\  
(e.g., “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF”). 

 
 
65. A file, similar to the following, will open: 
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Identify Land-use Types by Subwatershed 
 
66. To identify which land-use types are associated with which subwatersheds (or subbasins), scroll 

down to the “GEN-INFO” section. 
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Note that the subwatersheds are numerically numbered (e.g., 101, 102, …, etc.), where each 
subwatershed ID is represented by the first character in number (e.g., “1” in “101” refers to 
Subwatershed 1). The last two numbers represent the land-use type ID (e.g., 01 is Water/Wetlands, 
02 is Urban, etc.). So, if Subwatershed 5 contains an Urban land-use type, then “502” will be in the 
listing.   In this example, eight of the nine land-use types are represented in the basin. The four land-
use types that will not be zeroed out, have been highlighted whose IDs are as follows: 

x02     Urban 
x04     Forest 
x06     Agriculture – Cropla 
X08     Agriculture – Pastur 

 
Modify Microbial Loading Rates 
 
67. Scroll to the section, titled “MON- ACCUM”. 

 
 

●
●
●
●
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The first subwatershied with its eight land-use types have been highlighted. The arrows represent the 
rows in the first subwatershed that need to be zeroed out. Obviously, this is repeated for each 
subwatershed. 

 
68. Zero out those rows that are represented by the following land-use types:  

x01     Water/Wetlands 
x03     Barren or Mining 
x05     Upland Shrub Land 
x07     Grass Land 

 
 

●
●
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There is no “Traditional” land-use type in the file. 

 
69. Save the file and exit. 

 
Modify Microbial Loading Rates in the HSPF *.uci File by Using the HSPF User Interface 
 
70. Open WinHSPF by double-clicking (left) on the icon to execute WinHSPF3.0. If the icon cannot be 

found on the Desktop screen, locate the executables on the hard drive (WinHSPF.exe), typically in 
<…\BASINS45\models\WinHSPF30\bin\>. 

 
 
71. The following WinHSPF window appears. 

 
 
72. Select “File>Open”. 
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73. The following window appears. Browse to the *.uci folder.  In this example, it can be found at 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily\04030101.uci”, 
then click “Open”. 

 
 
74. The HSPF project workflow for the Manitowoc River Basin appears. 

 
 

The user may want to copy the original UCI file and save it someplace safe, in case an unforeseen 
accident occurs with the one being edited. 
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75. Select “Functions>Input Data Editor” or click  in the tool bar to view the calibrated HSPF 
microbial parameters. 

 
 
76. The following “Input Data Editor” window appears. Only bolded sections have records in the UCI 

file. For example, “FORMATS” does not contain data, but “FTABLES” does.  
a. Expand “PERLND” by clicking “+” at the left and “PQUAL”. 
b. Choose “MON-ACCUM”. 
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77. The screen containing the parameter values of “ACQOP” (“MON-ACCUM”) appear. 

 
 

The first subwatershed (i.e., 1xx) with its eight land-use types (e.g., 101, 102, 103, …, 108) have been 
circled in red.  Example rows needing to be zeroed-out are x01, x03, x05, and x07, where the example 
arrows are shown. 

 
  

●
●
●
●
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78. Zeroed-out rows designated by x01, x03, x05, and x07, of which the first subwatershed is circled in 
red. 

 
  

●
●
●
●
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79. When all appropriate rows have been zeroed-out, the screen will look like the following: 

 
 
80. Click “Apply”, then “Ok”. 
 
81. Click “File>Save”, then “File>Exit”. 

 

  

●
●
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EXECUTING HSPF 
 
82. If HSPF is not open, activate the WinHSPF3.0 icon on the Windows desktop: 

 
 
83. If the icon cannot be found on the Desktop, locate the executable on the hard drive (WinHSPF.exe), 

typically in “C:\BASINS45\models\WinHSPF30\bin\”. 

 
 
84. The following WinHSPF window appears. 
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85. In the window below, select “File>Open”. 

 
 
86. The following window appears. Browse 

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF\04030101.uci” and click “Open”. 

 
 

The HSPF project on Manitowoc River Basin will appear in the HSPF GUI, with the workflow schematic 
shown below. The WinHSPF UI shows linkage of subwatersheds, proportion of land use type in each 
subwatershed, etc. Details about WinHSPF UI can be found in the WinHSPF Manual, typically in 
“…\BASINS45\docs\WinHspf30.chm”. 
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87. The following screen appears presenting the basin workflow. 

 
 
88. To run the HSPF simulation, click the “Run Simulation” icon. Save the HSPF project by clicking “File”, 

then “Save” on the main menu bar. Leave the HSPF workflow schematic screen open, since you 
may want to refer to it while operating in the BASINS interface. 

 
 
89. A progress window appears. 
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90. When the simulation finishes, the progress window will disappear, and you will find output files in 
the working folder, similar to the following. 
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DOWNLOADING AND EXPORTING A TIME SERIES OF FLOW OBSERVATIONS 
 
For flow-related parameter calibration, observed discharge data are required. This section describes 
discovery, access, and retrieval of observed discharges associated with the USGS gaging station near the 
pour point of the Manitowoc River basin. BASINS will be used initially to download a time series of flow 
observations and export those data in a form consistent with input requirements of PEST. 
 
91. A BASINS shortcut icon should appear on the computer’s desktop. 

 
 

If the icon cannot be found on the Desktop, locate the executable (“BASINS.exe”) on the hard drive, 
typically in …\BASINS45\bin\, as illustrated below. 
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92. Double-click left on the icon to execute BASINS. The User Interface (UI) of BASINS appears. Click 
“Close” on the “Welcome to BASINS 4.1” window, even though BASINS4.5 is being executed. 

 
 
93. On the menu bar, select “File>Open Project”. 
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94. To open your Mapwindow project file (in this case, “Manitowoc.mwprj”), which was created by 
SDMPB and is located “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\” in this 
example, select “Manitowoc.mwprj”, and click “Open”. 

 
 
95. The following map layer appears. 
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Register Simulation Results for the Manitowoc River Basin 
 
96. Go to the “File”, “Manage Data” menu in the BASINS menu bar. With the “Data Sources” window 

open, see that no times series data sources are pre-loaded except, possibly, a met.wdm file. Time 
series data sources from the HSPF simulation are needed to view the simulation results, so they will 
be added.  

 
 
97. To add time series data source, select “File”, then “Open” from the “Data Sources” window. A 

selection window appears:  
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98. Select “WDM Time Series”, then “OK”. Navigate to the project folder, and select the file 
“04030101.wdm”. It contains the output time series written from HSPF to WDM. 

 
 

Note: For the pour point simulation, the *.wdm file name may be “SDMProject” (e.g., 
SDMProject.wdm) for a pour point analysis. The name may reflect the HUC-8 ID number (i.e., 
“04030101.wdm”) as in this case. Do not select the met.wdm file. 

 
99. With this data source open, the file name similar to the following appears in the “Data Sources” 

window. 
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Download Discharge Data Associated with Gage Stations in the Manitowoc River Basin 
 
This Section describes the procedure for downloading USGS gage station daily flow observations for the 
entire Manitowoc River Basin and daily and instantaneous flow observations at the pour point of the 
Manitowoc River Basin. 
 
Daily Discharge Time Series for USGS Gaging Stations on the Manitowoc River Basin 
 
100. To download locations of observed discharge data associated with flow gage stations in the 

Manitowoc River Basin, select “File>Download Data” on the menu bar. 

 
 
101. The “Download Data” window appears; check “Discharge”, then click “Download”. 
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102. When the following screen appears, click “OK”. 

 
 
103. BASINS will download locations of USGS gage stations, and it will be displayed at the bottom of 

the “Legend” on the left-hand side of the screen and on the map. 

 
 

Map layers can be turned off, symbols for the gage stations can be changed, and labels can be added 
to see the stations more clearly on the map. 
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104. In the “Legend” panel, turn off the “Animals” and “Septic” map layer by clicking on the box at 
the left to remove the check mark (√).  

 
 
105. On the “Legend” panel, click on “Observed Data Stations” (including the “NWIS Daily Discharge 

Stations” layer) and drag it to the top. 

 
 



 

 

65 
 

106. Click the symbol at the right of the “NWIS Daily Discharge Stations” layer. 

 
 
107. The “Point style” window appears. Put “10” for “Size”, click the circle in the “Symbols” tab, click 

“Apply”, then “Ok”. 
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108. Right-click on the name of the layer, then select “Label Setup”. 

 
 
109. The following window appears. Double-click “site_no” under “Fields”, and ensure “[site_no]” 

appears under the “Expression” box. Click “Ok”. 
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110. In the window below, select the appropriate position of the label, then click “Ok”. 

 
 
111. The following figure appears with larger symbols and codes of the USGS gage stations in the 

Manitowoc River Basin. 
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In the figure, three gage stations in the Manitowoc River Basin have been highlighted with red boxes: 
04085427 is located at the outlet (near the pour point) of the watershed, and 04085395 and 
04085425 are within the watershed. Flow observations at the 04085427 gage station will be 
downloaded in this example, first for the daily flow observations, then for the “instantaneous” flow 
observations. 

 
Daily Discharge Time Series for the USGS Gaging Station 04085427 
 
112. To download discharge data at the 04085427 gage station,  

a. Highlight the “NWIS Daily Discharge Stations” layer in the “Legend” panel (bottom, left-side 
of screen). 

b. On the tool bar, click , then click on each gage station on the map while holding the 
Ctrl key down. The gage stations will be highlighted. 
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113. Choose “File”, then “Download Data” again, this time specifying download “Daily Discharge” 
data values. Click “Download”. 

 
 
114. The window similar to the following appears. The daily flow observation time series file name 

will already be identified, but you can pick a different name or folder location. Choose “Add data to 
new WDM file”. Click “Ok”. 

 
 
115. When the download is complete, this message appears. Click “OK”:  
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116.  When a screen similar to the following appears, click “OK”. 

 
 
117. The “Data Sources” window appears, indicating NWIS data have been added to the project. 

Choose “file”, then “Exit”. 

 
 
118. The main BASINS screen appears; choose “File”, then “Save” in the menu. 
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Instantaneous Discharge Data for USGS Gage Station 04085427 
 
The USGS Instantaneous Data Archive (IDA) for Instantaneous Discharge data provides hourly and 
sub-hourly discharge data at USGS gaging stations. As of June 23, 2017, access to USGS Instantaneous 
Data Archive (IDA) for Instantaneous Discharge data is not available on the USGS web site, as 
illustrated in the following screen capture. 

  
 
In the event that USGS IDA for Instantaneous Discharge data become available and the web service is 
activated within the SDMPB, Appendix A describes how the user can access and retrieve the 
instantaneous discharge data using the BASINS download data tools. 

 
View Observed Data 
 
119. Flow observation data must be exported to prepare files for flow-related parameter calibration 

using the PEST inverse model. On the menu bar, select “Analysis>List”. 
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120. The following “Select Data” window appears. 

 
 
121. To review the time steps associated with the time series, select “Attributes>Add”. Repeat once. 
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122. Two additional attribute columns will be added in the “Select Data” window. 

 
 
123. For the two additional attribute columns, select “time step” and “Time Unit”. 
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124. After being chosen, the data time step appears in “Matching Data”. For example, in the figure 
below, “OBSERVED” “PREC” (precipitation) at “X295Y153” has a “1” “Hour” time step. 

 
 
125. In the “Constituent” column, find “FLOW” for daily flows by clicking on “FLOW”. In the 

“Matching Data” section, the “Time Unit” for “FLOW” is daily (“Day”). “Time Step” and “Time Unit” 
can be easily determined by opening tabulated data. 
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126. To check the “Time Unit”, select “04085427” in “Matching Data”. Ensure that “04085427” 
appears in “Selected Data” section. This ensures that data with their own time step will appear. 
Click “Ok”. 
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127. The following window appears. The “Time Unit” of the data can be easily identified as daily 
increments. Close the “Timeseries List” window. 

 
 

In this example, HSPF input flow parameters will be calibrated with daily flow observations. If the user 
would like to use 15-minute or hourly flow observation data for the HSPF flow parameter calibration, 
a similar procedure could be used for these data sets, using the observation data download described 
in Appendix A. 
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Export Flow Data as a Text File for Parameter Calibration 
 
Parameter calibration will be performed using daily flow observations. This section describes the 
procedure used in preparing a text (*.txt) input file of observed flow for use in the calibration of HSPF 
flow-related parameters by PEST. Because calibration is iterative and over writes existing files,  
files associated with the initial HSPF simulation must be maintained in a different folder location. The 
time period associated with this calibration is from January 1, 2000 (2000/01/01) to December 31, 2012 
(2012/12/31), respectively. 
 
128. To export flow observation data, open the “Select Data” window again (from “analysis” and 

“List” from the BASINS menu icons). In the “Constituent” column, choose “FLOW”. In “Matching 
Data”, select “04085427” which is the gaging station that is nearest to the outlet of the Manitowoc 
River Basin and will be used for HSPF flow parameter calibration. Ensure that “04085427” appears 
in “Selected Data”. 
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Although we are going to perform HSPF modeling from 2000 to 2012, the “Date Range of Selected 
Data” section indicates the daily flow observations are available from 1972/07/26 to 2017/06/23. This 
will affect to model parameter calibration and validation period; therefore, the start and end dates 
need to be changed to 2000/01/01 and 2012/12/31, respectively. 

 
129. Click the “Subset, Split, or Filter Selected Data” box. 

 
 
130. The “Filter Data” screen appears. Under the “Subset By Date” tab, change the “Start” and “End” 

dates to 2000/01/01 and 2012/12/31, respectively. Click “Ok”. 
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131. The following “Timeseries List” window appears. 

 
 

Formats associated with the dates and values may need to be checked and changed, if necessary. The 
dates need to have a format of yyyy/mm/dd. The values must not contain commas, so they must be 
removed from the numbers, if they exist (e.g., change 1,240 to 1240). 
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132. Select “View”, then “Data and Value Formats…”. 

 
 
133. The “Formats” window appears as follows. 

a. If a comma (,) appears in the “Standard Format” remove it.   In this case, no comma appears. 
b. Choose “Year Month Day”, if not chosen. 
c. Click “Apply”, then “Ok”.  
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134. The following screen with corrected formats for dates numbers appears. 

 
 
135. To export the data for use by other models such as PEST, select “File>Save Grid As Text”. 
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136. In the window below, file name and the location can be defined. Here, the time series will be 

stored as 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\NWIS\04030101_obs_daily.txt”. Once 
the file name and folder path are defined, click “Save”. 

 
 
137. Close the “Timeseries List” window, using the upper right-hand corner “x”. 
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PREPARING PEST INPUT FILES FOR HSPF FLOW PARAMATER CALIBRATION 
 
Parameter calibration will be performed using daily flow observations. This section describes the 
procedure to prepare PEST input files for calibration of HSPF flow-related parameters. Because 
calibration is iterative and writes over existing files, files associated with the initial HSPF simulation that 
are over-written must be saved in a different location. 
 

138. Create a new folder (“...\Flow\Daily\”) in  
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\”. 
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139. Copy the meteorological and flow time series data, and HSPF input files to new folders. 
a. Copy three HSPF input files (04030101.uci, 04030101.wdm, and met.wdm) from 

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF” 
to the new “...\Flow\Daily” folder: 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily” 

b. Copy “04030101_obs_daily.txt” from 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\NWIS” 
to the new “...\Flow\Daily” folder: 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily”, and 
change the name of the file to “04030101_obs.txt”. 

c. Copy “HSPF_PEST_flow.exe” and “Input_flow.in” from  
“C:\Users\gwhelan\iemTechnologies\SDMPB\bin\Data\HSPF-PEST” to 

 “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST” 

 “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily”. 
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The executable “HSPF_PEST_flow.exe” prepares files necessary for HSPF flow parameter calibration with 
PEST. 

A. Three PEST input files 
a. PEST control file (.pst):  PEST parameters, model parameters metadata (names, initial 

values, ranges, etc.), parameter groups, observed flow data, and path of model 
executables. 

b. PEST template file (.tpl):  Structure of the model input file and location of where the 
calibrating parameter values are to be placed. 

c. PEST instruction file (.ins): How PEST will read the model output file. 
B. Two batch files 

a. “runHSPF.bat”: Executes HSPF (i.e., WinHSPFlt.exe) 
b. “runPEST.bat”: Executes HSPF parameter calibration with PEST 

C. Flow observation time series file:  Flow observation date with missing values as “-9999”. This file is 
not used for parameter calibration. 

 
“Input_flow.in”, the default input file used with the “HSPF_PEST_flow.exe”, contains details for preparing 
PEST input files: “HSPF_PEST_flow.exe” and “Input_flow.in” which can be found in Appendix B. 
“Input_flow.in” defines 

A. Folder paths of HSPF (i.e., WinHSPFlt.exe), PEST (i.e., pest.exe) and a working folder where HSPF 
input files, generated by SDMPB, are located. In this example, the folder path for the daily 
calibration is 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily” 

B. Calibration parameter names and ranges for each land use group. 
C. Land use groups that have different parameter values. 
D. Number of years for model warm-up. 

 
As the default, “HSPF_PEST_flow.exe” and “Input_flow.in” are located in  

“C:\Users\gwhelan\iemTechnologies\SDMPB\bin\Data\HSPF-PEST”, created by SDMPB, and copied to 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST”. These files can be located in any 
folder, but both must be in the same folder. In this example for parameter calibration with daily flow 
observations, “HSPF_PEST_flow.exe” and “Input_flow.in”, respectively, must be located in working folder 
(e.g., “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily”). 
 
The working folder paths in “Input_flow.in” must be updated to reflect the locations of the 1) batch 
version of HSPF (i.e., WInHSPFLt.exe), 2) working folder, and 3) inverse model PEST. This information is 
captured in the first three lines of the “Input_flow.in” file, as discussed in Appendix B. The inverse model, 
PEST, estimates specific HSPF input parameters to minimize differences between observed and simulated 
results (flows and microbial densities). When automating the calibration process, a non-Windows-based 
version of HSPF (i.e., WinHSPFLt.exe) is required, one which allows batch runs with no user interaction. 
Because different organizations constructed software builds for BASINS and SDMPB installation, the 
current software installation process installs WinHSPFLt.exe in two different locations: 

 C:\BASINS45\models\HSPF\bin\ and 

 <…\SDMPB\bin\> 
as both include WinHSPFLt.exe; hence, there is the possibility that two different versions of the software 
might exist. To ensure consistency, the version of WinHSPFLt.exe contained in the SDMPB build (i.e., 
<…\SDMPB\bin\) will be the one used in the calibration process. 
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140. Open “Input_flow.in” in each folder with a text editor.  

 
 

The following lines in “Input_flow.in” may need to be updated. Ensure that these lines are correct. 

 Line 1 identifies the path of the folder location of WinHSPFLt.exe.  

 Line 2 identifies the path of the working folder here input UCI file, WDM files, and a flow 
observation file are located, and output files of “HSPF_PEST_flow.exe” will be generated. 

 Line 3 identifies the path of the folder location of PEST.exe. 

 Line 4 identifies the number of years for model warm-up, from start of the simulation as it 
appeared in the input UCI file 

Refer to Appendix B for additional information on modifying the “Input_flow.in” file. Ensure that 
the name of the folder locations end with a backslash (\) for the first three lines. 
 

The time period associated with this calibration is from January 1, 2000 (2000/01/01) to December 
31, 2012 (2012/12/31), respectively. For this example, parameter calibration with daily observations 
will use the first seven years (i.e., 2000-2006) for model warm up and the final five years for 
calibration (i.e., 2007-2012). As such, the fourth line will need to contain a “7”. 
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141. For this example, change the 

 first three lines to the appropriate folder locations. 

 fourth line from a “1” to a “7”.  

 Save and exit. 

 
 
Prepare HSPF for the Flow Calibration Period 
 
HSPF input files were prepared with MET data from 2000 to 2012 which needs to be divided into two 
sub-periods: one for parameter calibration and one for validation. In this example, parameter calibration 
with daily flow observations will be performed for 2007 to 2012, with first seven years as model warm-
up. 
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142. Open WinHSPF by double-clicking (left) on the icon to execute WinHSPF3.0. If the icon cannot be 

found on the Desktop screen, locate the executables on the hard drive (WinHSPF.exe), typically in 
<…\BASINS45\models\WinHSPF30\bin\>. 

 
 
143. The following WinHSPF window appears. 

 
 
144. Select “File>Open”. 
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145. The following window appears. Browse to 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily\04030101.uci”, then 
click “Open”. 

 
 
146. The HSPF project workflow for the Manitowoc River Basin appears. 

 
 



 

 

90 
 

147. To change the simulation period to reflect the calibration period (2007-2012), select 
“Edit>GLOBAL”. 

 
 
 
148. The “Global Block” window appears. Check to ensure that the simulation time goes January 1, 

2000 (2000/01/01) to December 31, 2012 (2012/12/31). Click “Apply”, then “Ok”. 

 
 

149. In the WinHSPF UI, save the changes by clicking  or “File>Save”. Close WinHSPF. 
 
150. “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily\04030101.uci” 

does not need to be modified. 
 
Execute HSPF for the Flow Calibration Period 

 
151. In “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily”, execute 

“HSPF_PEST_flow.exe”. The following command window will appear. 
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152. In this example, we calibrate parameters at the outlet of the watershed. From the figure in the 
Step 124, one can easily indicate the watershed outlet is Subwatershed 9 (i.e., RCHRES 9). Put “9” 
in the command window and press ENTER. When the command window appears (shown below), 
press ENTER to close it. The command window indicates simulation and calibration periods. 

 
 
153. Once “HSPF_PEST_flow.exe” is executed, the three PEST input files, two batch files, and a flow 

observation time series file will appear in the folder.

 
 

Now PEST input files for HSPF flow parameter calibration process have been prepared for daily flows. 

 
  



 

 

92 
 

CALIBRATING HSPF FLOW PARAMETERS WITH PEST 
 

“runPEST.bat” is a batch file that executes calibration for HSPF flow input parameters located in the 
following folder (for this example): 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily”. 

 
154. Execute “runPEST.bat” in  
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily”.  

 
 

During parameter calibration, a command window will show calibration progress as it processes, and 
the HSPF monitoring window will appear and disappear multiple times, illustrated in the following 
figure. 

 
155. HSPF flow parameter calibrations with PEST will conclude when the command window 

disappears.   
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VIEWING OUTPUT FILES OF THE FLOW CALIBRATION RESULTS 
 
View PEST Output Files of Flow Calibration Results with a Text Editor 
 
The parameter calibration results are recorded in the “.rec” file. In this example, “04030101_flow.rec” in 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily” contains parameter 
calibrations with daily flow data.  
 
156. To view results of daily flow calibrations, open “04030101_flow.rec”, located in 

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily\”, with a text editor. 
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157. Daily results are presented in the figure below. In the example, daily flow parameter calibration 
results are summarized in “OPTIMISATION RESULTS” which contains calibrated parameter values 
(under “Estimated value”) and their confidence limits, followed by iterative comparisons of flow 
calculations and observations (see “Observations ------->”). For additional insight on relationships 
between calibration parameters and environmental factors, Appendix C provides heuristic 
relationships between land use types and various calibration parameters. 
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158. Statistics between calculations and observations are listed in “Objective Function ----->” and 
“Correlation coefficient ---->“, as illustrated below. The sum of squared weighted residuals is a 
measure of the discrepancy between the data and an estimation model. The correlation coefficient 
(“r”) is a statistical measure of the degree in the change of one parameter because of change in 
another. When done, close the file. 
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159. The HSPF UCI file written by PEST (“04030101_flow.uci”) contains parameters calibrated by 
PEST, which represents the final HSPF simulation associated with flow calibration. Daily calibrated 
flow results in “04030101_flow.uci” are located, respectively, in the following folders: 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily”. 

 
 
160. Open “04030101_flow.uci” in “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-

PEST\Flow\Daily” with any text editor, and go to the “SNOW-PARM1” section, where the calibrated 
parameter value of “KMELT” can be found. 
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161. In “PWAT-PARM2” section, calibrated parameter values of “LZSN”, “INFILT”, “KVARY”, and 

“AGWRC” can be found. 
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162. In the “PWAT-PARM3” section, calibrated parameter values of “DEEPFR”, “BASETP”, and 
“AGWETP” can be found. Note that “AGWETP” was only calibrated for “Water/Wetlands”, and the 
value was fixed as “0” for other land uses, (EPA, 2000). 
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163. In the “PWAT-PARM4” section, calibrated parameter values of “CEPSC”, “UZSN”, “NSUR”, 
“INTFW”, “IRC”, and “LZETP” can be found. 

 
 

For details about the HSPF UCI file, see Bicknell et al. (2005) or “C:\BASINS45\docs\HSPF.chm”. 

 
View Calibrated Flow Parameter Values with WinHSPF  
 
The WinHSPF user interface can be used to view calibrated parameter values. 
  
164. Double-click (left) on the icon to execute the WinHSPF. 
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165. The following WinHSPF window appears. 

 
 
166. In the window above, select “File>Open”. 

 
 
167. The following window appears. Browse and choose 

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily\04030101_flow.uci”, 
then click “Open”. Make sure NOT to select “04030101.uci”, since it is the initial UCI file prepared by 
SDMPB. 
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168. The HSPF project on the Manitowoc River Basin will populate the WinHSPF UI which illustrates 

linkage of subwatersheds, proportion of land use types in each, etc. Details about WinHSPF UI can 
be found in the WinHSPF Manual, typically in the install folder “\BASINS45\docs\WinHspf30.chm”. 

 
 
169. To view the calibrated HSPF flow parameters, select “Functions>Input Data Editor” or click on 

 in the tool bar. 
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170. The following window appears. Note that only bolded sections have records in the UCI file. For 
example, “FORMATS” has no records in the UCI file, but “FTABLES” does. 

 
 
171. Expand the “PERLND” section by clicking + at the left. 
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172. Expanding “PERLND”, by clicking “+” to the right, produces the following figure which indicates 
there are records in “GENERAL”, “ATEMP”, “SNOW”, “PWATER”, “PSTEMP”, and “PQUAL”. 

 
 
173. Expand “SNOW” and “PWATER”. 
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174. Double-click (left) on “SNOW-PARM1” to open the window below, where the calibrated 
parameter value of “KMELT” can be found. Click “OK” to close. 

 
 
175. In the “Input Data Editor” window, double-click (left) on “PWAT-PARM2” to open the following 

window, where calibrated parameter values for “LZSN”, “INFILT”, “KVARY”, and “AGWRC” can be 
found. Click “OK” to close. 
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176. In the “Input Data Editor” window, double-click (left) on “PWAT-PARM3” to open the following 
window, where calibrated parameter values for “DEEPFR”, “BASETP”, and “AGWETP” can be found. 
Click “OK” to close. 

 
 
177. In the “Input Data Editor” window, double-click (left) on “PWAT-PARM4” to open the following 

window, where calibrated parameter values for “CEPSC”, “UZSN”, “NSUR”, “INTFW”, “IRC”, and 
“LZETP” can be found. Click “OK” to close. 
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REGISTERING CALIBRATION RESULTS WITH BASINS 
 
This section registers flow results for calibrated simulations (<…\HSPF\Flow\Daily\04030101.wdm>). 
 
178. Execute BASINS. When “Welcome to BASINS 4.5” appears, click “Manitowoc” to open the 

BASINS project generated by SDMPB. 

 
 
179. The following map layers appear in the BASINS UI. 
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180. Select “File>Manage Data”. 

 
 
181. The following “Data Sources” window appears. 

 
 
 

HSPF daily flow simulation results, based on calibrated parameter values, were stored in the 
“04030101.wdm” file located in the 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily\” folder. 
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182. In the “Data Sources” window, select “File>Open” which results in the “Select a Data Source” 

window.  
a. Select “WDM Time Series” by double-clicking on it.  
b. Browse and select “04030101.wdm” in 

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily\”. 
c. Click “Open”.  

Once the file is imported, it will appear in the “Data Sources” window. 

 
 
183. Close the “Data Sources” window, by selecting “File>Exit”. 
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COMPARING HSPF FLOW SIMULATION RESULTS BY PLOTTING MULTIPLE TIME SERIES 
 
HSPF performs hourly simulations and can publish the results as hourly, daily, monthly, etc. The 
observed flows obtained from the USGS gage station are daily values, so the calibrated results are 
associated with the observed daily values. 
 
Identify Data Sources Containing Daily Flow 
 
To plot daily flow data time series of discharges, the file containing the time series data must be 
identified within BASINS plotting tools. Once identified, calibrated and observed flow time series can be 
plotted simultaneously. 
 
184. Within BASINS, select “Analysis>Graph”. 

 
 
185. The following “Select Data To Graph” window appears. 
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186. To identify data source locations, a column of “Data Sources” must be added. Select 

“Attributes>Add”. 

 
 
187. In the “Select Data To Graph” window, select “Data Source” for the column to be added. 
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188. To see the full path of the data source, the width of each column must be adjusted. In 
“Matching Data”, click and drag the vertical lines between adjacent columns to adjust widths. 

 
 
189. After adjustment, column widths will look like those below. 
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View Results for a Daily Time Step 
 
190. Results associated with daily flow time series will be plotted. “FLOW” under the “Constituent” 

column contains flow time series with daily time steps. These results must be identified and 
chosen.  

a. Click “FLOW” in the “Constituent” section. Make sure all “FLOW” time series with selected 
“Constituents” appear in “Matching Data”. 

b. Under ”Matching Data”: 
i. select “FLOW” for “OBSERVED” and “04085427”, which the observed gaging station 

daily data at the pour point of the watershed. 
ii. Select the two “RCH9” “FLOW” data, each representing uncalibrated 

(“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF\04030101.wdm”) 
and calibrated (“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-
PEST\Flow\Daily\04030101.wdm”) simulation results.   

iii. Make sure that time series appear in “Selected Data”. 
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191. The simulation period is from “2001/01/01” to “2012/12/31”, excluding the one-year model 
warm-up period of 1990.  

a. Check the “Submit, Split, or Filter Selected Data” box. 
b. Click “OK”.  
c. Change the “Start” date to “2001/01/01” and the “end” data to “2012/12/31”. 
d. Click “Ok”. 

 
 
192. The “Select Data To Graph” window disappears, and the “Choose Graphs to Create” window 

appears. Check “Timeseries”, then click “Generate”. 

 
 
193. The following “Timeseries Graph” is generated. 
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Note that in plot label, the first two labels have the same name, but they can be differentiated, as the 
labeling order follows that of the Selected Data section:  

 
 
In this case, the first label refers to uncalibrated flows, the second label refers to the calibrated flows, 
and the third label refers to observed flows. When multiple results are plotted, the first label is 
usually associated with the left Y-axis. When editing the plot, the software will designate which curve 
is associated with which axis (e.g., left Y-axis versus right Y-axis).   

 
194. To differentiate the curves more easily, users can control curve color. Select “Edit>Graph”. 

 
 
195. The following “Edit Timeseries Graph” window appears. 
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196. Under the “Axes” tab, change the “Title” text box to “YEAR”. Click “Apply”. 

 
 
197. For “Axis”, select “Left Y”, then change the “Title” text box to “Average Daily Discharge (cfs)”. 

Click “Apply”. 
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198. Under “Curves”,  
a. select “Daily Observed Flow At 04085427” for “Curve”,  
b. change the “Label” text box to “Observed”.  
c. Change “Color” to blue.  
d. Click “Apply”. 

 
 

Note that the results of this curve correlate to the “Left Y Axis”. 

 
199. The first and second time series have the same name: “Daily 04030101 Flow At Rch9”. The first 

(uncalibrated) must be selected first. For “Curve”, select the time series “Daily 04030101 Flow At 
Rch9”, then change the “Label” text box to “Simulated (uncalibrated)”. Change “Color” to gray. 
Click “Apply”. 

 
 

Note that the results of this curve correlate to the “Left Y Axis”. 
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200. For “Curve”, select the second time series “Daily 04030101 Flow At Rch9”, then change the 

“Label” text box to “Simulated (calibrated)”. Change “Color” to red. Click “Apply”. 

 
 

Note that the results of this curve correlate to the “Left Y Axis”. 

 
201. Close “Edit Timeseries Graph” window. Three time series appear in the “Timeseries Graph” 

window. 

 
 

This figure overlays observed, uncalibrated and calibrated flow time series, and illustrates 
improvements in calibrated over uncalibrated flows, using PEST. 
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202. The graph can be exported as an image file. In the “Timeseries Graph” window, select 
 “File>Save As…”. 

 
 
203. Choose the desired file format (.tif, for example), define a file name (Result.tif, for example), 

then click “Save”. 
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204. The exported image file is shown below. 

 
 
205. Close the “Timeseries Graph” window. 
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PREPARING MICROBIAL OBSERVATION DATA 
 
HSPF microbial parameter calibration requires microbial observation data at the outlet of the watershed 
(i.e., “*_microbe_obs_009.txt”). The data needs to be prepared in the following format. 

 

yyyymmdd  hh:mm conc(1) 
yyyymmdd  hh:mm conc(2) 
⁞ 

yyyymmdd  hh:mm conc(n) 

 
yyyymmdd captures the year (yyyy), month (mm), and day (dd); and hh:mm captures the hour (hh) and 
minute (mm). conc(i) is ith observation of microbial density or concentration (Counts/L or Cells/L), and n 
is the number of observations.  
 
206. Locate (or create) a txt file, titled “04030101_microbe_obs_009.txt”. In this example, the 

“04030101_microbe_obs_009.txt” file can be located in the folder: 
< …\SDMPB\bin\Data\HSPF-PEST\> 
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207. Open the text file with a text editor (e.g., Notepad, TextPad, etc.) 

 
 
208. Exit the file by “File>Exit”. 
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PREPARING PEST INPUT FILES FOR HSPF MICROBIAL PARAMETER CALIBRATION 
 
Create Microbial Folder and Populate with Necessary Files 
 
This section prepares the microbial working folder and populates it with PEST input files for the HSPF 
microbial parameter calibration. 
 
209. Create a new folder (“...\Microbe\”); in this example the subfolder is in 

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\”. 
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The HSPF UCI file (“04030101_flow.uci”), written by PEST, contains parameters calibrated by PEST 
which represent the final HSPF simulation associated with flow calibration. The calibrated flow time 
series is captured in the modified “04030101.wdm” file. In this example, daily calibrated flow results 
in the “04030101_flow.uci” and “04030101.wdm” files are located in  
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily”. 

 
 
Because microbial calibration will use microbial observations in 2011 and 2012, and closely associated 
with the flow simulation results, the calibration will use flow parameters calibrated with daily flow 
from 2007 to 2012. 
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210. Copy  

 04030101_flow.uci, 04030101.wdm, met.wdm from  
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Flow\Daily” to 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe” and 

 “04030101_microbe_obs_009.txt” to 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe”. 
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The executable “HSPF_PEST_microbe.exe” prepares necessary files for the HSPF microbial parameter 
calibration with PEST. 

 Four PEST files 
o PEST control file (.pst): PEST parameters, model parameters metadata (names, initial 

values, ranges, etc.), parameter groups, observed flow data, and path of model 
executables. 

o PAR2PAR TPL file (_P2P.tpl): Structure model input file (i.e., “*_microbe.uci”) and 
locations of where calibrating parameter values are to be placed. 

o PEST template file (.tpl): Structure of the PAR2PAR input file and locations of where 
calibrating parameter values are to be placed. 

o PEST instruction file (.ins): Describes how PEST will read the model output file for 
calculating error statistics.  

 Two batch files 
o “runHSPF.bat”: Executes HSPF (i.e., WinHSPFlt.exe) and PAR2PAR (i.e., par2par.exe”) 
o “runPEST.bat”: Executes HSPF parameter calibration with PEST 

 
“Input_microbe.in”, the default input file used with “HSPF_PEST_microbe.exe”, contains details for 
preparing PEST input files which can be found in Appendix D. “Input_microbe.in” defines 

 Folder paths of HSPF (i.e., WinHSPFlt.exe), PEST (i.e., pest.exe) and a working folder where 
HSPF input files are located (i.e., “…\ HSPF-PEST\Microbe\”. In this example, the folder path 
for microbial calibrations is 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe”. 

 Calibration parameter names and their ranges for each land use group 

 Land use groups that differentiate parameter values 

 Number of years for model warm-up 
 
As default, “HSPF_PEST_microbe.exe” and “Input_microbe.in” are located in 
“C:\Users\gwhelan\iemTechnologies\SDMPB\bin\Data\HSPF-PEST”, created by SDMPB, and copied to 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST”. These files can be located in 
any folder, but both must be in the same folder. In this example for parameter microbial calibrations, 
“HSPF_PEST_microbe.exe” and “Input_microbe.in” must be located in 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe”. 
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211. In this example, copy “HSPF_PEST_microbe.exe” and “Input_microbe.in” from  
“C:\Users\gwhelan\iemTechnologies\SDMPB\bin\Data\HSPF-PEST” to 

 “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST” 

 “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe”. 

  
 

Once “Input_microbe.in” is located in  
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe”, the working folder 
paths in “Input_microbe.in” must be updated.  
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212. Open “Input_microbe.in”, which illustrates the updated working folder path for the hourly 
microbial calibration. 

 
 
213. With a text editor,  

 Update the working folder path on the second line.  

 On the fourth line, change the value on line 4 to “7”, which indicates the first seven years 
(i.e., 2000-2006) to be used for the model warm-up. 
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Ensure that the folder path for the HSPF and the PEST codes listed on the first and the third lines are 
also correct and name of the folder location ends with a backslash (\). 
 
NOTE:  Local well data associated with the Manitowoc basin indicate an absence of microbe (i.e., 
enterococci) in underground water (i.e., interflow and groundwater). Thus, microbial concentrations 
in interflow and groundwater (i.e., “IOQC” and “AOQC”) do not need to be calibrated, so these data 
can be removed from the file. 

 
214. In “Input_microbe.in”, remove the lines associated with “IOQC” and “AOQC”. 

 
 
215. “Input_microbe.in” looks like the following. Save and exit by “File>Save”, then “File>Exit”. 
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Execute Microbial Calibration using PEST 
 
216. In “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe”, execute 

“HSPF_PEST_microbe.exe” by double-clicking on the icon. When the command window below 
appears, put the number of microbial monitoring locations for the parameter calibration, “1” in this 
case, and press ENTER. 

 
 
217. In the command window below, put “9”, to set the Subbasin 9 as the calibration point, and press 

ENTER. 
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218. In the command window below, press ENTER to close it. The command window indicates 

simulation and calibration periods. 

   
 
219. Once “HSPF_PEST_microbe.exe” is executed, the necessary microbial calibration files (four PEST 

input files and two batch files) have been added to the 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe” folder. 

 
  



 

 

131 
 

CALIBRATING HSPF MICROBIAL PARAMETERS WITH PEST 
 
Parameter calibration usually takes several hours, depending on the setting in PEST, number of 
parameters, and model nonlinearity. Users should disable the machine’s screen saver during execution, 
if possible. 
 

220. Within the “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe” 
folder, execute “runPEST.bat”. During microbial parameter calibration, a command window appears 
and disappears multiple times, as shown below, which indicates PEST and HSPF are running 
successfully. Once HSPF microbial parameter calibration with PEST is finished, the command window in 
the figure above disappears. 
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221. Parameter calibration results are recorded in the “.rec” file: “04030101_microbe.rec” in 

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe”. 
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222. Open “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-
PEST\Microbe\04030101_microbe.rec” with a text editor to view the results. In this example, 
microbial parameter calibration results are summarized in “OPTIMISATION RESULTS” which 
contains calibrated parameter values under “Estimated value”, followed by iterative comparisons 
of flow calculations with observations (see “Observations ------->”).  
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223. Statistics between calculations and observations are listed in “Objective Function ----->” and 
“Correlation coefficient ---->“, as illustrated in the figure below. The sum of squared weighted 
residuals is a measure of discrepancy between the data and an estimation model. The correlation 
coefficient (“r”) is a statistical measure of degree in change of one parameter because of change in 
another. When done, close the file. 
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VIEWING OUTPUT FILES OF THE MICROBIAL CALIBRATION RESULTS  
 
With the final execution of HSPF using PEST, the HSPF UCI file (04030101_microbe.uci) located in 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe” includes final values 
for calibrated parameters.  

 
 
 

Calibration values in the PEST output file (04030101_microbe.rec) are not final because results differ 
slightly due to the monthly variability of some parameters, although the statistics (e.g., correlation 
coefficient) reported are valid and reflect calibration. This section illustrates how to view calibration 
results using a text editor or from within WinHSPF. 

 
 
View Microbial Results Using a Text Editor 
 
Appendix D documents the HSPF microbial parameters that were varied in the calibration process, 
including ACQOP (MON-ACCUM in case of monthly variable), WSQOP, FSTDEC, THFST, and MONTH-
DATA. This section reviews their location and values in the UCI file “04030101_microbe.uci”. For details 
about the HSPF UCI file, see Bicknell et al. (2005) or “C:\BASINS45\docs\HSPF.chm”. 
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224. Open “04030101_microbe.uci” with a text editor. 
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225. Go to “MONTH-DATA” where calibrated monthly parameter values are found. This section 
documents combined monthly point source loads from direct instream cattle shedding (“cattle in 
stream)” and “leaky septics” in Counts/d. Each month is designated by the sequence across the 
row. “MONTH-DATA 1”, “MONTH-DATA 2”, …, indicate data from different subwatersheds. 
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226. Go to “QUAL-INPUT” in “PERLND” (pervious land), where calibrated parameter value of 
“WSQOP” is found. Note that “IOQC” and “AOQC” are not calibrated and assumed as “0”. 
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227. Go to “MON-ACCUM” in “PERLND” (pervious land), where monthly calibrated parameter values 
of “ACQOP” ( “MON-ACCUM”) are found. 
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228. Go to “QUAL-INPUT” in “IMPLND” (impervious land), where calibrated parameter values of 
“ACQOP”, “SQOLIM”, and “WSQOP” are found. Because these are impervious areas, “ACQOP” and 
“SQOLIM” in “IMPLND” do not vary by month. 
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229. Go to “GQ-GENDECAY” in “RCHRES” (reaches), where calibrated parameter values of “FSTDEC” 
and “THFST” are found. 

  
 
230. Close the text editor. 

View Microbial Results Using a WinHSPF 
 
The WinHSPF user interface can also be used to view values assigned to calibrated parameter values. 
 
231. Double-click (left) on the icon to execute the WinHSPF. If the icon cannot be found on the 

Desktop screen, locate the executable on the hard drive (WinHSPF.exe), typically in 
\BASINS45\models\WinHSPF30\bin\. 
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232. The following WinHSPF window appears. 

 
 
233. Select “File>Open”. 

 
 
234. Browse “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe\”, 

choose “04030101_microbe.uci”, and click “Open”.  
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235. The HSPF Manitowoc River Basin workflow appears. The WinHSPF UI shows linkages of the 

subwatersheds and reaches, proportions of land use type in each, etc. Details about WinHSPF UI 
can be found in WinHSPF Manual, typically located in “\BASINS45\docs\WinHspf30.chm”. 

 
 

236. Select “Functions>Input Data Editor” or click  in the tool bar to view the calibrated HSPF 
microbial parameters. 
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237. The following “Input Data Editor” window appears. Only bolded sections have records in the UCI 
file. For example, “FORMATS” does not contain data, but “FTABLES” does.  

 
 
238. Expand “PERLND” by clicking “+” at the left. 
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239. Subsections in “PERLND” composed of the following records are expanded: “GENERAL”, 
“ATEMP”, “SNOW”, “PWATER”, “PSTEMP”, and “PQUAL”. 

 
 
240. Expand “PQUAL”. 

  
 
 



 

 

146 
 

241. In the “Input Data Editor” window, double-click (left) on “QUAL-INPUT”, under “PQUAL”, to view 
calibrated parameter values of “WSQOP”, “IOQC”, and “AOQC”. Click “OK” to close. 
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242. In the “Input Data Editor” window, double-click (left) on “MON-ACCUM” to view monthly 
calibrated parameter values of “ACQOP” ( “MON-ACCUM”). Click “OK” to close. 
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243. In the “Input Data Editor” window, first expand “IMPLND”, then expand “IQUAL”. 

 
 
244. In the “Input Data Editor” window, double-click (left) on “QUAL-INPUT” to view calibrated 

parameter values of “ACQOP”, “SQOLIM”, and “WSQOP”. Click “OK” to close. 
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245. In the “Input Data Editor” window, double-click (left) on “MONTH-DATA” to view calibrated 
parameter values of “MONTH-DATA”. Click “OK” to close. 
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REGISTERING CALIBRATED SIMULATION RESULTS AND OBSERVATIONS WITH BASINS 
 
HSPF microbial calibrated and uncalibrated simulation results with observations will be imported into 
BASINS for viewing and comparison. This section describes how to register simulation and observation 
time series results of microbial concentrations with BASINS, which will be used as the viewer. 

 
246. Execute BASINS with the BASINS icon. When “Welcome to BASINS 4.5” appears, click 

“Manitowoc” to open the BASINS project generated by SDMPB. 

 
 
247. The following map layers appear in the BASINS UI. 
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248. Under “File”, select “File>Manage Data”. 

 
 
249. The “Data Sources” window below appears. 

 
 
 

The “Data Source” window indicates that four time-series files have been registered.  
C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF\04030101.wdm” contains 
uncalibrated microbial simulation results.  
 
Data stored in the “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe\” 
folder have not been registered with BASINS, including calibrated microbial simulation results 
(“04030101.wdm”) and microbial observations (“04030101_microbe_obs_009.txt”). We will register 
the calibration results with BASINS. 
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Register Calibrated Microbial Simulation Results 
 
250. To import the calibrated microbial simulation results located in  

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-
PEST\Microbe\04030101.wdm”, and select “File>Open”. 

 
 
251. The following “Select a Data Source” window appears. Select “WDM Time Series” by double-

clicking on it. 
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252. The following window appears. Browse and select 
“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-
PEST\Microbe\04030101.wdm”, then click “Open”. 

 
 
253. “C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe\04030101.wdm 

(185)” appears in the “Data Sources” window. 

 
 
 

Because the microbial observations are stored in “04030101_microbe_obs_009.txt”, which is a text 
file, a different method is required to import and register these data with BASINS. 
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Register Microbial Observations 
 
254.  In “Data Sources” window, select “File>Open”. 

 
 
255. The following “Select a Data Source” window appears. Select “Read Data With Script” by double-

clicking on it. 
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256. The following window appears. 
a. Browse and select “04030101_microbe_obs_009.txt” in the 

“C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-PEST_1\HSPF-PEST\Microbe\” folder,  
b. Click “Open”. 

 
 
257. The following window appears. 

 
 
258. Because “04030101_microbe_obs_009.txt” is a text file, a script is required to read it. Highlight 

the first line under “Script File” column and click “Edit”. 
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259. The “Script Creation Wizard” window appears. In “04030101_microbe_obs_009.txt”, 
observation data starts from line 1, so no change at the “File Properties” tab is necessary. Select 
the “Data Mapping” tab. 

 
 
260. The following screen appears. 
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261. At the “Data Mapping” tab,  
a. use “Beg-End Column” to specify the location of the observation and its corresponding time 

in the file. 
b. fill out the rows, from “Value” to “Minute”, with the values shown in the screen capture. 
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262. Under the “Constant” column,  
a. scroll down until items under the Name column start with ”Scenario”,  
b. under the “Constant” column, record “Observed”, “04085427”, and “Enterococci” for 

“Scenario”, “Location”, and “Constituent”, respectively. These refer to the observed 
enterococci densities at sampling location 04085427. 

c. Click “Save Script”, and save the script as C:\Users\gwhelan\iemTechnologies\SDMPB\HSPF-
PEST_1\HSPF-PEST\Microbe\readtext_microbe_obs.ws” for future use.  

d. Click “Read Data” on the “Script Creation Wizard” window. 

 
 
263. When the prompt below appears, click “OK”. 
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264. “C:\Temp\SDMProject\Manitowoc\HSPF-PEST\Microbe\04030101_microbe_obs_009.txt (1)” 
will appear in the “Data Sources” window. 

 
 
 

All necessary microbial concentration time series have been imported to the BASINS project to 
compare microbial uncalibrated, calibrated simulations to observations. 

 
 
265. Select “File>Exit” to close the “Data Sources” window, then “File>Save” in the BASINS. 
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COMPARING HSPF MICROBIAL SIMULATION RESULTS BY PLOTTING MULTIPLE TIME SERIES 
 

266. Select “Analysis>Graph”. 

 
 
267. The following “Select Data To Graph” window appears. 

 
 
 

Since the “Data Source” column should have been added when uncalibrated and calibrated flow 
results with observations were plotted, it should not be necessary to add it again. [As a reminder, 
“Add” was chosen under “Attributes”, then “Data Source” for the new column.] 
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268. As described in previous sections, the width of each column should be adjusted so the full path 

of the data source can be viewed. 

 
 
269. Under the “Constituent” column, observed data are denoted by “Enterococci”, and uncalibrated 

and calibrated simulation results are both denoted by “DQAL”. Highlight “Enterococci” and “DQAL”, 
so they are displayed in “Matching Data”. 
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“Observed” data (under “Scenario”) near the watershed pour point are at “04085427” (under 
“Location”). Corresponding simulated data near the watershed pour point are at “RCH9” (under 
“Location”). The uncalibrated and calibrated simulation results (under “Data Source” column) are 
captured in the “04030101.wdm” file in the “…\HSPF” and “…\Microbe” folders, respectively.  

 
 
270. As captured below, choose the three time series indicated in “Selected Data”. 

 
 
 

Since the first seven years (2000 – 2006) were used as warm-up for the watershed modeling, they 
are excluded in the comparison; hence, the dates associated with the viewing the microbial density 
time series will be from 2007 through 2012 and need to be modified. The start and end dates will be 
“2007/01/01” and “2012/12/31”. 
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271. Click the “Subset, Split, or Filter Selected Data” box. Click “Ok.” 

 
 
272. The “Filter Data” screen appears. Under the “Subset By Date” tab, change the “Start” and “End” 

dates to 2007/01/01 and 2012/12/31, respectively. Click “Ok”. 
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273. The “Choose Graphs to Create” window appears. Check “Timeseries”, then click “Generate”.  

 
 
274. The following “Timeseries Graph” is generated, in which two Y-axes appear. This is caused by 

the large differences in magnitude between time series curves. Values on the axes differ by 
approximately one-order of magnitude. 

 
 
 

In the above graph, note that two Y-axis are appeared. This is caused by large difference between 
time series. You can see the values on the both axis have about an order of magnitude difference. To 
clearly indicate each time series, we can change the color of the curves, and the y-axis can be changed 
from linear to logarithmic. 

 
 
275. Select “Edit>Graph”. 
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276. The “Edit Timeseries Graph” window below appears. Under the “Axes” tab, choose “Bottom X” 
for “Axis”, and change “Title” to “YEAR”. Click “Apply”. 

 
 
277. Select “Left Y” for “Axis” and “Logarithmic” for “Type”, then type “Uncalibrated Enterococci 

Concentration (Cells/L)” for “Title”, and set “Zoom Range” as 10,000 to 10,000,000. Click “Apply”. 
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278. Select “Right Y” for “Axis” and “Logarithmic” for “Type”, then type “Observed/Calibrated 
Enterococci Concentration (Cells/L)” for “Title”, and set “Zoom Range” as 1000 to 1,000,000. Click 
“Apply”. 

 
 
279. Go to the “Curve” tab.  

a. Select “Observed Enterococci at 04085427” for “Curve”, then change “Label” to “Observed”. 
Note that the “Y axis” is “Right”. 

b. Since this observation is intermittent, only express the data with symbols that do not have a 
continuous line.  

i. Uncheck “Line”. 
ii. Change “Size” to “9”. 

iii. Select symbol type as “Circle”. 
iv. Check “Fill”. 
v. Change “Color” to blue. 

vi. Click “Apply”. 
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280. Select the first time series, “Hourly 04030101 Dqal at RCH9” for “Curve”. “Left” “Y Axis” has 

been selected for this time series. 
a. Change “Label” to “Simulated (Uncalibrated). 
b. Change “Color” to grey. 
c. Click “Apply”. 

 
 
281. Select the second time series, “Hourly 04030101 Dqal at RCH9” for “Curve”. “Left” “Y Axis” has 

been selected for this time series. 
a. Change “Label” to “Simulated (Calibrated). 
b. Change “Color” to red. 
c. Click “Apply”. 

 
  



 

 

168 
 

 
282. Close the “Edit Timeseries Graph” window, and all three time series in “Timeseries Graph” 

window will be plotted. 

 
 
283. The graph can be exported as an image file. In the “Timeseries Graph” window, select “File>Save 

As…”. 

 
 
284. Choose desired file format (.tif in this example), define the file name (Result.tif in this example) 

and click “Save”. 
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DISCLAIMER 
 
Information in this document has been funded in part by the United States Environmental Protection 
Agency under Interagency Agreement DW-89-92399101-1 to the Idaho National Laboratory. It has been 
subjected to the Agency's peer and administrative review and has been approved for publication as an 
EPA document. Mention of trade names or commercial products does not constitute endorsement or 
recommendation for use. 
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APPENDIX A 
USGS Instantaneous Data Archive for Instantaneous Discharge Data using the BASINS 

Download Data Tools 
 
 
The USGS Instantaneous Data Archive (IDA) for Instantaneous Discharge data provides hourly and sub-
hourly discharge data at USGS gaging stations. As noted in the main text, as of June 23, 2017, access to 
USGS Instantaneous Data Archive (IDA) for Instantaneous Discharge data is not available on the USGS 
web site. In the event that USGS IDA for Instantaneous Discharge data become available and the web 
service is activated within the SDMPB, this section describes how the user can access and retrieve the 
instantaneous discharge data using the BASINS download data tools. 
 
1. To download discharge data at the 04085427 gage station from the USGS web site,  

c. Highlight the “NWIS Daily Discharge Stations” layer in the “Legend” panel (see red box in the 
figure below). 

d. On the tool bar, click , then click on each gage station on the map while holding the 
Ctrl key down. The gage stations will be highlighted. 
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2. On the menu bar, select “File>Download Data”. 

 
 
3. The “Download Data” window appears. Check “Daily Discharge” and “Instantaneous Discharge”. If 

the “Daily Discharge” has been chosen in a previous data download, only choose “Instantaneous 
Discharge”. Click “Download”. 
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4. The following window appears. The daily flow observation time series file name will already be 
identified, but you can pick a different name or folder location. You can also store the data in an 
existing WDM file by choosing “Add data to existing WDM file” and locating the WDM file. In this 
example, a WDM file, “flow.wdm”, will be created in the example folder location 
“C:\Temp\SDMProject\Manitowoc\nwis\”. Click “Ok”. 

 
 
5. BASINS will download daily flow data. Click “OK” when the message for “WDM Datasets added” 

appears. 
 
6. BASINS will download instantaneous flow data for only those stations that appear. Click “OK” when 

the message appears noting: IDA data found for the selected station. 
 
7. When the “Data Download” screen appears, click “OK”. 
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If multiple stations are chosen (which is not in this case), then a message like the following will 
appear, noting only those stations where instantaneous flow data are available. 

 
 
If multiple stations are chosen (which is not in this case), then a message like the following will 
appear, noting only those stations where instantaneous flow data are available. 

 
 
When the “Data Download” screen appears, click “OK”. 
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8. The following “Data Sources” window appears to show time series data files associated with this 
project. Here, there are two WDM files and two RDB files as data sources. Close this window by 
selecting “File>Exit”. 
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APPENDIX B 
Flow Calibration: Details of “HSPF_PEST_flow.exe” and “Input_flow.in” 

 
 
This section provides details of the FORTRAN code for preparing HSPF parameter calibration with PEST 
(i.e., “HSPF_PEST_flow.exe”). “HSPF_PEST_flow.exe” is designed to  

 consume the HSPF input UCI file (*.uci) prepared by SDMPB 

 consume a flow observation file (*_obs.txt) 

 consume a user input file (Input_flow.in) 

 prepare PEST input files (*.pst, *. tpl, *.ins) 

 prepare batch files for running HSPF and PEST (“runHSPF.bat” and “runPEST.bat”, respectively) 

 prepare the file containing observed flows with missing values (“*_obs.out”). 
 
Input files include: 

 Input UCI file (“<project name>.uci”): represents the main HSPF input file prepared by SDMPB 
which includes all input data (e.g., simulation time, time series input file names, output file 
names, land use segmentation, print options, parameters, etc.), except time series input. Users 
do not need to directly modify the UCI file, since it can be modified through the HSPF user 
interface, although experienced users can modify this ASCII file directly. Only one UCI file exists 
per working folder, as specified in the “Input_flow.in” file.  

 Flow observation (“<project name>_obs.txt”): includes observed flow time series with the 
desired time step for parameter calibration which is downloaded and exported through BASINS. 
Users do not need to modify this file since it typically reflects USGS gaging station data. The time 
series in this file can include missing data. 

 User input file (“Input_flow.in”): includes information for generating PEST input files. 
 
Figure B.1 presents the generic format of the “Input_flow.in” file. Descriptions of input data are: 
 

HSPFPATH 
WORKPATH 
PESTPATH 
ny_warm 
nLUgroup 
nLU 
LU 
  ⁞ 
(blank line) 
para 
lower      upper 
  ⁞ 

Figure B.1. Constructions of user input file (“Input_flow.in”) 
 
 

 HSPFPATH: path of WinHSPFlt.exe. When HSPF is installed with BASINS, WinHSPF 3.0 (with user 
interface) and its light version, WinHSPFlt.exe (without user interface), are installed together. 
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PEST executes WinHSPFlt.exe as executed on the Command Window. WinHSPFlt.exe is typically 
located in “<BASINS folder>\models\HSPF\bin\” or “<SDMPB folder>\bin\”. 

 WORKPATH: path of working folder where input UCI file, WDM files, and a flow observation file 
are located, and output files of “HSPF_PEST_flow.exe” will be generated. 

 PESTPATH: path of pest.exe. 

 ny_warm: number of years for model warm-up, from start of the simulation as it appeared in 
the input UCI file 

 nLUgroup: number of land use groups. “1” means PEST calibrates the same parameter value for 
all land use groups. nLU and LU must be repeated nLUgroup times. 

 nLU: number of land use types included in each land use group. For example, a land use group 
may include two types such as Agricultural and Forest. There are nine land use types: 
Water/Wetlands, Urban, Barren or Mining, Forest, Upland Shrub Land, Agriculture-Cropla, Grass 
Land, Agriculture-Pastur, and Transitional. “Cropla” and “Pastur” refer to Cropland and Pasture. 

 LU: Land use types included in each land use group. LU must be repeated as many as nLU times. 
LU must be same as it appears in the input UCI file. If there are land use types that do not 
appear in the UCI file, the program skips them. 

 para: name of each parameter. para should be the same as it appears in the input UCI file. 

 lower and upper: minimum and maximum values of each parameter in the calibration process. 
This line must be repeated nLUgroup times for each parameter. Possible and recommended 
parameter ranges can be found in EPA (2000). 

 
Figure B.2 illustrates an example user input file “Input_flow.in”. It differentiates parameter values into 
four land use groups, which means PEST calibrates four different values for each parameter. Output files 
include: 

 PST file (“<project name>_flow.pst”): PEST control file that includes PEST parameters, 
information of model parameters, parameter groups, observed flow, model executables, etc. 
Users can modify or add PEST parameters, as necessary. Explanation of PEST parameters can be 
found in the PEST manual (Doherty, 2005) at http://www.pesthomepage.org/Downloads.php. 

 TPL file (“<project name>_flow.tpl”): PEST template file that includes structure of the model 
input file (i.e., HSPF UCI file) and location of calibrating parameter values. 

 INS file (“<project name>_flow.ins”): PEST instruction file that explains how PEST reads the 
model output file for calculating error statistics. 

 “runHSPF.bat”: Batch file that executes HSPF. 

 “runPEST.bat”: Batch file that executes the HSPF parameter calibration with PEST. 

 Flow observation with missing data (“<project name>_obs.out”): A file that includes flow 
observations with missing data denoted as “-9999”; this file is not used by PEST. 

 
The following assumptions apply when constructing the PEST input file: 

 Simulation start and end times, including model warm-up, are assumed to be the same, as they 
appear in the HSPF input UCI file prepared by SDMPB. 

 PEST calibrates HSPF flow parameters during calibration which is when observation and 
simulation periods overlap. If no overlap occurs, “HSPF_PEST_flow.exe” returns an error, noting 
that an inconsistency exists between the two periods. 
  

http://www.pesthomepage.org/Downloads.php


 

 

178 
 

C:\Basins45\models\HSPF\bin\ 
C:\Temp\SDMProject\Manitowoc\HSPF\Flow\Hourly\ 
C:\PEST\ 
2 
4 
1 
Urban or Built-up La 
2 
Agricultural Land 
Forest Land 
1 
Wetlands/Water 
1 
Barren Land 
 
KMELT 
0.0000          0.200 
0.0000          0.100 
0.0000          0.200 
0.0000          0.200 
INFILT 
0.0010          0.200 
0.0010          0.500 
0.0010          0.500 
0.0010          0.500 
AGWRC 
0.8500         0.900 
0.8500         0.950 
0.8500         0.999 
0.8500         0.999 
BASETP 
0.0000         0.050 
0.0000         0.200 
0.0000         0.200 
0.0000         0.200 
LZETP 
0.1000         0.500 
0.1000         0.900 
0.1000         0.900 
0.1000         0.900 

Figure B.2. Example user input file “Input_flow.in”, differentiating parameter values into four land use 
groups 
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 PEST minimizes the squared error between observations and calculations at the outlet of the 
watershed, as defined in the input UCI file prepared by SDMPB. The outlet of the watershed 
appears on the last line of “OPN SEQUENCE” section in the input UCI file. 

 It changes “Flags” in “PRINT-INFO” and “BINARY-INFO” sections, throughout the input UCI file, 
to “6” which means “never print” in default output and binary files, thereby saving output size. 

 It removes “EXT TARGETS” section in the input UCI file, instead adding a “PLTGEN” section after 
the “FTABLES” section to print selected flow (i.e., calculated flow discharge at the calibration 
point within the watershed) in a separate output file. Writing to “PLTGEN” includes adding a 
name of the separated output file (i.e., *_flow.p93), a “PLTGEN” line in “OPN SEQUENCE” 
section, and a “NETWORK” section after the “EXT SOURCES” section. 

 It indicates the time step of the observed flow in “*_obs.txt”, then writes the “PLTGEN” section 
accordingly. Thus, if a user prepares 15-minute, 30-minute, or hourly flow observations in 
“*_obs.txt”, the model writes hourly flow values to calibrate parameters with hourly flow. Only 
15-minute, 30-minute, hourly, or daily time steps can be indicated. 

 It assumes all parameters do not vary by month, even if some vary in the input UCI file prepared 
by SDMPB. 

 It turns on “Snow Accumulation and Melt”, if it is turned off in the input UCI file. 

 It turns off soil temperature and water quality modeling for simulation efficiency. 

 If the parameter AGWETP is calibrated, it assumes AGWETP varies only for the land use type 
“Wetlands/Water”, and is fixed for other land use types as “0” (EPA, 2000). 
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APPENDIX C 
Flow Calibration: Heuristic Relationships between Land Use Types 

and Various Calibration Parameters 
 
 
Parameter ranges and their calibrated values may vary by land use types. Although there are no 
recommended ranges that vary by land use types, heuristic relationships between land use types for 
various parameters are defined as follows: 
 

 INFILT – highest for water/wetlands, next highest for forest 

 LZSN – highest for forest, lowest for water/wetlands 

 CEPSC – may change over the course of the growing season for agricultural land uses and 
deciduous forest (monthly) 

 UZSN – may change over the course of the growing season for agricultural land uses (monthly); 
highest for water/wetlands, next highest for forest 

 LZETP – higher for forest and wetlands, next highest for row crops, then grassland 
 
The above relationships can be used to establish parameter ranges for calibration or to evaluate 
calibration results. 
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APPENDIX D 
Microbial Calibration: Details of “HSPF_PEST_microbe.exe” and “Input_microbe.in” 

 
 
This section provides details of the FORTRAN code for preparing HSPF calibration of microbial 
parameters using PEST (i.e., “HSPF_PEST_microbe.exe”). “HSPF_PEST_microbe.exe” is designed to  

 consume the HSPF input UCI file (*_flow.uci) which is prepared during the HSPF flow parameter 
calibration with PEST 

 consume a microbial observation file (*_microbe_obs.txt) 

 consume a user microbial input file (Input_microbe.in) 

 prepare PEST input files (*_microbe.pst, *_microbe.tpl, *_microbe.ins) 

 prepare an input file (*_microbe _P2P.tpl) for PAR2PAR, which is a PEST utility that manipulates 
parameters 

 prepare batch files for running HSPF and PEST (runHSPF.bat and runPEST.bat, respectively). 

 prepare a file containing observed microbial densities (concentrations) with missing values 
“*_microbe_obs.txt”. 

 
Input files include:  

 Input UCI file (“<project name>_flow.uci”): the main HSPF input file resulting from HSPF flow 
parameter calibration process using PEST, which includes calibrated HSPF flow parameters, all 
input data (e.g., simulation time, time series input file names, output file names, land use 
segmentation, print options, parameters, etc.), except time series input. Users do not need to 
modify the UCI file directly, since it can be modified through the HSPF user interface, although 
experienced users can modify this ASCII file directly. Only one UCI file exists per working folder, 
as specified in the “Input_microbe.in” file.  

 Microbial density observations (“<project name>_microbe_obs.txt”): includes observed 
microbial densities varying in time, where intermittent or fixed time steps are allowed; this file 
can include missing data. 

 User-defined microbial input file (“Input_microbe.in”): includes information for generating PEST 
and PAR2PAR input files. 

 
Figure D.1 presents the generic format of the “Input_microbe.in” file. Descriptions of input data are: 

 HSPFPATH: path of WinHSPFlt.exe. When HSPF is installed with BASINS, WinHSPF 3.0 (with user 
interface) and its light version, WinHSPFlt.exe (without user interface), are installed together. 
PEST executes WinHSPFlt.exe, as it is executed in the Command Window. WinHSPFlt.exe is 
typically located in “<BASINS folder>\models\HSPF\bin\” or “<SDMPB folder>\bin\”. 

 WORKPATH: path of working folder where the input UCI file, WDM files, and a microbial 
observation file are located, and where output files of “HSPF_PEST_microbe.exe” will be 
generated. 

 PESTPATH: path of pest.exe. 

 ny_warm: number of years for model warm-up from start of the simulation, as appeared in the 
input UCI file 

 nLUgroup: number of land use groups. “1” means PEST calibrates the same parameter value for 
all land use groups. nLU and LU have to be repeated nLUgroup times. 

 nLU: number of land use types included in each land use group. For example, a land use group 
may include two land use types, such as Agricultural and Forest. There are up to nine land use 
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types:  Water/Wetlands, Urban, Barren or Mining, Forest, Upland Shrub Land, Agriculture-
Cropla, Grass Land, Agriculture-Pastur, and Transitional. “Cropla” and “Pastur” refer to Cropland 
and Pasture. 

 LU: Land use types included in each land use group. LU has to be repeated as many as nLU 
times. LU must be the same as it appears in the input UCI file. If there are land use types that do 
not appear in the UCI file, the program skips them. 

 para: name of each parameter. para should be the same as it appears in the input UCI file. 
Parameters that start with “MON-“ or “MONTH-“ indicate parameters that vary monthly. 

o (lower) and (upper): minimum and maximum values for those parameters that vary 
monthly, and are not used if the parameters do not vary monthly. When “-9999” is 
used, no minimum or maximum value is assigned to the parameter. 

 lower and upper:  
o Parameters that vary monthly represent minimum and maximum values of proportional 

change, multiplying the initial values of these parameters by this factor. This line must 
be repeated nLUgroup times for each parameter, except ‘MONTH-DATA’, ‘FSTDEC’ and 
‘THFST’ since those are not grouped by land use. 

o Parameters that do not vary monthly represent minimum and maximum values. 
 
 

HSPFPATH 
WORKPATH 
PESTPATH 
ny_warm 
nLUgroup 
nLU 
LU 
  ⁞ 
 
para        (lower)       (upper) 
lower      upper 
  ⁞ 

Figure D.1. Constructions of user input file (“Input_microbe.in”) 
 
 
An example user input file “Input_microbe.in” is illustrated in Figure D.2. It separates parameter values 
into two land use groups which means PEST calibrates two different values for each parameter. 
Parameter names in PEST input files are differentiated by numbers following parameter names. Note 
that only one range can be provided for ‘MONTH-DATA’, ‘FSTDEC’, and ‘THFST’. Output files include: 

 PST file (“<project name>_microbe.pst”): PEST control file including PEST parameters, 
information of model parameters, parameter groups, microbial observation, model executables, 
etc. Users can modify or add PEST parameters, as necessary. An explanation of PEST parameters 
can be found in the PEST manual (Doherty, 2005) at 
http://www.pesthomepage.org/Downloads.php. 

  

http://www.pesthomepage.org/Downloads.php
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C:\Basins45\models\HSPF\bin\ 
C:\Temp\SDMProject\Manitowoc\HSPF-PEST\Microbe\ 
C:\PEST\ 
1 
2 
3 
Water/Wetlands 
Urban 
Barren or Mining 
6 
Forest 
Upland Shrub Land 
Agriculture - Cropla 
Grass Land 
Agriculture - Pastur 
Traditional  
 
MON-ACCUM     0.000     -9999 
0.00000     1000.00000 
0.00000     1000.00000 
WSQOP 
 0.01000    10.00000 
 0.70000     2.20000 
IOQC 
 0.00000     1.E10 
 0.00000     1.20000 
AOQC 
 0.00000     1.E10 
 0.00000     1.20000 
FSTDEC 
 0.00001     2.00000 
THFST 
 1.00000     2.00000 
MONTH-DATA    -9999     -9999 
0.00000     1000.00000 

Figure D.2. Example user input file “Input_microbe.in” 
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 PAR2PAR TPL file (“<project name>_microbe_P2P.tpl”): PAR2PAR template file, indicating the 
HSPF model input file structure (i.e., “*_microbe.uci”) and locations where calibrating 
parameter values are to be placed. In PEST calibration, this PEST utility (i.e., “PAR2PAR.exe”) 
must be executed prior to every HSPF execution to prepare the HSPF UCI file with parameters 
that change proportionally. Details of PAR2PAR can be found in the PEST manual (Doherty, 
2005) at http://www.pesthomepage.org/Downloads.php. 

 PEST TPL file (“<project name>_microbe.tpl”): PEST template file indicating structure of the 
PAR2PAR input file, instructing how to calculate parameters with proportional change, and 
providing locations where calibrating parameter values are to be placed. 

 INS file (“<project name>_microbe.ins”): PEST instruction file indicating how PEST will read the 
model output file for calculating the error statistics. 

 “runHSPF.bat”: Batch file that executes HSPF (i.e., WinHSPFlt.exe) and PAR2PAR (i.e., 
par2par.exe”). 

 “runPEST.bat”: Batch file that executes HSPF parameter calibration with PEST 
 
The following assumptions apply when constructing the PEST input file: 

 Simulation start and end times include the original simulation period which is indicated by the 
input UCI file (i.e., “*_flow.uci”) and microbial observation period. Users need to ensure 
“met.WDM” includes input MET data for the simulation period. 

 PEST calibrates HSPF microbial parameters during calibration which is when observation and 
simulation periods overlap. 

 PEST minimizes the squared error between observations and calculations at the outlet of the 
watershed, as defined in the input UCI file. If a parameter name in the User input file (i.e., 
“Input_microbe.in”) starts with “MON-“ or “MONTH-“, it assumes the parameter varies by 
month and sets it to change proportionally throughout calibration. PEST, therefore, does not 
calibrate the parameter value itself, but the proportional value related to the initial parameter 
value. 

 Soil temperature and water quality modeling in the UCI file are turned on. 

 The “PLTGEN” section is added after the “FTABLES” section in the UCI file to print selected 
microbial concentrations at the calibration points within the watershed in a separate output file. 
Writing the “PLTGEN” section includes adding a name of the separate output file 
(*_microbe.p9X), “PLTGEN” line in the “OPN SEQUENCE” section, and a “NETWORK” section 
after the “EXT SOURCES” section. 

http://www.pesthomepage.org/Downloads.php

